progeCAD Professional manual The low-cost alternative to AutoCAD

Index



Do you want to try progeCAD Professional?
Download the trial: you can try the product, without any limit, for 30 days!

A manual page a day... Click here to see the manual table of contents.

Working with drawings - Setting up a drawing

Creating and naming layers

Layer Names
  1. A layer name can be made of up to 255 characters: letters, numbers, spaces, and several special characters. Layer names cannot include the following characters:
  2. < > / \ " : ; ? * | = `
  3. The Layer Properties Manager sorts layers alphabetically by name. In many cases layer names are determined by personal or corporate standards. To organize your customized layer naming scheme, use common prefixes for layer names that include correlated components of the drawing, in order you can find them quickly typing in wild-card characters.
  4. If you frequently use the same layering scheme, you can set up a drawing template with layers, linetypes and colors already assigned.
  5. Note: You can use progeCAD Explorer to copy layers from one drawing to another. For example, you might have a drawing that contains all the standard layers needed for a project. You can create a new drawing and use the progeCAD Explorer dialog box to copy the predefined layers and paste them in the new drawing (See Working with the progeCAD Explorer.).
Setting the current layer
  1. When you create new entities, they are drawn on the current layer. In a drawing you can have a great number of layers but only one at a time can be current. It is possible to draw on layer 0, but it's a good standard not to use this layer but to keep the conceptual grouping of objects and draw on layers with specific names defined by the user. To draw new entities on a different layer, you must first make that layer the current layer. The succeeding objects you create are associated with the new current layer and have its colour, linetype, and other properties. You can't make current a frozen layer. For details See Setting the current layer.
To make a layer current
  1. Do one of the following:
  2. On the Entity Properties toolbar, from the layer drop down list, choose the layer you want to make current.
  3. Choose Format > Layer.
  4. On the Entity Properties toolbar, click the Explore Layers tool.
  5. Type layer and then press Enter.
  6. On the status bar, right-click on the current layer control, and from the list, select the layer you want to make current.
  7. In the Layer Name list, select the layer you want to make current.
  8. Do one of the following:
  9. Choose Edit > Current.
  10. In the Layer Name list, select the name you want to make current, and then click the Current tool .
  11. Double-click the layer name in the Layer Name list.
  12. Right-click the layer name you want to change, and from the shortcut menu select Current.
  13. To complete the command and return to your drawing, close the window.
Controlling layer visibility
  1. A layer can be visible or invisible. Entities on invisible layers are not displayed and do not print. By controlling layer visibility, you can turn off unnecessary information, such as construction lines or notes. By changing layer visibility, you can put the same drawing to multiple uses.
  2. For example, if you are drawing a floor plan, you can draw the layout of light fixtures on one layer and the location of plumbing lines on another. By selectively turning layers on and off, you can print the electrical engineering drawings and the plumbing drawings from the same drawing file. For even more convenience, you can control the visibility of layers within individual viewports, so that layers that display in one viewport are invisible in other viewports in the same drawing.
  3. When you turn a layer off, entities drawn on that layer are no longer visible. When you turn the layer back on, the entities on that layer are redisplayed. For details See Controlling layer visibility.
To turn layers on or off
  1. Do one of the following:
  2. Choose Format > Layer.
  3. On the Entity Properties toolbar, click the Explore Layers tool.
  4. Type layer and then press Enter.
  5. In the Layer Name list, select the layer you want to turn on or off.
  6. Turn on or off the layer selected.
  7. To complete the command and return to your drawing, close the window.
  8. You can also freeze layers to improve the performance of operations such as zooming and panning or producing hidden lines or shaded images. When a layer is frozen, entities drawn on that layer are no longer visible.
To freeze or thaw layers
  1. Do one of the following:
  2. Choose Format > Layer.
  3. On the Entity Properties toolbar, click the Explore Layers tool.
  4. Type layer and then press Enter.
  5. In the Layer Name list, select the layers you want to freeze or thaw.
  6. Clic on the freeze icon.
  7. To complete the command and return to your drawing, close the window.