progeCAD Professional manual The low-cost alternative to AutoCAD

Index



Do you want to try progeCAD Professional?
Download the trial: you can try the product, without any limit, for 30 days!

A manual page a day... Click here to see the manual table of contents.

Customizing progeCAD - Programming progeCAD

Using LISP routines

progeCAD supports the LISP programming language and is compatible with AutoLISP, the implementation of the LISP language in AutoCAD. This means that you can load and run any AutoLISP program written for use with AutoCAD.

To load a LISP routine
  1. Advanced experience level
  2. Do one of the following:
  3. Choose Tools > Load LISP or SDS Application.
  4. Type appload and then press Enter.
  5. Drag and drop the LISP file into progeCAD.
  6. In the Load Application Files dialog box, click Add File.
  7. Select the LISP file that you want to load, and then click Open.
  8. Click OK.
 
 
  1. Lists the names of LISP and SDS files already loaded.
  2. Click to add a LISP or SDS file.
  3. Click to remove the highlighted file.
  4. Click to load the highlighted file.
  1. Click to unload the highlighted file.
  2. Select to save the current list to the icadload.dfs file when you click Load, Unload, or OK.
  1. NOTE You can also load a LISP routine by typing (load "d:/path/routine.lsp") in the command bar (you must include the parentheses and the quotation marks), where d:/path is the drive and path where the LISP routine is located on your computer, and routine.lsp is the LISP routine file name.
To run a LISP routine
  1. Advanced experience level
  2. Do one of the following:
  3. Choose Tools > Load LISP or SDS Application.
  4. Type appload and then press Enter.
  5. In the Load Application Files dialog box, choose the routine you want to run (make sure that it is the only one selected), and then click Load.
  6. Some LISP routines are created in such a way that you can run them by simply typing the name of the routine, or by typing a keyword, directly in the command bar. If nothing happens when you attempt to run the LISP routine from within the Load Application Files dialog box, turn on the display of the command bar or Prompt History window by choosing View > Command Bar or View > Prompt History Window, and look for an entry that is similar to the following:

Loading D:\path\routine.lsp

C:KEYWORD

  1. where D:\path\routine.lsp is the complete drive, path, and file name of the LISP routine. You may need to scroll back several lines in the command bar or Prompt History window to find the lines indicating where the LISP routine was loaded. You can run the LISP routine by typing the name of the routine or keyword appearing after the C drive designation.
  2. For example, if you loaded a LISP routine named drawbox.lsp and see the designation C:DRAWBOX in the command bar or Prompt History window, you can run the LISP routine by typing drawbox in the command bar.