progeCAD Professional manual The low-cost alternative to AutoCAD

Index



Do you want to try progeCAD Professional?
Download the trial: you can try the product, without any limit, for 30 days!

A manual page a day... Click here to see the manual table of contents.

Customizing progeCAD - Customizing menus

Understanding menu compatibility

MNU files are menu files managed by all AutoCAD releases, and MNS files are included in AutoCAD Releases 13, 14, and 2000. progeCAD reads both file formats, even when menu macros include AutoLISP code. This feature allows you to continue using your existing AutoCAD menus.

progeCAD support of specific sections in AutoCAD MNU and MNS files

Menu section

Definition

progeCAD support

***POP0

Cursor menu

Supported

***POPn

Pull-down menus

Supported

***AUXn

Auxiliary menus

Not supported

***BUTTONn

Button menus

Not supported

***ICON

Icon menus

Not supported

***SCREEN

Screen menus

Not supported

***TABLETn

Tablet menus

Not supported

To see how progeCAD reads AutoCAD menu source files
  1. Type menu and then press Enter.
  2. Under Files Of Type, select AutoCAD Menu File (mnu).
  3. In the Open Menu dialog box, go to the AutoCAD Support folder and select the Acad.mnu file (or Acad.mns for Releases 13, 14, and 2000).
  4. To load the AutoCAD menu file into progeCAD, click Open.

The progeCAD menu bar now looks identical to the AutoCAD menu bar.

  1. To see how it works, choose a few commands from the menu bar, such as File > Open or Draw > Line.