progeCAD Professional manual The low-cost alternative to AutoCAD

Index



Do you want to try progeCAD Professional?
Download the trial: you can try the product, without any limit, for 30 days!

A manual page a day... Click here to see the manual table of contents.

Image

Image commands

Attaching images
  1. When you attach an image to a drawing, the image displays in the drawing but is not saved in the drawing. The image file remains saved in its original location on your computer, network, or other media.
  2. If you send or receive drawings that contain images, it is important to include with the drawing all of the image files attached to it. When you open a drawing that contains images, the source image files must be accessible for the images to display in the drawing.
To attach an image
  1. Do one of the following:
  2. Choose Image > Attach Raster Image.
  3. On the Reference toolbar, click the Image Attach tool (
  4. ).
  • Type imageattach and then press Enter.
  • Specify a file to attach, and then click Open.
  • In Image Path will be Saved As, enter a different image file location, if necessary. You can click [ > ] to choose how you want to save the image path:
  • Full Path -- The image is referenced using its full path, for example, c:\My Pictures\MyImage.jpg. Use this option if the image is saved in a folder unrelated to the current drawing folder.
  • Relative Path -- The image is referenced using a path relative to the current drawing folder, for example, ..\My Pictures\MyImage.jpg. Use this option if the image is stored in a subfolder of the current drawing folder.
  • File Name Only -- The image is referenced using its file name in the current drawing folder, for example, MyImage.jpg. Use this option if the image is saved in the same folder as the current drawing.
  • In the Attach Image dialog box, specify the position, scale, rotation, transparency, and clipping options, and then click OK.
    For the automatic insertion of georeferenced images, use a positioning File (.tfw) that contains all raster attributes like: scale, position and rotation angle. This file should have the same name as the raster file. If it is so and it's placed in the same directory of the image file, it will be viewed in the Positioning File box. To use it in the insertion of the image, select the option Use positioning file. The same option can be used to select a .twf file that doesn't have the same name of the image file or that is in a different path then the image one. With that setting activated, the mask gets updated to reflect the settings related to the tfw file.

NOTE Transparency works for images that support alpha transparency, that is, images that have at least one color that can be viewed as a transparent color.

  1. In the drawing, specify an insertion point, scale, and rotation if you chose to spec-ify those on the screen.
  2.  
    1.  
     
    1. Enter a different image file location, if necessary.
    2. Choose to place the image automatically in the drawing using specifications located in a positioning file. Enter the TWF file associated with the image or click [...] to select it.
    3. Choose to specify the insertion point in the drawing upon insertion, or enter coordinates.
    4. Choose to specify the size of the image in the drawing upon insertion, or enter the size values.
    5. Choose whether to turn clipping display on or off for the image.
    1. Choose whether entities located under the image are visible (for images that support alpha transparency).
    2. Choose to specify rotation in the drawing upon insertion, or enter how many degrees to rotate the image to the left.
    3. Click to view image information, including color depth and resolution.
    4. Choose to save the image path as its full path, relative path to the current drawing folder, or file name in the current drawing folder.
  3. TIP You can also attach images using the Image Manager. Choose Image > Image Management, and then click Attach to specify an image and then attach it, or if you want to quickly add another occurrence of an image already located in the drawing, select the image in the Image Manager and then click Add.
Modifying images
  1. You can modify an image by changing its brightness, contrast, fade, size, rotation, or transparency. These changes affect the image in the drawing only -- not the original image file.
  2. In addition to modifying a single image or multiple images that you select, you can also modify all occurrences of an image within a drawing. For example, if your com-pany logo appears in multiple locations throughout a drawing, you can use the Image Manager to specify the changes once and apply them to all occurrences of the logo.
  3. You can use other progeCAD commands for typical modifications, such as Delete, Move, Layer, and more.
To modify images
  1. Do one of the following:
  2. Choose Image > Image Management.
  3. On the Reference toolbar, click the Image tool (
  4. ).
  • Type image and then press Enter.

TIP You can also modify images by selecting one or more images in a drawing, and then choosing Modify > Properties.

  1. In the Images list, select the image you want to modify. If there is more than one occurrence of the image in the drawing, do one of the following:
  2. To modify all occurrences of the image, select a top-level image in the list.
  3. To modify a single occurrence of the image, expand a top-level image in the list, and then select the individual image.
  4. Adjust the Brightness, Contrast, and Fade by moving the slider to the setting you want or by entering an exact number. The image preview shows how your changes will affect the image.

TIP If you want to restore the image to the default brightness, contrast, and fade settings, click Reset.

  1. Adjust the Size by making changes to the width (X) and height (Y) in drawing units. Mark Keep Aspect Ratio if you want the width and height to change together to retain the aspect ratio of the image.
  2. Adjust the Rotation by entering the number of degrees you want to rotate the image to the left. Zero degrees indicates no rotation.
  3. Mark Use Transparency if you want entities located under the image to be visible (for images that support alpha transparency, that is, images that have at least one color that can be viewed as a transparent color).
  4. Mark Show Clipping Boundary if you want to show the image clipped, if a clip-ping boundary is defined for the image. Unmarking this option displays the whole image, even if a clipping boundary is defined.
  5. Click OK.
  6.  
    1.  
     
    1. Click a top-level image to modify all occurrences located in the drawing. Expand a top-level image and click an individual image to modify that occurrence only.
    2. Move the slider or enter an exact number for image brightness.
    3. Move the slider or enter an exact number for image contrast.
    4. Move the slider or enter an exact number for image fade, which fades the image without displaying entities located under the image.
    1. Click to return to the default brightness, contrast, and fade settings.
    2. Enter the width (X) and height (Y) in drawing units. Mark Keep Aspect Ratio to change width and height together.
    3. Choose whether to turn clipping display on or off for the image.
    4. Choose whether entities located under the image are visible (for images that support alpha transparency).
    5. Enter how many degrees to rotate the image to the left.
Changing the display of images
  1. You can change the following for how all images display in a drawing:
  2. Image quality -- Images can display in high or low resolution.
  3. Image frames -- Images can display with or without frames on their edges.
Changing the display quality for all images
  1. High quality displays images in high resolution and requires more system resources. Draft quality displays images in low resolution and consumes fewer system resources. Changing the quality setting affects all images in the drawing.
To change the display quality for all images
  1. Do one of the following:
  2. Choose Image > Image Quality.
  3. On the Reference toolbar, click the Image Quality tool (
  4. ).
  • Type imagequality and then press Enter.
  • Choose High or Draft.
Turning image frames on or off for all images
  1. When an image border is set to 0 it will not be printed or visualized, setting to1, it will be printed and visualized while, setting to 2 it will be visualized but not printed . Each image frame dis-plays with the properties (layer, color, linetype, etc.) that are assigned to the image.
  2. Turning image frames off may be helpful, for example, if the images are part of a background in the drawing.
To turn image frames on or off for all images
  1. Do one of the following:
  2. Choose Image > Display Image Frame.
  3. On the Reference toolbar, click the Image Frame tool (
  4. ).
  • Type imageframe and then press Enter.
  • Choose an option.
Clipping images
  1. You can clip images so that only a portion of the image is visible in a drawing. The visible portion can be in the shape of a rectangle or polygon.
  2. Image clipping can be turned on an off. If you turn off clipping for an image, the entire image is visible provided that the image is on a layer that is on and thawed. The clipping information is retained however, and you can turn clipping back on at any time.
  3. If you delete clipping from an image, the clipping is removed permanently but the image itself remains in the drawing.
To clip an image in the shape of a rectangle
  1. Make sure that image frames are turned on (option 1).
  2. Do one of the following:
  3. Choose Image > Clip Image.
  4. On the Image toolbar, click the Image Clip tool (
  5. ).
  • Type imageclip and then press Enter.
  • Select the edge of the image you want to clip.
  • Choose New to create a new clipping boundary.
  • Choose Rectangle.
  • Define the first corner of the clipping rectangle.
  • Define the opposite corner of the clipping rectangle.
    Only the portion of the image located within the clipping rectangle is visible..
  1.  
To clip an image in the shape of a polygon
  1. Make sure that image frames are turned on (option 1).
  2. Do one of the following:
  3. Choose Image > Clip Image.
  4. On the Reference toolbar, click the Image Clip tool (
  5. ).
  • Type imageclip and then press Enter.
  • Select the edge of the image you want to clip.
  • Choose New to create a new clipping boundary.
  • Choose Polygonal.
  • Select the points for the polygon, and then press Enter to close the polygon.
    Only the portion of the image located within the clipping polygon is visible.
To turn clipping on or off for an image
  1. Make sure that image frames are turned on (option 1).
  2. Do one of the following:
  3. Choose Image > Clip Image.
  4. On the Reference toolbar, click the Image Clip tool (
  5. ).
  • Type imageclip and then press Enter.
  • Select the edge of the image for which you want to turn clipping on or off.
  • Choose On or Off.
To remove clipping from an image
  1. Make sure that image frames are turned on (option 1).
  2. Do one of the following:
  3. Choose Image > Clip Image.
  4. On the Reference toolbar, click the Image Clip tool (
  5. ).
  • Type imageclip and then press Enter.
  • Select the edge of the image for which you want to remove clipping.
  • Choose Delete.
Unloading and reloading images
  1. If you find that including an image affects system performance, you can unload it so only the image frame displays to mark its location. If you want an unloaded image to print, reload it before printing. You may also want to reload an image if the original file contains new content.
To unload and reload an image
  1. Do one of the following:
  2. Choose Image > Image Management.
  3. On the Reference toolbar, click the Image tool (
  4. ).
  • Type image and then press Enter.
  • In the Images list, select the desired image. If there is more than one occurrence of the image in the drawing, do one of the following:
  • To unload or reload all occurrences of the image, select a top-level image in the list.
  • To unload or reload a single occurrence of the image, expand a top-level image in the list, and then select the individual image.
  • Do one of the following:
  • To unload the image so only its outer edge displays, click Unload.
  • To reload the image so its contents display and print, click Reload.
Changing the path for images
  1. If the file associated with an image is renamed or moved to a different location, the program displays a message indicating that it cannot load the image. You can re-establish the link to the file by changing the path for the image.
To change the path for an image
  1. Do one of the following:
  2. Choose Image > Image Management.
  3. On the Reference toolbar, click the Image tool (
  4. ).
  • Type image and then press Enter.
  • In the Images list, select the desired image. If there is more than one occurrence of the image in the drawing, do one of the following:
  • To change the path for all occurrences of the image, select a top-level image in the list.
  • To change the path for a single occurrence of the image, expand a top-level image in the list, and then select the individual image.
  • Click the [...] button.
  • Select the file with its new name or in its new location, and then click Open.
  • Click Set Path.
Deleting images
  1. Once an image is no longer required in the drawing, you can delete it from the draw-ing. Deleting an image removes it from the drawing, and from the list of images in the Image Manager dialog box.
To delete an image
  1. Do one of the following:
  2. Choose Image > Image Management.
  3. On the Reference toolbar, click the Image tool (
  4. ).
  • Type image and then press Enter.
  • In the Images list, select the image you want to delete. If there is more than one occurrence of the image in the drawing, do one of the following:
  • To delete all occurrences of the image, select a top-level image in the list.
  • To delete a single occurrence of the image, expand a top-level image in the list, and then select the individual image.
  • Click Detach.
Draw Order command
  1. The draw order commands allow you to arrange the images and entities in your drawing. When multiple entities overlap, you can change the order in which they are displayed and printed. You can move entities to the front, back, or on top or below of another entity.
To reorder entities
  1. Do one of the following:
  2. Choose Image > Draw Order.
  3. Type draworder and then press Enter.
  4. Select the entity you want to reorder, and then press Enter.
  5. In the prompt box, specify the new drawing order, and then press Enter:
  6. Front, brings the selected image(s) to the front of the display. On the Draw Order toolbar, the Bring to Front tool (
  7. ) .
  • Back, sends the selected image(s) behind all other drawing elements. On the Draw Order toolbar, the Send to Back tool (
  • ) .
  • Upper, select the object respect which it must be put as first.
  • Down, select the object respect which it must be put as second.
Correlate Command
  1. Create Correlation command applies a linear correlation to align a raster image to a vectorial drawing or another image, setting insert point, scale and rotation.
  2. To adapt an image to a drawing pick two source points and two destination points; these are used as reference points to stretch the image corresponding to the drawing.
  3. The next sample show as you can create a correlation between a vectorial drawing, a building plant and a raster image a map that shown the building context.
  4.  
To Create a Correlation
  1. Do one of the following:
  2. Choose Image > Image Correlate.
  3. On the Reference toolbar, click the Image Correlate tool (
  4. ).
  • Type imatch and then press Enter.
  • Select the raster image that you want to use for the corresponding.
  • Specify the reference points marked as 1 and 2 on the raster image.
  •  
  • Specify the source points marked as 1 and 2 on the vectorial image.
  •  
  •  
  •  
  •  
  •  
  •  
  •