progeCAD Professional manual The low-cost alternative to AutoCAD

Index



Do you want to try progeCAD Professional?
Download the trial: you can try the product, without any limit, for 30 days!

A manual page a day... Click here to see the manual table of contents.

Working with other programs - Using progeCAD data in other programs

Embedding drawings

When you embed an progeCAD drawing, it becomes part of the other program's document file. When you edit the drawing, you edit only the version that is embedded in the other document.

Embedding is useful when you don't want to maintain a link to the progeCAD drawing for the data you include in the other document. Edits made to the new drawing do not affect the original drawing. To transfer the file to other computers, you can transfer all the data in one file, but embedded objects increase the file size.

From within a document in a program that supports ActiveX, such as Microsoft Word, you can either create a new embedded progeCAD drawing or embed an existing progeCAD drawing.

To create an progeCAD drawing in another document
  1. In the document, choose Insert > OLE Object (or the equivalent command for that program).
  2. In the dialog box, click the options for creating a new file.
  3. Under Object Type, choose progeCAD Drawing, and then click OK.
  4. Create the progeCAD drawing.
  5. If progeCAD is running in its own window, choose File > Exit.

If progeCAD is running within the other document (in place), click somewhere in the document outside the progeCAD drawing to close progeCAD.

  1. To edit the progeCAD drawing from within the document, double-click the drawing.
  2. NOTE You can also embed an existing progeCAD drawing from within another document. Follow step 1 in the preceding procedure, and then click the option for creating an object from an existing file.
To embed selected progeCAD entities
  1. In progeCAD, select the entities you want to embed.
  2. Choose Edit > Copy (or press Ctrl+C).
  3. Open the document in which you want to embed the entities.
  4. Choose Edit > Paste (or the equivalent command).
To embed an entire progeCAD drawing
  1. Open the document in which you want to embed the drawing.
  2. Choose Insert > OLE Object.
  3. Click Create From File.
  4. Click Browse, and then choose the file you want to embed.
  5. Click Insert, and then click OK.