progeCAD Professional manual The low-cost alternative to AutoCAD

Index



Do you want to try progeCAD Professional?
Download the trial: you can try the product, without any limit, for 30 days!

A manual page a day... Click here to see the manual table of contents.

Working with other programs - Using data from other programs in progeCAD drawings

Linking objects to drawings

If another program supports ActiveX, you can link its data to progeCAD drawings. Use linking when you want to include the same data in many files. When you update the data, all links to other files reflect the changes.

For example, if you created your company logo in an ActiveX-compatible drawing program, and you want to include it in the title block of every drawing you create with progeCAD, you can link it to each progeCAD drawing. When you change the original logo in the drawing program, the progeCAD drawing updates automatically.

When you link data from another program, the progeCAD drawing stores only a reference to the location of the file in which you created the data. You link data from a saved file, so progeCAD can find the data and display it.

Because linking adds only a reference to a file, the data does not significantly increase the file size of the progeCAD drawing. However, links require some maintenance. If you move any of the linked files, you need to update the links. In addition, if you want to transport linked data, you must include all linked files.

You can update a linked object automatically every time you open the drawing, or you can do so only when you specify. Anytime a link is updated, changes made to the object in its original file also appear in the progeCAD drawing, and the changes also appear in the original file if they were made through progeCAD.

To link a file to an progeCAD drawing
  1. Save the original file.

Because a link consists of a reference to the original file, you must save the file before you can link to it.

  1. In the original file, select the data you want in the progeCAD drawing.
  2. Choose that program's command to place data on the Clipboard.

Usually, you choose Edit > Copy.

  1. Display the progeCAD drawing to which you want to link the file.
  2. In progeCAD, choose Edit > Paste Special.
  3. In the Paste Special dialog box, select Paste Link.
  4. Click OK.
To create a linked object from within progeCAD
  1. Display the progeCAD drawing in which you want to display the linked object.
  2. Choose Insert > OLE Object.
  3. On the Insert toolbar, click the OLE Object tool (
  4. ).
  • Type insertobj and then press Enter.
  • In the Insert Object dialog box, click Create From File.
  • Specify the file by doing one of the following:
  • Type a path and file name in the File box.
  • Click Browse to select the file using a file dialog box.
  • Select the Link check box.
  • Select Display As Icon if you want that program's icon to appear in the drawing instead of the data.
  • Click OK.

The first page appears in the progeCAD drawing, unless you chose to display it as an icon. To reposition the object, select and drag it.