progeCAD Professional manual The low-cost alternative to AutoCAD

Index



Do you want to try progeCAD Professional?
Download the trial: you can try the product, without any limit, for 30 days!

A manual page a day... Click here to see the manual table of contents.

Working with other programs - Using data from other programs in progeCAD drawings

Embedding objects into drawings

Embed an object into your progeCAD drawing when you want to keep all the data you work with in one file or if you want to transfer the file to other computers. You can embed data from programs that support object linking and embedding.

For example, if you want to distribute data about a department's computer equipment along with an progeCAD drawing of the department's floor plan, you can embed a Microsoft Excel spreadsheet into the floor plan.

When you embed data from another program, progeCAD becomes the container for that data. The object embedded in the progeCAD drawing becomes part of the progeCAD file. When you edit the data, you open its program from within the progeCAD drawing.

Any changes you make to the embedded data exist only in the progeCAD drawing, so it is not necessary to keep that data in a separate file. If the data does exist in a separate file, the original file does not change when you modify the embedded object in progeCAD. Also, changes to the original file do not affect the embedded object in the progeCAD drawing.

To embed another program's object into an progeCAD drawing
  1. Open the file that contains the data you want.
  2. In the file, select the data you want to embed in the progeCAD drawing.
  3. Choose that program's command to place data on the Clipboard.

Usually, you choose Edit > Copy.

  1. In the progeCAD window, display the drawing in which you want to embed the object.
  2. Choose Edit > Paste, or click the Paste tool (
  3. ) on the Standard toolbar.

The data on the Clipboard is pasted into the drawing as an embedded object. The object appears in the center of the view, but you can select and move it by moving the cursor.

To embed an object from an existing file within progeCAD
  1. Do one of the following:
  2. Choose Insert > OLE Object.
  3. On the Insert toolbar, click the OLE Object tool (
  4. ).
  • Type insertobj and then press Enter.
  • In the Insert Object dialog box, click Create From File.
  • Specify the file by doing one of the following:
  • Type a path and file name in the File box.
  • Click Browse to select a file.
  • Select Display As Icon if you want that program's icon to appear in the drawing instead of the data.
  • Click OK.

The first page of the file appears in the progeCAD drawing, unless you chose to display it as an icon. You can select the object and drag to reposition it.

To create a new embedded object from within progeCAD
  1. Do one of the following:
  2. Choose Insert > OLE Object.
  3. On the Insert toolbar, click the OLE Object tool (
  4. ).
  • Type insertobj and then press Enter.
  • In the Insert Object dialog box, click Create New.
  • From the Object Type list, select the type of object you want to create, and then click OK.

The program for creating that object opens within progeCAD. If the program is compatible with ActiveX, it opens in place (within the other program) in the progeCAD drawing; otherwise, the program opens in its full window.

  1. Create the object in the other program.
  2. If the program is running within the other document (in place), click anywhere outside the embedded object to close the program.

If the program is running in its full window, choose File > Exit.