progeCAD Professional manual The low-cost alternative to AutoCAD

Index



Do you want to try progeCAD Professional?
Download the trial: you can try the product, without any limit, for 30 days!

A manual page a day... Click here to see the manual table of contents.

Drawing in three dimensions

Hiding, shading, and rendering

As you create three-dimensional entities, the program displays both wire-frame and surface models in wire-frame view, which makes it difficult to visualize your three-dimensional models. To better visualize the model, you can remove all the lines that are hidden behind other entities or surfaces when seen from the current viewpoint.

Shading goes a step further by removing hidden lines and then assigning flat colors to the visible surfaces, making them appear solid. Shaded images are useful when you want to quickly visualize your model as a solid object, though they lack depth and definition.

Rendering provides an even more realistic image of your model, complete with light sources, shadows, surface material properties, and reflections, giving your model a photo-realistic look. As shown in the following illustrations, when you render a model, the program removes hidden lines and then shades the surfaces as though they were illuminated from imaginary light sources.

 

 

 

 

 

 

 

 

Wire-frame model.

 

Hidden-line image.

 

Shaded image.

 

Rendered image.

Creating hidden-line images
  1. Creating a hidden-line view of your drawing removes all the lines that are hidden behind other surfaces when seen from your vantage point. When you remove hidden lines or shade a model, the program treats the entities differently, depending on how you created them. Wire-frame models always appear transparent, because they have no surfaces. Surface models appear filled, with surfaces applied to all visible sides.
To create a hidden-line image
  1. Do one of the following:
  2. Choose View > Hide.
  3. On the Render toolbar, click the Hide tool (
  4. ).
Type hide and then press Enter.
 

 

 

Before creating a hidden-line image.

 

After removing hidden lines.

Creating shaded images
  1. Creating a shaded image of your drawing removes hidden lines and then applies shading to the visible surfaces based on their entity color. Because they are intended to provide a quick visualization, shaded images do not have a light source and use continuous colors across surfaces, causing them to appear flat and unrealistic.
To create a shaded image
  1. Do one of the following:
  2. Choose View > Shade and select shading mode do you want.
  3. On the Shade toolbar, click the Shade Highlighting Outline tool (
  4. ).
Type shade and then press Enter.
  1. To control the appearance of the shaded image, choose Tools > Drawing Settings, and then click the 3D Settings tab and select the options you want. You can shade the surfaces and edges of the model in four ways:
  2. Faces shaded; edges not highlighted.
  3. Faces shaded; edges highlighted in the background color.
  4. Faces filled in the background color; edges drawn using the entity color (similar to a hidden-line view).
Faces filled using the entity color; edges highlighted in the background color.
Creating rendered images
  1. Creating a rendered image of your drawing removes hidden lines and then shades the surface as though it were illuminated from multiple light sources.
  2. Full rendering creates a photo-realistic image of your model, complete with light sources, shadows, surface material properties, and reflections. You can illuminate your image with spotlights, distant lighting to simulate sunshine, and ambient light. If you choose not to customize the light sources, the program generates default light sources for you.
  3. Rays from these imaginary light sources are traced as they reflect off and refract through the surfaces of the model, a process called ray tracing. Ray tracing determines where shadows fall and how reflections on shiny materials such as metal and glass appear. You can modify the reflective properties of the materials that make up your model to control how the light rays reflect off its surfaces.
  4. Full rendering automatically creates a base on which your model is displayed, if you don't already have one, so it does not appear suspended in space. A background is also automatically added to the image. A background such as a cloudy sky or an imported raster graphic such as a stone wall can also be added behind the image, making it even more realistic.
To create a quickly rendered image
  1. Do one of the following:
  2. Choose View > Render > Render.
  3. On the Render toolbar, click the Render tool (
  4. ).
Type render and then press Enter.
To create a fully rendered image
  1. Do one of the following:
  2. Choose View > Render > Full Render.
  3. On the Render toolbar, click the Full Render tool (
  4. ).
Type fullrender and then press Enter.
  1. Note For more information, See Render..
 

Fully rendered image.

Creating custom rendered images
  1. progeCAD allows you to create custom rendered images by applying materials, backgrounds, and lighting (including shadows) to your drawing:
  2. Materials Specify materials for different surfaces and define how the materials map to those surfaces. Predefined materials are available in the materials library, which can be customized further using the built-in editor. You can choose to use procedural or bitmap materials.
  3. Backgrounds Specify the background or backdrop for a rendered image. Several predefined backgrounds are available. By default, no background is used and it appears black. The background is an infinite, planar surface and reflects off of any reflective surfaces in your model. The background is not affected by lighting however, so no shadows or highlights are seen on the background.
  4. Lighting Specify the placement of lights, light color, and light intensity to determine how your drawing or scene is lit, including shadows and reflections in the scene. Lights can be placed either outside the field of view or inside to illuminate different areas of the scene. Several predefined lighting controls are available, including ambient lighting, diffuse lighting, specular reflections, specular highlights, and transparency.
To apply materials, backgrounds, and lighting
  1. Do one of the following:
  2. Choose View > Render, and then choose Materials, Background, or Ligh.
  3. On the Render toolbar, click the Materials tool (
  4. ), Background ( ), or Lights tool ( ).
  • Type materials, backgrounds, or lighting and then press Enter.
  • Make your selections.
  • NOTE You can specify additional options by choosing View > Render > Preferences. For more information about creating custom rendered images, click Help in any of the Render dialog boxes.
Printing a rendered image
  1. You cannot print a rendered image directly to a printer. Instead, you must first save the drawing to a different format -- either a bitmap (.bmp), JPEG (.jpg), TIFF (.tif), TrueVision TGA (.tga), or Portable Network Graphic (.png). After you save a rendered image, you can print it from another graphics program.
To save a rendered image of your drawing
  1. Create a rendered image of the drawing.
  2. Do one of the following:
  3. Choose View > Render > Preferences.
  4. On the Render toolbar, click the Render Preferences tool (
  5. ).
  • Type setrender and then press Enter.
  • On the Rendering tab, click Save Last Image.
  • Enter a file name and path.
  • In Save As Type, choose the file format.
  • Click Save.