progeCAD Professional manual The low-cost alternative to AutoCAD

Index



Do you want to try progeCAD Professional?
Download the trial: you can try the product, without any limit, for 30 days!

A manual page a day... Click here to see the manual table of contents.

Printing drawings - Customizing print options

Setting the scale and view

You can print or plot the entire drawing or a selected portion, depending on which options you select in the Print dialog box. You can choose to print what is visible on the screen, or you can specify to print an area of the drawing.

You can control the position of the drawing on the paper by specifying the origin of the print area, the location of the lower left corner of the print area, in relation to the lower left corner of the paper. The origin is normally set to 0,0, which places the lower left corner of the print area as close to the lower left corner of the paper as the printer or plotter will allow. You can specify a different origin.

When you create a drawing, you generally draw entities full-size. When you print the drawing, you can specify the scale of the resulting print or let the program adjust the size of the drawing to fit the paper. To print the drawing at a specific scale, specify the scale as a ratio of drawing units to printed units.

If you are printing from a Layout tab, the scale and view options you specify can be different for each layout that you create.

To automatically scale the drawing for printing
  1. If necessary, click the desired Layout tab or the Model tab.
  2. Do one of the following:
  3. Choose File > Plot.
  4. On the Standard toolbar, click the Plot tool (
  5. ).
  • Type print and then press Enter.
  • Click the Scale/View tab.
  • To scale the drawing to fit on one printed page, in Print Scale, select Scale to Fit.
  • Select Save Changes to Layout, and then click Apply to save your changes.
To specify the scale factor yourself
  1. If necessary, click the desired Layout tab or the Model tab.
  2. Do one of the following:
  3. Choose File > Plot.
  4. On the Standard toolbar, click the Plot tool (
  5. ).
  • Type print and then press Enter.
  • Click the Scale/View tab.
  • In Print Scale, do one of the following:
  • Select a pre-defined scale. For example, choose 1:2 if you want 1 printed unit (inch or millimeter) to equal 2 drawing units.
  • Select Custom, and then under User Defined Scale, type the ratio of printed units of measure (inches or millimeters) to drawing units.
  • To specify the printed units of measure, click Inches or Millimeters.
  • Select Save Changes to Layout, and then click Apply to save your changes.
To specify a portion of the drawing to print
  1. If necessary, click the desired Layout tab or the Model tab.
  2. Do one of the following:
  3. Choose File > Plot.
  4. On the Standard toolbar, click the Plot tool (
  5. ).
  • Type print and then press Enter.
  • Click the Scale/View tab.
  • Under Print Area, click one of the following:
  • Current View - prints the view on the screen.
  • Saved View - prints the selected saved view.
  • Extents - prints the area that contains entities in the drawing.
  • Limits - prints to the limits defined for the layout or drawing.
  • Window - prints the portion of the drawing contained in the specified window, maintaining the aspect ratio of the windowed area to the drawing.

If you clicked Window, you must specify the window. Under Windowed Print Area, enter the diagonal x- and y-coordinates of the window, or select the area on the screen.

To print only the area in the window without considering whether there is extra space on the screen, select the Print Only Area Within Specified Window check box.

  1. Under Entities To Print, click one of the following:
  2. All Entities Within Print Area - prints all drawing entities contained within the specified print area.
  3. Selected Entities Within Print Area - prints only the entities you select from within the specified print area.
  4. Select Save Changes to Layout, and then click Apply to save your changes.
  5.  
    1. Displays either "Model" or the layout name to which the print settings apply.
    2. Click to select the area of the drawing that you want to print.
    3. Type the x- and y-coordinates of the two opposing corners of the rectangular area to print; or, to specify coordinates in the drawing window, click Select Print Area.
    4. Select to print the area of the window while ignoring the aspect ratio to the remainder of the drawing.
    5. Click to specify drawing units and paper size in millimeters or inches.
    1. Specify the custom scale for the print area by typing the ratio of drawing units to printed inches or printed millimeters. (Available only if Custom is selected for Print Scale.)
    2. Select to fit the specified print area to the current paper size select a scale ratio, or select to specify your own custom scale in User Defined Scale.
    3. Click to print only selected entities within the specified print area.
    4. Click to print all entities within the specified print area.
    5. Select to save the print settings for the model or layout.
    6. Select to print using the current print settings or using the settings from the last time you printed.
  6. NOTE progeCAD saves your print settings each time you print. To restore the progeCAD default print settings, click Reset in the Print dialog box.
To specify the print area origin
  1. If necessary, click the desired Layout tab or the Model tab.
  2. Do one of the following:
  3. Choose File > Plot.
  4. On the Standard toolbar, click the Plot tool (
  5. ).
  • Type print and then press Enter.
  • Click the Advanced tab.
  • Under Print Offset, do one of the following:
  • To center the specified print area on the printed page, select the Center on Page check box.
  • To specify an origin for the print area, type the x- and y-offset.
  • Select Save Changes to Layout, and then click Apply to save your changes.