progeCAD Professional manual The low-cost alternative to AutoCAD

Index



Do you want to try progeCAD Professional?
Download the trial: you can try the product, without any limit, for 30 days!

A manual page a day... Click here to see the manual table of contents.

Printing drawings - Defining layouts for printing - Type s or press Enter to scroll through the layouts.

Working with layout viewports

When you begin working in a drawing on the Model tab, it consists of a single view of your model. You may have created additional views by dividing the drawing space into multiple windows; each window is a separate viewport on the Model tab.

On a Layout tab, you must create at least one layout viewport to see your model. However, you can create multiple layout viewports that display unique views of your model located in model space. Each layout viewport functions as a window into your model space drawing -- with each window looking different from the next. You can customize the view center, scale, layer visibility, and contents of each layout view-port. Each layout viewport is created as a separate entity that you can move, copy, or delete.

Click any layout viewport to make it the current viewport, and then add or modify model space entities in that viewport, even while snapping to model space entities from paper space. Any changes you make in one layout viewport are immediately visible in the other viewports (if the other layout viewports are displaying that portion of the drawing). Zooming or panning in the current viewport affects only that viewport.

This section focusses on working with layout viewports in paper space on a Layout tab. For additional information about viewports in model space, See Dividing the current window into multiple views.

Creating layout viewports
  1. The first time you switch to a Layout tab, all of your model space entities disappear. You must create at least one layout viewport on the Layout tab to see your work.
  2. You can create layout viewports anywhere inside the drawing area. You can control the number of viewports created and the arrangement of the viewports.
To create layout viewports
  1. Do one of the following:
  2. Choose View > Viewports.
  3. On the Layouts toolbar, click the Viewports tool (
  4. ).
  • Type mview and then press Enter.
  • In the prompt box, choose Fit To View, Create 2 Viewports, Create 3 Viewports, or Create 4 Viewports, or specify two opposing corners to create a custom viewport.
  • In the prompt box, choose the viewport orientation.
  • Do one of the following:
  • To arrange the viewports to fill the current graphic area, in the prompt box, choose Fit To Screen.
  • To fit the viewports within a bounding rectangle, specify the corners of a rectangle.
  • TIP When you create a layout viewport, the layout viewport border is created on the current layer. You can make layout viewport borders invisible by creating a new layer before you create layout viewports and then turning off that layer after you create the layout viewports. To select a layout viewport's borders, you must turn that layer back on before you can rearrange or modify the layout viewport.
 

You can create a single layout viewport, or you can divide the graphic area into two viewports arranged vertically ( A ) or horizontally ( B ); three viewports arranged left ( C ), right ( D ), above ( E ),
below ( F ), vertically ( G ), or horizontally ( H ); or four viewports ( I ).

Poligonal viewport
  1. Using the Object option you can select some closed entities, such as a circle or a closed polyline created in paper space, and trasform it in a layout viewport
To create a poligonal viewport
  1. Draw a circle or a closed polyline
  2. Do one of the following:
  3. Choose View > Viewports> Object.
  4. Type mview, press Enter and choose Object option.
  5. On the Viewports toolbar, click Object tool (
  6. ).
  1. Select the drawn object.
Viewing and scaling layout viewports
  1. If you have created numerous layout viewports, your system performance may be affected. If necessary, you can turn a layout viewport on or off. Turning off a layout viewport does not delete the viewport or its contents; it simply turns off its display.
  2. You can also change how you view items within a layout viewport by specifying a scale factor, which changes how large or small model space entities appear within the layout viewport.
To turn layout viewports on or off
  1. Click the desired Layout tab.
  2. Do one of the following:
  3. Choose View > Viewports.
  4. On the Layouts toolbar, click the Viewports tool (
  5. ).
  • Type mview and then press Enter.
  • Choose On or Off.
  • Select the edge of the layout viewport to turn on or off, and then press Enter.
To change the layout viewport scale
  1. Type entprop and then press Enter.
  2. Select the edge of the layout viewport.
  3. In Scale, enter the scale at which you want to view model space entities from within the layout viewport.
  4. Click OK.
To change the scale of model space entities relative to paper space
  1. Click the Model tab.
  2. Click a viewport to make it current.
  3. Choose View > Zoom > Zoom.
  4. On the Zoom toolbar, click the Zoom Scale tool (
  5. ).
  1. Type the zoom scale factor relative to paper space by appending the suffix xp to the scale factor, and then press Enter.

For example, to increase the scale of the entities in the viewport on the Model tab to twice the size of paper space units, type 2xp. To decrease the scale to half the size of paper space units, type .5xp.

Modifying layout viewports
  1. After you create layout viewports, you can modify them as needed. On the Layout tab, you can snap to the viewport borders using entity snaps. You can also copy, delete, move, scale, and stretch layout viewports as you would any other drawing entity.
  2. Additionally, you can lock a layout viewport so the viewport scale and view center do not change in model space while panning or zooming in the layout viewport. If you are working on model space entities from a Layout tab, locking the layout viewport prevents you from constantly changing the layout viewport scale and view center.
  3. And assigning a UCS to each viewport allows you to quickly switch between layout viewports and immediately draw in a different UCS. This can greatly increase pro-ductivity, especially when creating complex 3D models.
  4. Modifying a layout viewport on a Layout tab does not affect the model space entities within the layout viewport.
To modify layout viewport properties
  1. Type entprop and then press Enter.
  2. Select the edge of the layout viewport you want to modify.
  3. Adjust the center point, width, or height of the viewport.
  4. In Scale, enter the scale at which you want to view model space entities from within the layout viewport.
  5. Mark Lock Viewport to lock the viewport scale and view in model space while panning or zooming in the layout viewport.
  6. Mark UCS per Viewport if you want to use a unique UCS for each layout view-port.
  7. Click OK.
  8. Note You can select only layout viewports for modification. If you click a viewport on the Model tab, it makes that viewport active, not available for modification.
  1. Modifying view mode in a layout viewport

It's possible to set a different view mode for every Viewport in the Paper Space.

To modifying view mode in a layout viewport
  1. Click the desired Layout tab.
  2. Type entprop and then press Enter
  3. Select the edge of the layout viewport you want to modify.
  4. Select the desired View mode from the Vis. Type list (2D is set by default).
  5. Press Ok to confirm.
  6.  

     
    1. Enter the center point of the layout viewport.
    2. Enter the width of the layout viewport.
    3. Enter the height of the layout viewport.
    4. Enter the scale used for viewing model space entities from within the layout viewport.
    5. Select the visualization type.
    1. Mark to use a unique UCS for each layout viewport.
    2. Mark to lock the viewport scale and view in model space while panning or zooming in the layout viewport.
    3. Click to select the center of the layout viewport in the drawing.