progeCAD Professional manual The low-cost alternative to AutoCAD

Index



Do you want to try progeCAD Professional?
Download the trial: you can try the product, without any limit, for 30 days!

A manual page a day... Click here to see the manual table of contents.

- Working with blocks

In-place block edit

In the previous progeCAD versions to modify and therefore replace all the occurrences inserted in a block drawing, it was needed to explode it, make the changes, and make it up again with the same name to redefine it.

Now it's possible to modify the block definition directly in the current drawing using the options of local modification.

Using the option of local modification, it's possible to modify it staying in the visual contest of the current drawing.

At the modification time a toolbar is displayed: Refedit. Using the toolbar buttons, it's possible to add or remove objects of the working group and delete or save the modifications made to the reference.

The group of the objects extracted from the block, is displayed as usual, while all the other objects, included the ones of the current drawing, and are displayed with less intensity.

During the local modification of a block it's possible to add or remove objects from the working group. If a new object is created during the local modification of a reference, that object is almost always automatically added to the working group. The objects that are not added to the working group are displayed in the drawing with a reduced intensity.

To modify a local block
  1. Do one of the following:
  2. Choose Tools > In-place Block Edit > Edit Reference and then select the block.
  3. Double click on the block to modify.
  4. Type refedit and press Enter key, then select the block.
  5. Modify the working group objects then click on the icon Save changes (
  6. ).
    The objects of the working group will be saved in the block and the occurrences of the same drawing will be updated.
To add objects to a block
  1. Do one of the following:
  2. Choose Tools > In-place Block Edit > Edit Reference and then select the block.
  3. Double click on the block to modify.
  4. Type refedit and press Enter key, then select the block.
  5. Do one of the following:
  6. If the objects to be added don't exist yet it's enough to create them. They will be display with the same intensity of the ones that are part of the working group.
  7. Instead, if the objects are present in the drawing but displayed with less intensity compared to the ones that are part of the working group , click on the icon Add objects (
  8. ), select the objects to be added and press Enter.
  1. Click on the icon Save changes (
  2. ).
    The block occurrences in the drawing will be updated.
To remove the object from a block
  1. Do one of the following:
  2. Choose Tools > In-place Block Edit > Edit Reference and then select the block.
  3. Double click on the block to modify.
  4. Type refedit and press Enter key, then select the block.
  5. Do one of the following:
  6. If the objects must be removed from the block definition but not from the position in which they are in the local block occurrence that gets changed, click on the icon Remove objects (
  7. ), select the objects to be removed and press Enter.
  • If the objects have to be completely removed from the block definition and from the drawing, select the objects and press Canc.
  • Click on the icon Save changes (
  • ).
    The block occurrences in the drawing will be updated.
To delete the block local change
  1. Do one of the following:
  2. Choose Tools > In-place Block Edit > Edit Reference and then select the block.
  3. Double click on the block to modify.
  4. Type refedit and press Enter key, then select the block.
  5. Modifying the objects of the working group.
  6. Click on the icon Discard changes (
  7. ).