progeCAD Professional manual The low-cost alternative to AutoCAD

Index



Do you want to try progeCAD Professional?
Download the trial: you can try the product, without any limit, for 30 days!

A manual page a day... Click here to see the manual table of contents.

Modifying entities - Copying entities

Copying between drawings

You can use the Clipboard to cut or copy entities from one drawing to another. Cutting removes the selected entities from a drawing and stores them on the Clipboard. Copying duplicates the selected entities from a drawing and places them on the Clipboard.

To cut entities to the Clipboard
  1. Select the entities you want to cut.
  2. Do one of the following:
  3. Choose Edit > Cut.
  4. On the Standard toolbar, click the Cut to Clipboard tool (
  5. ).
  • Type cutclip and then press Enter.
To copy entities to the Clipboard
  1. Select the entities you want to copy.
  2. Do one of the following:
  3. Choose Edit > Copy.
  4. On the Standard toolbar, click the Copy tool (
  5. ).
  • Type copyclip and then press Enter.
  • Anything that you can copy to the Clipboard can be pasted into a drawing. The format in which the program adds the Clipboard contents to the drawing depends on the type of information in the Clipboard. For example, if you copy progeCAD drawing entities to the Clipboard, the program pastes them into the drawing as progeCAD entities. If you copy objects to the Clipboard from other programs, they are pasted into the current drawing as embedded ActiveX objects.
Copy Quick
  1. You can use the new command Copy Quick to copy a great number of objects from one progeCAD drawing to another. It's a progeCAD version of the standard Copy, which is very useful when you have to copy quickly a lot of objects. You can use it only with progeCAD drawings. Both the original file that contains the objects you want to copy and the destination file where objects will be copied must be opened.
To make a quick copy
  1. Do one of the following
  2. Select Edit > Copy Quick
  3. Use the keyboard shortcut CTRL+D
  4. Select objects in the file of origin.
  5. Click the destination drawing Tab to make it current.
  6. Select Paste from the menu Edit or press CTRL+V.
  7. In the Edit menu you can find both Copy Quick and Copy Quick with base point (CTRL+SHIFT+D). With this command option you can indicate quickly a base point for the copy.
  8.  
  1. The Edit menu contains all the principal functions of Copy/Paste.
  2. Note: To copy objects in the same drawing it's better to use Copy (alias CP) from the Modify menu or the toolbar.
To paste entities from the Clipboard
  1. Do one of the following:
  2. Choose Edit > Paste.
  3. On the Standard toolbar, click the Paste from Clipboard tool (
  4. ).
  • Type pasteclip and then press Enter.
To paste as a block the copied objects
  1. Do one of the following:
  2. Select Edit > Paste as Block.
  3. Bring to an end all active commands, right click in the working area and choose Paste as Block from the context menu.
  4. Type pasteblock and then press Enter.
  5. The objects copied in Notepad will be pasted as a block in the insertion point specified in the drawing.
  6.  
  1. In the Insert Block mask, set the position and dimensions of the block. If the Position block when inserting box is checked, the insertion point coordinates, scale factor and rotation angle can be specified directly on the screen during block insertion.