progeCAD Professional manual The low-cost alternative to AutoCAD

Index



Do you want to try progeCAD Professional?
Download the trial: you can try the product, without any limit, for 30 days!

A manual page a day... Click here to see the manual table of contents.

Working with the progeCAD Explorer - Working with blocks and external references

Creating and naming blocks

You can combine any number of entities into a single block. After you create a block, you can insert copies of it into a drawing. Each block insertion is treated as a single entity; for example, you can rotate or scale each block when you insert it. The program adds the name of the new block you insert to the Block Name list in the progeCAD Explorer.

To create a block
  1. Do one of the following:
  2. Choose Format > Explore Blocks.
  3. Type expblocks and then press Enter.
  4. Do one of the following:
  5. Choose Edit > New > Block.
  6. On the progeCAD Explorer toolbar, click the New Item tool (
  7. ).
  1. Enter a name for the new block.
  2. Specify the insertion point for the block.
  3. Select the entities to be combined into the block, and then press Enter.

The program adds a new block to the blocks list, with the name you entered for it.

  1. To complete the command and return to your drawing, close the window.
To change a block name in the current drawing
  1. Do one of the following:
  2. Choose Format > Explore Blocks.
  3. Type expblocks and then press Enter.
  4. Do one of the following:
  5. Select the block, choose Edit > Rename, type a new name, and then press Enter.
  6. Click the block name you want to change, type a new name, and then press Enter.
  7. Right-click the block name you want to change, and from the shortcut menu, select Rename, type a new name, and then press Enter.
  8. To complete the command and return to your drawing, close the window.