progeCAD Professional manual The low-cost alternative to AutoCAD

Index



Do you want to try progeCAD Professional?
Download the trial: you can try the product, without any limit, for 30 days!

A manual page a day... Click here to see the manual table of contents.

Working with the progeCAD Explorer - Working with text fonts and styles

Creating and naming text styles

Fonts are character sets that consist of letters, numbers, punctuation marks, and symbols. Each font is stored in its own font file. Text styles apply additional formatting to fonts. You can create multiple text styles based on the same font, changing the various characteristics to alter the appearance of the font. To create a new text style, you assign formatting characteristics to a font.

progeCAD uses *.shx font files and provides a selection of fonts. These fonts are located in the progeCAD/Fonts directory. You can also use any font designed to work with AutoCAD. Many fonts are available from third-party vendors.

To create a new text style
  1. Do one of the following:
  2. Choose Format > Explore Text Styles.
  3. On the Style toolbar, click the Explore Text Styles tool (
  4. ).
  • Type expfonts and then press Enter.
  • Choose Edit > New > Style.
  • Select the font on which you want to base the new style, and then click Open.

The program adds a new style to the text styles list with the default name, NewStyle1.

  1. Type the name for the new style by typing over the highlighted default text, and then press Enter.
  2. To complete the command, close the window.
  3. NOTE You can also create a new text style by selecting the Styles element and clicking the New Item tool ( ).
To change a text style name in the current drawing
  1. Do one of the following:
  2. Choose Format > Explore Text Styles.
  3. On the Style toolbar, click the Explore Text Styles tool (
  4. ).
  • Type expfonts and then press Enter.
  • Do one of the following:
  • Select the text style, choose Edit > Rename, type a new name, and then press Enter.
  • Click the text style name you want to change, type a new name, and then press Enter.
  • Right-click the text style name you want to change, and from the shortcut menu, select Rename, type a new name, and then press Enter.
  • To complete the command and return to your drawing, close the window.