progeCAD Professional manual The low-cost alternative to AutoCAD

Index



Do you want to try progeCAD Professional?
Download the trial: you can try the product, without any limit, for 30 days!

A manual page a day... Click here to see the manual table of contents.

Creating complex entities

Creating planes

With the Plane tool, you can draw rectangular, triangular, or quadrilateral areas filled with a solid color. The default method is to specify the corners of the plane. After you specify the first two corners, the plane is displayed as you specify the remaining corners. Specify corner points in a triangular manner. The program prompts you for the third point and then the fourth point. If you continue specifying points, the third- and fourth-point prompts toggle until you press Enter to complete the command.

Creating planes in progeCAD is similar to the Solid command in AutoCAD.

To draw a quadrilateral plane
  1. Do one of the following:
  2. Choose Draw > Plane.
  3. On the Surfaces toolbar, click the 2D Solid tool (
  4. ).
  • Type plane and then press Enter.
  • Specify the first point.
  • Specify the second point.
  • Specify the third point.
  • Specify the fourth point.
  • To complete the command, press Enter.
 
 

After you select the first two points ( A ) and ( B ), the sequence in which you select the third ( C ) and fourth ( D ) points determines the shape of the resulting quadrilateral plane.

  1. The prompt box provides additional options for drawing planes. For example, you can draw rectangular, square, or triangular planes.
To draw a rectangular plane
  1. Do one of the following:
  2. Choose Draw > Plane.
  3. On the Surfaces toolbar, click the 2D Solid tool (
  4. ).
  • Type plane and then press Enter.
  • Choose Rectangle.
  • Specify the first point.
  • Specify the opposite corner.
  • Specify the rotation angle.
  • To complete the command, specify the opposite corner to draw another rectangle, or press Enter.
 
 

Opposite corners ( A and B ) and rotation angle ( C ).

 

Resulting plane.

  1. You can control whether planes are shown filled or as outlines using the Fill tool in the Format menu. You can convert planes into individual line entities corresponding to the outline of the plane using the Explode tool (
  2. ) on the Modify toolbar.