progeCAD Professional manual The low-cost alternative to AutoCAD

Index



Do you want to try progeCAD Professional?
Download the trial: you can try the product, without any limit, for 30 days!

A manual page a day... Click here to see the manual table of contents.

Creating complex entities

Drawing donuts

Donuts are solid, filled circles or rings created as closed, wide polylines. You can draw a donut using one of several methods. The default method is to specify the inside and outside diameters of the donut, and then specify its center. You can then create multiple copies of the same donut by specifying different center points until you press Enter to complete the command.

To draw a donut
  1. Do one of the following:
  2. Choose Draw > Donut.
  3. Type donut and then press Enter.
  4. Specify the inside diameter of the donut.
  5. Specify the outside diameter of the donut.
  6. Specify the center of the donut.
  7. Specify the center point to draw another donut, or choose Done to complete the command.
  8.  

    Inside diameter ( A ) and outside diameter ( B ).

  9. The prompt box provides additional options for drawing donuts. For example, you can specify the width of the donut and two points on the diameter of the donut, or you can specify the width and three points on the donut. You can also draw a donut tangent to existing entities.
  10. NOTE A donut can be a completely filled circle by specifying an inside diameter of zero.
To draw a donut tangent to existing entities
  1. Do one of the following:
  2. Choose Draw > Donut.
  3. Type donut and then press Enter.
  4. In the prompt box, choose Radius Tangent Tangent.
  5. Specify the width of the donut.
  6. Specify the diameter of the donut.
  7. Select the first tangent entity to which to draw the donut.
  8. Select the second tangent entity to which to draw the donut.
  9.  

    Width ( A ) and diameter ( B ) of the donut and tangent entities ( C ).

  10. You can edit donuts using the Edit Polyline tool in the Modify > Object menu. You can convert donuts into arc entities using the Explode tool (
  11. ) on the Modify toolbar. You can control whether donuts are shown filled or as outlines using the Fill tool in the Format menu.
  1. NOTE You can control the default outside and inside diameter of donuts by choosing Tools > Drawing Settings, and then clicking the Entity Creation tab and choosing the options you want.