progeCAD Professional manual The low-cost alternative to AutoCAD

Index



Do you want to try progeCAD Professional?
Download the trial: you can try the product, without any limit, for 30 days!

A manual page a day... Click here to see the manual table of contents.

Creating complex entities

Drawing polylines

With progeCAD, a polyline is a connected sequence of arcs and lines that is treated as a single entity. You can draw a polyline with any linetype and using a width that either remains constant or tapers over the length of any segment. When editing a polyline, you can modify the entire polyline or change individual segments.

After you specify the start point of a polyline, a prompt box provides several options as you draw, such as Distance, Halfwidth, and Width. You can specify different starting and ending widths to create a tapered polyline segment.

After you draw at least one polyline segment, you can use the Undo tool (

) to remove the previous segment. After you draw two or more polyline segments, you can use the Close option to complete the command by drawing a segment that ends at the start point of the first polyline segment you drew. Choose Done to complete the command without closing the polyline.
 

 

 
 
 

Curved polyline with tapered width.

 

Polyline with straight
segments.

 

Closed polyline.

To draw a polyline with straight segments
  1. Do one of the following:
  2. Choose Draw > Polyline.
  3. On the Draw toolbar, click the Polyline tool (
  4. ).
  • Type polyline and then press Enter.
  • Specify the start point.
  • Specify the endpoint of each segment.
  • To complete the command, choose Close or Done.
  •  

    Polyline start point ( A ) and segment endpoints ( B ).

  • With the Draw Arcs option, you can continually draw arc segments until you select the Draw Lines option to go back to drawing line segments. When you draw arc segments, the first point of the arc is the endpoint of the previous segment. By default, you draw arc segments by specifying the endpoint of each segment. Each successive arc segment is drawn tangent to the previous arc or line segment. If you choose Close while in the Draw Arcs option, the closing segment is created as an arc.
  • You can also specify the arc using any of the following methods:
  • Start point, included angle, center point
  • Start point, included angle, radius
  • Start point, center point, endpoint
  • Start point, included angle, endpoint
  • Start point, center point, included angle
  • Start point, center point, chord length
  • Start point, direction, endpoint
  • Start point, radius, included angle
Start point, second point, endpoint
To draw a line segment followed by an arc polyline segment
  1. Do one of the following:
  2. Choose Draw > Polyline.
  3. On the Draw toolbar, click the Polyline tool (
  4. ).
  • Type polyline and then press Enter.
  • Specify the start point.
  • Specify the endpoint.
  • In the prompt box, choose Draw Arcs.
  • Specify the endpoint of the arc segment.
  • To complete the command, choose Done.
  •  

    Polyline start point ( A ), line endpoint/arc start point ( B ), and arc endpoint ( C ).

  • You can edit entire polylines and individual segments using the Edit Polyline tool in the Modify > Object menu. You can convert polylines into arc and line entities using the Explode tool (
  • ) on the Modify toolbar. You can control whether wide polylines are shown filled or as outlines using the Fill tool in the Format menu.