progeCAD Professional manual The low-cost alternative to AutoCAD

Index



Do you want to try progeCAD Professional?
Download the trial: you can try the product, without any limit, for 30 days!

A manual page a day... Click here to see the manual table of contents.

Creating complex entities - Drawing polygons

Drawing polygons by side

The side polygon drawing method creates an equal-sided polygon defined by its center point and the distance to the midpoint of a side. You specify the number of sides, the center point, and the location of the midpoint of one side, which determines both the size and orientation of the polygon.

To draw a polygon by side
  1. Do one of the following:
  2. Choose Draw > Polygon.
  3. On the Draw toolbar, click the Polygon, Center-Side tool (
  4. ).
  • Type polygon and then press Enter.
  • Type 3 to specify three sides for the polygon.
  • Specify the center of the polygon.
  • In the prompt box, choose Specify By Side, and then press Enter.
  • Specify the midpoint of the side.
 
 

 

 

The center ( A ) and midpoint of one side ( B ).

 

Resulting polygon.

  1. You can edit each side of a polygon individually using the Edit Polyline tool in the Modify > Object menu. You can convert the sides into individual line entities using the Explode tool (
  2. ) on the Modify toolbar. You can control whether wide polygon lines are shown filled or as outlines using the Fill tool in the Format menu.