progeCAD Professional manual The low-cost alternative to AutoCAD

Index



Do you want to try progeCAD Professional?
Download the trial: you can try the product, without any limit, for 30 days!

A manual page a day... Click here to see the manual table of contents.

Creating complex entities

Drawing rectangles

With progeCAD, rectangles are closed polylines with four sides. You draw a rectangle by specifying its opposite corners. The rectangle is normally aligned parallel to the current snap and grid alignment, but you can use the Rotated option to align the rectangle to any angle.

To draw a rectangle
  1. Do one of the following:
  2. Choose Draw > Rectangle.
  3. On the Draw toolbar, click the Rectangle tool (
  4. ).
  • Type rectangle and then press Enter.
  • Specify one corner of the rectangle.
  • Specify the opposite corner of the rectangle.
  •  

     

     

    Opposite corners ( A and B ).

     

    Resulting rectangle.

  • You can edit each side of a rectangle individually using the Edit Polyline tool in the Modify > Object menu. You can convert the sides into individual line entities using the Explode tool (
  • ) on the Modify toolbar. You can control whether wide rectangle lines are shown filled or as outlines using the Fill tool in the Format menu.
  1. You can also use the Rectangle tool to draw a square. Instead of specifying the opposite corners, you specify the length of one side and the alignment of the square.
To draw a square
  1. Do one of the following:
  2. Choose Draw > Rectangle.
  3. On the Draw toolbar, click the Rectangle tool (
  4. ).
  • Type rectangle and then press Enter.
  • In the prompt box, choose Square.
  • Specify one corner of the square.
  • Specify the length of one side of the square by selecting its other end.

The point you specify determines both the size and alignment of the square.

  1.  
  2.  

     

     

    Endpoints of one side of the square ( A and B ).

     

    Resulting square.

  3. NOTE To control the width of the rectangle line, choose the Width Of Line option in the prompt box. After you change the width of the line, the new width setting remains in effect for subsequent rectangles until you change it again.