Manuale di progeCAD Professional L'alternativa ad AutoCAD a basso costo

Indice



Vuoi provare progeCAD Professional?
Scarica la trial: avrai la possibilità di provare il prodotto, senza alcuna limitazione, per 30 giorni!

Una pagina del manuale al giorno... Fai clic qui per vedere l'indice del manuale.

Personalizzare progeCAD

Programmazione di progeCAD

Un altro modo per personalizzare progeCAD è quello di aggiungere programmi scritti in diversi linguaggi eseguibili con progeCAD, inclusi:

LISP

VBA (Visual Basic for Applications)

ADS

DCL

DIESEL

In progeCAD, si possono eseguire molti programmi originariamente creati per essere utilizzati con AutoCAD. Inoltre, si possono utilizzare programmi scritti interamente in AutoLISP senza modifiche. In aggiunta si possono eseguire molti programmi ADS originalmente scritti per AutoCAD dopo una ricompilazione utilizzando le librerie di run-time di progeCAD. Molti programmi prodotti da terze parti per AutoCAD sono compatibili con progeCAD.

NOTa La creazione di programmi da utilizzare con progeCAD non rientra tra gli scopi di questo manuale. Per informazioni inerenti la programmazione in progeCAD, vedere la sezione dell'help relativa alle Developer References.

Utilizzo delle routine LISP

progeCAD supporta il linguaggio di programmazione LISP ed è compatibile con AutoLISP, la versione del linguaggio LISP per AutoCAD. Ciò significa che è possibile caricare e far funzionare qualsiasi programma AutoLISP scritto per AutoCAD.

Per caricare una routine LISP
  1. Livello esperienza Avanzato
  2. Eseguire una delle seguenti operazioni:
  3. Scegliere Strumenti > Carica LISP o applicazione SDS.
  4. Digitare appload e premere Invio.
  5. Trascinare il file LISP (Drag and Drop) all'interno di progeCAD.
  6. Nella finestra di dialogo Carica applicazioni, cliccare Aggiungi File.
  7. Selezionare il file LISP che si desidera caricare, quindi cliccare Apri.
Cliccare OK.
 
  1. Elenca i nomi dei file LISP ed SDS già caricati.
  2. Cliccare per aggiungere un file LISP o SDS.
  3. Cliccare per rimuovere il file evidenziato.
  4. Cliccare per caricare il file evidenziato.
  1. Cliccare per scaricare il file evidenziato.
  2. Selezionare per salvare la lista corrente nel file icadload.dfs quando si clicca su Carica, Scarica o OK.
  1. NOTA Si può caricare una routine LISP anche digitando (load "d:/ path/routine.lsp") nella barra comandi (occorre includere le parentesi e le virgolette), dove d:/path è il drive e il percorso della routine LISP sul computer, e routine.lsp è il nome del file di routine LISP.
Per eseguire una routine LISP
  1. Livello Avanzato
  2. Eseguire una delle seguenti operazioni:
  3. Scegliere Strumenti > Carica LISP o applicazione SDS.
  4. Digitare appload e premere Invio.
  5. Nella finestra di dialogo Carica Applicazione, scegliere la routine che si desidera eseguire (assicurarsi che sia la sola selezionata), quindi cliccare Carica.
  6. Alcune routine LISP sono create in modo che sia possibile avviarle semplicemente digitandone il nome, o digitando una parola chiave direttamente nella barra comandi. Se non succede nulla quando si tenta di caricare la routine LISP dalla finestra di dialogo Carica Applicazione, attivare la visualizzazione della barra comandi o della finestra dei comandi in sequenza (progeCAD Lista), scegliendo Visualizza > Visualizzazione > Finestra di testo e cercare un'immissione che sia simile alla seguente:

Caricare D:\path\routine.lsp

C:KEYWORD

  1. dove D:\path\routine.lsp sono il drive, il percorso completo e il nome del file della routine LISP. Potrebbe essere necessario far scorrere diverse righe nella barra comandi o nella finestra dei comandi in sequenza per trovare le righe che indicano dove è stata caricata la routine LISP. Se si vede un'immissione simile a questa, si può mettere in funzione la routine LISP digitandone il nome o la parola chiave che appare dopo la C.
  2. Per esempio, se è stata caricata una routine LISP chiamata drawbox.lsp e si vede la designazione C:DRAWBOX nella barra comandi o nella finestra dei comandi in sequenza, si può mettere in funzione la routine LISP digitando drawbox nella barra comandi.