Manuale di progeCAD Professional L'alternativa ad AutoCAD a basso costo

Indice



Vuoi provare progeCAD Professional?
Scarica la trial: avrai la possibilità di provare il prodotto, senza alcuna limitazione, per 30 giorni!

Una pagina del manuale al giorno... Fai clic qui per vedere l'indice del manuale.

Lavorare con altri programmi - Utilizzo dei dati di altri programmi nei disegni progeCAD

Collegamento di oggetti ai disegni

Se un altro programma supporta ActiveX, è possibile collegare i suoi dati ai disegni progeCAD. Si utilizza il collegamento quando si vogliono includere gli stessi dati in più file. Quando si aggiornano i dati, tutti i collegamenti agli altri file riflettono le modifiche.

Per esempio, se si crea il logo della propria compagnia in un programma compatibile con ActiveX, e si vuole inserire nel cartiglio di ogni disegno creato con progeCAD, è possibile collegarlo al disegno. Quando si modifica il logo originale nel programma di disegno, il disegno progeCAD si aggiorna automaticamente.

Quando si collegano i dati da un altro programma, il disegno progeCAD memorizza solo un riferimento alla posizione del file nel quale si sono creati i dati. Collegando i dati di un file salvato, progeCAD può trovarli e visualizzarli.

Poiché il collegamento si limita ad aggiungere il riferimento ad un file, i dati non aumentano in modo significativo le dimensioni del file di disegno progeCAD. Comunque i collegamenti richiedono della manutenzione. Se si spostano dei file collegati, occorre aggiornare i collegamenti. Inoltre, se si desidera trasportare i dati collegati, occorre includere tutti i file collegati.

È possibile aggiornare automaticamente un oggetto collegato ogni volta che si apre il disegno oppure solo quando si desidera. Ogni volta che un collegamento viene aggiornato, le modifiche apportate all'oggetto nel suo file originale appaiono nel disegno progeCAD e anche nel file originale, se esse erano state effettuate tramite progeCAD.

Per collegare un file ad un disegno progeCAD
  1. Salvare il file originale.

Poiché il collegamento è un riferimento al file originale, occorre salvare il file prima di collegarlo.

  1. Nel file originale, selezionare i dati che si desiderano nel disegno progeCAD.
  2. Scegliere il comando del programma per collocare i dati negli Appunti.

Generalmente si utilizza Modifica > Copia.

  1. Visualizzare il disegno progeCAD al quale si vuole collegare il file.
  2. In progeCAD, scegliere Modifica > Incolla Speciale... .
  3. Nella finestra di dialogo Incolla Speciale, selezionare il pulsante di opzione Incolla collegamento.
  4. Cliccare OK.
Per creare un oggetto collegato dall'interno di progeCAD
  1. Visualizzare il disegno progeCAD nel quale si desidera inserire l'oggetto collegato.
  2. Scegliere Inserisci > Oggetto OLE... .
  3. Sulla barra degli strumenti Inserisci, cliccare l'icona Oggetto OLE (
  4. ).
  • Digitare inserogg e premere Invio.
  • Nella finestra di dialogo Inserisci oggetto, selezionare Crea dal file.
  • Specificare il file eseguendo una delle seguenti operazioni:
  • Digitare un percorso e il nome del file nella casella File.
  • Cliccare Sfoglia per selezionare il file utilizzando una finestra di dialogo.
  • Selezionare l'opzione Collegamento.
  • Selezionare Visualizza come icona se si desidera che nel disegno appaia l'icona del programma invece dei dati.
  • Cliccare OK.

Nel disegno progeCAD appare la prima pagina del file, a meno che si scelga di visualizzarla come icona. Si può selezionare l'oggetto e trascinarlo per riposizionarlo.