Manuale di progeCAD Professional L'alternativa ad AutoCAD a basso costo

Indice



Vuoi provare progeCAD Professional?
Scarica la trial: avrai la possibilità di provare il prodotto, senza alcuna limitazione, per 30 giorni!

Una pagina del manuale al giorno... Fai clic qui per vedere l'indice del manuale.

Lavorare con altri programmi - Utilizzo dei dati di altri programmi nei disegni progeCAD

Includere oggetti nei disegni

Si include un oggetto all'interno di un disegno progeCAD quando si cerca di mantenere tutti i dati all'interno di un file o se si cerca di trasferire il file su un'altro computer. È possibile incorporare dati da altri programmi che supportano il collegamento e l'incorporamento di oggetti.

Per esempio, se si cerca di distribuire dei dati relativi ad un ufficio attrezzato con computer insieme al disegno realizzato con progeCAD della pianta di quest'ufficio, è possibile incorporare un foglio di calcolo di Microsoft Excel nella pianta del piano.

Quando si incorporano dati da un'altro programma, progeCAD diventa il contenitore di questi dati. L'oggetto incorporato nel disegno diventa parte del file. Per modificare i dati, si apre il programma all'interno del disegno progeCAD.

Ogni modifica apportata ai dati incorporati esiste solo nei disegni progeCAD, così non è necessario mantenere dati in un file separato. Se i dati esistono su un file separato, il file originale non cambia quando si modifica l'oggetto incorporato. Le modifiche al file originale non hanno effetto sull'oggetto incorporato nel disegno progeCAD.

Per incorporare un oggetto di un altro programma in un disegno progeCAD
  1. Aprire il file contenente i dati desiderati.
  2. Nel file, selezionare i dati che si desiderano incorporare nel disegno progeCAD.
  3. Scegliere il comando di quel programma per mettere i dati negli Appunti.

Generalmente, si utilizza Edita > Copia.

  1. Nella finestra di progeCAD, visualizzare il disegno nel quale si intende incorporare l'oggetto.
  2. Scegliere Modifica > Incolla, o cliccare l'icona Incolla (
  3. ) sulla barra degli strumenti Standard.

I dati sugli Appunti vengono incollati nel disegno come oggetto incorporato. Esso appare al centro della vista, ma si può selezionare e spostare muovendo il cursore.

Per incorporare un oggetto di un file esistente all'interno di progeCAD
  1. Eseguire una delle seguenti operazioni:
  2. Scegliere Inserisci > Oggetto OLE... .
  3. Sulla barra degli strumenti Inserisci, cliccare l'icona Oggetto OLE (
  4. ).
  • Digitare inserogg e premere Invio.
  • Nella maschera Inserisci oggetto, scegliere Crea dal file.
  • Specificare il file eseguendo una delle seguenti operazioni:
  • Digitare un percorso e un file nella casella File.
  • Cliccare Sfoglia per selezionare un file.
  • Selezionare Visualizza Come Icona se si vuole che nel disegno appaia l'icona di quel programma invece dei dati.
  • Cliccare OK.

Nel disegno progeCAD appare la prima pagina del file, a meno che si scelga di visualizzarlo come icona. Si può selezionare l'oggetto e trascinarlo per riposizionarlo.

Per creare un nuovo oggetto incorporato all'interno di progeCAD
  1. Eseguire una delle seguenti operazioni:
  2. Scegliere Inserisci > Oggetto OLE... .
  3. Sulla barra degli strumenti Inserisci, cliccare l'icona Oggetto OLE (
  4. ).
  • Digitare inserogg e premere Invio.
  • Nella maschera Inserisci oggetto, scegliere Crea Nuovo.
  • Dall'elenco Tipo di Oggetto, selezionare il tipo di oggetto che si vuole creare, quindi cliccare OK.

Il programma per creare quell'oggetto si apre all'interno di progeCAD. Se il programma è compatibile con ActiveX, esso si apre sul posto (all'interno dell'altro programma) nel disegno progeCAD; altrimenti, il programma si apre nella sua finestra.

  1. Creare l'oggetto nell'altro programma.
  2. Se il programma sta funzionando all'interno dell'altro documento (sul posto), cliccare un punto qualsiasi all'esterno dell'oggetto incorporato per chiudere il programma.

Se il programma sta funzionando nella sua finestra, scegliere File > Esci.