Manuale di progeCAD Professional L'alternativa ad AutoCAD a basso costo

Indice



Vuoi provare progeCAD Professional?
Scarica la trial: avrai la possibilità di provare il prodotto, senza alcuna limitazione, per 30 giorni!

Una pagina del manuale al giorno... Fai clic qui per vedere l'indice del manuale.

Formattazione e stampa dei disegni - Personalizzare le opzioni di stampa

Utilizzare gli stili stampa

progeCAD utilizza gli stili stampa per cambiare l'aspetto del disegno stampato senza modificare le entità nel disegno. L'assegnamento degli stili stampa permette di personalizzare il colore, lo spessore della penna, il tipo di linea, e lo spessore linea che saranno usati per la stampa del disegno.

Aiutano a controllare l'aspetto del disegno stampato, piuttosto che descrivere come appaiono sullo schermo. Per esempio, è possibile mappare tutte le entità gialle nel disegno in modo che vengano stampate blu, senza modificare le entità. Oppure mapparle in modo che vengano stampate con qualunque spessore linea, tipo linea, spessore penna specificato.

Poichè gli stili stampa sono salvati nelle tabelle stile stampa, dei file posizionati sul computer, disco, o server; è possibile riutilizzarli per aiutare ad eliminare la necessità di riconfigurare le impostazioni di stampa ogni volta che si stampa un disegno. Per esempio, nel caso di più clienti che abbiano le loro preferenze di stampa, è possibile salvare per ogni cliente gli stili stampa in un file con nome. Questi file possono essere condivisi tra tante persone o memorizzati in rete, per garantire ad ognuno in ufficio di utilizzare lo stesso standard.

Comprendere le tabelle stile stampa
  1. Una tabella stile stampa è un insieme di stili stampa che permette di cambiare l'aspetto del disegno stampato senza modificare le entità.
    Ogni tabella stile stampa è salvata in un file memorizzato su computer, disco, o server.
  2. Un disegno può usare un tipo di tabella stile stampa alla volta. Ci sono due tipi di tabelle stile stampa:
  3. Tabelle stile stampa dipendenti dal colore (CTB) contengono un insieme di stili stampa basati su ognuno dei 255 Colori indice disponibili nel disegno. True color e Cataloghi colore non sono applicabili.
  4. Tabelle stile stampa con nome (STB) contengono un insieme di stili stampa definibili dall'utente. Queste non dipendono dal colore.
  5. Con le tabelle stile stampa dipendenti dal colore, non è possibile assegnare uno stile stampa a una singola entità o layer. Per usare questi stili stampa, si assegna un colore specifico a un'entità o layer. Quando si specifica una tabella stile stampa dipendente dal colore in fase di stampa, i colori delle entità e dei layer sono mappati sulla base dei colori della tabella stile stampa scelta.
  6. Con le tabelle stile stampa con nome, si può assegnare uno stile a una singola entità e ai layer. Le entità e i layer associati ad uno stile stampa, saranno stampati secondo la tabella stile stampa assegnata in fase di stampa. Se si specifica uno stile stampa per un'entità, questo sovrascriverà ogni stile stampa assegnato al layer sul quale l'entità risiede.
  7. Qualche volta uno stile stampa con nome assegnato ad un'entità o layer non è presente nella tabella stile stampa associata a un layout o disegno. Questo può accadere se lo stile di stampa è stato eliminato dalla tabella stile stampa o se è stata assegnata una tabella stile stampa diversa al disegno che quindi non lo contiene. In questo caso, l'entitàè stampata usando le proprietà di default, che è come assegnare lo stile stampa Normal a un'entità o layer. Se si pensa di scambiare le tabelle stile stampa con nome all'interno dello stesso disegno, è una buona norma coordinare le tabelle per usare gli stessi nomi stile stampa.
  8. Se un nuovo disegno è basato su un modello, questo userà lo stesso tipo di tabella stile stampa del modello, diversamente il tipo di tabella stile stampa sarà specificato nel Wizard Nuovo Disegno (Autocomposizione). Di default, un nuovo disegno usa il tipo di tabella stile stampa specificato in Strumenti > Opzioni, scheda Stampa. Ogni disegno è progettato per usare tabelle stile stampa, ma l'utente sceglie di implementarle o meno.
  9. Comparazione dei tipi di tabella stile stampa

     

    Tabella stile stampa
    dipendente dal colore (CTB)

    Tabella stile stampa con nome (STB)

    Descrizione

    Contiene stili stampa predefiniti associati al colore, c'è uno stile stampa per ognuno dei 255 Colori indice disponibili nel disegno. Le entità con colore identico sono stampate allo stesso modo.

    Contiene stili stampa univoci realizzati dall'utente. Le entità con lo stesso colore possono avere impostazioni di stampa differenti.

    Esempio

    Tutte le entità blu vengono stampate con uno spessore linea .5 millimetri.

    Un'entità blu è stampata con uno spessore linea .7 millimetri; un'atra .5 millimetri.

    Numero di stili stampa

    255 (fissi).

    Almeno uno(vari).

    Nomi stile stampa

    L'intervallo dei nomi Stile Stampa va da "Color_1" a "Color_255". Non è possibile rinominare gli stili stampa.

    Vengono definiti nuovi nomi di stile stampa. È possibile rinominare tutti gli stili stampa ad eccezione dello stile stampa Normal.

    Aggiungere, eliminare, e modificare stili stampa

    È possibile modificare stili stampa esistenti, ma non aggiungerli o eliminarli.

    È possibile aggiungere o eliminare stili stampa. È consentita la modifica di tutti gli stili stampa ad eccezione del Normal, che utilizza le caratteristiche di default delle entità.

    Creazione di tabelle aggiuntive

    Si.

    Si.

    Assegnazione

    Stile stampa corrente: Alle nuove entitàè sempre assegnato BYCOLOR.

     

    Stili stampa: Assegnati ai colori nella tabella stile stampa.

     

    Tabelle stile stampa: Assegnate ad una scheda Layout o al Model.

    Stile stampa corrente: Assegnato alle nuove entità.

     

    Stili stampa: Assegnati a entità e layer.

     

    Tabelle stile stampa: Assegnate ad una scheda Layout o al Model.

    Legame con file di supporto

    È possibile importare file di configurazione di stampa esistenti (PCP) nei file tabella stile stampa. I file CTB sono simili ai PCP usati nelle precedenti versioni di progeCAD.

    Non applicabile.

Implementazione tabelle stile stampa
  1. Ogni disegno è progettato per utilizzare tabelle stile stampa, ma si può decidere se implementarle o meno. Anche se si usa una delle tabelle stile stampa disponibili con progeCAD, è richiesta una pianificazione prima per assicurarsi che il disegno sia stampato come da progetto.
  2. Per esempio, un singolo disegno come la pianta di un piano, può richiedere la stampa dei seguenti fogli:
  3. Pianta del Piano Principale Muri stampati con spessore, linee nere.
  4. Schema elettrico Muri stampati con normali linee grigie, in modo da non essere evidenziati.
  5. Pianta HVAC Muri stampati con normali linee grigie, in modo da non essere evidenziati.
  6. Pianta Tetto Muri stampati con sottili, linee grigie e tipo di linea Hidden, indicano quelle nascoste sotto il tetto in una vista piana.
  7. In quest'esempio, è possibile creare quattro tabelle stile stampa con nome, ognuno contenente uno stile stampa chiamato "StileStampaMuro". Ognuno di questi conterrà le nostre impostazioni che controllano la stampa dei muri. Assegnare StileStampaMuro alle entità muro o al layer sul quale si trovano. Quindi cambiare la tabella stile stampa con nome ogni volta che si stampa, o creare quattro layout e assegnare una tabella stile stampa differente a ognuno di essi.
  8. La seguente tabella descrive, in ordine, i passaggi per iniziare ad utilizzare le tabelle stile stampa dipendenti dal colore e con nome.
 
Iniziare usando tabelle stile stampa

Dipendenti dal colore

Con nome

Operazione

Comando

Dove trovare i dettagli

X

X

Creare un nuovo disegno. Selezionare un modello di disegno che usa il tipo di tabella stile stampa desiderato o sceglierlo dalla maschera Avvio > Usa Autocomposizione (Wizard).

File > Nuovo

See Creazione di un nuovo disegno.

X

X

(Opzionale) Creare una nuova tabella stile stampa.

File > Gestione stili stampa

See Creazione di nuove tabelle stile stampa.

X

 

Assegnare colori a entità e layer che corrispondano alle impostazioni della tabella stile stampa.

Edita > Proprietà

Strumenti > progeCAD Explorer

See Controllo della visibilità del layer.; See Modificare le proprietà degli oggetti.; See Impostazione del colore del layer.

 

X

Impostare lo stile stampa corrente assegnato alle nuove entità.

Strumenti > Impostazioni disegno > Creazione Entità; barra di stato; printstyle

See Impostazione dello stile stampa corrente.

 

X

Assegnare gli stili stampa alle entità.

Edita > Proprietà; barra degli strumenti Proprietà Oggetto; printstyle

See Modificare le proprietà degli oggetti.

 

X

Usare il progeCAD Explorer per assegnare gli stili stampa ai layer.

Strumenti > progeCAD Explorer

See Impostazione dello stile stampa di un layer.

X

X

Assegnare una tabella stile stampa alla scheda Model, un layout, o a tutti i layout nel disegno.

File > Stampa > Avanzate

See Assegnazione tabelle stile stampa.

X

X

(Opzionale) Modificare la tabella stile stampa assegnata.

File > Gestione stili stampa

File > Stampa > Avanzate

See Modifica delle tabelle stile stampa.

X

X

Stampare il disegno.

File > Stampa

See Stampare o plottare un disegno.

  1. La seguente tabella descrive come personalizzare, e lavorare con gli stili stampa all'interno dei disegni.
  2. Ulteriori personalizzazioni delle tabelle stile stampa

    Operazione

    Comando

    Dove trovare i dettagli

    Copiare, rinominare, o eliminare le tabelle stile stampa.

    File > Gestione stili di stampa

    See Copiare, rinominare, o eliminare le tabelle stile stampa.

    Modificare un disegno per usare un'altro tipo di tabella stile stampa, per esempio, convertire un disegno che usa tabelle stile stampa dipendenti dal colore in uno che usa tabelle stile stampa con nome.

    convertpstyles

    See Cambiare il tipo di tabella stile stampa in un disegno.

    Convertire una tabella stile stampa dipendente dal colore in una tabella stile stampa con nome.

    convertctb

    See Conversione delle tabelle stile stampa.

    Cambiare la posizione di default per il salvataggio delle tabelle stile stampa.

    Strumenti > Opzioni > Percorsi/File

    See Modificare le opzioni della scheda Percorsi/File.

    Personalizzare il comportamento degli stili stampa nella creazione di nuovi disegni e all'apertura di disegni esistenti.

    Strumenti > Opzioni > Stampa

    See Modificare le opzioni della scheda Stampa.

Assegnazione tabelle stile stampa
  1. Selezionare una tabella stile stampa se si cerca di cambiare il modo in cui sarà visualizzato il disegno stampato. Le tabelle stile stampa possono modificare l'aspetto di colori, spessore penne, tipi di linea, e spessore linee stampati.
  2. È possibile assegnare tabelle stile stampa globalmente per tutti i layout (inclusa la scheda Model), o singolarmente alla scheda Model o uno dei Layout favorendo la personalizzazione dei layout di stampa in un disegno.
  3. Comunque, assegnando diversi nomi di tabelle stile stampa a vari layout si possono avere diversi nomi di stile stampa; un nome di stile stampa assegnato a un'entità o layer può non appartenere alla tabella stile stampa utilizzata in fase di stampa. In questo caso, le entità vengono stampate usando le loro proprietà di default, che è come assegnare lo stile stampa Normal a un'entità o layer.
Per assegnare le tabelle stile stampa
  1. Se necessario, cliccare una scheda Layout o la Model.
  2. Eseguire una delle seguenti:
  3. Scegliere File > Stampa.
  4. Nella barra degli strumenti Standard, cliccare l'icona Stampa (
  5. ).
  • Digitare stampa e premere Invio.
  • Cliccare la scheda Avanzate.
  • Sotto Tabella Stili Stampa (Assegnamento penne), selezionare una tabella stile stampa o una delle seguenti:
  • Nessuno -- Non applica una tabella stile stampa. Le entità vengono stampate in base alle loro proprietà.
  • Icad -- Usa la tabella stile stampa di default ed i colori assegnati.
  • Monochrome -- Stampa tutti i colori in nero.
  • Al messaggio, rispondere Si per assegnare la tabella stile stampa a tutti i Layout nel disegno, inclusa la scheda Model, oppure No per assegnarlo solo al Layout visualizzato nella maschera di stampa accanto all'etichetta Nome Layout.
  • Selezionare Salva cambiamenti Layout, e cliccare Applica per salvare le modifiche.
  • NOTA Alla creazione un disegno è impostato per usare le tabelle stile stampa dipendenti dal colore o con nome. Per dettagli sulla conversione di un disegno che usa un diverso tipo di tabella stile stampa, See Comprendere le tabelle stile stampa.
Creazione di nuove tabelle stile stampa
  1. progeCAD offre diverse tabelle stile stampa che ci aiutano ad iniziare. Se si cerca di personalizzare ulteriormente il risultato della stampa, è possibile creare la nostra tabella stile stampa partendo: da una bozza, dalle impostazioni di registro del progeCAD o importando un file di configurazione di stampa (file PCP).
Per creare nuove tabelle stile stampa
  1. Eseguire una delle seguenti operazioni:
  2. Scegliere File > Gestione stili di stampa.
  3. Digitare stylesmanager e premere Invio.
  4. Doppio clic su Autocomposizione Aggiungi tabella stili di stampa.
  5. Completare l'autocomposizione.
    Sull'ultima pagina dell'autocomposizione, si può cliccare sul pulsante Editor tabella stili stampa per impostare gli stili per la tabella. Per maggiori dettagli circa le opzioni dell'Editor tabella stile stampa, vedere la sezione successiva.
Modifica delle tabelle stile stampa
  1. Quando è stato creato un disegno, questo è impostato per usare tabelle stile stampa dipendenti dal colore o con nome.
  2. Tabelle stile stampa dipendenti dal colore (file .ctb) È possibile modificare i singoli stili stampa all'interno della tabella, ma non aggiungerne, rinominarli, o eliminarli. Le tabelle stile stampa dipendenti dal colore hanno sempre 255 stili, un nome per ogni colore. Le modifiche interesseranno tutte le entità e layer con quel colore.
  3. Tabelle stile stampa con nome (file .stb) È possibile aggiungere, modificare, rinominare, ed eliminare i singoli stili stampa all'interno della tabella. Comunque, non è possibile modificare, rinominare, o eliminare lo stile stampa Normal. Le modifiche interesseranno tutte le entità e layer ai quali è assegnato un nome di stile.
  4. NOTA Se non si ha memoria del tipo di tabella stile stampa assegnato al disegno, usare la variabile di sistema PSTYLEMODE per determinarlo.
  1. Ogni stile stampa all'interno di una tabella stile stampa specifica un colore, numeri di penna, tipo di linea e spessore linea. progeCAD riconosce impostazioni aggiuntive per compatibilità con AutoCAD, inclusi: dithering, scala di grigi, retinatura, adattivo, stile fine linea, stile connessione linea, e stile riempimento.
  2. Quando si specificano le caratteristiche dello stile di stampa, è necessario considerare i limiti della periferica di stampa.
  3. NOTA Si raccomanda di modificare solo le tabelle stile stampa che sono state create. Modificandone una di default del progeCAD, verranno sovrascritte le informazioni che saranno perse.
Per modificare le tabelle stile stampa
  1. Eseguire una delle seguenti operazioni:
  2. Scegliere File > Gestione stili di stampa.
  3. Digitare stylesmanager e premere Invio.
  4. Doppio clic sulla tabella stile stampa che si cerca di modificare.
  5. Cliccare la scheda Generale, e quindi:
  6. Inserire una nuova descrizione per la tabella.
  7. Selezionare Applica fattore di scala globale a tipi di linea non-ISO, per applicare il fattore di scala ai tipi di linea non ISO usati per ogni stile stampa nella corrente tabella stile stampa. Questo applica anche un modello di riempimento, non ancora usato in progeCAD, ma riconosciuto per compatibilità con AutoCAD.
  8. Inserire un fattore di scala da applicare ai tipi di linea non ISO per dei stili stampa della tabella corrente.
  9. Cliccare la scheda Proprietà, e quindi:
  10. Apportare dei cambiamenti a uno stile stampa selezionandolo dalla lista Stili stampa, quindi agire sul colore, mappatura penne, tipo e spessore linea. Le modifiche sono salvate automaticamente per lo stile stampa selezionato.
  11. Aggiungere un nuovo stile stampa cliccando su Aggiungi stile. Inserire un nuovo nome, quindi cliccare OK. Selezionare le opzioni per lo stile stampa. (Disponibile solo per gli stili stampa con nome.)
  12. Rinominare uno stile stampa selezionandolo dalla lista Stili stampa. Cliccare Elimina stile. (Disponibile solo per gli stili stampa con nome.)
  13. Cliccare OK.
 
 
  1. Selezionare uno stile stampa da modificare.
  2. Inserire una descrizione per lo stile stampa selezionato.
  3. Cliccare per creare un nuovo stile stampa. (Solo per tabelle stile stampa con nome.)
  4. Cliccare per eliminare lo stile stampa selezionato. (Solo per tabelle stile stampa con nome.)
  5. Cliccare per modificare la lista degli spessori linea disponibili per la tabella stile stampa corrente.
  6. Cliccare per salvare la tabella stile stampa con un nuovo nome o in una nuova posizione.
  1. Scegliere uno spessore linea per lo stile stampa selezionato.
  2. Scegliere un tipo di linea per lo stile stampa selezionato.
  3. Digitare o variare lo spessore della penna virtuale per lo stile stampa selezionato (per stampanti che non hanno le penne, come le laser o a getto d'inchiostro).
  4. Digitare o variare lo spessore della penna fisica per lo stile stampa selezionato.
  5. Scegliere un colore per lo stile stampa selezionato.
Copiare, rinominare, o eliminare le tabelle stile stampa
  1. Copiare, rinominare, o eliminare una tabella stile stampa può essere fatto così come per altri file su un computer. Indipendentemente da quale tabella stile stampa il disegno usi, è possibile usare la Gestione Stile Stampa per tabelle stile stampa dipendenti dal colore o con nome.
Per copiare, rinominare, o eliminare le tabelle stile stampa
  1. Eseguire una delle seguenti operazioni:
  2. Scegliere File > Gestione stili di stampa.
  3. Digitare stylesmanager e premere Invio.
  4. Selezionare una tabella stile stampa.
    Le tabelle stile stampa dipendenti dal colore sono file .ctb, quelle con nome sono .stb.
  5. Copiare, rinominare, o eliminare la tabella stile stampa può essere fatto così come per altri file su un computer.
Cambiare il tipo di tabella stile stampa in un disegno
  1. Quando un disegno è stato creato, è impostato per usare tabelle stile stampa dipendenti dal colore (file .ctb) o con nome (file .stb). Un disegno può usare un tipo di tabella stile stampa alla volta. Se necessario, dopo che un disegno è stato creato è possibile convertirlo, per usare l'altro tipo di tabella stile stampa.
  2. Se non si ricorda il tipo di tabella stile stampa assegnato al disegno, usare la variabile di sistema PSTYLEMODE per determinarlo.
Per cambiare le tabelle stile stampa usate nel disegno
  1. Se si cerca di riusare delle informazioni di uno stile stampa esistente, convertire le tabelle stile stampa dipendenti dal colore, in nostro possesso, in quelle con nome. Per dettagli, See Per convertire una tabella stile stampa dipendente dal colore in una con nome.
  2. Aprire il disegno che usa tabelle stile stampa dipendenti dal colore (file .ctb).
  3. Digitare convertpstyles, e premere Invio.
  4. Se la tabella stile stampa dipendente dal colore è già stata convertita in una con nome, cliccare OK nel messaggio visualizzato.
    Se la tabella non è stata convertita, cliccare Annulla. Prima usare convertctb per convertire le tabelle stile stampa dipendenti dal colore in quelle con nome. Se non viene fatto, tutte le informazioni dello stile stampa nel disegno potrebbero essere perse.
  5. Selezionare una tabella stile stampa con nome (file .stb) che si cerca di usare per il disegno.
  6. Cliccare Apri.
  7. NOTA Se non si ha convertito la tabella stile stampa dipendente dal colore in una con nome, si potrebbe essere avvertiti che la tabella selezionata non contiene la mappatura colore e il disegno non può essere convertito.
Per modificare un disegno usando tabelle stile stampa dipendenti dal colore
  1. Aprire il disegno che usa le tabelle stile stampa con nome (file .stb).
  2. Digitare convertpstyles, quindi premere Invio.
  3. Se si è sicuri di cercare di convertire il disegno e rimuovere l'associazione con gli stili stampa, cliccare OK nel messaggio visualizzato.
    Se non si vuole rimuovere l'associazione con gli stili stampa, cliccare Annulla.
  4. NOTA Convertendo un disegno per usare tabelle stile stampa dipendenti dal colore verranno rimosse dalle entità e dai layer tutte le informazioni dello stile stampa con nome. Comunque, le tabelle stile stampa con nome non vengono eliminate dal computer.
Conversione delle tabelle stile stampa
  1. È possibile convertire una tabella stile stampa dipendente dal colore in una con nome. Non è possibile convertire una tabella stile stampa con nome in una dipendente dal colore.
  2. Convertire una tabella stile stampa dipendente dal colore in una con nome può essere d'aiuto nelle seguenti situazioni:
  3. Non si voglia creare una tabella stile stampa con nome da bozza.
  4. Si cerchi di creare una tabella stile stampa con nome che ha le stesse impostazioni di una tabella stile stampa dipendente dal colore, ma con alcuni nuovi stili stampa o altre impostazioni personalizzate.
Per convertire una tabella stile stampa dipendente dal colore in una con nome
  1. Digitare convertctb, e premere Invio.
  2. Selezionare la tabella stile stampa dipendente dal colore (file .ctb) che si cerca di convertire.
  3. Cliccare Apri.
  4. Inserire un nome per la nuova tabella stile stampa con nome (file .stb).
  5. Cliccare Salva.
  6. Gli stili stampa nella nuova tabella sono chiamati Style 1, Style 2, e così via. Se si cerca di utilizzare nomi stile stampa differenti, rinominare gli stili stampa prima di assegnarli ad entità e layer nel disegno. Rinominando gli stili stampa dopo averli assegnati, in fase di stampa non verranno trovati. Per informazioni su come rinominare gli stili stampa, See Modifica delle tabelle stile stampa.
Disabilitare le tabelle stile stampa
  1. Se necessario, cliccare una scheda Layout o Model.
  2. Eseguire una delle seguenti operazioni:
  3. Scegliere File > Stampa.
  4. Nella barra degli strumenti Standard, cliccare l'icona Stampa (
  5. ).
  • Digitare stampa e premere Invio.
  • Cliccare la scheda Avanzate.
  • Sotto Tabella stili stampa (Assegnamento penne), selezionare Nessuno.
  • Dal messaggio, scegliere Si per disabilitare le tabelle stile stampa in tutti i Layout del disegno, inclusa la scheda Model, o scegliere No per disabilitarla solo nel layout corrente, mostrato accanto all'etichetta Nome Layout nella maschera Stampa.
  • Selezionare Salva cambiamenti Layout, e cliccare Applica per salvare le modifiche.