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Preface 
 

This User’s Guide provides a detailed description of ProgeCAD Architecture overall concept, 
features, components and commands. The Quick Start Guide of ProgeCAD Architecture is a 
brief introduction to the basic ProgeCAD Architecture features and functionalities, and is 
particularly helpful for users experienced in CAD. 

 

ProgeCAD Architecture is an advanced BIM (Building Information Modeling) vertical software 
application, which is built on top of IntelliCAD, the alternative CAD solution. The program is 
designed to meet in a very friendly and flexible way the entire needs of an architect, including 
advanced architectural design, rendering and virtual walkthrough. ProgeCAD Architecture 
adopts a modern BIM structure providing unique advantages to its user, regarding intelligent 
model shaping directly applied on the real 3D building model. Due to the IntelliCAD concept, 
ProgeCAD Architecture keeps all the usual CAD features and functions which have been 
introduced by AutoCAD® plus the DWG compatibility as well. Moreover, ProgeCAD Architecture 
handles smart entities and intelligent building objects within its familiar BIM environment. More 
specifically, the program functionality applied on the intelligent objects results in the native 
application of all the Standard Icad/Acad commands (copy, move, trim, break, mirror, extend, 
copy-paste etc) directly to any building object (walls, openings, slabs, beams, columns etc), as 
well as in the native use of the Editing Tools (grips, "right click -> properties" etc) to every 
building object. Regarding the BIM-structured composite intelligent Objects, the design process 
is enhanced by a number of parametric dialogs embedding sophisticated algorithms to edit and 
shape any architectural objects (stairs, roofs, rails etc). As for the overall building model, due to 
its innovative BIM structure, ProgeCAD Architecture is capable to generate and continuously 
update the project drawings (sections, views, perspectives, etc) while also keeping any 
interventions made by the user (insertion of library items, text, annotation, etc). As a conclusion, 
through ProgeCAD Architecture any design ideas can be realized and presented easily, quickly 
and in a completed way. 
 
This user guide provides an in-depth walkthrough of the different aspects of ProgeCAD 
Architecture, by also giving detailed advice on how to use and get maximum benefit from the 
program. 



 



 

 

 

 

 

1. Introduction 
 

1.1 Installing ProgeCAD Architecture 
1. Insert the CD in your computer CD-ROM drive (e.g. D:, E:). If you received your software via 

Internet, run the downloaded installation program. 

2. When the installation popup menu appears, choose the language for the installation and click 
OK. 

3. When the Welcome page appears (as shown below), click Next. 

 
4. When the License Agreement dialog box appears, read it carefully. If you agree with the 

terms check the respective “radio button” and then click ‘’Next’’ (you must agree with the 
terms to proceed with the installation). 
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5. In the next screen type your username and organization information and check if you want to 

create a desktop icon. Then click “Next” to see if the information is correct (see the following 
window) and finally click “Install”, so that the installation procedure begins. 

 
6. As soon as the installation procedure is completed, the following last window appears on the 

screen and you have to click “Finish”. In case that the “Run ProgeCAD Architecture” check 
box is selected, the application will be executed. 
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7. After the installation, the program appears in the program list (ProgeCAD Architecture). 

Attention! To make sure that the program can actually "see" the "key" (hasp), run the 
I1hasp.bat (or I2hasp.bat) program from the ProgeCAD Architecture directory (by clicking twice). 
After the HASP program is loaded a relevant message will appear. It is strongly recommended 
to deactivate any anti-virus programs running in your PC. In case the program is still not running, 
please check if the key is plugged into the port of your PC.  
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1.2 ProgeCAD Architecture Concept 
 
ProgeCAD Architectute is the IntelliCAD-based BIM solution, designed to meet in a very friendly 
and flexible way all the needs of an architect, including advanced architectural design, rendering 
and virtual walkthrough. ProgeCAD Architecture adopts a modern BIM structure, totally 
redesigned within the framework of the second BIM generation RnD project of 4M Suite, the 
integrated building design suite of 4M. Intelligent model shaping and high design accuracy are 
directly applied on the real 3D model of the building ProgeCAD Architecture embeds IntelliCAD 
engine, the world famous CAD alternative, keeping all the usual CAD features and functions (as 
they have been introduced by AutoCAD®), providing therefore the interface expected by the 
majority of the CAD users. Besides ProgeCAD Architecture also ensures the communication 
among designers, due to its full compatibility with the DWG file format (www.opendwg.com). 
Next figure demonstrates the basic concept of ProgeCAD Architecture: 
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ProgeCAD Architecture intelligent objects are handled through a user-friendly interface, 
constituting a very familiar and strong modeling environment. In particular, as shown in the 
figure, the Icad/Acad functionality applied on the Intelligent Objects results in the: 
 
- Native application of all the Standard Icad/Acad commands (copy, move, trim, break, mirror, 

extend, copy-paste etc) directly to any building object (walls, openings, slabs, beams, 
columns etc).  

- Native use of the Editing Tools (grips, "right click -> properties" etc) to every building object. 
 
Regarding the BIM-structured composite intelligent Objects, ProgeCAD Architecture includes: 
 
- Parametric dialogs with intelligent algorithms to edit and shape the building objects.  
- Intelligent infrastructure plus the necessary editing commands regarding object materials & 

textures.  
 
As a result, ProgeCAD Architecture produces a complete output, consisting of: 
- The full set of the project drawings (view plan drawings, views, cross sections, axonometric 

views, perspectives etc). What is also important here, is that due to its smart BIM structure, 
ProgeCAD Architecture is continuously updating the project drawings (sections, views, 
perspectives, etc) while also keeping any interventions made by the user (insertion of library 
items, text, annotation, etc). The set of the project drawings is properly viewed and managed 
by a tree-view browser, a smart explorer of the project drawings in fact. 

- High quality photorealistic scenes, which are also generated directly through the building 
model (PhotoIDEA component)  

- 3D/4D virtual reality videos, that can be easily created by the user (WalkIDEA component) to 
present fast and smooth 3D walkthrough and 4D stereoscopic view. 

 
Additionally, all the operations mentioned above are supported by the latest IntelliCAD engine, 
significantly empowered regarding ProgeCAD Architecture objects, in order to ensure high 
speed performance, even for large scale drawings. 
 
 

1.3 Working with ProgeCAD Architecture 
 
As mentioned above, ProgeCAD Architecture is an Integrated Workstation for Architectural 
Building Design, developed to cover all an Architect’s needs, including architectural synthesis & 
model creation, rendering and virtual walkthrough.  
 
First of all, as far as Walls & Openings are concerned, ProgeCAD Architecture embeds all the 
features required for the unrestricted "shaping" of the basic building framework, such as parallel 
moving of walls, trimming, extending, joining, breaking, copying, mirroring walls etc, as well as 
placing on them openings of any kind and type (windows, sliding, doors, openings, arches). 
Drawing facilities, such as the "right click -> properties" or the extended use of grips on any 
building object (walls, opening, slabs, columns, beams etc), speed up the design process. In 
addition, the real time display of the model transformations, during the modifications, enables the 
user to focus absolutely on the design process, thus avoiding time-consuming drawing tasks.  
 
Regarding the “Composite Building Elements”, such as slabs, staircases, roofs, rails, gables, 
ramps etc, ProgeCAD Architecture considers them as intelligent objects too, logically linked to 
one another so that they can properly respond and automatically update themselves to any 
modification. In particular, each element has its own attributes that can be edited by the user at 
any stage. More than simple drawing tasks, the object dialogs may also enable sophisticated 
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drawing algorithms, ensuring the correct element shaping in every case (i.e. a freeway staircase, 
a complicated roof with lofts etc).  
 
As for the overall building model itself, due to its innovative BIM structure, ProgeCAD 
Architecture is capable to generate and continuously update the entire set of the project 
drawings (sections, views, perspectives, etc), at the same time keeping as well any interventions 
made by the user (insertion of library items, text, annotation, etc). 
 
In conclusion, the user can shape the building model with practically no limitations, working 
either on the view plan, any 3D view or even on front views, cross-sections and perspectives, 
watching at the same time the effects of those interventions. In addition, thanks to its BIM 
structure, ProgeCAD Architecture handles efficiently several other important aspects of the 
design & construction processes, such as for instance the bill of materials (BoM), the smart 
topographical functions, even the seamless integration between ProgeCAD Architecture and 
each one of the other 4M Suite software solutions (STRAD for Structural Design, FINE for the 
Building Services – HVAC, Electrical, Sanitary etc), all of them using and referring to the same, 
standard Building Information Model (4M-BLD file format).   
 
Further to the project drawings, ProgeCAD Architecture takes advantage of its BIM structure to 
generate high quality photorealistic scenes, as well as impressive animation videos, through the 
two powerful components PhotoIDEA and WalkIDEA respectively. More specifically: 
 
� PhotoIDEA supports the creation of high quality photorealistic images using a state-of-the-art 

“ray tracing” technology. With PhotoIDEA, the real representation of any scene of the 3D 
model becomes an extremely simple procedure. PhotoIDEA uses a rich library of real 
materials with texture (e.g. marble, wood, stone, carpets etc), which can be selected and 
adjusted properly if necessary. The fact that the attributes of the ProgeCAD Architecture 
building objects include material information simplifies the editing process. Given that each 
part of any object (e.g. walls, frames, roofs, stair elements etc) is assigned by default to a 
certain material, the result of the photorealistic representation can appear on screen from the 
first steps of the design. The selection and editing of the materials the user wishes to use in 
the project, the positioning of the lighting sources, the selection of background and 
photographic objects and, finally, the running of the "Photorealism" command with various 
quality options are all performed in a friendly and fast way through the "PhotoIDEA" group of 
commands. 

� WalkIDEA is the virtual Walkthrough module of ProgeCAD Architecture, which enables the 
user to take a "walk" inside or outside the building model, in order to face the reality. 
WalkIDEA makes “alive” the scenes of PhotoIDEA in a very simple manner: Either by using 
the mouse or a joystick or by defining a viewing path. Any virtual "trip" can be stored as an 
avi file. More than a simple walk, the "WalkIDEA" group of commands also includes some 
supplementary effects, such as the ascension of a staircase, the option to open a door while 
"walking" etc. In addition, WalkIDEA can offer the experience of a 4D stereoscopic reality 
through a pair of stereo glasses. 
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1.4 User’s Guide Structure 
 

This user’s guide is divided into 11 chapters: 

This Chapter 1 describes the package installation procedure, as well as its general philosophy 
and basic operation principles. 

Chapter 2 refers to certain basic drawing principles, which are necessary, especially to those 
who are not familiar with designing packages. This chapter can be run over, or even skipped, by 
those who are familiar with AutoCAD (an autodesk’s product and trademark) or IntelliCAD. 

Chapter 3 describes in detail the operation of AutoREG, the Topographical component of the 
ProgeCAD Architecture. 

Chapters 4-7 describe the Architectural Synthesis component AutoBLD along with all its 
functions and commands. More specifically: 

Chapter 4 shows the building definition principles and the basics on the structural elements 
adopted by ProgeCAD Architecture. 

Chapter 5 describes the drawing of the basic architectural theme elements in detail, primarily 
walls and openings as well as pillars and slabs. 

Chapter 6 provides the detailed instructions for drawing composite elements, such as roofs, 
staircases, rails and gables. 

Chapter 7 describes all the remaining AutoBUILD group of commands, emphasising on the 
viewing and generating functions of the project drawings. 

Chapter 8 describes the drawing utilities of the PLUS group of commands, used mostly for the 
further processing of the project drawings. 

Chapter 9 presents, through an example, the necessary steps of how to create a simple project, 
so that all the issues described in the previous chapters of this Guide become clearer.  

Chapter 10 describes how the user can work with PhotoIDEA component in order to create 
photorealistic images of high quality. 

Finally, Chapter 11 of the User’s Guide includes the WalkIDEA component Instructions 
concerning the virtual reality walkthrough.  
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1.5 Main menu 
As soon as the program starts running, the following main menu appears on the screen:  

 
The main menu options include the following groups: 

1. The project files management options (New Project, Open Project and Project Information) 
which are located within the FILE group of commands. 

2. The AutoREG group of commands, including the instructions required for the creation and 
editing of the Topographical diagram. 

3. The AutoBLD menu, which includes all the drawing-editing and viewing commands of the 
Architectural Design process. 

4. The PhotoIDEA menu option, with the commands supporting the photorealism. 

5. The WalkIDEA group of commands, supporting the virtual reality walkthrough. 

6. The bonus menu named PLUS, which includes a series of drawing utilities for the ProgeCAD 
Architecture user. 
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To start drawing with ProgeCAD Architecture, a 
new project should be first defined with the 
“New Project” command, which is included in 
the “FILE” menu. With this command, a 
window will appear on the screen where you 
must type the name of the Project. Then, click 
OK and you will be ready to start drawing and 
work on the project. 

In order to "open" an existing project, e.g. a project created through ProgeCAD Architecture (i.e. 
for further editing or just for viewing), just select "Open Project", and a list with the existing 
projects in your disk will be displayed on the screen. The functionality of this window list follows 
the windows standards. 

 
It is pointed out that the ProgeCAD Architecture projects are saved into directories with the 
extension BLD, following the general 4M "Building" standardisation. If an existing project is 
selected, it is loaded and displayed on the screen. In any case, you can start working with 
ProgeCAD Architecture, using its commands grouped as described above. A detailed 
description of those commands is provided within the Chapters 3-11 of this User Guide. Before 
that, a brief reference to the basic drawing principles is given within next Chapter 2, a Chapter 
that could be skipped by the user who is familiar with CAD programs. 
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2. Drawing Principles 
 

 

2.1 ProgeCAD Architecture General Drawing 
Commands  
The aim of this section is to describe the operation of the general drawing commands. 
The commands which belong to the specific architectural commands of ProgeCAD 
Architecture, such as the group of commands AutoREG or AutoBLD, are described in 
detail within the next chapters. The objective of the following paragraphs is rather the 
familiarization of the user with the basic principles of the CAD programs. The users 
who know how to work with CAD programs can ignore this section.  

2.1.1 Working with ProgeCAD Architecture 
You can work with the ProgeCAD Architecture window and its elements in a variety of 
ways. For example, you can display and rearrange the toolbars, display the command 
bar, and enable the status bar. The toolbars and command bar can also be floated 
anywhere on the screen or docked to the edges of the main ProgeCAD Architecture 
window.  
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A. You can customize the menu bar at the top of the window. 

B. You can customize the toolbars, changing the appearance and arrangement of tools and 
adding your own commands and macros. 

C. Your drawings are displayed in the drawing window. 

D. Click a tab to switch between the drawing of your model and a printed layout. 

E. You can type commands in the command bar. To reposition the command bar, drag it to 
another location on your screen. 

F. The status bar displays information such as the name or purpose of a tool, the current cursor 
coordinates, layer name, and mode settings. 

G. The user coordinate system (UCS) icon indicates the orientation of the drawing in three-
dimensional space. 

H. You can move and dock the toolbars to any location on your screen. 

J. Properties Panel. Displays all entity data. 

I. Building Explorer. Displays information for the building. 

2.1.2 Displaying commands on a shortcut menu 
Shortcut menus provide quick access to specific commands. A shortcut menu displays 
when you right-click an entity, toolbar, status bar, the Model tab name, or a Layout tab 
name. The selections presented in the shortcut menu depend on what you clicked.  

When you right-click a toolbar, the program displays a shortcut menu that lets you 
toggle the command bar, status bar, and various toolbars on and off. If you select one 
or more entities and then right-click, the program displays a shortcut menu from which 
you can choose a command to modify the selected entities. To display a shortcut menu 
from which you can choose an entity snap, press and hold down the <Shift> key, and 
then right-click anywhere within the drawing window.  

2.1.3 Displaying and hiding toolbars 
When you start ProgeCAD Architecture the first time, multiple toolbars are displayed. 
ProgeCAD Architecture provides more than a dozen toolbars, which you can 
customize by adding and deleting tools. You can also move and resize toolbars, and 
you can create new toolbars. You can use a shortcut menu to display or hide toolbars.  

You can also choose whether toolbars are displayed large or small and in color. You 
can choose to display or hide ToolTips, which provide descriptions of tools that display 
when you pause the cursor over them. Go to View > Toolbars to make these 
selections.  

Toolbars are either docked or floating. A floating toolbar has a title bar and a Close 
box, can be located anywhere on the screen, and can be resized. A docked toolbar 
does not display a title or Close box, cannot be resized, and is attached along one of 
the edges of the drawing window.  

• To dock a toolbar, drag it to the perimeter of your drawing; to undock it, drag it 
away from the perimeter.  

• To position a toolbar in a docking area without docking it, press Ctrl while you 
drag it.  

• To move a toolbar, drag it to a new location.  

• To resize a toolbar, move your cursor to the edge until it changes to a resize 
arrow, and then drag.  
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To choose which toolbars to display  
1. Do one of the following:  

• Choose View > Toolbars.  

• Right-click anywhere on a docked toolbar to display the toolbar shortcut menu, 
and then choose Toolbars. You can also select the toolbars you want displayed 
directly on the shortcut menu.  

2. In the Select Toolbars dialog box, choose the toolbars you want displayed, and 
then click OK.  

 
Select the check boxes for the toolbars you want to display. 

2.1.4 Using the command bar  
The command bar is a dockable window in which you type ProgeCAD Architecture 
commands and view prompts and other program messages. To display the command 
bar, choose View > Command Bar. The command bar displays the three most recent 
lines of prompts. You can move the command bar by dragging it.  

When the command bar is floating, you can drag the top or bottom of the window to 
change the number of lines of text it displays. You can dock the command bar at the 
top or bottom of the drawing. 

2.1.5 Using the status bar 
If you elect not to use the command bar, the status bar displays information about the 
selected command or tool. It also displays the current cursor coordinates, the name of 
the current layer, mode settings, and other information about current settings.  

In addition to displaying information, the status bar is a quick way to access many 
features. You can click status bar items to make changes, and right-click items to 
display short-cut menus that allow you more choices.  

 
A. Information about the current command. 
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B. Cursor coordinates (x,y,z) 

C. Layer name. Double-click to change layers. 

D. Drawing color. Double-click to change colors. 

E. Linetype. By default, the linetype is BYLAYER. snaps. 

F. Lineweight. By default, the lineweight is BYLAYER. Double-click to change lineweights. 

G. Text style. Double-click to change text styles. 

H. Dimension style. Double-click to change dimension styles. 

I. Snap setting. Double-click to toggle on or off. 

J. Grid setting. Double-click to toggle on or off. 

K. Orthogonal setting. Double-click to toggle on or off. 

L. Entity snap setting. Double-click to select entity. Double-click to change linetypes. 

M. Lineweight display. Double-click to toggle on or off. 

N. Model space or paper space. Double-click to toggle between model space and paper space. 

O. Digitizer mode. Double-click to toggle on or off. 

To change the items that display on the status bar 
1. Right-click an empty area of the status bar. 

2. Select an item to add or remove it. 

To change the setting of an item on the status bar 
1. Do one of the following:  

• Double-click the status bar item.  

• Right-click the status bar item you want to change, and then select the desired 
setting. 

2.1.6 Using prompt boxes 
ProgeCAD Architecture commands often provide several options. These options 
appear in the status bar or command bar and also in a prompt box (called a context 
menu in AutoCAD) initially displayed in the upper right corner of the screen. You can 
move the prompt box by dragging it; future prompt boxes will appear where you last 
placed it. The options appear as menu selections. Choose the appropriate option by 
selecting it in the prompt box. To close a prompt box, click the Close box.  

 
Command options appear in a prompt box.  
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The prompt box is displayed by default. To turn off the display of prompt boxes, choose 
Tools > Options, click the Display tab, and then click the Display Prompt Boxes check 
box to clear it. 

2.1.7 Selecting commands  
Select commands using any of these methods:  

• Choose a command from a menu.  

• Click a tool in a toolbar.  

• Type the command in the command bar.  

Some commands remain active until you end them, so you can repeat an action 
without having to select a command repeatedly. You can end a command by clicking 
Done in the prompt box or by pressing Esc.  

2.1.8 Using commands  
You can use most commands while another command is active. For example, while 
drawing a line, you may want to use the Pan command to move the drawing across the 
screen to select the endpoint of the line. You can also change the settings of drawing 
aids such as snap or grid while other commands are active.  

2.1.9 Starting commands using toolbars  
To start a command from a toolbar, click a tool and respond to the prompts.  

Some tools, such as Line or Arc, contain flyouts, which are options either for using the 
basic tool with different methods or that contain other, related tools. Flyouts are 
indicated by a small triangle in the lower right corner of a tool. To display a flyout, click 
the tool and hold down the mouse button. To select a tool from a flyout, point to the tool 
you want and then release the mouse button. The tool you select on the flyout 
becomes the default tool on the toolbar.  

2.1.10 Starting commands using menus  
To start a command from a menu, choose it from the list of menu options available.  

2.1.11 Starting commands using the command bar  
Type a command, and then press Enter. If the command bar is displayed, the 
command you typed appears there. If the command bar is not displayed, the command 
you typed appears in the status bar.  

2.1.12 Repeating a command  
You can repeat the command you just used without having to reselect it by doing one 
of the following:  

• Press the spacebar.  

• Press Enter.  

• Click the right mouse button.  

TIP: If you are using the command bar to type commands, you can type multiple 
before starting some commands (Circle, Arc, and Rectangle, for example) to repeat a 
command indefinitely. When you are done with a command, press Esc.  
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2.1.13 Nesting a command  
If you are working in the command bar, you can use another command from within a 
command, called nesting. To use a command inside an active command, type an 
apostrophe before you type the command, such as ‘circle, ‘line, or ‘pyramid. You can 
nest commands indefinitely in ProgeCAD Architecture. Many menu and toolbar macros 
work this way by default; for example, select color, reference grid, zoom, and snap. 
When you have finished with the nested command, the original command resumes.  

2.1.14 Using the Prompt History window  
The Prompt History window displays a history of the commands and prompts issued 
since you started the current session of ProgeCAD Architecture. By default, the 
program tracks up to 256 command lines. There is no limit to the number of command 
lines you can track, but program performance may be degraded if you choose to track 
an excessively high number of lines.  

To display or close the Prompt History window 

• Press F2. 

To change the number of command lines to track 
1. Do one of the following: 

• Choose Tools > Options, and then click the Display tab.  

• Type options and then press Enter. Click the Display tab.  

2. In the Command Lines To Track field, type the number of command lines you 
want to display, and then click OK.  

2.1.15 Using scripts  
The ProgeCAD Architecture Script Recorder captures and saves many of your actions 
so you can play them back. After you enable the Script Recorder, all commands and 
options that you type in the command bar are recorded until you type a command to 
stop recording. When you run the script, the program carries out the recorded 
commands in succession.  

2.1.16 Correcting mistakes  
ProgeCAD Architecture tracks the commands you use and the changes you make. If 
you change your mind or make a mistake, you can undo, or reverse, the last action or 
several previous actions. You can also redo any actions that you reversed.   

 
A Click the Undo tool to reverse the last action. 

B Click the Redo tool to reverse the previous undos. 

You can undo multiple actions by typing undo and specifying the number of actions to 
undo.  
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2.1.17 Customizing ProgeCAD Architecture 
You can tailor many aspects of ProgeCAD Architecture to better suit your needs. For 
example, you can easily create and modify toolbars by simply dragging and dropping 
icons. If you want to restore any area of the user interface back to its default state, click 
Reset. ProgeCAD Architecture stores your customized settings in the Windows registry 
rather than in a separate file.  

ProgeCAD Architecture supports the most important AutoCAD customization files, 
including linetypes, hatch patterns, text fonts, the unit conversion file, menus, toolbars, 
and aliases. In addition, ProgeCAD Architecture unifies four AutoCAD customization 
functions with a single customize command: command aliases, keyboard shortcuts, 
menus, and toolbars.  

You can also add custom programs written in any of several programming languages, 
including the following:  

• LISP (the program’s Autodesk® AutoLISP-compatible language)  

• SDS (the program’s Autodesk® ADS-compatible language)  

• Microsoft® Visual Basic for Applications (VBA)  

Tip: You can easy modify menus and toolbars by selecting Tools>Menu Select. In this 
window you can change the language and the type of appearance: 

 
Please note that each mouse button performs a specific function. The functions of the 
mouse buttons are the following: 

Left button:  Selection of a command, point or object. 

Right button:  Enter 

Middle button:  "Esnap" command. 

Note: In case your mouse has only two buttons (or it has three buttons, but the 
mouse driver has not been properly installed for the middle button to function), 
the first two functions are executed as described while the third one can be 
substituted by the combination of the "Shift" key and the right mouse button 
(right click while <Shift> is pressed down) 
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2.2 Working with drawings 
CAD drawings help you organize information for greater efficiency. With ProgeCAD 
Architecture, you can draw entities representing different types of information on 
various layers and use those layers to control color, linetype, and visibility. ProgeCAD 
Architecture also includes drawing aids that help you draw accurately.  

This section explains setting up drawings and using built-in drawing aids, including how 
to:  

- Create new drawings, open existing drawings, and save changes to drawings.  

- Use aids such as the grid, snap, and orthogonal settings to draw accurately.  

2.2.1 Creating a new drawing  
When you start ProgeCAD Architecture, the program automatically creates a new 
drawing based on a template drawing, Idea2k_en.dwg. This template includes 
predefined settings such as drawing units, text size, and drawing area. You can either 
use these settings or change them according to your needs. There is nothing unique 
about a template drawing. You can use any drawing as a template for future drawings.  

You can save many steps by basing a new drawing on an existing template (.dwt file). 
By doing this, a new drawing will contain all the settings and entities you need. When 
you open a new drawing from your custom template, you can modify existing settings 
and delete any entities that you don’t need. When you save a drawing that was created 
using a template, you do not change the template.  

To create a new drawing based on a template 
1. Do one of the following:  

• Choose File > New.  

• Type newwiz and then press Enter. 
2. Click Use A Template Drawing, and then click Next.  

3. To display the Open Template dialog box, click Browse.  

4. Select the template (.dwt) file that you want, and then click Open. You can also 
choose any drawing (.dwg) file to use as a template.  

5. Click Finish.  

2.2.2 Opening a drawing  
You can open drawing (.dwg) files, Drawing Exchange Format (.dxf) files, Design Web 
Format (.dwf) files, and drawing template (.dwt) files.  

You can also open and check drawings that you suspect are damaged.  

Opening an existing drawing  
You can open any of these drawing files:  

- Standard drawing files with a .dwg extension.  

- Drawing Exchange Format files with a .dxf file extension.  

- Design Web Format files with a .dwf file extension.  
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- Drawing templates with a .dwt file extension.  

To open an existing drawing 
1. Use one of the following methods:  

• Choose File > Open.  

• On the Standard toolbar, click the Open tool ( ).  

• Type open and then press Enter.  
2. In Files of Type, choose the type of file you want to open. 

3. Choose the folder containing the desired file. 

4. Choose the drawing you want to open. 

5. Click Open.  

If the drawing requires a password, enter the password, click OK to verify the 
password, and then click Open again.  

TIP: To quickly open a drawing file from the Open Drawing dialog box, double-click the 
drawing name. 

 

A. Displays a description of the file size, creation date, and other information about the drawing. 

B. Opens the drawing as read-only to prevent making changes to the file. 

C. Turns the drawing preview on or off. 

D. Unavailable when opening drawings; available only when saving drawings. 

E. Displays an image of the drawing before you open it. 

TIP: To quickly open a drawing file that you recently used, choose File > <file name>. 
The program tracks the last four drawings 
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2.2.3 Opening damaged files  
Files can become damaged for many reasons. For example, if you are working on a 
drawing during a power outage, a system crash, or a hardware failure, your drawing file 
may become damaged. ProgeCAD Architecture allows you to open and check 
damaged files to attempt file recovery.  

Recovering a file attempts to open one of the following file types:  

- Standard drawing files with a .dwg extension.  

- Drawing Exchange Format files with a .dxf file extension.  

- Design Web Format files with a .dwf file extension.  

- Drawing templates with a .dwt file extension.  

You can also check any open file for errors.  

To open a damaged file 
1. Use one of the following methods: 

• Choose File > Recover. 

• Type recover and then press Enter. 
2. In Files of Type, choose the type of file you want to recover. 

3. Choose the directory containing the damaged file. 

4. Choose the damaged file you want to recover. 

5. Click Open.  

To check a drawing file for errors 
1. With the drawing open that you want to check, do one of the following: 

• Choose File > Audit. 

• Type audit and then press Enter. 
2. Choose whether you want ProgeCAD Architecture to fix any found errors 

automatically, and then press Enter.  

NOTE If the AUDITCTL system variable is set to On and errors are found during a file 
recovery or audit, an ASCII file is created that describes the audit. The ASCII file is 
saved in the same folder as the audited drawing, and has the same name as the 
drawing file, but with an .adt file extension.  

2.2.4 Setting up a drawing  
You can specify individual settings when you create a new drawing or when you modify 
settings in a drawing created from a template.  

Setting the current layer  
Layers are like the overlays that you use in manual drafting. You use layers to organize 
different types of drawing information. Every drawing has at least one layer, the default 
layer, named “0.” Your drawing can also contain an unlimited number of additional 
layers. When you create an entity, it is created on the current layer.  

To set the current layer  
1. Do one of the following: 
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• Choose Settings > Explore Layers. 

• On the Settings toolbar, click the Explore Layers tool ( ) 

• Type explayers and then press Enter. 

• Type la and then press Enter. 

2. Double-click the layer name that you want to make current. 

3. Close the ProgeCAD Architecture Explorer window. 

 
Double-click the layer name that you want to make current.  

TIP: On the status bar, right-click on the current layer control, and from the list, select 
the layer you want to make current.  

Setting the current entity color 
An entity’s color determines how it is displayed and, if you are using a color printer, 
how it prints. Entities are created in the current color. There are 255 standard colors 
and two additional color properties that are often referred to as colors. 

You can use seven of the 255 standard colors by name: red, yellow, green, cyan, blue, 
magenta, and white. (Numbers eight and nine are not named.) Each color has a unique 
number from 1 to 255. The two additional color properties are BYLAYER and 
BYBLOCK. These color properties cause an entity to adopt the color either of the layer 
or of the block in which it is a member. BYLAYER is color number 256, and BYBLOCK 
is color number 0. In all commands for which you would use a color, you can indicate 
BYLAYER and BYBLOCK as well as by numbers 256 and 0, respectively. 

You can choose colors by selecting them from the Color dialog box. In the command 
bar or in some dialog boxes, you specify a color either by name or by number. 

When you open a new drawing, entities are created in the color BYLAYER, which 
adopts the color of the current layer. Initially, layer 0 is both the only layer and the 
current layer. Its default color is white, so your entities appear as white.  

To set the current entity color 
1. Do one of the following:  

• Choose Settings > Drawing Settings.  

• On the Settings toolbar, click the Drawing Settings tool ( ) 

• Type settings and then press Enter. 



 
 

22  4M 

2. Click the Entity Creation tab. 

3. Click Select Color. 

4. In the Color dialog box, click BYBLOCK, BYLAYER, or the color of your choice, or 
type the color number in the Index box.  

5. Click OK. 

6. Click OK again.  

TIP: On the status bar, right-click on the current color, and select from the list the color 
you want to use for new entities. You can also click Select Color to choose additional 
colors.  

 
A. Click to set the color to one of the standard colors. 

B. Click to set the color to one of the gray shades. 

C. Click to set the color to any of the available colors. 

D. Indicates the current color. 

E. Displays the color number. 

F. Click to set the current color BYLAYER. 

G. Click to set the current color BYBLOCK. 

Setting the current linetype  
Linetypes help convey information. You use different linetypes to differentiate the 
purpose of one line from another. A linetype consists of a repeating pattern of dots, 
dashes, or blank spaces. Linetypes determine the appearance of entities both on the 
screen and when printed. By default, every drawing has at least three linetypes: 
CONTINUOUS, BYLAYER, and BYBLOCK. Your drawing may also contain an 
unlimited number of additional linetypes. 

When you create an entity, it is created using the current linetype. By default, the 
current linetype is BYLAYER. progeCAD indicates that the entity linetype is determined 
by the current layer’s linetype by assigning the BYLAYER property as the default 
linetype setting. When you assign BYLAYER, changing a layer’s linetype changes the 
linetype of all the entities assigned that layer (if they were created using the linetype 
BYLAYER). 
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You can also select a specific linetype as the current linetype, which overrides the 
layer’s linetype setting. Entities are then created using that linetype, and changing the 
layer linetype has no effect on them.  

As a third option, you can use the linetype BYBLOCK property, in which case new 
entities are drawn using the CONTINUOUS linetype until you group them into a block. 
The entities then inherit the block’s linetype setting when you insert the block into a 
drawing.  

To set the current linetype 
1. Do one of the following: 

• Choose Settings > Drawing Settings.  

• On the Settings toolbar, click the Drawing Settings tool ( ) 

• Type settings and then press Enter. 
2. Click the Entity Creation tab. 

3. In the Entity Linetype list, choose the linetype that you want to make current. 

4. Click OK.  

TIP: On the status bar, right-click the word BYLAYER for the current linetype, click 
Properties, and then choose the linetype that you want to make current.  

Setting the linetype scale  
You can specify the linetype scale. The smaller the scale, the more repetitions of the 
linetype pattern are generated per drawing unit. For example, a linetype pattern is 
defined as a sequence of dashed lines and open spaces, each 0.25 units long. The 
line-type scale uses the drawing scale factor to determine the length. A scale factor of 
0.5 would reduce the length of each line and space to 0.125 units; a scale factor of 2 
would increase the length of each to 0.5 units. 

NOTE: Setting the linetype scale too large or too small may result in a line pattern 
looking like a solid line, depending on what the scale view is or at what scale the 
drawing is plotted.  

You can control a new entity’s individual linetype scale factor as well as the overall or 
global scale factor applied to all the entities in the drawing.  

To set the current individual linetype scale 
1. Do one of the following: 

• Choose Settings > Drawing Settings. 

• On the Settings toolbar, click the Drawing Settings tool ( ). 

• Type settings and then press Enter. 
2. Click the Entity Creation tab. 

3. In the Linetype Scale field, type or choose the linetype scale that you want to make 
current. 

4. Click OK.  

To change the global linetype scale  
1. Do one of the following:  

• Choose Settings > Drawing Settings.  
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• On the Settings toolbar, click the Drawing Settings tool ( ). 

• Type settings and then press Enter. 
2. Click the Entity Creation tab. 

3. In the Global Linetype Scale field, type or choose the global linetype scale that you 
want to change. 

4. Click OK.  

Setting the current lineweight  
Lineweights help differentiate the purpose of one line from another. Lineweights 
determine how thick or thin entities appear both on the screen and when printed. Every 
drawing has these lineweights: DEFAULT, BYLAYER, BYBLOCK, and many additional 
lineweights in millimeters (or you can use inches). 

When you create an entity, it is created using the current lineweight. By default, the 
current lineweight for a new entity is BYLAYER. This means that the entity line-weight 
is determined by the current layer. When you assign BYLAYER, changing a layer’s 
lineweight changes the lineweight of all the entities assigned that layer (if they were 
created using the lineweight BYLAYER).  

You can also select a specific lineweight (or DEFAULT) as the current lineweight, 
which overrides the layer’s lineweight setting. Entities are then created using that 
lineweight (or the DEFAULT lineweight), and changing the layer lineweight has no 
effect on them.  

As a third option, you can use the lineweight BYBLOCK property, in which case new 
entities are drawn using the DEFAULT lineweight until you group them into a block. 
The entities then inherit the block’s lineweight setting when you insert the block into a 
drawing.  

If you choose a lineweight that is less than .025 millimeter, it displays as one pixel 
when you create your drawing. When you print your drawing, it prints at the thinnest 
lineweight that is available for your printer.  

You cannot assign lineweights to planes, points, TrueType fonts, and raster images (if 
supported in your version of progeCAD).  

To set the current lineweight 
1. Do one of the following:  

• Choose Settings > Drawing Settings.  

• On the Settings toolbar, click the Drawing Settings tool ( ). 

• Type settings and then press Enter. 
2. Click the Entity Creation tab.  

3. In the Lineweight list, choose the lineweight that you want to make current.  

4. Click OK.  

TIP: On the status bar, right-click the word BYLAYER for the current linetype, and then 
choose the current lineweight. You can also double-click the word LWT to toggle the 
display of lineweights on and off.  
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NOTE: To see lineweights in your drawing, you may need to turn on lineweights. For 
details, see “Controlling the display of lineweights”. 

Setting drawing units 
With ProgeCAD Architecture, you typically draw at full-size (1:1 scale), and then set a 
scale factor when you print or plot your drawing. Before you begin drawing, however, 
you need to determine the relationship between drawing units and real-world units.  

For example, you can decide whether one linear drawing unit represents an inch, a 
foot, a meter, or a mile. In addition, you can specify the way the program measures 
angles. For both linear and angular units, you can also set the degree of display 
precision, such as the number of decimal places or smallest denominator used when 
displaying fractions. The precision settings affect only the display of distances, angles, 
and coordinates. ProgeCAD Architecture always stores distances, angles, and 
coordinates using floating-point accuracy.  

To set the linear drawing units 
1. Do one of the following:  

• Choose Settings > Drawing Settings.  

• On the Settings toolbar, click the Drawing Settings tool ( ). 

• Type settings and then press Enter.  
2. Click the Drawing Units tab.  

3. Under Change Settings For, choose Linear Units.  

4. Under Unit Types, select a unit type.  

5. Under Display Precision, type the display precision according to the number of 
decimal places you want, or click the arrows to select it. The field above this setting 
shows an example of the linear unit type at the current precision.  

6. Click OK.  

 

A. Select the type of linear units. B. Choose the display precision for linear units.  
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To set the angular drawing units  
1. Do one of the following:  

• Choose Settings > Drawing Settings. 

• On the Settings toolbar, click the Drawing Settings tool ( ). 

• Type settings and then press Enter.  
2.  Click the Drawing Units tab. 

3. Under Change Settings For, choose Angular Units. 

4. Under Unit Types, select a unit type. 

5. Under Display Precision, type the display precision according to the number of 
decimal places you want, or click the arrows to select it. The field above this setting 
shows an example of the angular unit type at the current precision.  

6. Under Angle Direction, select the direction in which angles increase when you 
specify a positive angle value.  

7. Under Angle Base, specify the compass location for the zero angle. For example, 
by default, angle 0 is at the “three o’clock” or “east” position. The adjacent icon 
shows the current location of the angle base.  

8. Click OK.  

 
A. Determines the type of units you are controlling. 

B. Select the type of angular units. 

C. Choose the display precision for angular units.  

D. Select the direction in which angles increase. 

E. Select the angle base, the direction of the zero angle. 
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Understanding scale factors  
Instead of drawing to a particular scale, you draw everything in the program full-size. 
Although it’s a good idea to keep your scale factor in mind when setting up a drawing, 
you don’t need to set the scale until you print it. For example, when you draw a 
mechanical part 40 inches in length with ProgeCAD Architecture, you actually draw it 
as 40 inches, rather than applying a scale factor as you draw. When you print your 
drawing, you can assign the scale at which the drawing is to print. 

Scale, however, does affect the way a few elements such as text, arrows, or linetypes 
print or plot in your drawing. For these, you can make adjustments when you first set 
up your drawing so that they print or plot at the correct size. For example, when you 
draw text, you need to determine the text size so that when you plot it later at a 
particular scale, the text height is correct.  

After you determine the eventual scale of your finished drawing, you can calculate the 
scale factor for the drawing as a ratio of one drawing unit to the actual scale unit 
represented by each drawing unit. For example, if you plan to print your drawing at 1/8” 
= 1’-0”, your scale factor ratio is 1:96 (1/8” = 12” is the same as 1 = 96). If you want 
your printed scale to be 1 inch = 100 feet, your scale factor ratio is 1:1200.  

The following table shows some standard architectural and engineering scale ratios 
and equivalent text heights required to create text that measures 1/8-inch high when 
you plot the drawing at the specified scale. 
Standard scale ratios and equivalent text heights 

Scale Scale factor Text height  

1/16” = 1’-0” 192 24” 

1/8” = 1’-0” 96 12” 

3/16” = 1’-0” 64 8” 

1/4” = 1’-0” 48 6” 

3/8” = 1’-0” 32 4” 

1/2” = 1’-0” 24 3” 

3/4” = 1’-0” 16 2” 

1” = 1’-0” 12 1.5” 

1 1/2” = 1’-0” 8 1” 

3” = 1’-0” 4 0.5” 

1” = 10’ 120 15” 

1” = 20’ 240 30” 

1” = 30’ 360 45” 

1” = 40’ 480 60” 

1” = 50’ 600 75” 

1” = 60’ 720 90” 

1” = 100’ 1200 150”  

You can use these scale factors to predetermine the size of your drawing to make sure 
that it fits on a specific size paper when you print it. You control the size of your 
drawing by the drawing limits. To calculate the drawing limits to match the size of your 
paper, multiply the dimensions of your paper size by your scale factor.  
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For example, if the paper you use to print measures 36 inches x 24 inches and you plot 
your drawing at 1/8” = 1’-0” (in other words, using a scale factor of 96), the size of your 
drawing measured in drawing units is 36 x 96 (or 3,456 units) wide and 24 x 96 (or 
2,304 units) high.  

Keep in mind that you can print the finished drawing at any scale, regardless of the 
scale factor you calculate. You can also print on paper of a different size and use the 
Layout tabs to create different views of your drawing and to position and scale those 
views differently. The scaling factor is not related to the size of the entities you draw; it 
simply provides a preliminary guide to help you establish the text height and drawing 
limits when you begin your drawing. You can change the text height and drawing limits 
at any time.  

Setting the text height 
The text height setting controls the height of text, measured in drawing units. Set this 
value initially so that text used for your most common annotations, when scaled to the 
size at which you will print a drawing, measures 1/8-inch high on the printed drawing.  

For example, if you plan to print your drawing at 1/8” = 1’-0” and you want your text to 
be 1/8-inch high in the final drawing, create that text 1 foot high (in your real-world 
drawing units) so that when you print it, it appears 1/8-inch high on the paper. You 
must create text 4 feet high that you want to print 1/2-inch high.  

To set the text height  
1. Do one of the following:  

• Choose Settings > Drawing Settings.  

• On the Settings toolbar, click the Drawing Settings tool ( ). 

• Type settings and then press Enter.  
2. Click the Entity Creation tab. 

3. Under Change Settings For, choose Text. 

4. In the Default Text Height field, select the text height or type the text height value 
that you want. 

5. Click OK. 

 

A. Choose Text. B. Specify the text height in drawing units.  
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NOTE: The default text height applies only if the current text style height is 0.0. 
Otherwise, the text height for the current style takes precedence.  

Setting the drawing limits  
You can specify the drawing limits that form an invisible boundary around your drawing. 
You can use the drawing limits to make sure that you do not create a drawing larger 
than can fit on a specific sheet of paper when printed at a specific scale.  

For example, if you plan to print your drawing at 1/8” = 1’-0” (in other words, using a 
scale factor of 96) on a sheet of paper measuring 36 inches x 24 inches, you can set 
drawing limits to 3,264 units wide (that is, 34 x 96) and 2,112 units high (22 x 96), 
which allows a 1-inch margin around the edges of the printed image.  

To set the drawing limits 
1. Do one of the following:  

• Choose Settings > Drawing Settings.  

• On the Settings toolbar, click the Drawing Settings tool ( ). 

• Type settings and then press Enter. 

2. Click either the Coordinate Input tab or the Display tab. 

3. Under Change Settings For, choose Limits. 

4. Specify the x-coordinate and y-coordinate of the upper right drawing limit and the 
lower left drawing limit. You can also click Select to specify the drawing limits by 
selecting points in the drawing.  

5. To constrain your drawing to these drawing limits, click the Disallow Input Beyond 
Limits check box.  

6. Click OK. 

 

A Choose limits. 

B. Specify the x-coordinate and y-coordinate of the upper right drawing limit. 

C. Specify the x-coordinate and y-coordinate of the lower left drawing limit. 
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D. When you click this check box, the program prevents you from drawing outside the drawing 
limits. 

E. Specify the drawing limits by selecting points in the drawing. 

2.2.5 Setting and changing the grid and snap alignment 
Grid and snap settings are effective tools to use in your drawing to ensure accuracy. 
Although many users find it convenient to match grid points to snap settings, they are 
independent of each other and should not be confused. Grid points are for visual 
reference only; they do not affect your drawing and they do not print. Snap points are, 
by themselves, not visible; however, when set, they constrain the creation of new 
entities. 

Setting a reference grid 
A reference grid displays as a pattern of regularly spaced dots. You can turn the 
display on and off, and you can specify how far apart the dots are spaced.  

The reference grid extends only to the limits of the drawing, helping you to visualize the 
boundary of your drawing and to align entities and visualize distances between entities. 
You can turn the grid on and off as needed. You can also change the spacing of the 
grid at any time.  

To turn the grid on and set the grid spacing  
1. Do one of the following:  

• Choose Settings > Drawing Settings. 

• On the Settings toolbar, click the Drawing Settings tool ( ). 

• Type settings and then press Enter. 
2. Click the Coordinate Input tab. 

3. Under Change Settings For, choose Snap And Grid. 

4. Under Reference Grid, click the Show Grid check box. 

5. Under Reference Grid Spacing, in the X field, choose the horizontal grid spacing. 

6. Under Reference Grid Spacing, in the Y field, choose the vertical grid spacing. 

7. Click OK.  

TIP: To toggle the grid display on and off at any time, double-click the GRID setting on 
the status bar, click the Reference Grid tool ( ) on the Settings toolbar, or press F7.  
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A. Click the check box to enable orthogonal mode. 

B. Click the check box to display the reference grid. 

C. Specify the x and y grid spacing. 

D. Click the check box to enable snap mode. 

E. Specify the x and y snap spacing. 

F. Click the check box to use an isometric snap and grid. 

G. Click the current isometric plane. 

H. Specify the grid rotation angle. 

I. Indicates the current grid rotation angle. 

J. Specify the x- and y-coordinates of the snap origin. 

K. Click to match the grid spacing to the snap spacing. 

Setting snap spacing  
Another way to ensure drawing accuracy is to turn on and set snap spacing. When 
snap is turned on, the program restricts the selection points to predetermined snap 
intervals. Although it is often helpful to match the snap spacing to some interval of the 
grid spacing or another related setting, the settings do not have to match.  

To turn snap settings on and set snap spacing 
1. Do one of the following:  

• Choose Settings > Drawing Settings.  

• On the Settings toolbar, click the Drawing Settings tool ( ). 

• Type settings and then press Enter. 
2. Click the Coordinate Input tab. 

3. Under Change Settings For, choose Snap And Grid. 

4. Under Snap Settings, click the Snap check box to turn Snap on. 
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5. Under Snap Settings Spacing, in the X field, choose the horizontal snap spacing. 

6. Under Snap Settings Spacing, in the Y field, choose the vertical snap spacing. 

7. Click OK.  

TIP: To toggle snap settings on and off at any time, double-click the SNAP setting on 
the status bar, click the Snap tool ( ) on the Settings toolbar, or press F9.  

In addition to setting the snap spacing, you can change the snap and grid orientation. 
You can also rotate the alignment of the grid or set it to create isometric drawings.  

Changing the snap and grid angle and base point  
The snap and grid are both normally based on the drawing origin, the 0,0 coordinate in 
the World Coordinate System (WCS). You can relocate the snap and grid origin, 
however, to help you draw entities in relation to a different location. You can also rotate 
the grid to a different angle to realign the crosshairs to the new grid angle. If the grid is 
on, and the grid spacing is 0,0, then the grid defaults to the snap spacing.  

To change the snap angle and base point  
1. Do one of the following:  

• Click Settings > Drawing Settings.  

• On the Settings toolbar, click the Drawing Settings tool ( ) 

• Type settings and then press Enter.  
2. Click the Coordinate Input tab.  

3. Under Change Settings For, select Snap And Grid.  

4. Under Snap Settings, click the Snap check box to turn Snap on.  

5. Under Reference Grid, click the Show Grid check box to turn Show Grid on.  

6. Under Snap And Grid Settings, in the X Origin field, type the x-coordinate of the 
new snap origin.  

7. Under Snap And Grid Settings, in the Y Origin field, type the y-coordinate of the 
new snap origin.  

8. Under Snap And Grid Settings, in the Rotation field, type the grid rotation angle.  

9. Click OK. 

 
Default grid and snap alignment. Rotated grid and snap alignment.  
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Using isometric snap and grid  
You can use the Isometric Snap And Grid option to create two-dimensional isometric 
drawings. With the isometric option, you are simply drawing a simulated three-
dimensional view on a two-dimensional plane, much the same as you might draw on a 
piece of paper. Do not confuse isometric drawings with three-dimensional drawings. 
You create three-dimensional drawings in three-dimensional space.  

The isometric option always uses three preset planes, which are denoted as left, right, 
and top. You cannot alter the arrangement of these planes. If the snap angle is 0, the 
three isometric axes are 30 degrees, 90 degrees, and 150 degrees.  

When you check the Isometric Snap And Grid option and select an isometric plane, the 
snap intervals, grid, and crosshairs align with the current plane. The grid is always 
shown as isometric and uses y-coordinates to calculate the grid spacing. If you click 
the Draw Orthogonal check box, the program restricts the drawing of entities to the 
current isometric plane.  

TIP: To toggle between isometric planes, press F5. 

To turn the Isometric Snap And Grid option on 
1. Do one of the following:  

• Choose Settings > Drawing Settings.  

• On the Settings toolbar, click the Drawing Settings tool (  

• Type settings and then press Enter. 
2. Click the Coordinate Input tab. 

3. Under Change Settings For, select Snap And Grid. 

4. Click the Isometric Snap And Grid check box. 

5. Under Isometric Crosshairs, click the option for the isometric plane you want (Top, 
Left, or Right). 

6. Click OK.  

 
Isometric planes left (A), right (B), top (C).  
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2.2.6 Using the Draw Orthogonal option 
You can restrict cursor movement to the current horizontal and vertical axes so that 
you can draw at right angles, or orthogonally. For example, with the default 0-degree 
orientation (angle 0 at the “three o’clock” or “east” position), when the Draw Orthogonal 
option is enabled, lines are restricted to 0 degrees, 90 degrees, 180 degrees, or 270 
degrees. As you draw lines, the rubber-banding line follows either the horizontal or 
vertical axis, depending on which axis is farthest from the cursor. When you enable the 
isometric snap and grid, cursor movement is restricted to orthogonal equivalents within 
the current isometric plane. 

NOTE: ProgeCAD Architecture ignores orthogonal drawing when you type coordinates 
in the command bar or when you use entity snaps.  

To enable orthogonal drawing 
1. Do one of the following:  

• Choose Settings > Drawing Settings.  

• On the Settings toolbar, click the Drawing Settings tool ( ). 

• Type settings and then press Enter. 
2. Click the Coordinate Input tab. 

3. Click the Draw Orthogonal check box. 

4. Click OK.  

TIP: To toggle orthogonal drawing on and off at any time, double-click the ORTHO 
setting on the status bar, click the Draw Orthogonal tool ( ) on the Settings tool-bar, 
or press F8.  

2.2.7 Using entity snaps  
Entity snaps enable you to quickly select exact geometric points on existing entities 
without having to know the exact coordinates of those points. With entity snaps, you 
can select the endpoint of a line or arc, the center point of a circle, the intersection of 
any two entities, or any other geometrically significant position. You can also use entity 
snaps to draw entities that are tangent or perpendicular to an existing entity. 

You can use entity snaps any time the program prompts you to specify a point -for 
example, if you are drawing a line or other entity. You can work with entity snaps in one 
of two ways:  

- Enable a running entity snap that remains in effect until you turn it off by choosing 
an entity snap when no other command is active. 

- Enable a one-time entity snap for a single selection by choosing an entity snap 
when another command is active. You can also use a one-time entity snap to 
override a running entity snap. 

When using entity snaps, the program recognizes only visible entities or visible portions 
of entities. You cannot snap to entities on layers that have been turned off or to the 
blank portions of dashed lines.  

When you specify one or more entity snaps, an entity snap target box is added to the 
crosshairs. In addition, an icon appears adjacent to the crosshairs indicating the active 
entity snap. When you select an entity, the program snaps to the snap point closest to 
the center of the target box.  
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TIP: If you type the name of the entity snap, you need to type only the first three letters. 

To change the size of the entity snap target box 
1. Do one of the following:  

• Choose Settings > Drawing Settings.  

• On the Settings toolbar, click the Drawing Settings tool ( ). 

• Type settings and then press Enter. 
2. Click the Coordinate Input tab. 

3. Under Change Settings For, choose Entity Selection. 

4. Under Entity Snap Aperture, change the value in the Aperture field. 

5. Click OK.  

 

A. Choose Entity Selection. B. Type or select the entity snap aperture size. 

Setting entity snaps 
You can set entity snaps using any of the following methods: 

- Choose Settings > Entity Snap, and choose the entity snap you want to set.  

- On the Entity Snaps toolbar, click one of the entity snap tools.  

- In the command bar, type an entity snap command.  

- In the status bar, double-click ESNAP.  

- Press and hold down the Shift key while right-clicking anywhere within the drawing 
window to display the entity snap shortcut menu, and then choose the entity snap 
you want to set.  
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You can also set entity snaps using the Drawing Settings dialog box. To do this, 
choose Settings > Entity Snap > Entity Snap Settings. The Drawing Settings dialog box 
is displayed with the Coordinate Input tab active. In the Entity Snap Modes list, click the 
check box for each of the entity snaps that you want to set.  

TIP: When you select an entity snap, a check mark appears next to the entity snap in 
the menu, the associated tool in the Entity Snaps toolbar is active, and the 
corresponding box is checked in the Coordinate tab of the Drawing Settings dialog box.  

The "Esnap" command can be activated either by holding down the "SHIFT" key and 
right clicking the mouse or by clicking the middle mouse button (if there is one available 
and active) or through the additional toolbar (version for Windows). The following menu 
will appear: 

 
Nearest Snap tool  
Use the Nearest Snap tool to snap to the nearest point of another entity. You can snap 
to the nearest point on an arc, circle, ellipse, elliptical arc, line, point, polyline segment, 
ray, spline, or infinite line that is visually closest to the cursor.  

To set the Nearest Snap  
Do one of the following:  

• Choose Settings > Entity Snap > Nearest Snap.  

• On the Entity Snaps toolbar, click the Set Nearest Snap tool ( ). 

• Type nearest and then press Enter.  

Endpoint Snap tool  
Use the Endpoint Snap tool to snap to the endpoint of another entity. You can snap to 
the closest endpoint of an arc, line, polyline segment, ray, plane, or three-dimensional 
face. If an entity has thickness, the Endpoint Snap also snaps to the endpoints of the 
edges of the entity.  

To set the Endpoint Snap  
Do one of the following:  

• Choose Settings > Entity Snap > Endpoint Snap.  

• On the Entity Snaps toolbar, click the Set Endpoint Snap tool ( ). 

• Type endpoint and then press Enter.  
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To snap to the endpoint, select anywhere on the entity near its endpoint (A). 

Midpoint Snap tool  
Use the Midpoint Snap tool to snap to the midpoint of another entity. You can snap to 
the midpoint of an arc, ellipse, line, polyline segment, plane, infinite line, or spline. In 
the case of infinite lines, the midpoint snaps to the first defined point. If an entity has 
thickness, the midpoint entity snap also snaps to the midpoint of the edges of the 
entity.   

To set the Midpoint Snap  
Do one of the following:  

• Choose Settings > Entity Snap > Midpoint Snap.  

• On the Entity Snaps toolbar, click the Set Midpoint Snap tool ( ). 

• Type midpoint and then press Enter.  

 
To snap to the midpoint, select anywhere on the entity near its midpoint (A). 

Center Snap tool  
Use the Center Snap tool to snap to the center point of another entity. You can snap to 
the center of an arc, circle, polygon, ellipse, or elliptical arc. To snap to the center, you 
must select a visible portion of the entity.  

To set the Center Snap  
Do one of the following:  

• Choose Settings > Entity Snap > Center Snap.  

• On the Entity Snaps toolbar, click the Set Center Snap tool ( ). 

• Type center and then press Enter.  

 

To snap to the center, select anywhere on the visible portion of the entity (A).  
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Perpendicular Snap tool  
Use the Perpendicular Snap tool to snap to the perpendicular point of another entity. 
You can snap to an arc, circle, ellipse, line, polyline, infinite line, ray, spline, or edge of 
a plane to form a perpendicular alignment with that entity or with an imaginary 
extension of that entity. 

To set the Perpendicular Snap  
Do one of the following:  

• Choose Settings > Entity Snap > Perpendicular Snap.  

• On the Entity Snaps toolbar, click the Set Perpendicular Snap tool ( ). 

• Type perpendicular and then press Enter.  

 

To form a perpendicular angle (A) to an entity (B), select anywhere on the entity.  

Tangent Snap tool  
Use the Tangent Snap tool to snap to the tangent point of another entity. You can snap 
to the point on an arc, ellipse, spline, or circle that, when connected to the previous 
point, forms a line tangent to that entity.  

To set the Tangent Snap  
Do one of the following:  

• Choose Settings > Entity Snap > Tangent Snap.  

• On the Entity Snaps toolbar, click the Set Tangent Snap tool ( ). 

• Type tangent and then press Enter.  

 
To snap to a tangent, select the entity near the tangent point (A).  

Quadrant Snap tool  
Use the Quadrant Snap tool to snap to the quadrant point of another entity. You can 
snap to the closest quadrant of an arc, circle, ellipse, or elliptical arc. 

To set the Quadrant Snap  
Do one of the following:  

• Choose Settings > Entity Snap > Quadrant Snap.  
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• On the Entity Snaps toolbar, click the Set Quadrant Snap tool ( ). 

• Type quadrant and then press Enter.  

 
To snap to a quadrant, select the entity near the quadrant point (A).  

Insertion Point Snap tool  
Use the Insertion Point Snap tool to snap to the insertion point of an attribute, block, or 
text entity. 

To set the Insertion Point Snap  
Do one of the following:  

• Choose Settings > Entity Snap > Insertion Point Snap.  

• On the Entity Snaps toolbar, click the Set Insertion Point Snap tool ( ). 

• Type insertion and then press Enter.  

 
To snap to an insertion point, select anywhere on the entity (A).  

Point Snap tool  
Use the Point Snap tool to snap to a point entity. 

To set the Point Snap  
Do one of the following:  

• Choose Settings > Entity Snap > Point Snap.  

• On the Entity Snaps toolbar, click the Set Point Snap tool ( ). 

• Type node and then press Enter.  

 
To snap to a point entity, select the entity (A).  
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Intersection Snap tool  
Use the Intersection Snap tool to snap to the actual intersection in three-dimensional 
space of any combination of entities. You can snap to the combination of an arc, circle, 
line, polyline, ray, or infinite line. If the target covers only one entity, the program 
prompts you to select a second entity, and then snaps to the point at which the two 
entities would intersect if they were of infinite length. You can snap to the vertices of 
three-dimensional entities and the corners of entities that have thickness. 

To set the Intersection Snap  
Do one of the following:  

• Choose Settings > Entity Snap > Intersection Snap.  

• On the Entity Snaps toolbar, click the Set Intersection Snap tool ( ). 

• Type intersection and then press Enter.  

 
To snap to an intersection, select the intersection (A).  

Plan View Intersection Snap tool  
Use the Plan View Intersection Snap tool to snap to the location in the plan view of the 
current user coordinate system (UCS) where two entities would intersect if they were 
projected onto that plan view. The z-coordinates for the selected entities are ignored; 
the intersection point uses the current elevation as its z-coordinate. If the target covers 
only one entity, the program prompts you to select a second entity, and then snaps to 
the point at which the two would intersect in plan view if they were of infinite length.  

To set the Plan View Intersection Snap  
Do one of the following:  

• Choose Settings > Entity Snap > Plan View Intersection Snap.  

• On the Entity Snaps toolbar, click the Set Plan View Intersection Snap tool ( ). 

• Type planviewint and then press Enter.  

 
Select the two entities ([A] and [B]) to snap to a plan view intersection (C).  
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Quick Snap command  
Normally, an entity snap searches all the entities crossing the target and selects the 
one closest to the center of the target. Use the Quick Snap command to modify the 
current entity snap so that the program stops searching for the snap point as soon as it 
finds one entity with at least one point of the current entity type. 

To set the Quick Snap  

• Type quick and then press Enter. 

Clear Entity Snaps tool  
Use the Clear Entity Snaps tool to turn off all entity snap settings, regardless of how 
they were set: by menu, tool, command, or in the Drawing Settings dialog box.  

To set Clear Entity Snaps  
Do one of the following:  

• Choose Settings > Entity Snap > Clear Entity Snaps.  

• On the Entity Snaps toolbar, click the Clear Entity Snaps tool ( ). 

• Type none and then press Enter.  

2.2.8 Using fly-over snapping  
Fly-over snapping is a visual aid to help you see and use entity snaps more efficiently. 
When fly-over snapping is turned on, ProgeCAD Architecture will display a colored 
marker at matching entity snap points as you move the crosshairs around the drawing. 

Each entity has its own type of marker: 

 
1. Endpoint Snap 

2. Nearest Snap 

3. Midpoint Snap 

4. Center Snap 

5. Perpendicular Snap 

6. Tangent Snap 

7. Quadrant Snap 

8. Insertion Snap 

9. Node (point) Snap 

10. Intersection Snap  

When fly-over snapping is enabled and multiple entity snaps are on, you can press 
TAB to cycle through the available entity snap points of the entities covered by the 
target box. For example, when the Endpoint and Midpoint snaps are set and the 
aperture box is on a line, pressing TAB will cycle between the line's closest endpoint 
and midpoint.  
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To set the Fly-over snapping option  
1. Choose Settings > Entity Snap > Entity Snap Settings. The Drawing Settings 

dialog box opens to the Coordinate Input tab. 

2. Click Fly-over. The Options dialog box opens to the Snapping tab. 

3. Turn on the Enable Fly-over Snapping option. 

4. Set the fly-over options.  

5. Define the color, size, and thickness of the snap marker. 

6. Click OK. 

7. Click OK again 

TIP: You can also set the Fly-over option using the Options dialog box. Choose Tools > 
Options and select the Snapping tab to choose the fly-over settings. 

2.2.9 Saving your drawing   
When you save a drawing, your work is saved in a drawing (.dwg) file.  

After you have saved your drawing for the first time, you can save it with a new name. 
In addition to drawing (.dwg) files, you can also save a drawing in a Drawing Exchange 
Format (.dxf) file or a drawing template (.dwt) file.  

If you created your drawing using a template, saving the drawing does not alter the 
original template.  

If you need an added level of security for your drawing files, you can save the drawing 
with a password so only you and those who know the password can open the drawing.  

Saving a drawing 
To save a drawing, choose any of the following methods:  

• Choose File > Save.  

• On the Standard toolbar, click Save ( ). 

• Type save and then press Enter.  

• Type qsave and then press Enter.  
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TIP: When you save a drawing the first time, the program displays the Save Drawing 
As dialog box so that you can choose a directory and type a name for the drawing. You 
can use any name when you first save the drawing.  

 
A. Displays a description of the file size, creation date, and other information about the drawing. 

B. Unavailable when saving drawings; available only when opening drawings.  

C. Turns the drawing preview on or off. 

D. Saves the drawing with a password.  

E. Displays an image of the drawing before you save it.   

Saving a drawing with a new name or file format  
You can save a drawing with a new name and in any of the following file formats:  

- Standard drawing files with a .dwg extension. You can choose a .dwg file format 
that is compatible with various versions of AutoCAD.  

- Drawing exchange format files with a .dxf file extension. You can choose a .dxf file 
format that is compatible with various versions of AutoCAD.  

- Drawing templates with a .dwt file extension. Drawing templates allow you to easily 
create new drawings that reuse your drawing settings and entities.  

To save a drawing with a new name or file format 
1. Do one of the following:  

• Choose File > Save As.  

• Type saveas and then press Enter. 
2. In the Save Drawing As dialog box, under Save As Type, choose the file format. 

3. Specify the name of the file you want to create. 
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4. Click Save.  

TIP: You can also export drawing files to various file formats. For more details, see 
“Exporting drawings”. 

Saving a drawing with a password  
Sometimes drawings may contain confidential information and you want to control who 
has access to that information. If you need an added level of security, you can save a 
drawing with a password so only you and those who know the password can open the 
drawing.  

To save a drawing with a password, you must also save it in the AutoCAD 2004 
drawing (.dwg) file format.  

NOTE: If you forget a drawing’s password, the drawing cannot be opened or 
recovered. You may want to store all passwords in a safe place.  

To save a drawing with a password  
1. Do one of the following:  

• Choose File > Save As.  

• Type saveas and then press Enter.  
2. In the Save Drawing As dialog box, under Save As Type, choose AutoCAD 2004 

(dwg).  

3. Click Password Protect.  

4. Choose a folder where you want to save the drawing.  

5. In File Name, specify the name of the file you want to create.  

6. Click Save.  

7. In the Password dialog box, enter a password.  

8. If desired, record and store the password in a safe place. If you forget the drawing’s 
password, the drawing cannot be opened or recovered. 

9. Click OK. 

Attention: It should be mentioned that the .dwg file that is produced from 
ProgeCAD Architecture, constitutes a model which includes the 3D entities (walls, 
opening, slabs etc) produced from ProgeCAD Architecture. In case that someone 
wants to edit this model through progeCAD or AutoCAD, all those 3D entities must 
be firstly transformed into 2D drawings (simple lines). This transformation can be 
easily achieved through the “printview” command, which is described in paragraph 
2.10. 
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2.3 Creating simple entities 
With ProgeCAD Architecture, simple entities include lines (both finite and infinite), 
circles, arcs, ellipses, elliptical arcs, points, and rays. In addition, ProgeCAD 
Architecture includes a freehand sketch tool. Entities drawn freehand are also 
considered to be simple entities.  

This section explains several methods for creating simple entities, including how to:  

- Use menu commands on the Insert menu.  

- Use the tools on the Draw 2D toolbar.  

- Type commands in the command bar.  

In some cases, there are a number of different ways to create an entity. For the most 
part, one or two are given here. Refer to the online Help to learn how to create entities 
using other methods.  

When you use a tool or a drawing command, the program prompts you to enter 
coordinate points, such as endpoints or insertion points. You can enter the points or 
distances either using a mouse or by typing coordinate values in the command bar. As 
you draw, ProgeCAD Architecture also displays a context-sensitive prompt box with 
appropriate additional options for the type of entity you are drawing.  

After you create entities, you can modify them using the entity modification tools.  

2.3.1 Drawing lines  
A line consists of two points: a start point and an endpoint. You can connect a series of 
lines, but each line segment is considered a separate line entity.  

To draw a line 
1. Do one of the following: 

• Choose Insert > Line.  

• On the Draw 2D toolbar, click the Line tool ( ). 

• Type line and then press Enter. 
2. Specify the start point. 

3. Specify the endpoint. 

4. In the prompt box, choose Done to complete the command.  

 
Start point (A) and endpoint (B). 

The prompt box provides several options as you draw. For example, when you draw 
the first line segment, you can specify its length or orientation angle. After you draw at 
least one line segment, you can click Undo to remove the previous line segment. You 
can click Done to end the line command. After you draw two or more line segments, 
you can click Close to complete the line command by drawing a line segment that 
connects to the start point of the first line segment you drew.  
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If the last entity you drew was an arc, you can also draw a line tangent to and starting 
from the endpoint of the arc.  

To draw a line as a continuation from the end of an arc 
1. Do one of the following: 

• Choose Insert > Line. 

• On the Draw 2D toolbar, click the Line tool ( ). 

• Type line and then press Enter. 
2. In the prompt box, choose Follow. 

3. Specify the length of the line. 

 
Endpoint of previous arc (A) and length of the line (B).  

2.3.2 Drawing circles  
The default method for drawing a circle is to specify a center point and radius. You can 
draw circles using any of the following methods: 

• Center-Radius ( ). 

• Center-Diameter ( ). 

• Two points ( ). 

• Three points ( ). 

• Radius-Tangent-Tangent ( ). 

• Convert Arc to Circle ( ). 

To draw a circle by specifying its center and radius  
1. Do one of the following:  

• Choose Insert > Circle.  

• On the Draw 2D toolbar, click the Circle Center-Radius tool ( ). 

• Type circle and then press Enter. 
2. Specify the center point. 

3. Specify the radius of the circle.  

 
Center point (A) and radius (B). 
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To draw a circle tangent to existing entities 
1. Do one of the following:  

• Choose Insert > Circle.  

• On the Draw 2D toolbar, click the Circle Radius-Tangent tool ( ). Go to step 3.  

• Type circle and then press Enter. 
2. In the prompt box, choose Radius-Tangent-Tangent. 

3. Specify the radius of the circle. 

4. Select the first entity to which to draw the circle tangent. 

5. Select the second entity to which to draw the circle tangent.  

 
Radius of circle (A) and tangent lines (B) and (C).  

To convert an arc to a circle 
1. Do one of the following:  

• Choose Insert > Circle. 

• On the Draw 2D toolbar, click the Convert Arc to Circle tool. ( ). Go to step 3.  

• Type circle and then press Enter. 
2. In the prompt box, choose Turn Arc Into Circle. 

3. Select the arc you want to convert to a circle.  

 
Select an arc (A) to convert to a circle.  

2.3.3 Drawing arcs 
An arc is a portion of a circle. The default method for drawing an arc is to specify three 
points - the start point, a second point, and the endpoint. You can draw arcs using any 
of the following methods:  

• Three points on an arc ( ). 

• Start point-center-endpoint ( ), or Start point-endpoint-center ( ), or Center-
start point-endpoint ( ).  

• Start point-center-included angle ( ), or Start point-included angle-center ( ), 
or Center-start point-included angle ( ).  

• Start point-center-chord length ( ), or Center-start point-chord length ( ). 
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• Start point-endpoint-radius ( ), or Start point-radius-endpoint ( ).  

• Start point-endpoint-included angle ( ), or Start point-included angle-endpoint 
( ).  

• Start point-endpoint-starting direction ( ), or Start point-starting direction-
endpoint ( ).  

• Start point-radius-angle ( ). 

• As a tangent continuation of the previous arc or line ( ). 

To draw an arc by specifying three points 
1. Do one of the following:  

• Choose Insert > Arc.  

• On the Draw 2D toolbar, click the 3-Point Arc tool ( ).  

• Type arc and then press Enter.  
2. Specify the start point. 

3. Specify a second point. 

4. Specify the endpoint.  

 
Start point (A), second point (B), and endpoint (C). 

The prompt box provides additional options for drawing arcs. For example, after you 
specify the start point of an arc, you can choose Angle, Center, Direction, Endpoint, or 
Radius. You can select the options in a different order as well. For instance, you can 
draw an arc by specifying its start point, endpoint, and radius, or you can specify the 
start point, radius, and then endpoint.  

To draw an arc by specifying its start point, center point, and endpoint 
1. Do one of the following:  

• Choose Insert > Arc.  

• On the Draw 2D toolbar, click the Arc Start-Center-End tool ( ).  

• Type arc and then press Enter. 
2. Specify the start point. 

3. In the prompt box, choose Center. 

4. Specify the center point. 

5. Specify the endpoint.  
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Start point (A), center point (B), and endpoint (C).  

To draw an arc by specifying two points and an included angle 
1. Do one of the following:  

• Choose Insert > Arc.  

• On the Draw 2D toolbar, click the Arc Start-End-Angle tool ( ).  

• Type arc and then press Enter. 
2. Specify the start point. 

3. In the prompt box, choose Angle or type angle. 

4. To draw an arc in a counterclockwise direction, enter a positive value for the 
included angle. To draw an arc in a clockwise direction, enter a negative value for 
the included angle. 

5. Specify the endpoint.  

 
Start point (A), endpoint (B), and included angle (C).  

If the last entity you drew was an arc or a line, you can also draw an arc tangent to and 
starting from the endpoint of the arc or line.  

To draw an arc tangent to an arc or line  
1. Do one of the following:  

• Choose Insert > Arc.  

• On the Draw 2D toolbar, click the Tangent Arc tool ( ). Go to step 3.  

• Type arc and then press Enter. 
2. In the prompt box, choose Follow. 

3. Specify the endpoint.  
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Endpoint (A).  

TIP: To convert an arc to a circle, on the Draw 2D toolbar, click the Convert Arc To 
Circle flyout tool ( ).  

2.3.4 Drawing ellipses  
The default method for drawing an ellipse is to specify the endpoints of one axis of the 
ellipse, and then specify a distance representing half the length of the second axis. The 
endpoints of the first axis determine the orientation of the ellipse. The longer axis of the 
ellipse is called the major axis, and the shorter one is the minor axis. The order in 
which you define the axes does not matter. The program determines the major and 
minor axes based on their relative lengths. You can draw ellipses using any of the 
following methods:  

• Axis-axis ( )  

• • Axis-rotation ( )  

• • Center-axis ( )  

• • Center-rotation ( )  

To draw an ellipse by specifying the axis endpoints 
1. Do one of the following:  

• Choose Insert > Ellipse. 

• On the Draw 2D toolbar, click the Ellipse Axis-Axis tool (  ).  

• Type ellipse and then press Enter. 
2. Specify the first endpoint. 

3. Specify the second endpoint. 

4. Specify the half-length of the other axis.  

 
First axis endpoint (A), second axis endpoint (B), and half-length of other axis (C).  

2.3.5 Drawing elliptical arcs 
An elliptical arc is a portion of an ellipse. The default method for drawing an elliptical 
arc is to specify the endpoints of one axis of the ellipse, and then specify a distance 
representing half the length of the second axis. Then you specify the start and end 
angles for the arc, measured from the center of the ellipse in relation to its major axis. 
You can draw elliptical arcs using any of the following methods:  
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• Axis-axis ( ). 

• Axis-rotation ( ). 

• Center-axis ( ). 

• Center-rotation ( ). 

To draw an elliptical arc by specifying the axis endpoints 
1. Do one of the following:  

• Choose Insert > Elliptical Arc.  

• On the Draw 2D toolbar, click the Elliptical Arc Axis-Axis tool (  ).  

• Type ellipse and then press Enter, and then type a (for Arc) and press Enter.  
2. Specify the first endpoint. 

3. Specify the second endpoint. 

4. Specify the half-length of the other axis. 

5. Specify the start angle of the arc. 

6. Specify the end angle.  

NOTE: ProgeCAD Architecture draws elliptical arcs in the direction you specify. Go to 
Settings > Drawing Settings > Drawing Units tab. Under Change Settings For, select 
Angular Units. The default setting is counterclockwise.  

 
First axis endpoint (A), second axis endpoint (B), half-length of other axis (C), start angle of arc 

(D), and end angle (E).  

2.3.6 Creating point entities  
You can draw a point entity formatted as either a single dot or as one of 19 other 
possible display styles. 

To draw a point 
1. Do one of the following: 

• Choose Insert > Draw Point. 

• On the Draw 2D toolbar, click the Point tool ( ). 

• Type point and then press Enter. 
2. Specify the location of the point.  

To draw several points 
1. Do one of the following: 

• Choose Insert > Draw Point. 

• On the Draw 2D toolbar, click the Point tool ( ).  
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• Type point and then press Enter. 
2. In the prompt box, choose Multiple Points. 

3. Specify the location of each point. 

4. In the prompt box, choose Done to complete the command.  

Changing the size and appearance of point entities  
Changing the size and appearance of point entities affects all point entities already in 
the drawing, as well as all points that you subsequently draw. Positive values represent 
the absolute size of the point entity measured in drawing units. Negative values 
represent a percentage relative to the drawing screen, so that points retain their visual 
size as you use the Zoom command to change the magnification of the drawing.  

To change the size and appearance of point entities 
1. Do one of the following:  

• Choose Settings > Drawing Settings.  

• On the Settings toolbar, click the Drawing Settings tool ( ). 

• Type settings and then press Enter. 
2. Click the Entity Creation tab. 

3. Under Change Settings For, click Points. 

4. Under Point Display Type, select the style you want. 

5. Under Point Size, select the point size, or choose one of the options. 

6. Click OK.  

When you regenerate the drawing, all point entities change to reflect the new size and 
appearance settings. 

 

A. To increase or decrease the point size, type or C Select the button for the Point Display Type 
that select a value. you want. 
B. To use one of the preset point size options, click the one that you want.  
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2.3.7 Drawing rays  
A ray is a line in three-dimensional space that starts at a point and extends to infinity. 
Because rays extend to infinity, they are not calculated as part of the drawing extents. 
The default method for drawing a ray is to select the start point of the ray and then 
specify its direction. You can draw a ray in any of the following ways:  

• Horizontal draws the ray parallel to the x-axis of the current user coordinate 
system (UCS).  

• Vertical draws the ray parallel to the y-axis of the current UCS.  

• Angle draws the ray parallel to a specified angle.  

• Bisect draws the ray perpendicular to an existing entity.  

• Parallel draws the ray parallel to an existing entity.  

To draw a ray 
1. Do one of the following: 

• Choose Insert > Ray.  

• On the Draw 2D toolbar, click the Ray tool ( ). 

• Type ray and then press Enter. 
2. Specify the start point. 

3. Specify the direction. 

4. To complete the command, press Enter.  

 
Start point (A) and direction (B).  

2.3.8 Drawing infinite lines 
Infinite lines are sometimes referred to as construction lines. An infinite line is a line 
through a given point, oriented at a specified angle in three-dimensional space and 
extending to infinity in both directions. Because infinite lines extend to infinity, they are 
not calculated as part of the drawing extents.   

The default method for drawing an infinite line is to select a point along the line and 
then specify the direction of the line. You can draw an infinite line in any of the 
following ways:  

• Horizontal draws the infinite line parallel to the x-axis of the current UCS.  

• Vertical draws the infinite line parallel to the y-axis of the current UCS.  

• Angle draws the infinite line parallel to a specified angle.  

• Bisect draws the infinite line perpendicular to an existing entity.  

• Parallel draws the infinite line parallel to an existing entity.  

To draw an infinite line 
1. Do one of the following: 
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• Choose Insert > Infinite Line.  

• On the Draw 2D toolbar, click the Infinite Line tool ( ). 

• Type infline and then press Enter.  
2. Specify a point along the line.  

3. Specify the direction.  

4. To complete the command, press Enter.  

 
Point along the infinite line (A) and the direction (B).  

You can also draw infinite lines at a specific angle or at an angle relative to an existing 
entity.  

To draw an infinite line at a specified angle relative to another entity 
1. Do one of the following:  

• Choose Insert > Infinite Line.  

• On the Draw 2D toolbar, click the Infinite Line tool ( ). 

• Type infline and then press Enter. 

2. In the prompt box, choose Angle. 

3. In the prompt box, choose Reference. 

4. Select the reference entity. 

5. Specify the angle of the infinite line in relation to the selected entity. 

6. Specify the location of the infinite line. 

7. To complete the command, press Enter.  

 
Reference entity (A) and angle in relation to entity (B).  

2.3.9 Creating freehand sketches  
A freehand sketch consists of many straight line segments, created either as individual 
line entities or as a polyline. Before you begin creating a freehand sketch, you must set 
the length, or increment, of each segment. The smaller the segments, the more 
accurate your sketch, but segments that are too small can greatly increase the file size. 

After you specify the length of the sketch segments, the crosshairs change to a Pencil 
tool. Your freehand sketch is not added to the drawing until you “write” the sketch into 
your drawing. This means that you temporarily save the segment that you’ve drawn 
and the segment length, and you can continue sketching.  
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To create a freehand sketch 
1. Do one of the following:  

• Choose Insert > Freehand.  

• On the Draw 2D toolbar, click the Draw Freehand tool ( ).  

• Type freehand and then press Enter. 
2. Specify the length of the sketch segments. 

3. Click the mouse button to place the Pencil tool ( ) on the drawing to begin 
sketching. 

4. Move the pencil image to draw a temporary freehand sketch. 

5. Click the mouse button to lift the pencil up to stop sketching. 

6. In the prompt box, choose Write, Then Resume to write the temporary freehand 
sketch into the drawing. 

7. Click the mouse button to put the pencil down again and resume sketching. 

8. Click the mouse button again to lift the pencil up to stop sketching.  

9. In the prompt box, choose Done to write the temporary freehand sketch into the 
drawing and end the command.  

 
A freehand sketch consists of individual line entities or a polyline.  

Erasing freehand sketch lines  
You can erase temporary freehand sketch lines that have not yet been written into the 
drawing by choosing the Delete On option in the prompt box. The pencil changes to an 
Eraser tool. You can erase portions of the line when you move the eraser over a 
temporary freehand line without clicking the mouse button.  

To erase freehand sketch lines 
1. Do one of the following:  

• Choose Insert > Freehand.  

• On the Draw 2D toolbar, click the Draw Freehand tool ( ). 

• Type freehand and then press Enter. 
2. Specify the length of the sketch segments. 

3. Select a point on the drawing to display the Pencil tool and begin sketching. 

4. Click the mouse button to lift the pencil up to stop sketching. 

5. In the prompt box, choose Delete On. 

6. Move the Eraser tool ( ) to the beginning or end of the freehand sketch line that 
you drew, and then move it as far along the line as you want to erase. 

7. Click the mouse button to put the Pencil tool down to resume sketching. 
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Setting the sketch method and accuracy 
Using polylines for freehand sketches makes it easier to go back and edit sketches. 
You control whether to create freehand sketches using line segments or polylines in 
the Drawing Settings dialog box. You can also control the length of sketch segments in 
this dialog box.  

To specify lines or polylines when sketching 
1. Do one of the following:  

• Choose Settings > Drawing Settings.  

• On the Settings toolbar, click the Drawing Settings tool ( ).  

• Type settings and then press Enter.  
2. Choose the Entity Creation tab.  

3. Under Change Settings For, click Freehand Sketches.  

4. Under Freehand Sketching Methods, click either Freehand Command Creates 
Lines or Freehand Command Creates A Polyline.  

5. Click OK. 

 
A. Select the sketch method. 

B. Specify the default length of sketch segments. 
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2.4 Creating complex entities 
With ProgeCAD Architecture, complex entities include polylines (including rectangles 
and polygons), spline curves, donuts, and planes. In addition, ProgeCAD Architecture 
includes tools for adding hatching to your drawings. 

This section explains several methods for creating complex entities, including how to:  

- Use menu commands on the Insert menu.  

- Use the tools on the Draw 2D toolbar.  

- Type commands in the command bar.  

When you type a drawing command or select a tool, the program prompts you to enter 
coordinate points, such as endpoints or insertion points. As you draw, the program 
displays a context-sensitive prompt box with appropriate additional options for the type 
of entity you are drawing.  

After you create complex entities, you can modify them using the entity-modification 
tools. Several of these entity types require special editing commands. 

2.4.1 Drawing rectangles  
With ProgeCAD Architecture, rectangles are closed polylines with four sides. You draw 
a rectangle by specifying its opposite corners. The rectangle is normally aligned 
parallel to the current snap and grid alignment, but you can use the Rotated option to 
align the rectangle to any angle. 

To draw a rectangle 
1. Do one of the following:  

• Choose Insert > Rectangle.  

• On the Draw 2D toolbar, click the Rectangle tool ( ). 

• Type rectangle and then press Enter. 
2. Specify one corner of the rectangle. 

3. Specify the opposite corner of the rectangle. 

 
Opposite corners (A and B). Resulting rectangle.  

You can edit each side of a rectangle individually using the Edit Polyline tool ( ) on 
the Modify toolbar. You can convert the sides into individual line entities using the 
Explode tool ( ) on the Modify toolbar. You can control whether wide rectangle lines 
are shown filled or as outlines using the Fill tool ( ) on the Settings tool-bar.  

You can also use the Rectangle tool ( ) to draw a square. Instead of specifying the 
opposite corners, you specify the length of one side and the alignment of the square.  

To draw a square 
1. Do one of the following: 
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• Choose Insert > Rectangle.  

• On the Draw 2D toolbar, click the Rectangle tool ( ). 

• Type rectangle and then press Enter.  
2. In the prompt box, choose Square.  

3. Specify one corner of the square.  

4. Specify the length of one side of the square by selecting its other end.  

The point you specify determines both the size and alignment of the square.  

 
Endpoints of one side of the square (A and B). Resulting square.  

TIP: To control the line width of the rectangle, choose the Width Of Line option in the 
prompt box. After you change the width of the line, the new width setting remains in 
effect for subsequent rectangles until you change it again.  

2.4.2 Drawing polygons  
Polygons are closed polylines composed of a minimum of three and a maximum of 
1,024 equal-length sides. The default method for drawing a polygon is to specify the 
center of the polygon and the distance from the center to each vertex. You can draw a 
polygon using any of the following methods:  

• Center - by vertex ( ) on the Draw 2D toolbar  

• Center - by side ( ) on the Draw 2D toolbar  

• Edge ( ) on the Draw 2D toolbar  

The vertex polygon drawing method creates an equal-sided polygon defined by its 
center point and the distance to its vertices. You specify the number of sides, the 
center point, and the location of one vertex, which determines both the size and 
orientation of the polygon.  

To draw a polygon by vertex 
1. Do one of the following: 

• Choose Insert > Polygon. 

• On the Draw 2D toolbar, click the Polygon, Center-Vertex tool ( ). 

• Type polygon and then press Enter. 
2. Type 5 to specify five sides for the polygon. 

3. Specify the center of the polygon. 

4. Specify the vertex of the polygon.  
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The center (A) and vertex (B). Resulting polygon.  

Drawing polygons by side  
The side polygon drawing method creates an equal-sided polygon defined by its center 
point and the distance to the midpoint of a side. You specify the number of sides, the 
center point, and the location of the midpoint of one side, which determines both the 
size and orientation of the polygon.  

To draw a polygon by side 
1. Do one of the following:  

• Choose Insert > Polygon.  

• On the Draw 2D toolbar, click the Polygon, Center-Side tool ( ). 

• Type polygon and then press Enter.  
2. Type 3 to specify three sides for the polygon.  

3. Specify the center of the polygon.  

4. In the prompt box, choose Specify By Side, and then press Enter.  

5. Specify the midpoint of the side.  

 
The center (A) and midpoint of one side (B). Resulting polygon.  

You can edit each side of a polygon individually using the Edit Polyline tool ( ) on the 
Modify toolbar. You can convert the sides into individual line entities using the Explode 
tool ( ) on the Modify toolbar. You can control whether wide polygon lines are shown 
filled or as outlines using the Fill tool ( ) on the Settings toolbar.  

2.4.3 Drawing polylines 
With ProgeCAD Architecture, a polyline is a connected sequence of arcs and lines that 
is treated as a single entity. You can draw a polyline with any linetype and using a 
width that either remains constant or tapers over the length of any segment. When 
editing a polyline, you can modify the entire polyline or change individual segments.  

After you specify the start point of a polyline, a prompt box provides several options as 
you draw, such as Distance, Halfwidth, and Width. You can specify different starting 
and ending widths to create a tapered polyline segment. 
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After you draw at least one polyline segment, you can use the Undo tool ( ) to remove 
the previous segment. After you draw two or more polyline segments, you can use the 
Close option to complete the command by drawing a segment that ends at the start 
point of the first polyline segment you drew. Choose Done to complete the command 
without closing the polyline. 

 
Curved polyline with tapered width.Polyline with straight Closed polyline. segments.  

To draw a polyline with straight segments 
1. Do one of the following:  

• Choose Insert > Polyline.  

• On the Draw 2D toolbar, click the Polyline tool ( ). 

• Type polyline and then press Enter. 
2. Specify the start point. 

3. Specify the endpoint of each segment. 

4. To complete the command, choose Close or Done. 

 
Polyline start point (A) and segment endpoints (B). 

With the Draw Arcs option, you can continually draw arc segments until you select the 
Draw Lines option to go back to drawing line segments. When you draw arc segments, 
the first point of the arc is the endpoint of the previous segment. By default, you draw 
arc segments by specifying the endpoint of each segment. Each successive arc 
segment is drawn tangent to the previous arc or line segment. If you choose Close 
while in the Draw Arcs option, the closing segment is created as an arc.  

You can also specify the arc using any of the following methods:  

• Start point, included angle, center point  

• Start point, included angle, radius  

• Start point, center point, endpoint  

• Start point, included angle, endpoint  

• Start point, center point, included angle  

• Start point, center point, chord length  

• Start point, direction, endpoint  

• Start point, radius, included angle  
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• Start point, second point, endpoint  

To draw a line segment followed by an arc polyline segment 
1. Do one of the following:  

• Choose Insert > Polyline.  

• On the Draw 2D toolbar, click the Polyline tool ( ). 

• Type polyline and then press Enter.  
2. Specify the start point.  

3. Specify the endpoint.  

4. In the prompt box, choose Draw Arcs.  

5. Specify the endpoint of the arc segment.  

6. To complete the command, choose Done.  

 
Polyline start point (A), line endpoint/arc start point (B), and arc endpoint (C).  

You can edit entire polylines and individual segments using the Edit Polyline tool ( ) 
on the Modify toolbar. You can convert polylines into arc and line entities using the 
Explode tool ( ) on the Modify toolbar. You can control whether wide polylines are 
shown filled or as outlines using the Fill tool ( ) on the Settings toolbar.  

Drawing splines  
A spline is a smooth curve defined by a set of points. You can use splines to create 
sculptured shapes such as the cross section of a turbine blade or an airplane wing. 

To draw a spline 
1. Do one of the following:  

• Choose Insert > Spline.  

• On the Draw 2D toolbar, click the Spline tool ( ). 

• Type spline and then press Enter.  
2. Specify the first point of the spline. 

3. Specify the second point of the spline. 

4. Specify as many more points as you want.  

5. When you have finished, press Enter.  

You can add tangents to the spline, which are lines that give it shape.  

To add tangents to a spline 
1. Specify the starting tangent point. 

2. Specify the ending tangent point.  
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Spline. Spline with starting tangent point (A) and ending tangent point (B).  

Specifying fit tolerance 
By default, a spline passes through all of the control points. When you draw a spline, 
you can change this by specifying the fit tolerance. The fit tolerance value determines 
how closely the spline fits the set of points you specify. For example, a spline fit 
tolerance value of 0 causes the spline to pass through the control points. A value of 
0.01 creates a spline that passes through the start and endpoints and within 0.01 units 
of the intermediate control points.  

To specify the fit tolerance 
1. Do one of the following:  

• Choose Insert > Spline.  

• On the Draw 2D toolbar, click the Spline tool ( ). 

• Type spline and then press Enter. 
2. Specify the first point of the spline. 

3. Specify the second point of the spline. 

4. In the prompt box, choose Fit Tolerance. 

5. To accept the default of 0.0000, press Enter. To specify a different fit tolerance, 
type the number, and then press Enter. 

6. Specify the additional points you need to draw a spline or a closed spline.  

Drawing a closed spline  
You can draw a closed spline, which is a spline for which the start point and endpoint 
are the same. Because the spline is closed, you specify only one tangent.  

To draw a closed spline 
1. Do one of the following:  

• Choose Insert > Spline.  

• On the Draw 2D toolbar, click the Spline tool ( ). 

• Type spline and then press Enter. 
2. Specify the first point of the spline. 

3. Specify the second point of the spline. 

4. Specify as many more points as you want. 

5. When you have finished, in the prompt box, choose Close. 

6. To complete the command, specify the tangent point. 
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The start point and endpoint (A) of a closed spline.  

2.4.4 Drawing donuts 
Donuts are solid, filled circles or rings created as closed, wide polylines. You can draw 
a donut using one of several methods. The default method is to specify the inside and 
outside diameters of the donut, and then specify its center. You can then create 
multiple copies of the same donut by specifying different center points until you press 
Enter to complete the command.  

To draw a donut 
1. Do one of the following: 

• Choose Insert > Donut. 

• On the Draw 2D toolbar, click the Donut tool ( ). 

• Type donut and then press Enter. 
2. Specify the inside diameter of the donut. 3 Specify the outside diameter of the 

donut. 

3. Specify the center of the donut. 

4. Specify the center point to draw another donut, or choose Done to complete the 
command.  

 
Inside diameter (A) and outside diameter (B).  

The prompt box provides additional options for drawing donuts. For example, you can 
specify the width of the donut and two points on the diameter of the donut, or you can 
specify the width and three points on the donut. You can also draw a donut tangent to 
existing entities.  

TIP: A donut can be a completely filled circle by specifying an inside diameter of zero.  

To draw a donut tangent to existing entities 
1. Do one of the following:  

• Choose Insert > Donut.  

• On the Draw 2D toolbar, click the Donut tool ( ).  

• Type donut and then press Enter. 
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2. In the prompt box, choose Radius-Tangent-Tangent. 

3. Specify the width of the donut. 

4. Specify the diameter of the donut. 

5. Select the first tangent entity to which to draw the donut. 

6. Select the second tangent entity to which to draw the donut.  

 
Width (A) and diameter (B) of the donut and tangent entities (C).  

You can edit donuts using the Edit Polyline tool ( ) on the Modify toolbar. You can 
convert donuts into arc entities using the Explode tool ( ) on the Modify toolbar. You 
can control whether donuts are shown filled or as outlines using the Fill tool ( ) on the 
Settings toolbar.  

TIP: You can control the default outside and inside diameter of donuts by choosing 
Settings > Drawing Settings, and then clicking the Entity Creation tab and choosing 
the options you want.  

2.4.5 Creating planes 
With the Plane tool, you can draw rectangular, triangular, or quadrilateral areas filled 
with a solid color. The default method is to specify the corners of the plane. After you 
specify the first two corners, the plane is displayed as you specify the remaining 
corners. Specify corner points in a triangular manner. The program prompts you for the 
third point and then the fourth point. If you continue specifying points, the third- and 
fourth-point prompts toggle until you press Enter to complete the command.  

Creating planes in ProgeCAD Architecture is similar to the Solid command in AutoCAD.  

To draw a quadrilateral plane 
1. Do one of the following:  

• Choose Insert > Plane.  

• On the Draw 2D toolbar, click the Plane tool ( ).  

• Type plane and then press Enter. 
2. Specify the first point. 

3. Specify the second point. 

4. Specify the third point. 

5. Specify the fourth point. 

6. To complete the command, press Enter.  
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After you select the first two points (A) and (B), the sequence in which you select the third (C) 

and fourth (D) points determines the shape of the resulting quadrilateral plane. 

The prompt box provides additional options for drawing planes. For example, you can 
draw rectangular, square, or triangular planes.  

To draw a rectangular plane 
1. Do one of the following:  

• Choose Insert > Plane.  

• On the Draw 2D toolbar, click the Plane tool ( ). 

• Type plane and then press Enter. 
2. Choose Rectangle. 

3. Specify the first point. 

4. Specify the opposite corner. 

5. Specify the rotation angle. 

6. To complete the command, specify the opposite corner to draw another rectangle, 
or press Enter.  

 
Opposite corners (A and B) and rotation angle (C). Resulting plane.  

You can control whether planes are shown filled or as outlines using the Fill tool ( ) 
on the Settings toolbar. You can convert planes into individual line entities 
corresponding to the outline of the plane using the Explode tool ( ) on the Modify 
toolbar.  

2.4.6 Creating boundary polylines  
With the Boundary command, you can designate a specific area of a drawing for 
operations such as hatching and dimensioning. You create a boundary polyline by 
selecting an area inside a closed loop. The area you select can be bounded by a single 
closed entity or by multiple entities that intersect.  

NOTE: You cannot use a spline or an ellipse to create a boundary polyline.  

In cases where entities intersect, ProgeCAD Architecture interprets the boundary as 
the closed loop closest to the point specifying the area. In the following figure, for 
example, the area point selected in the rectangle results in a boundary consisting of 
the closed loop nearest the point selection, as opposed to the closed loop formed by 
the rectangle itself. 
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Selected point (A).Resulting boundary (B).  

To make boundaries more specific, you can create a boundary set. A boundary set 
specifies which entities are considered in determining the boundary path. This can 
make creating the boundary polyline faster if you are working with a complex drawing.  

In the following figure, the circle and triangle are the selected entities. If you select an 
area anywhere inside the circle or the triangle, the result is a polyline that bounds the 
shaded area.  

 
Selected entities (A and B).Point specified in the selected area (C), which results in a new 

boundary around the shaded area.  

Using islands and island detection 
Islands are closed loops that reside inside other closed loops. ProgeCAD Architecture 
provides island-detection options so that you can specify which islands, if any, should 
be considered in the area selection for a boundary. 

The following figure shows a rectangular polyline with two islands. The circle is referred 
to as the outer island, and the octagon is referred to as a nested island. 

 
Rectangular polyline (A) with outer island (B), with point (C) specifying the area selection, and 

nested island (D).  

You can choose from three island-detection methods.  

• Nested Islands The outer entity and all its islands are considered for the polyline. 

• Outer Only Only the outer entity and its outer island are considered for the polyline.  

• Ignore Islands Only the outer entity is considered for the polyline.  
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Nested islands (A), with outer island (B), and with ignore islands (C).  

To draw a boundary polyline  
1. Do one of the following: 

• Choose Insert > Boundary Polyline.  

• On the Draw 2D toolbar, click the Boundary tool ( ). 

• Type boundary and then press Enter. 
2. Specify the entities that you want made available for the boundary polyline by doing 

one of the following: 

• All entities Select All Visible Entities to have all entities in the drawing 
considered when creating the boundary polyline. 

• Custom selection Define only specific areas to be considered when creating the 
boundary polyline, which can improve system performance if you are working 
with a complex drawing. Click Select Boundary Set. In the drawing, select the 
entities individually or by choosing a selection method from the prompt box, and 
then press Enter. The Current Selection Set option becomes selected 
automatically, which indicates that the entities you selected with the Select 
Boundary Set button will be considered when creating the boundary polyline.  

NOTE: You can alternate between All Visible Entities and Current Selection Set 
without having to select entities again using the Select Boundary Set button. 
The Current Selection Set option uses the last set of entities you selected with 
the Select Boundary Set button. 

3. Choose an island-detection option. 

4. Click Select Area. 

5. In the drawing, click inside the area whose closed perimeter forms the boundary, 
not on the polyline itself. If desired, continue clicking inside additional closed 
perimeters. 

6. To complete the selection, press Enter. 

7. In the Boundary dialog box, click OK. 
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A. Opens the drawing area for selection of entities to be considered when creating the 
boundary polyline. 

B. Choose to consider all visible entities when creating the boundary polyline. 

C. Choose to use the entities you selected for the boundary set. (Becomes available after you 
click the Select Boundary Set button.) 

D. Select an island-detection option. 

E. Opens the drawing area for selection of the enclosed areas used to create new boundary 
polylines.  

2.4.7 Adding hatching  
When you add hatching to a drawing, ProgeCAD Architecture fills entities or enclosed 
areas with a pattern. You can choose a predefined hatch pattern, or you can create 
your own hatch pattern. 

First you specify the hatch pattern and other options, and then you choose which 
entities or enclosed areas that you want to hatch.  

NOTE: Hatch patterns are memory intensive and can take a considerable amount of 
time to draw and display. To improve performance, add hatching as one of the last 
steps when you create a drawing, or insert hatches on a separate layer that you can 
freeze as you continue to work on your drawing.  

To open the Boundary Hatch dialog box  
Do one of the following:  

• Choose Insert > Hatch.  

• On the Draw 2D toolbar, click the Boundary Hatch tool ( ). 

• Type bhatch and then press Enter. 
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Specifying a hatch pattern  
A hatch pattern consists of a repeating pattern of lines, dashes, and dots. You can 
select a hatch pattern from a set of predefined patterns, or you can define a pattern of 
your own. The hatch pattern you used most recently is the default pattern the next time 
you add hatching.  

The program supplies predefined standard hatch patterns, which are stored in the 
icad.pat and icadiso.pat hatch pattern library files. You can use other external hatch 
pattern libraries, such as an office standard library, customized patterns, and libraries 
available from vendors or standards organizations.  

NOTE: The icad.pat hatch pattern library files are ANSI (American National Standards 
Institute)-compliant patterns; the icadiso.pat hatch pattern library files are ISO 
(International Standards Organization)-compliant.  

To specify a predefined hatch pattern 
1. Do one of the following: 

• Choose Insert > Hatch.  

• On the Draw 2D toolbar, click the Boundary Hatch tool ( ). 

• Type bhatch and then press Enter. 
2. From the Boundary Hatch dialog box, click the Pattern Properties tab. 

3. In the Pattern Type list, click Predefined. With Predefined, you can apply a scale 
factor to make the pattern larger or smaller than the default size.  

4. For Scale, enter the scale factor as a percentage of the default.  

5. For Angle, enter the angle of the pattern in degrees (1-360). The default angle is 
clockwise; you can change the angle of any hatch pattern by entering a numerical 
value.  

6. For ISO Pen Width, enter the pen width. If you choose a predefined, ISO standard 
pattern, you can scale the pattern based on the ISO pen width. 

7. To copy the pattern properties from an existing hatch, choose Copy Hatch 
Properties and select the hatch. 

8. To associate the hatch pattern to its boundary entities, under Hatch Attributes, 
select the Associative check box. An associative hatch updates automatically if you 
move any of its boundaries. 

9. To continue, add a hatch by doing one of the following:  

• Select the entities you want to add a hatch. For details, see “Selecting entities 
for hatching”. Begin with step 2.  

• Select an area or boundary you want to add a hatch. For details, see “Selecting 
areas for hatching”. Begin with step 2.  

To specify a user-defined hatch pattern 
1. Do one of the following:  

• Choose Insert > Hatch.  

• On the Draw 2D toolbar, click the Boundary Hatch tool ( ). 

• Type bhatch and then press Enter. 
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2. From the Boundary Hatch dialog box, click the Pattern Properties tab. 

3. In the Pattern Type list, click User Defined. 

4. For Spacing, enter the line spacing for the pattern. 

5. To crosshatch the pattern, select the Cross-Hatched check box. You can choose to 
crosshatch the pattern. Cross-hatching imposes a copy of the specified user-
defined pattern at a 90-degree angle over the first pattern you defined.  

6. To copy the pattern properties from an existing hatch, choose Copy Hatch 
Properties, and select a hatch pattern from a hatched entity in the drawing.  

7. To associate the hatch pattern to its boundary entities, under Hatch Attributes, 
select the Associative check box. An associative hatch updates automatically if you 
move any of its boundaries.  

8. To continue, add a hatch by doing one of the following:  

• Select the entities you want to add a hatch. For details, see “Selecting entities 
for hatching”. Begin with step 2.  

• Select an area or boundary you want to add a hatch. For details, see “Selecting 
areas for hatching”. Begin with step 2.  

 
A. Determines how the hatch will be defined.  

B. Determines density of hatching for Predefined hatch patterns.  

C. Sets angle of hatch in relation to entity (User Defined only).  

D. Determines density of hatching for User Defined hatch patterns.  

E. Sets pen width for ISO-standard pattern.  

F. Imposes another copy of the specified pattern at a 90-degree angle over the first.  

G. Closes dialog to allow selection and copying of existing hatch pattern properties.  

H. Displays the tolerance that non-touching entities can be within and still be used to create the 
hatch pattern boundary.  

I. Select to update the hatch automatically if you move any of its boundaries.  
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To use a predefined library pattern 
1. Do one of the following: 

• Choose Insert > Hatch.  

• On the Draw 2D toolbar, click the Boundary Hatch tool ( ). 

• Type bhatch and then press Enter. 
2. From the Boundary Hatch dialog box, click the Pattern tab. 

3. For Hatch File, select the icad.pat or icadiso.pat hatch pattern library file. 

4. To select a predefined pattern, do one of the following:  

• In the Patterns list, click the pattern name.  

• Click the graphical representation of the hatch pattern. 

5. To continue, add a hatch by doing one of the following:  

• Select the entities you want to add hatching. For details, see “Selecting entities 
for hatching”. Begin with step 2.  

• Select an area or boundary you want to add hatching. For details, see 
“Selecting areas for hatching”. Begin with step 2.  

 
A. Hatch pattern library files.  

B. Hatch patterns listed by name.  

C. Hatch patterns shown graphically. 

NOTE: Hatch patterns are memory intensive and can take a considerable amount of 
time to draw and display. To improve performance, add hatching as one of the last 
steps when you create a drawing, or insert hatches on a separate layer that you can 
freeze as you continue to work on your drawing.  
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Selecting entities for hatching  
You can add hatching to any entity that forms a closed boundary, for example, a circle 
or rectangle. You can assign hatching to a single entity or several entities at the same 
time. 

To select entities for hatching 
1. Do one of the following:  

• Choose Insert > Hatch.  

• On the Draw 2D toolbar, click the Boundary Hatch tool ( ). 

• Type bhatch and then press Enter. 
2. From the Boundary Hatch dialog box, click the Boundary tab. 

3. Under Island Detection Options, choose one of the following: 

• Nested Islands The outer entity and all its islands are considered for hatching. 

• Outer Only Only the outer entity and its outer island are considered for 
hatching.  

• Ignore Islands Only the outer entity is considered for hatching.  

 
Nested islands (A), with outer island (B), and with ignore islands (C).  

4. To keep any new entities that are created for drawing the boundary hatch, select 
the Retain Boundaries check box. Existing entities are always retained.  

5. Click Select Entities.  

6. In the drawing, click the entities to be hatched individually or by choosing a 
selection method from the prompt box, and then press Enter when done.  

7. In the Boundary Hatch dialog box, click OK.  
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A. Choose to consider all visible entities when creating the boundary hatch. 

B. Mark the check box to keep any new entities that are created to draw the boundary hatch. 
Existing entities are always retained. 

C. (Display only) Indicates the boundary is created as a polyline. 

D. Determines how hatching interacts with islands. 

Ε. Opens the drawing area for selection of entities to be hatched. 

Selecting areas for hatching  
You can add hatching to an area enclosed by selected entities to form the hatch 
boundary. The hatch is formed in the enclosed area, not the entities themselves.  

After ProgeCAD Architecture draws the hatch, the entire hatch is treated as a single 
entity and it is is either associative or independent of the hatch boundary entities.  

To select an area for hatching 
1. Do one of the following:  

• Choose Insert > Hatch.  

• On the Draw 2D toolbar, click the Boundary Hatch tool ( ). 

• Type bhatch and then press Enter. 
2. From the Boundary Hatch dialog box, click the Boundary tab. 

3. Under Island Detection Options, choose one of the following:  

• Nested Islands The outer entity and all its islands are considered for hatching.  

• Outer Only Only the outer entity and its outer island are considered for 
hatching.  

• Ignore Islands Only the outer entity is considered for hatching.  



 
 

74  4M 

 
Nested islands (A), with outer island (B), and with ignore islands (C).  

4. To keep any new entities that are created for drawing the boundary hatch, select 
the Retain Boundaries check box. Existing entities are always retained.  

5. Specify the entities that you want made available for boundary hatching by doing 
one of the following:  

• All entities Select All Visible Entities to have all entities in the drawing 
considered when creating the boundary hatch. 

• Custom selection Define only specific areas to be considered when creating the 
boundary hatch, which can improve system performance if you are working with 
a complex drawing. Click Select Boundary Set. In the drawing, select the 
entities individually or by choosing a selection method from the prompt box, and 
then press Enter. The Current Selection Set option becomes selected 
automatically, which indicates that the entities you selected with the Select 
Boundary Set button will be considered when creating the boundary hatch.  

NOTE: You can alternate between All Visible Entities and Current Selection Set 
without having to select entities again using the Select Boundary Set button. 
The Current Selection Set option uses the last set of entities you selected with 
the Select Boundary Set button.  

6. In the Boundary Hatch dialog box, click Select Area.  

7. In the drawing, click inside the closed perimeter of a boundary, not on the boundary 
itself. If desired, continue clicking inside additional closed perimeters.  

8. To complete the selection, press Enter.  

9. In the Boundary Hatch dialog box, click OK.  
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A. Opens the drawing area for selection of entities to be considered when creating the 
boundary hatch.  

B. Choose to consider all visible entities when creating the boundary hatch.  

C. Choose to use the entities you selected for the boundary set. (Becomes available after you 
click the Select Boundary Set button.)  

D. Mark the check box to keep any new entities that are created to draw the boundary hatch. 
Existing entities are always retained.  

E. (Display only) Indicates the boundary is created as a polyline.  

F. Determines how hatching interacts with islands.  

G. Opens the drawing area for selection of enclosed areas to be hatched. 
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2.5 Modifying entities 
ProgeCAD Architecture provides many editing tools for modifying a drawing. You can 
easily move, rotate, or stretch drawing entities, or change their scale. When you want 
to remove an entity, you can delete it with a few clicks of the mouse. You can also 
make multiple copies of any entity and copy entities from one drawing to another.  

You can modify most entities using general-purpose editing commands, many of which 
are located on the Modify toolbar and the Modify menu. Some complex entities require 
special commands. This section explains how to:  

- Select entities using entity-selection methods and grips.  

- Change the properties of entities.  

- Rearrange entities by moving, rotating, or changing the display order.  

- Resize entities by stretching, scaling, extending, trimming, or editing their lengths.  

- Break and join entities.  

- Group entities.  

- Edit polylines.  

- Explode entities.  

- Create chamfers and fillets.  

2.5.1 Selecting entities 
You can create a selection set that consists of one or more entities before you modify 
them. Use any of the following methods to create a selection set:  

• Choose a command or tool first, and then select entities.  

• Select entities first, and then choose a command or tool (most entities).  

• Select entities by pointing, and then use grips to modify them.  

Displaying selected entities highlighted  
You can specify whether to display selected entities highlighted, which makes the 
selection set easier to see. By default, the highlighting feature is turned on.  

To turn the highlighting feature on or off 
1. Do one of the following:  

• Choose Settings > Drawing Settings.  

• On the Settings toolbar, click the Drawing Settings tool ( ). 

• Type settings and then press Enter. 
2. Click the Display tab. 

3. In the Change Settings For box, select Display. 

4. Select or clear the Highlight Item When Selected check box. 

5. Click OK.  
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Entity-selection methods  
When you choose a command that requires you to select entities (when you’re deleting 
or changing entity properties, for example), you can use any of the following selection 
methods, which are displayed in a prompt box:  

• Select all entities Selects all entities in the current drawing. 

• Add to set Adds one or more entities to the selection set. 

• Subtract from set Removes one or more entities from the selection set. 

• Previous selection Selects entities included in the previous selection set. 

• Last entity in drawing Selects the entity most recently added to the drawing. 

• Window-Inside Selects entities contained entirely within a rectangular selection 
window. 

• Crossing window Selects entities contained within or crossing the boundary of 
a rectangular selection window. 

• Outside window Selects entities falling completely outside a rectangular 
selection window. 

• Window polygon Selects entities contained entirely within a polygon selection 
window. 

• Crossing polygon Selects entities contained within or crossing the boundary of 
a polygon selection window. 

• Outside polygon Selects entities falling completely outside a polygon selection 
window. 

• Window circle Selects entities contained entirely within a circular selection 
window. 

• Crossing circle Selects entities contained within or crossing the boundary of a 
circular selection window. 

• Outside circle Selects entities falling completely outside a circular selection 
window. 

• Point Selects any closed entities that surround the selected point. 

• Fence Selects entities crossing a line or line segments. 

In addition to these methods, you can select entities that match a particular set of 
properties -for example, all entities on a particular layer or drawn in a certain color. 

You can also use a few selection methods automatically, without displaying the prompt 
box. For example, you can simply click to select entities, or you can use a Window-
Inside or Crossing Window by defining the opposite corners of a rectangular selection 
window. The direction in which you define the points of the rectangle (left-to-right or 
right-to-left) determines which type of window you create. 

To create a Window-Inside 
1. Click to select a point in the drawing. 

2. Click to the right of the first point to select a second point in the drawing. 
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Window-Inside by selecting the first (A) and second (B) points. 

This method is most commonly referred to as simply a window or selection window.  

To create a Crossing Window  
1. Click to select a point in the drawing.  

2. Click to the left of the first point to select a second point in the drawing.  

 
Crossing Window by selecting the first (A) and second (B) points. 

In addition to a rectangular window, you can define a selection window using other 
shapes such as a polygon, circle, or fence (a multi-segmented line that selects entities 
it crosses).  

To select entities using Window Polygon  
1. Activate an entity-modification command. 

2. In the prompt box, choose Window Polygon. 

3. Specify the vertices of the polygon. 

4. To complete the selection polygon, press Enter. 

 
Window Polygon by specifying the vertices of the polygon (A, B, and C).  

To select entities using Fence  
1. Activate an entity-modification command.  

2. In the prompt box, choose Fence.  
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3. Specify the endpoints of the Fence segments.  

4. To complete the Fence, press Enter.  

 
Fence by specifying the endpoints of the fence segments (A, B, and C).  

Choosing the command first 
When you choose an entity-modification tool or command, the program prompts you to 
select entities and displays a prompt box from which you can choose a selection 
method. You can select individual entities or use other techniques such as selection 
windows to select multiple entities.  

When you select entities, you add them to the selection set. After you select at least 
one entity, you can remove entities from the selection set. To finish adding entities to 
the selection set, press Enter. Most entity-modification commands then act on the 
entire selection set.  

Selecting entities first 
You can select entities first and then choose how to modify them. As you select each 
entity, it is highlighted with small squares called grips, which appear at strategic points 
on the entity.  

The locations of the grips depend on the type of entity selected. For example, grips 
appear at the endpoints and midpoint of a line, at the quadrant points and center point 
of a circle, and at the endpoints, midpoint, and center of an arc.  

 
Examples of grip locations.  

After you select one or more entities, you can choose an entity-modification command, 
such as Copy or Move, from the Modify menu or toolbar. You can also click the right 
mouse button to display a shortcut menu containing the entity-modification commands 
appropriate for the selected entities, and then choose the command from the menu.  

When you select entities and then issue a command, the program immediately acts on 
the entities you’ve selected. In many cases, a command-specific prompt box provides 
additional options for that editing operation. If you want to modify the selection set at 
that point, right-click to display the prompt box with the selection options and choose 
the option you want. To redisplay the command-specific prompt box, right-click again.  

You remove an individual entity from the selection set by selecting it again. To remove 
all the entities from the selection set, press Escape.  



 
 

80  4M 

Turning grips on and off  
You can turn the use of grips on and off and control the size and color of grips.  

To change grip settings 
1. Do one of the following:  

• Choose Settings > Drawing Settings.  

• On the Settings toolbar, click the Drawing Settings tool ( ). 

• Type ddgrips and then press Enter. 
2. In the Drawing Settings dialog box, click the Display tab. 

3. In the Change Settings For list, click Grips. 

4. Change the desired settings, and then click OK. 

 
A. Click to activate grips for all selected entities.  

B. Click to assign the color for grips. 

C. Specify the grip size. 

D. Displays the current grip size. 

Editing with grips  
To use grips for editing, you select an entity to display the grips, and then click a grip to 
make it active. The grip you select depends on the type of entity you’re modifying and 
the editing operation you’re performing. For example, to move a line entity, drag it by its 
midpoint grip. To stretch the line, drag one of the endpoint grips. You do not need to 
enter a command when using grips. 

2.5.2 Modifying the properties of entities 
You can change the layer, thickness, linetype, color, and linetype scale of one or more 
entities. Depending on the type of entity or entities you select, you can also change 
other properties, such as the start point and endpoint of lines, the center point and 
radius of circles, and the vertices of polylines. 
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You can modify all the properties of all entities simultaneously. For example, using the 
ai_propchk command, select all entities on a particular layer, and then move the 
entities to another layer by simply selecting a name from the Layer text box.  

In the Entity Properties dialog box, changes that you make in the Layer, Color, 
Thickness, Lineweight, Linetype, and Linetype Scale fields affect all selected entities. If 
you select several entities that all have different properties, the default value initially is 
Varies. Changes that you make in the entity tabs, such as Circle, Line, and Arc, affect 
all selected entities of that type. You can select the entities to be changed using any 
entity-selection method.  

To modify properties of entities 
1. Do one of the following:  

• Choose Modify > Properties. 

• On the Modify toolbar, click the Properties tool ( ). 

• Type ai_propchk and then press Enter. 
2. Select the entities. 

3. Make changes to the desired properties.  

You can also access many of the entity properties using the Entity Properties toolbar. 
Note that the Entity Properties toolbar settings that display when no entities are 
selected determine the properties of new entities when you draw them. 

The Properties Panel has two areas. The above area ‘’General’’ that appears common 
properties for all selected entities, such as layer, linetype, linetype scale, lineweight, 
color etc. 

 
By pressing the button with the arrow, the user can see the number an the type of the 
entities. The user can modify any common property. 

By selecting one entity, (eg line), the property panel change appearance and displays 
the properties of this selected entity. The user can modify any property of them. 
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2.5.3 Deleting entities 
You can remove entities from a drawing. You can delete entities using any of the entity-
selection methods. 

To delete a selection set  

1. Do one of the following:  

• Choose Edit > Delete.  

• On the Standard toolbar, click the Delete tool ( ).  

• Type delete and then press Enter.  
2. Select the entities, and then press Enter.  

TIP: Typing the Undelete command restores the most recently deleted selection set. If 
you have made additional modifications since deleting the entities, use Undelete rather 
than Undo to restore those entities without reversing those modifications. 

2.5.4 Copying entities 
You can copy one or more entities, making one copy or multiple copies within the 
current drawing. You can also copy entities between drawings. 

Use any of the following methods to copy entities within the current drawing:  

• Create a copy at a location referenced from the original.  

• Create a copy aligned parallel to the original.  

• Create a copy as a mirror image of the original.  

• Create several copies in a rectangular or circular pattern.  
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Copying entities within a drawing  
You can duplicate entities within the current drawing. The default method is to create a 
selection set and then specify a starting point, or base point, and an endpoint, or 
displacement point, for the copy. You can also make multiple copies or copy the 
selection set to a location you specify, using a direction vector. 

To copy a selection set once 
1. Do one of the following:  

• Choose Modify > Copy.  

• On the Modify toolbar, click the Copy tool ( ). 

• Type copy and then press Enter. 
2. Select the entities, and then press Enter. 

3. Specify the base point. 

4. Specify the displacement point. 

 
Entity to copy (A), base point (B), displacement point (C) and Result.  

To make multiple copies of a selection set 
1. Do one of the following:  

• Choose Modify > Copy.  

• On the Modify toolbar, click the Copy tool ( ). 

• Type copy and then press Enter. 
2. Select the entities, and then press Enter. 

3. In the prompt box, choose Multiple Copies. 

4. Specify the base point. 

5. Specify the displacement point of the first copy. 

6. Specify the displacement point of the next copy. 

7. Continue specifying displacement points to place additional copies. 

8. To complete the command, press Enter. 

 
To make multiple copies of an entity, select the entity to copy (A), specify the base point (B), 

and then specify the displacement points (C, D, and E). 
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Copying between drawings  
You can use the Clipboard to cut or copy entities from one drawing to another. Cutting 
removes the selected entities from a drawing and stores them on the Clipboard. 
Copying duplicates the selected entities from a drawing and places them on the 
Clipboard.  

To cut entities to the Clipboard  
1. Select the entities you want to cut.  

2. Do one of the following:  

• Choose Edit > Cut.  

• On the Standard toolbar, click the Cut tool ( ).  

• Type cutclip and then press Enter.  
To copy entities to the Clipboard 
1. Select the entities you want to copy. 

2. Do one of the following:  

• Choose Edit > Copy.  

• On the Standard toolbar, click the Copy tool ( ). 

• Type copyclip and then press Enter.  
Anything that you can copy to the Clipboard can be pasted into a drawing. The format 
in which the program adds the Clipboard contents to the drawing depends on the type 
of information in the Clipboard. For example, if you copy ProgeCAD Architecture 
drawing entities to the Clipboard, the program pastes them into the drawing as 
ProgeCAD Architecture entities. If you copy items to the Clipboard from other 
programs, they are pasted into the current drawing as embedded ActiveX® objects. 

To paste entities from the Clipboard 
Do one of the following:  

• Choose Edit > Paste.  

• On the Standard toolbar, click the Paste tool ( ). 

• Type pasteclip and then press Enter.  

Making parallel copies  
You can use the parallel feature to copy selected entities and align them parallel to the 
original entities at a specified distance. You can make parallel entities using arcs, 
circles, ellipses, elliptical arcs, lines, two-dimensional polylines, rays, and infinite lines.  

Making parallel copies of curved entities creates larger or smaller curves, depending on 
which side of the original entity you place the copy. For example, placing a parallel 
copy of a circle outside the circle creates a larger concentric circle; positioning the copy 
inside the circle creates a smaller concentric circle.  

To make a parallel copy by specifying the distance 
1. Do one of the following:  

• Choose Modify > Parallel.  

• On the Modify toolbar, click the Parallel tool ( ). 
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• Type parallel and then press Enter. 
2. Specify the distance by selecting two points or by entering a distance. 

3. Select the entity to copy. 

4. Specify on which side of the entity to place the parallel copy. 

5. Select another entity to copy, or press Enter to complete the command.  

 
To make a parallel copy, specify the distance between copies by entering a distance or 

selecting two points (A and B), select the entity to copy (C), and specify on which side to place 
the copy (D). 

To make a parallel copy passing through a point 
1. Do one of the following:  

• Choose Modify > Parallel.  

• On the Modify toolbar, click the Parallel tool ( ). 

• Type parallel and then press Enter.  
2. In the prompt box, choose Through Point.  

3. Select the entity to copy.  

4. Specify the point for the entity to pass through.  

5. Repeat steps 3 and 4, or press Enter to complete the command.  

 
To make a parallel copy passing through a point, select the entity to copy (A) and then specify 

the through point (B).  

Mirroring entities 
You can create a mirror image of an entity. You mirror the entity about a mirror line, 
which you define by specifying two points in a drawing. You can delete or retain the 
original entities. 

To mirror entities 
1. Do one of the following:  

• Choose Modify > Mirror.  

• On the Modify toolbar, click the Mirror tool ( ). 

• Type mirror and then press Enter. 
2. Select the entity, and then press Enter. 

3. Specify the first point of the mirror line. 
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4. Specify the second point of the mirror line. 

5. In the prompt box, choose one of the following:  

• Yes, Delete Entities – deletes the original entities.  

• No, Keep Entities – retains the original entities.  

 
To mirror an entity, select it (A), and then specify the first point (B) and second point (C) of the 

mirror line.  

Arraying entities 
You can copy an entity in a rectangular or polar (circular) pattern, creating an array. For 
a rectangular array, you control the number of copies in the array by specifying the 
number of rows and columns. You also specify the distance between each row and 
column. For a polar array, you control the number of copies that compose the array 
and whether to rotate the copies. 

To create a polar array 
1. Do one of the following:  

• Choose Modify > Array.  

• On the Modify toolbar, click the Array tool ( ).  

• Type array and then press Enter. 
2. Select the entities, and then press Enter. 

3. In the prompt box, choose Polar. 

4. Specify the center point of the array. 

5. Specify the number of items to array, including the original selection set. 

6. Specify the angle the array is to fill, from 0 to 360 degrees. The default setting for 
the angle is 360 degrees. Positive values create the array in a counterclockwise 
direction; negative values create the array in a clockwise direction.  

7. In the prompt box, choose one of the following:  

• Yes, Rotate Entities – rotates entities as they are arrayed.  

• No, Do Not Rotate – retains the original orientation of each copy as it is arrayed.  
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To create a polar array, select the entity to copy (A), specify the center point of the array (B), 

and then specify the number of items to array, the angle the array is to fill, and whether to rotate 
the items.  

To create a rectangular array 
1. Do one of the following:  

• Choose Modify > Array.  

• On the Modify toolbar, click the Array tool ( ).  

• Type array and then press Enter. 
2. Select the entities, and then press Enter. 

3. In the prompt box, choose Rectangular. 

4. Type the number of rows. 

5. Type the number of columns. 

6. Specify the distance between the rows. 

7. Specify the distance between the columns.  

 
To create a rectangular array, select the entity to copy (A), type the number of rows and 

columns, and then specify the distance between each row (B) and column (C).  

2.5.5 Rearranging entities 
You can move one or more entities, and you can also rotate entities about a specified 
point. If you have entities that overlap, you can also change the display order.  

Moving entities 
You can move entities around within the current drawing or from one drawing to 
another. The default method is to create a selection set and then specify a starting 
point, or base point, and an endpoint, or displacement point, to define the relocation of 
the entities. You can also relocate the entities using a direction vector. 
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To move a selection set 
1. Do one of the following:  

• Choose Modify > Move.  

• On the Modify toolbar, click the Move tool ( ). 

• Type move and then press Enter. 
2. Select the entities, and then press Enter. 

3. Specify the base point. 

4. Specify the displacement point. 

 
To move an entity, select it (A), and then specify the base point (B) and the displacement point 

(C). 

You can also move entities using grips. To move an entity using grips, select the entity 
to display its grips, and then click a grip and drag it. The grip you select depends on the 
type of entity you’re modifying. For example, to move a line entity, select the midpoint 
grip. To move a curved entity, such as an arc, circle, or ellipse, select the center point 
grip. Not all entities can be moved using grips.  

To move an entity using grips  
1. Select the entity.  

2. Click a grip to select it.  

3. Drag the entity to where you want to relocate it.  

4. Click to release.  

Rotating entities  
You can rotate entities about a specified point at a specified rotation angle or by an 
angle referenced to a base angle. The default method rotates the entities using a 
relative rotation angle from their current orientation.  

To rotate a selection set 
1. Do one of the following:  

• Choose Modify > Rotate.  

• On the Modify toolbar, click the Rotate tool ( ).  

• Type rotate and then press Enter. 
2. Select the entities, and then press Enter. 

3. Specify the rotation point. 

4. Specify the rotation angle. 
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To rotate an entity, select the entity to rotate (A), and then specify the rotation point (B) and the 

rotation angle (C).  

To rotate a selection set in reference to a base angle 
1. Do one of the following:  

• Choose Modify > Rotate.  

• On the Modify toolbar, click the Rotate tool ( ).  

• Type rotate and then press Enter. 
2. Select the entities, and then press Enter. 

3. Specify the rotation point. 

4. In the prompt box, choose Base Angle. 

5. Specify the base angle.  

6. Specify the new angle.  

 
To rotate an entity in reference to a base angle, select the entity (A), specify the rotation point 
(B), select the base angle and pick point (B) again (or type the @ symbol), specify the second 

point (C), and then specify the point representing the new angle (D).  

Reordering entities  
When multiple entities overlap, you can change the order in which they are displayed 
and printed. You can move entities to the front, back, or on top or below of another 
entity.  

To reorder entities: 
1. Do one of the following:  

• Choose Tools > Draw Order.  

• On the Tools toolbar, click the Draw Order tool ( ).  

• Type draworder and then press Enter.  
2. Select the entity you want to reorder, and then press Enter.  

3. In the prompt box, specify the new drawing order, and then press Enter.  
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4. If you are reordering above or under, select the entity you want the first entity to be 
above or below, and then press Enter.  

NOTE: The SORTENTS system variable automatically turns on, which may affect 
system performance.  

2.5.6 Resizing entities  
You can change the size of an entity or set of entities by stretching, scaling, extending, 
trimming, or editing their lengths.  

Stretching entities  
You can change the size of entities by stretching them. When you stretch entities, you 
must select the entities using either a crossing window or a crossing polygon. You then 
specify a displacement distance or select a base point and a displacement point. 
Entities that cross the window or polygon boundary are stretched; those completely 
within the crossing window or crossing polygon are simply moved.  

To stretch an entity 
1. Do one of the following:  

• Choose Modify > Stretch.  

• On the Modify toolbar, click the Stretch tool ( ). 

• Type stretch and then press Enter. 
2. In the prompt box, choose Crossing Window or Crossing Polygon. 

3. Select the entities, and then press Enter. 

4. Specify the base point. 

5. Specify the second point of displacement.  

 
To stretch entities, select them using a crossing window (A) or crossing polygon, and then 

specify the base point (B) and displacement point (C).  

To stretch an entity using grips, you select it to display its grips and then select a grip 
to make it the active grip. This becomes the base point. Then you move the active grip 
to a new location. The grip you select depends on the type of entity you’re modifying. 
For example, to stretch one corner of a rectangle, select the corner point grip. To 
stretch a line, select an endpoint grip. Not all entities can be stretched using grips.  

To stretch an entity using grips 
1. Select the entity. 

2. Click a grip to activate it. 

3. Drag the grip. 

4. Click to release.   
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To stretch an entity using grips, select the entity (A), select a grip (B), and drag the grip to its 

new location (C). 

Scaling entities  
You can change the size of a selected entity by scaling it in relation to a base point. 
You can change the size of an entity by specifying a base point and a length, which is 
used as a scale factor based on the current drawing units, or by specifying a scale 
factor. You can also use a scale factor referenced to a base scale factor, for example, 
by specifying the current length and a new length for the entity. 

To scale a selection set by a scale factor 
1. Do one of the following:  

• Choose Modify > Scale.  

• On the Modify toolbar, click the Scale tool ( ). 

• Type scale and then press Enter. 
2. Select the entities, and then press Enter. 

3. Specify the base point. 

4. Specify the scale factor. 

 
To scale an entity by a scale factor, select the entity (A), and then specify the base point (B) and 

the scale factor.  

You can also scale some entities using grips. To scale an entity, you select the entity, 
and then click a grip. You then change the size of the entity by moving the grip. The 
grip you select depends on the type of entity you’re modifying. For example, to scale a 
circle, select a quadrant point grip.  

To scale an entity using grips  
1. Select the entity. 

2. Click a grip to select it. 

3. Drag the grip. 

4. Click to release. 
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To scale using grips, select the entity (A), click a grip (B), and scale the entity by dragging the 

grip to its new location (C). 

Extending entities  
You can extend entities so that they end at a boundary defined by other entities. You 
can also extend entities to the point at which they would intersect an implied boundary 
edge. When extending entities, you first select the boundary edges, and then specify 
the entities to extend, selecting them either one at a time or using the fence selection 
method. 

You can extend arcs, lines, two-dimensional polylines, and rays. Arcs, circles, ellipses, 
lines, splines, polylines, rays, infinite lines, and viewports on a Layout tab can act as 
boundary edges.  

To extend an entity  
1. Do one of the following:  

• Choose Modify > Extend.  

• On the Modify toolbar, click the Extend tool ( ). 

• Type extend and then press Enter.  
2. Select one or more entities as boundary edges, and then press Enter.  

3. Select the entity to extend.  

4. Select another entity to extend, or press Enter to complete the command.  

 
To extend entities, select the boundary edge (A), and then select the entities to extend (B).  

To extend an entity to an implied boundary 
1. Do one of the following:  

• Choose Modify > Extend.  

• On the Modify toolbar, click the Extend tool ( ). 

• Type extend and then press Enter. 
2. Select one or more boundary edges, and then press Enter. 

3. In the prompt box, choose Edge Mode. 
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4. In the prompt box, choose Extend. 

5. Select the entity to extend. 

6. Select another entity to extend, or press Enter to complete the command.  

 
Select the boundary edge (A), and then select the entities to extend (B).  

To extend several entities using the fence selection method 
1. Do one of the following:  

• Choose Modify > Extend.  

• On the Modify toolbar, click the Extend tool ( ). 

• Type extend and then press Enter. 
2. Select one or more boundary edges, and then press Enter.  

3. In the prompt box, choose Fence.  

4. Specify the first point of the fence.  

5. Specify the second point of the fence.  

6. Specify the next fence point, or press Enter to complete the command.  

 
Select the boundary edge (A), and then specify the first point (B) and second point (C) of the 

fence. 

When you extend a wide polyline, its centerline intersects the boundary edge. Because 
the end of the polyline is always cut at a 90-degree angle, part of the polyline may 
extend past the boundary edge. A tapered polyline continues to taper until it intersects 
the boundary edge. If this would result in a negative polyline width, the ending width 
changes to 0.  
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A tapered polyline (A) continues to taper until it intersects the boundary edge (B).  

Trimming entities  
You can clip, or trim, entities so they end at one or more implied cutting edges defined 
by other entities. You can also trim entities to the point at which they would intersect an 
implied cutting edge. When trimming entities, you first select the cutting edges and then 
specify the entities to trim, selecting them either one at a time or using the fence 
selection method. 

You can trim arcs, circles, lines, open two-dimensional and three-dimensional 
polylines, and rays. Arcs, circles, lines, polylines, rays, infinite lines, and viewports on a 
Layout tab can act as cutting edges. An entity can be both a cutting edge and one of 
the entities being trimmed.  

To trim an entity 
1. Do one of the following:  

• Choose Modify > Trim. 

• On the Modify toolbar, click the Trim tool ( ).  

• Type trim and then press Enter. 
2. Select one or more cutting edges, and then press Enter. 

3. Select the entity to trim. 

4. Select another entity to trim, or press Enter to complete the command.  

 
To trim entities, select the cutting edge (A), and then select the entities to trim (B).  

To trim an entity to an implied boundary  
1. Do one of the following:  

• Choose Modify > Trim.  

• On the Modify toolbar, click the Trim tool ( ).  

• Type trim and then press Enter. 
2. Select one or more cutting edges, and then press Enter. 

3. In the prompt box, choose Edge Mode. 

4. In the prompt box, choose Extend. 

5. Select the entity to trim.  
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Select the implied boundary edge (A), and then select the entities to trim (B).  

To trim several entities using the fence selection method 
1. Do one of the following:  

• Choose Modify > Trim.  

• On the Modify toolbar, click the Trim tool ( ).  

• Type trim and then press Enter. 
2. Select one or more cutting edges, and then press Enter. 

3. In the prompt box, choose Fence. 

4. Specify the first point of the fence. 

5. Specify the second point of the fence. 

6. Specify the next fence point, or press Enter to complete the command.  

 
Select the boundary edge (A), and then specify the first point (B) and second point (C) of the 

fence.  

Editing the length of entities  
You can change the length of entities or the included angle of arcs. Use any of the 
following methods to change the length of an entity: 

• Dynamically drag the endpoint or angle.  

• Specify an incremental length or angle measured from an endpoint.  

• Specify the new length as a percentage of the total length or angle.  

• Specify a new length or included angle.  

You can change the length of arcs, lines, and open polylines.  

To change the length of an entity by dragging 
1.  Do one of the following:  

• Choose Modify > Edit Length.  

• On the Modify toolbar, click the Edit Length tool ( ). 

• Type editlen and then press Enter. 
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2. In the prompt box, choose Dynamic. 

3. Select the entity you want to change. 

4. Specify the new endpoint or included angle.  

 
Select the entity (A), and then select the new endpoint (B).  

2.5.7 Breaking and joining entities 
You can break an entity into two parts, removing a portion of the entity in the process. 
You can also join two entities into a single entity. 

Breaking entities 
You can break arcs, circles, ellipses, lines, polylines, rays, and infinite lines. When 
breaking entities, you must specify two points for the break. By default, the point you 
use to select the entity becomes the first break point; however, you can use the First 
option to select a break point different from the one that selects the entity. 

To break an entity 
1. Do one of the following:  

• Choose Modify > Break.  

• On the Modify toolbar, click the Break tool ( ). 

• Type break and then press Enter. 
2. Select the entity. 

3. Specify the second break point. 

 
Select the entity (A), and then specify the second break point (B).  

To select an entity and then specify the two break points 
1. Do one of the following:  

• Choose Modify > Break.  

• On the Modify toolbar, click the Break tool ( ). 

• Type break and then press Enter. 
2. Select the entity. 
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3. In the prompt box, choose First. 

4. Specify the first break point. 

5. Specify the second break point.  

 
Select the entity (A), and then specify the first (B) and second (C) break points.  

TIP: To break an entity in two without removing a portion of the entity, specify the same 
point for the first and second break points by typing the at sign (@) and pressing Enter 
instead of specifying the second break point.  

Joining entities  
You can join two entities into a single entity. You can join either two lines or two arcs. 
The two lines must be parallel; the two arcs must share the same center point and 
radius.  

When you join two lines, the farthest endpoints remain at their existing locations; the 
program draws a new line between these points. Arcs are joined counterclockwise, 
from the first arc you select to the second.  

To join two entities 
1. Do one of the following:  

• Choose Modify > Join.  

• On the Modify toolbar, click the Join tool ( ). 

• Type join and then press Enter. 
2. Select the first arc or line. 

3. Select the second arc or line. 

 
Select the first arc or line (A), and then select the second arc or line (B).  

2.5.8 Grouping entities  
A group is a collection of entities saved together as one unit. After you select the 
entities that belong in the group, you can later add more entities, remove entities, and 
reorder the entities. If necessary, you can also ungroup the entities at any time to work 
with the entities separately.  

The Group dialog box controls the settings for all groups in a drawing.  
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Creating groups  
When you create a group, you enter a group name and description, and then select the 
entities for the group.  

To create a group  
1. Do one of the following: 

• Choose Tools > Group. 

• On the Tools toolbar, click the Group tool ( ). 

• Type group and then press Enter. 

2. Under Create New Group, enter the name and description of the group. 

3. Click Selectable if you want all entities in the group to be selected when you select 
one entity of the group in the drawing. 

4. Click Select Entities and Create Group. 

5. Select the entities for the group, and then press Enter.  

6. In the Group dialog box, click OK.  

TIP: You can enter the name of a group in the command bar when selecting entities. 

Modifying groups  
To modify a group and its entities 
1. Do one of the following:  

• Choose Tools > Group.  
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• On the Tools toolbar, click the Group tool ( ). 

• Type group and then press Enter. 
2. In the Group dialog box, select the group you want to modify. 

3. Under Modify Selected Group, do one or more of the following: 

• Enter a new name, and then click Rename Group.  

• Enter a new description, and then click Change Group Description.  

• Select whether you want the group to be selectable in the drawing.  

• Click Add Entities to Group, select the entities to add to the group, and then 
press Enter.  

• Click Remove Entities from Group, select the entities to remove from the group, 
and then press Enter. 

4. In the Group dialog box, click OK.  

To change the order of entities in a group  
1. Do one of the following:  

• Choose Tools > Group.  

• On the Tools toolbar, click the Group tool ( ). 

• Type group and then press Enter.  

2. In the Group dialog box under Modify Selected Group, click Re-order Entities.  

3. In the Re-Order Grouped Entities dialog box, select the group you want to reorder. 

4. To see the order of entities in the group, click Highlight. Follow the prompts that 
display to view the entities, one by one.  

5. To reverse the order of all entities in the group, click Reverse Order.  

6. To change the order of specific entities or a range of entities:  

• In Remove from Position, enter the current position of the entity.  

• In Place to Position, enter the new position of the entity.  

• In Number of Entities, enter the number of entities or range of entities to 
reorder. For example, if you are changing the order of only one entity, enter 1.  

• Click Re-Order.  

NOTE The entities in a group are numbered 0, 1, 2, 3, and so on.  

7. Click OK, and then click OK again.  

Ungrouping entities 
When you ungroup entities, the entities remain in the drawing but the group is deleted 
from the drawing.  

To ungroup entities 
1. Do one of the following:  

• Choose Tools > Group.  

• On the Tools toolbar, click the Group tool ( ). 
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• Type group and then press Enter. 
2. In the Group dialog box, select the group to delete. 

3. Under Modify Selected Group, click Ungroup Entities. 

4. Click OK.  

2.5.9 Editing polylines  
You can modify any type of two-dimensional or three-dimensional polyline. Entities 
such as rectangles, polygons, and donuts, as well as three-dimensional entities such 
as pyramids, cylinders, and spheres, are all variations of polylines that you can edit. 

You can edit a polyline by opening or closing it, by changing its overall width or the 
widths of individual segments, and by converting a polyline with straight line segments 
into a flowing curve or an approximation of a spline. In addition, you can use the Edit 
Polyline tool to edit individual vertices, adding, removing, or moving vertices. You can 
also add new segments to an existing polyline, change the linetypes of a polyline, and 
reverse the direction or order of the vertices.  

To modify a polyline, you first select the polyline, and then select a polyline editing 
option. The available options vary depending on whether the selected polyline is a two-
dimensional or three-dimensional entity. If the selected entity is not a polyline, the Edit 
Polyline tool provides the option of turning it into one. You can convert only arcs and 
lines into polylines. If several arcs or lines are joined endpoint to endpoint, they can all 
be selected and turned into one polyline. 

To convert an entity into a polyline 
1. Do one of the following:  

• Choose Modify > Edit Polyline.  

• On the Modify toolbar, click the Edit Polyline tool ( ).  

• Type editpline and then press Enter. 
2. Select the entity. 

3. In the prompt box, choose Yes-Turn Into Polyline. 

4. In the prompt box, choose another option, or choose Done to complete the 
command.  

Opening and closing polylines 
When you close a polyline, the program draws a straight polyline segment from the last 
vertex of the polyline to the first vertex. Opening a polyline removes the closing 
segment. When you select a polyline for editing, the prompt box displays either the 
Open or Close option, depending on whether the polyline you select is closed or open. 

To close an open polyline 
1. Do one of the following:  

• Choose Modify > Edit Polyline.  

• On the Modify toolbar, click the Edit Polyline tool ( ). 

• Type editpline and then press Enter.  
2. Select the polyline.  

3. In the prompt box, choose Close. 
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4. In the prompt box, choose another option, or choose Done to complete the 
command. 

 
Closing an open polyline adds a straight polyline segment between the first (A) and last (B) 

vertices.  

Curving and decurving polylines 
You can convert a multi-segment polyline into a smooth curve using either the Fit or 
Spline option. The Fit option creates a smooth curve connecting all the vertices. The 
Spline option computes a smooth curve that is pulled toward the vertices but passes 
through only the first and last vertices. The Decurve option removes Fit or Spline 
curves and arcs, leaving straight segments between the vertices. 

To fit a curve to a polyline 
1. Do one of the following:  

• Choose Modify > Edit Polyline.  

• On the Modify toolbar, click the Edit Polyline tool ( ). 

• Type editpline and then press Enter. 
2. Select the polyline. 

3. In the prompt box, choose Fit. 

4. In the prompt box, choose another option, or choose Done to complete the 
command.  

 
Original polyline. - After applying Fit curve. - After applying Spline.  

Joining polylines 
You can add an arc, line, or polyline entity to an existing open polyline, forming one 
continuous polyline entity. To join an entity to a polyline, that entity must already share 
an endpoint with an end vertex of the selected polyline.  

When you join an entity to a polyline, the width of the new polyline segment depends 
on the width of the original polyline and the type of entity you are joining to it: 
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• A line or an arc assumes the same width as the polyline segment for the end 
vertex to which it is joined.  

• A polyline joined to a tapered polyline retains its own width values.  

• A polyline joined to a uniform-width polyline assumes the width of the polyline to 
which it is joined.  

To join an arc, or polyline to an existing polyline 
1. Do one of the following:  

• Choose Modify > Edit Polyline.  

• On the Modify toolbar, click the Edit Polyline tool ( ). 

• • Type editpline and then press Enter. 
2. Select the polyline. 

3. In the prompt box, choose Join. 

4. Select the arc, line, or polyline to join. 

5. In the prompt box, choose another option, or choose Done to complete the 
command.  

Changing the polyline width 
You can change the width of an entire polyline, applying a uniform width to the entire 
entity or tapering the polyline uniformly along its entire length.  

To apply a uniform width to an entire polyline 
1. Do one of the following:  

• Choose Modify > Edit Polyline.  

• On the Modify toolbar, click the Edit Polyline tool ( ). 

• Type editpline and then press Enter. 
2. Select the polyline. 

3. In the prompt box, choose Width. 

4. Specify the new polyline width. 

5. In the prompt box, choose another option, or choose Done to complete the 
command.  

To taper a polyline uniformly along its length 
1. Do one of the following:  

• Choose Modify > Edit Polyline.  

• On the Modify toolbar, click the Edit Polyline tool ( ). 

• Type editpline and then press Enter.  
2. Select the polyline.  

3. In the prompt box, choose Taper.  

4. Specify the starting width.  

5. Specify the ending width.  
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6. In the prompt box, choose another option, or choose Done to complete the 
command.  

Editing polyline vertices 
You can use the Edit Vertices option to modify individual polyline vertices. When you 
select this option, the program switches into a special vertex editing mode and places 
an x on the first vertex. The x indicates the vertex you are editing. The Next and 
Previous options move the x to the next or previous vertex. You can edit only one 
vertex at a time.  

When editing vertices, you can modify the polyline in the following ways:  

• Convert a polyline segment into a curve by specifying a new tangent angle.  

• Break a polyline into two separate polylines.  

• Insert a new vertex after the current vertex.  

• Move the current vertex.  

• Straighten the polyline segment between two vertices.  

• Change the width of the polyline segment between two vertices.  

To move a polyline vertex 
1. Do one of the following:  

• Choose Modify > Edit Polyline.  

• On the Modify toolbar, click the Edit Polyline tool ( ) 

• Type editpline and then press Enter.  
2. Select the polyline. 

3. In the prompt box, choose Edit Vertices. 

4. In the prompt box, choose Next Vertex. Repeat until the x reaches the vertex you 
want to move.  

5. In the prompt box, choose Move.  

6. Specify the new location for the vertex.  

7. In the prompt box, choose another option, or choose Exit to stop editing vertices.  

8. In the prompt box, choose another option, or choose Done to complete the 
command. 

 
Select the polyline (A), move the current vertex marker to the vertex you want to move (B), and 

then specify the new vertex location (C). 

To taper the width of an individual polyline segment 
1. Do one of the following:  

• Choose Modify > Edit Polyline.  
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• On the Modify toolbar, click the Edit Polyline tool ( ). 

• Type editpline and then press Enter.  
2. Select the polyline.  

3. In the prompt box, choose Edit Vertices.  

4. In the prompt box, choose Next Vertex. Repeat until the x reaches the first vertex of 
the segment you want to taper.  

5. In the prompt box, choose Width.  

6. Specify the starting width.  

7. Specify the ending width.  

8. In the prompt box, choose another option, or choose Exit to stop editing vertices 
and update the display.  

9. In the prompt box, choose another option, or choose Done to complete the 
command.  

 
Select the polyline (A), move the current vertex marker to the first vertex of the segment you 

want to taper (B), and then specify the new starting and ending widths for that segment. 

2.5.10 Exploding entities 
You can convert a complex entity, such as a block or polyline, from a single entity into 
its component parts. Exploding a polyline, rectangle, donut, polygon, dimension, or 
leader reduces it to a collection of individual line and arc entities that you can then 
modify individually. Blocks are converted to the individual entities, possibly including 
other, nested blocks that composed the original entity. 

With the following exceptions, exploding an entity usually has no visible effect on a 
drawing:  

• If the original polyline had a width, the width information is lost when you 
explode it. The resulting lines and arcs follow the centerline of the original 
polyline.  

• If you explode a block containing attributes, the attributes are lost, but the 
original attribute definitions remain. 

• Colors and linetypes assigned BYBLOCK may appear different after exploding 
an entity, because they will adopt the default color and linetype until inserted 
into another block.  

To explode an entity 
1. Do one of the following:  

• Choose Modify > Explode.  

• On the Modify toolbar, click the Explode tool ( ). 

• Type explode and then press Enter. 
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2. Select the entities to explode. 

3. Press Enter.  

2.5.11 Chamfering and filleting entities 
You can chamfer or fillet entities. A chamfer connects two nonparallel entities with a 
line to create a beveled edge. A fillet connects two entities with an arc of a specified 
radius to create a rounded edge. If both entities you are working with are on the same 
layer, the chamfer or fillet is drawn on that layer. If they are on different layers, the 
chamfer or fillet is drawn on the current layer.  

The Chamfer/Fillet settings in the Drawing Settings dialog box control the chamfer and 
fillet settings. The portions of the entities that extend beyond the chamfer or fillet are 
normally deleted when you create the chamfer or fillet. You can retain these original 
entities, however, by changing the settings in the dialog box.  

 

A. Click to remove or retain portions of entities that extend beyond the chamfer or fillet. 

B. Click to create a chamfer using two chamfer distances (distance-distance method). 

C. Specify the first and second chamfer distances when using the distance-distance method. 

D. Specify the chamfer length and angle when using the distance-angle method.  

E. Click to create a chamfer using the chamfer length and angle (distance-angle method).  

F. Click to specify the fillet radius by selecting two points in the drawing.  

G. Specify the fillet radius.  
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Chamfering entities  
You can connect two nonparallel entities by extending or trimming them and then 
joining them with a line to create a beveled edge. You can chamfer lines, polylines, 
rays, and infinite lines. When creating a chamfer, you can specify how far to trim the 
entities back from their intersection (distance-distance method), or you can specify the 
length of the chamfer and the angle it forms along the first entity (distance-angle 
method).  

When chamfering a polyline, you can chamfer multiple segments between two selected 
polyline segments, or you can chamfer the entire polyline.  

To chamfer two entities using the distance-distance method 
1. Do one of the following:  

• Choose Modify > Chamfer.  

• On the Modify toolbar, click the Chamfer tool ( ). 

• Type chamfer and then press Enter. 

2. In the prompt box, choose Chamfer Settings. 

3. In the Drawing Settings dialog box, click the Entity Modification tab. 

4. Under Chamfer Distances And Angles, click Distance-Distance. 

5. Under Chamfer Distances And Angles, specify the first and second chamfer 
distances. 

6. Click OK. 

7. Select the first entity. 

8. Select the second entity.  

 
Select the first (A) and second (B) entities. The chamfer is drawn, based on the first (C) and 

second (D) chamfer distances.  

To chamfer two entities using the distance-angle method 
1. Do one of the following:  

• Choose Modify > Chamfer.  

• On the Modify toolbar, click the Chamfer tool ( ). 

• Type chamfer and then press Enter.  
2. In the prompt box, choose Chamfer Settings.  

3. In the Drawing Settings dialog box, click the Entity Modification tab.  

4. Under Chamfer Distances And Angles, click Distance-Angle.  

5. Under Chamfer Distances And Angles, specify the chamfer distance and angle.  
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6. Click OK.  

7. Select the first entity.  

8. Select the second entity.  

 
Select the first (A) and second (B) entities. The chamfer is drawn, based on the distance 

measured along the first entity (C) and the angle (D) formed with the first entity.  

To chamfer all vertices in a polyline 
1. Do one of the following:  

• Choose Modify > Chamfer.  

• On the Modify toolbar, click the Chamfer tool ( ). 

• Type chamfer and then press Enter. 
2. In the prompt box, choose Polyline. 

3. Select the polyline.  

 
Original polyline. - Result after chamfering.  

To chamfer selected vertices in a polyline  
1. Do one of the following:  

• Choose Modify > Chamfer.  

• On the Modify toolbar, click the Chamfer tool ( ). 

• Type chamfer and then press Enter. 
2. Select the polyline along the segment where you want to begin the chamfer. 

3. Select the polyline along the segment where you want to end the chamfer. 

 
Select the polyline along the (A) and (B) - Result after chamfering. segments.  
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Filleting entities  
You can connect two entities with an arc of a specified radius to create a rounded 
edge. You can fillet pairs of line segments, straight polyline segments, arcs, circles, 
rays, and infinite lines. You can also fillet parallel lines, rays, and infinite lines. When 
filleting a polyline, you can fillet multiple segments between two selected segments, or 
you can fillet the entire polyline. 

To fillet two entities 
1. Do one of the following:  

• Choose Modify > Fillet.  

• On the Modify toolbar, click the Fillet tool ( ). 

• Type fillet and then press Enter. 
2. In the prompt box, choose Fillet Settings. 

3. In the Drawing Settings dialog box, specify the fillet radius. 

4. Click OK. 

5. Select the first entity. 

6. Select the second entity.  

 
Select the first (A) and second (B) entities. - Result after filleting.  

To fillet an entire polyline 
1. Do one of the following:  

• Choose Modify > Fillet.  

• On the Modify toolbar, click the Fillet tool ( ). 

• Type fillet and then press Enter. 
2. In the prompt box, choose Polyline. 

3. Select the polyline.  

 
Select a polyline (A) – Result after filleting 

To fillet selected vertices in a polyline 
1. Do one of the following:  
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• Choose Modify > Fillet.  

• On the Modify toolbar, click the Fillet tool ( ). 

• Type fillet and then press Enter. 

2. Select the polyline along the segment where you want to begin the fillet. 

3. Select the polyline along the segment where you want to end the fillet.  

 
Select the polyline along the (A) and (B) - Result after filleting. segments.  

When you fillet circles and arcs, more than one fillet can exist between the entities. The 
point at which you select the entities determines the fillet.  

 
Select entities (A and B). - Results after filleting.  

You can fillet parallel lines, rays, and infinite lines. The first entity must be a line or ray; 
the second entity can be a line, ray, or infinite line. The diameter of the fillet arc is 
always equal to the distance between the parallel entities. The current fillet radius is 
ignored.  

 
Original entities. - Result after filleting. 
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2.6 Working with coordinates 
For accuracy in a drawing, you can locate specific points by entering coordinates as 
you draw or modify entities. When you create two-dimensional entities, you enter two-
dimensional coordinates; for three-dimensional entities, you specify three-dimensional 
coordinates.  

You can also specify coordinates in relation to other known locations or entities in a 
drawing. In particular, when you work in three-dimensional drawings, it is often easier 
to specify coordinates in relation to a two-dimensional working plane, called a user 
coordinate system (UCS).  

This section explains how to work with coordinates, including how to:  

- Use two-dimensional and three-dimensional coordinate systems.  

- Specify absolute and relative coordinates.  

- Specify polar, spherical, and cylindrical coordinates.  

- Define and manipulate user coordinate systems.  

2.6.1 Using Cartesian coordinates 
Many commands in ProgeCAD Architecture require that you specify points as you draw 
or modify entities. You can do so by selecting points with the mouse or by typing 
coordinate values in the command bar. The program locates points in a drawing using 
a Cartesian coordinate system.  

Understanding how coordinate systems work  
The Cartesian coordinate system uses three perpendicular axes -x, y, and z- to specify 
points in three-dimensional space. Every location in a drawing can be represented as a 
point relative to a 0,0,0 coordinate point, referred to as the origin. To draw a two-
dimensional entity, you specify horizontal coordinate positions along the x-axis and 
vertical coordinate positions along the y-axis. Thus, every point on a plane can be 
represented as a coordinate pair composed of an x-coordinate and a y-coordinate. 
Positive coordinates are located above and to the right of the origin; negative 
coordinates are located to the left and below the origin.   

 
The three perpendicular axes of the Cartesian coordinate system.  
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When you work in two dimensions, you need enter only the x- and y-coordinates; the 
program assumes that the z-axis value is always the current elevation. When you work 
in three dimensions, however, you must also specify the z-axis value. When you look at 
a plan view of your drawing (a view from above, looking down), the z-axis extends 
straight up out of the screen at a 90-degree angle to the xy plane. Positive coordinates 
are located above the xy plane, and negative coordinates are below the plane.  

All ProgeCAD Architecture drawings use a fixed coordinate system, called the World 
Coordinate System (WCS), and every point in a drawing has a specific x,y,z-coordinate 
in the WCS. You can also define arbitrary coordinate systems located anywhere in 
three-dimensional space. These are called user coordinate systems and can be 
located anywhere in the WCS and oriented in any direction.  

You can create as many user coordinate systems as you want, saving or redefining 
them to help you construct three-dimensional entities. By defining a UCS within the 
WCS, you can simplify the creation of most three-dimensional entities into 
combinations of two-dimensional entities. 

To help you keep your bearings in the current coordinate system, the program displays 
a coordinate system icon. When you begin a new drawing, you are automatically in the 
WCS, indicated by the letter W in the icon. When you display a drawing in plan view, 
you see the coordinate system icon from the top, with the z-axis directed straight 
toward you. When you display a three-dimensional drawing in a view other than plan 
view, the coordinate system icon changes to reflect your new viewpoint.  

TIP: The visible portions of the axes are the positive directions. 

 
WCS icon. - Plan UCS icon. - 3D View WCS icon.  

The ProgeCAD Architecture UCS icon looks different from the UCS icon in AutoCAD, 
because it presents more information. Three colors represent the three axes, making it 
easier for you to recognize the orientation in three-dimensional space:  

• x-axis: red  

• y-axis: green  

• z-axis: blue  

If you prefer a single color for the cursor and UCS icon, you can make that change with 
the config or options command.  
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Understanding how coordinates are displayed  
The current position of the cursor is displayed as x,y,z-coordinates in the status bar 
and, by default, updates dynamically as you move the cursor. You can toggle the 
coordinate display to static mode by pressing F6, so that it updates only when you 
select a point in the drawing. 

 
You can also change the coordinate display to a different dynamic mode that shows 
the distance and angle (rather than x,y,z-coordinates) when the program displays a 
rubber-band line. To do this, choose Settings > Drawing Settings and select the 
Display tab. Under Coordinate Display, select the option for Coordinates In Polar Form 
For Distance And Angle Selection.  

 
You can control the coordinate display from the Drawing Settings dialog box.  

Finding the coordinates of a point  
To find the x,y,z-coordinates for a point on an entity, such as the endpoint of a line, 
select an appropriate entity snap (such as Endpoint) before selecting the entity. If you 
have no entity snaps set, the x,y-coordinates of the point you specified is displayed, 
with the z-coordinate equal to the current elevation.  

To find the coordinate of a point in the drawing 
1. Do one of the following:  

• Choose Tools > Inquiry > ID Coordinates.  

• On the Inquiry toolbar, click the ID Coordinates tool ( ). 

• Type idpoint and then press Enter. 
2. Select the point for which you want to find the coordinates. 

If the command bar is activated, the x,y,z-coordinates for the point you selected display 
in the command bar. If the command bar is not activated, the Prompt History window 
displays, showing the x,y,z-coordinates for the point you selected.  
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2.6.2 Using two-dimensional coordinates  
When working in two dimensions, you specify points on the xy plane. You can specify 
any point as an absolute coordinate (or Cartesian coordinate), using the exact x-
coordinate and y-coordinate locations in relation to the origin (the 0,0 coordinate point 
at which the two axes intersect), or as a relative coordinate in relation to the previous 
point. You can also specify points using relative or absolute polar coordinates, which 
locate a point using a distance and an angle.  

Entering absolute Cartesian coordinates  
To enter absolute Cartesian coordinates, type the coordinate location of the point in the 
command bar. For example, to use absolute Cartesian coordinates to draw a line from 
the origin (0,0) to a point 3 units to the right and 1 unit above the origin, start the Line 
command and respond to the prompts as follows:  

Start of line: 0,0 

Angle • Length • <Endpoint>: 3,1 

 
Drawing a line using the absolute Cartesian coordinate method.  

When using absolute Cartesian coordinates, you need to know the exact point 
locations for anything you draw. For instance, to use absolute Cartesian coordinates to 
draw an 8.5-unit square with its lower left corner at 4,5, you must determine that the 
upper left corner is at coordinate 4,13.5, the upper right corner at 12.5,13.5, and the 
lower right corner at 12.5,5.  

Entering relative Cartesian coordinates  
Another, simpler method is to use relative Cartesian coordinates: you specify a location 
in the drawing by determining its position relative to the last coordinate you specified. 
To use relative Cartesian coordinates, type the coordinate values in the command bar, 
preceded by the at symbol (@). The coordinate pair following the @ symbol represents 
the distance along the x-axis and the y-axis to the next point. For example, to draw an 
8.5-unit square with its lower left corner at 4,5 using relative Cartesian coordinates, 
start the Line command, and then respond to the prompts as follows:  

Start of line: 4,5 

Angle • Length • <Endpoint>: @8.5,0 

Angle • Length • Follow • Undo • <Endpoint>: @0,8.5 

Angle • Length • Follow • Close • Undo • <Endpoint>: @-8.5,0 

Angle • Length • Follow • Close • Undo • <Endpoint>: C 
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Drawing a square using the relative Cartesian coordinates method; enter C to close.  

The first relative coordinate (@8.5,0) locates the new point 8.5 units to the right (along 
the x-axis) from the previous point of 4,5; the second relative coordinate (@0,8.5) 
locates the next point 8.5 units above (along the y-axis) the previous point, and so on. 
Entering C (for Close) draws the final line segment back to the first point specified 
when you started the Line command.  

Entering polar coordinates  
Using relative polar coordinates makes drawing a square tilted at a 45-degree angle a 
simple task. Polar coordinates base the location of a point on a distance and angle 
from either the origin (absolute coordinate) or from the previous point (relative 
coordinate).  

To specify polar coordinates, type a distance and an angle, separated by the open 
angle bracket (<). For example, to use relative polar coordinates to specify a point 1 
unit away from the previous point and at an angle of 45 degrees, type @1<45.  

To draw the square from the example in the previous section, “Entering relative 
Cartesian coordinates,” this time tilted at a 45-degree angle, start the Line command, 
and then respond to the prompts as follows:  

Start of line: 4,5 

Angle • Length • <Endpoint>: @8.5<45 

Angle • Length • Follow • Undo • <Endpoint>: @8.5<315 

Angle • Length • Follow • Close • Undo • <Endpoint>: @8.5<225 

Angle • Length • Follow • Close • Undo • <Endpoint>: C 

 
Drawing a tilted square using the relative polar coordinates method; enter C to close.  
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NOTE: This example, like all examples in this guide, assumes the program’s default 
settings: Angles increase counterclockwise and decrease clockwise. Thus, an angle of 
315 degrees is the same as -45 degrees.  

2.6.3 Using three-dimensional coordinates 
Specifying coordinates in three-dimensional space is similar to working in two 
dimensions, except that you also use the z-axis to locate coordinates. Three-
dimensional coordinates are represented in the format x,y,z (for example, 2,3,6).  

Using the right-hand rule  
To visualize how ProgeCAD Architecture works with three-dimensional space, use a 
technique known as the right-hand rule. Hold up your right hand in a loose fist with your 
palm facing you. Extend your thumb in the direction of the positive x-axis and your 
index finger upward in the direction of the positive y-axis. Then extend your middle 
finger straight toward you in the direction of the z-axis. These three fingers are now 
pointing in the positive x, y, and z directions, respectively.  

You can also use the right-hand rule to determine the positive rotation direction. Point 
your thumb in the positive direction of the axis about which you want to rotate, and then 
curl the rest of your fingers toward your palm. These fingers are curling in the positive 
rotation direction.  

 
The right-hand rule helps you determine the positive direction of the x-, y-, and z-axes and the 

positive rotation direction.  

Entering x,y,z-coordinates  
When working in three dimensions, you can specify x,y,z-coordinates as absolute 
distances in relation to the origin (the 0,0,0 coordinate point at which the three axes 
intersect) or as relative coordinates based on the last point selected. For example, to 
specify a point 3 units along the positive x-axis, 4 units along the positive y-axis, and 2 
units along the positive z-axis, specify the coordinate 3,4,2.  

Entering spherical coordinates  
When working in three-dimensional space, you can use spherical coordinates to 
specify a three-dimensional point by entering its distance from either the origin 
(absolute distance) or the last point (relative distance), along with its angle in the xy 
plane and its angle up from the xy plane. In spherical format, you separate each angle 
with the open angle bracket (<).  

Thus, to draw a line from the origin to a point 10.2500 drawing units away, at an angle 
of 45 degrees from the x-axis and 35 degrees from the xy plane, start the Line 
command, and then respond to the prompts as follows:  
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Start of line: 0,0,0 

Angle • Length • <Endpoint>: 10.2500<45<35 

 
When you draw a line from a start point (A) to an endpoint (B) using spherical coordinates, you 

specify its length (C, in this case 10.2500 units), the angle in the xy plane (D, in this case 45 
degrees), and the angle from the xy plane (E, in this case 35 degrees).  

2.6.4 Using xyz point filters  
Point filters provide a method of locating a point in a drawing relative to another point 
without specifying the entire coordinate. Using a point filter, you can enter partial 
coordinates, and then the program prompts you for the remaining coordinate 
information. To use xyz point filters, respond to the prompt for a coordinate with a filter 
in the following form: 

.coordinate  
where coordinate is one or more of the letters x, y, and z. The program then prompts 
you for the filtered coordinate(s). For example, if you type .xy, the program prompts you 
to select a point whose xy-coordinate you want, and then prompts you for the z-
coordinate. The filters .x, .y, .z, .xy, .xz, and .yz are all valid filters.  

Using point filters in two dimensions  
You can use point filters when you work in two dimensions to locate points in relation to 
existing entities. For example, to draw a circle centered in a rectangle, start the Circle 
command, and then respond to the prompts as follows:  
2Point • 3Point • RadTanTan • Arc • Multiple • <Center of circle>: .y 

Select Y of: mid 

Snap to midpoint of: (select the left side of the rectangle) 

Still need XZ of: mid 

Snap to midpoint of: (select top of the rectangle) 

Diameter • <Radius>: (specify radius of circle) 

 
You can use point filters to center the circle by separately selecting the midpoints of two sides 

of the rectangle (A and B) and then specifying its radius.  
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Using point filters in three dimensions  
You can use point filters when you work in three-dimensional space to locate points in 
two dimensions and then specify the z-coordinate as the elevation above the xy plane. 
For example, to begin drawing a line from a point with a z-coordinate 3 units above the 
center of a circle, insert the circle, and then start the Line command and respond to the 
prompts as follows:  
ENTER to use last point • Follow • <Start of line>: .xy 

Select XY of: cen 

Snap to centerpoint of: (select a point on the circle) 

Still need Z of: 3 (locates the starting point 3 units above the center ofthe circle) 

Length of line: (specify the length of the line) 

 
You can use point filters to draw a line by first selecting a point in the xy plane (A), specifying 

the z-coordinate (B), and then specifying the length of the line (C).  

2.6.5 Defining user coordinate systems  
When working in three-dimensional space, you can define a UCS with its own 0,0,0 
origin and orientation separate from the WCS. You can create as many user coordinate 
systems as you want, and then save and recall them as you need them to simplify 
construction of three-dimensional entities.  

For example, you can create a separate UCS for each side of a building. Then, by 
switching to the UCS for the east side of the building, you can draw the windows on 
that side by specifying only their x-and y-coordinates. When you create one or more 
user coordinate systems, the coordinate entry is based on the current UCS.  

 
UCS aligned with the front wall of the house.  

Defining a user coordinate system  
To define a UCS, you can use any of the following methods:  

• Specify a new origin and points on the positive x- and y-axes.  

• Specify a new origin and point on the positive z-axis.  

• Align the UCS with an existing entity. 
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• Rotate the current UCS around any of its axes. 

• Align the UCS with its z-axis parallel to the current viewing direction.  

• Align the UCS xy plane perpendicular to the current view.  

When you define a new UCS, the UCS icon changes to indicate the origin and 
orientation of the new UCS.  

To define a UCS by specifying a new origin and points on the positive x- and y-
axes 
1. Do one of the following:  

• Choose Settings > User Coordinate Systems.  

• On the Settings toolbar, click the User Coordinate Systems tool ( ).  

• Type setucs and then press Enter. 
2. In the User Coordinate Systems dialog box, click Explore UCSs. 

3. In the ProgeCAD Architecture Explorer, be sure that Coordinate Systems is 
selected, and click the New Item tool ( ). 

4. In the prompt box, choose 3 Point.  

5. Select the new origin.  

6. Select a point on the positive x-axis.  

7. Select a point in the positive y direction.  

8. In the ProgeCAD Architecture Explorer - Coordinate Systems dialog box, type the 
name for the new UCS, and then close the dialog box.  

 
Define the new UCS by selecting the origin (A), a point on the positive x-axis (B), and a point in 

the positive y direction (C).  

Using a preset user coordinate system  
ProgeCAD Architecture lets you select a preset UCS. The six planes defined by looking 
along the x,y,z-axes align the UCS with the top, left, front, bottom, right, or back, based 
on either the WCS or the current UCS in effect when you select the tool. You can also 
select the previous UCS, align the UCS to the current view, or select the WCS.  

When you select a UCS, the cursor orientation and UCS icon change to reflect the new 
UCS. The display does not change, however, unless you select the Change View To 
Plan View Of The Selected UCS check box.  

After you align the UCS to a preset UCS, you can use the ProgeCAD Architecture 
Explorer to save the UCS. To do this, in the ProgeCAD Architecture Explorer window, 
choose Edit > New > UCS, and then select Current.  
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To select a preset UCS 
1. Do one of the following:  

• Choose Settings > User Coordinate Systems.  

• On the Settings toolbar, click the User Coordinate Systems tool ( ).  

• • Type setucs and then press Enter.  
2. Under Set The Selected UCS Relative To, select either Current UCS to change to 

the new UCS by reorienting relative to the current UCS or World Coordinate 
System (WCS) to base the new UCS orientation on the WCS.  

3. Under Select UCS, click the button corresponding to the UCS you want as the new 
current UCS. 

 

A. Specify whether to define the new UCS relative to the current UCS or to the World 
Coordinate System (WCS). 

B. Select to change the display to the plan view of the new UCS. 

C. Click to select the previous UCS. 

D. Click one of these buttons to select the view you want of a preset UCS. 

E. Click to select the WCS. 

F. Click to align the UCS with the current view. 

G. Click to display the ProgeCAD Architecture Explorer. 
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2.7 Viewing your drawing  
ProgeCAD Architecture provides many ways to display and view your drawing. You 
can also change various display settings to speed up the display or printing of a 
drawing. This section explains how to:  

- Navigate within a drawing by scrolling, panning, and rotating the view.  

- Change the magnification of a drawing by zooming in and out.  

- Work with multiple windows or views of a drawing.  

- Control the display of elements to optimize performance when working with large or 
complex drawings.  

2.7.1 Redrawing and regenerating a drawing 
As you work on a drawing, visual elements may remain after the completion of a 
command. You can remove these elements by refreshing, or redrawing, the display.  

To redraw (refresh) the current window display  
Do one of the following:  

• Choose View > Redraw.  

• On the View toolbar, click the Redraw tool ( ). 

• Type redraw and then press Enter.  
Information about drawing entities is stored in a database as floating point values, 
ensuring a high level of precision. Sometimes a drawing must be recalculated, or 
regenerated, from the floating-point database to convert those values to the 
appropriate screen coordinates. This occurs automatically. You can also manually 
initiate a regeneration. When the drawing is regenerated, it is also redrawn.  

To regenerate the current window, type regen in the command bar. If more than one 
window is displayed, type regenall to regenerate all the windows.  

2.7.2 Moving around within a drawing  
You can move the view of a drawing displayed in the current viewport by scrolling, 
panning, or rotating the view. Doing this changes the portion of the drawing you are 
viewing without changing the current magnification. Scrolling lets you move around in 
the drawing horizontally and vertically. Panning lets you move the drawing in any 
direction. Rotating lets you view your drawing from any angle.  

Using scroll bars  
To assist you in navigating within a drawing, horizontal and vertical scroll bars are 
available in each drawing window. The size of the scroll box in relation to the scroll bar 
indicates the current level of drawing magnification. The position of the scroll box in 
relation to the scroll bar indicates the location of the center of the drawing in relation to 
the extents of the drawing (the smallest rectangle containing all the entities in the 
drawing). 

To turn scroll bars on or off  
Do one of the following:  

• Choose View > Scroll Bars.  

• Type scrollbar, press Enter, and then select On, Off, or Toggle.  
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Using the Pan command  
You can move the drawing in any direction using the Pan tool ( ) on the View toolbar. 
Panning shifts or slides the view of the drawing horizontally, vertically, or diagonally. 
The magnification of the drawing remains the same, as does its orientation in space. 
The only change is the portion of the drawing displayed.  

To pan, you can use any of the following methods:  

• For precise panning, specify two points defining the magnitude and direction of 
the pan. The first point, or base point, indicates the starting point of the pan. 
The second point indicates the amount of pan displacement relative to the first 
point.  

• To pan in real time, use the right mouse button.  

• If you have a mouse with a wheel, use the wheel to pan up or down.  

• To pan in small increments, use the arrow keys.  

To pan by specifying two points 
1. Do one of the following:  

• Choose View > Pan.  

• On the View toolbar, click the Pan tool ( ). 

• Type pan and then press Enter. 
2. Specify the pan base point either by typing the coordinates or by specifying a point 

in the drawing window.  

3. Specify the pan displacement point either by typing the coordinates or by specifying 
a point in the drawing window.  

 
Select the pan base point (A),and then select a second point (B) to specify the pan 

displacement. 

To pan in real time 
1. Simultaneously press Ctrl+Shift and click and hold the right mouse button. 

2. Move the cursor in the direction you want to pan. 

3. To stop panning, release the mouse button. 

To pan using a mouse with a wheel  

• Rotate the wheel backward to pan up or forward to pan down.  

NOTE: You must have the scroll bars displayed to use this feature. To display the 
scroll bars, choose View > Scroll Bars.  
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To pan using the arrow keys  

• Press the up, down, right, or left arrow keys.  

Rotating the view  
ProgeCAD Architecture allows you to rotate your view of a drawing in real time. This 
allows you to view your model from any angle.  

If desired, you can continue the view rotation after you release your mouse. Choose 
Tools > Options to enable continuous motion.  

To rotate the view in real time 
1. Type rtrot, and then press Enter.  

NOTE: You can also type rtrotx, rtroty, or rtrotz to lock the rotation in the 
corresponding axis.  

2. Click and drag the mouse in the drawing. The view rotates according to the 
movement of your mouse.  

3. To stop rotating, release the mouse button.  

4. If desired, continue rotating the view.  

5. When finished, press Enter or right-click the drawing.  

2.7.3 Changing the magnification of your drawing   
You can change the magnification of your drawing at any time by zooming. The cursor 
changes to a magnifying glass ( ) when a zoom tool is active. Zoom out to reduce the 
magnification so you can see more of the drawing, or zoom in to increase the 
magnification so you can see a portion of the drawing in greater detail. Changing the 
magnification of the drawing affects only the way the drawing is displayed; it has no 
effect on the dimensions of the entities in your drawing.  

Zooming in and out  
One of the easiest ways to change the magnification of the drawing is to zoom in or out 
by a preset increment. On the View toolbar, the Zoom In tool ( ) doubles the current 
magnification of the drawing. The Zoom Out tool ( ) reduces the magnification of the 
drawing by half. The portion of the drawing located at the center of the current viewport 
remains centered on the screen as you zoom in and out.  

 

Zoom in. - Zoom out.  

Zooming methods  
To zoom, you can use any of the following methods:  

• To define the portion of the drawing to zoom, create a window.  

• To zoom in real time, use the mouse.  
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• If you have a mouse with a wheel, use the wheel button to zoom in and out.  

To zoom in to an area using a window 
1. Do one of the following:  

• Choose View > Zoom > Window.  

• On the View toolbar, click the Zoom Window tool ( ). 

• Type zoom and then press Enter. 
2. Select one corner of the window around the area you want to magnify. 

3. Specify the opposite corner of the window around the area you want to magnify.  

 
To specify a rectangular window around the area you want to magnify, select first one 

corner(A), and then select the opposite corner (B). 

To zoom in real time 
1. Simultaneously press Ctrl+Shift and click and hold the left mouse button. 

2. To zoom in, move the cursor up the screen; to zoom out, move the cursor down the 
screen. 

3. To stop zooming, release the mouse button.  

To zoom using a mouse with a wheel 

• Rotate the wheel away from you to zoom in or toward you to zoom out.  

Each rotation of the wheel away from you zooms out .8 times; each rotation toward you 
zooms in 1.25 times.  

Displaying the previous view of a drawing  
After you zoom in or pan to view a portion of your drawing in greater detail, you may 
want to zoom back out to see the entire drawing. On the View menu, the Zoom 
Previous tool ( ) lets you restore the previous view. Selecting this tool repeatedly 
steps back through up to 25 successive zoomed or panned views. 

Zooming to a specific scale 
You can increase or decrease the magnification of your view by a precise scale factor 
measured relative to the overall size of the drawing or in relation to the current display. 
When you change the magnification factor, the portion of the drawing located at the 
center of the current viewport remains centered on the screen. 

To change the magnification of the view relative to the overall size of the drawing, type 
a number representing the magnification scale factor. For example, if you type a scale 
factor of 2, the drawing appears at twice its original size. If you type a magnification 
factor of .5, the drawing appears at half its original size.  
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You can also change the magnification of the drawing relative to its current 
magnification by adding an x after the magnification scale factor. For example, if you 
type a scale factor of 2x, the drawing changes to twice its current size. If you type a 
magnification factor of .5x, the drawing changes to half its current size.  

To zoom to a specific scale relative to the current display 
1. Do one of the following:  

• Choose View > Zoom > Zoom In.  

• On the View toolbar, click the Zoom In tool ( ).  

• Type zoom and then press Enter. 
2. Type the scale factor, followed by an x (such as 2x). 

3. Press Enter.  

Combining zooming and panning 
You can specify the point you want at the center of the view when you change the 
drawing magnification. You can specify the point you want at the lower left of the view 
when you change the magnification of the drawing with the Zoom Left tool ( ) on the 
View toolbar. With the exception of the Zoom Window tool, the other zoom tools zoom 
in or out from the center of the current view. 

To change the center of the current view 
1. Do one of the following:  

• Choose View > Zoom > Center.  

• On the Zoom toolbar, click the Zoom Center tool ( ). 

• Type zoom, press Enter, and then in the prompt box, choose Center. 
2. Select the point you want located at the center of the new view.  

3. Specify the zoom scale factor or the height of the drawing in drawing units. 

 
Current view showing the point to be centered in the new view (A), and the new view zoomed 

using a scale factor of 2x.  

Displaying the entire drawing  
You can use the Zoom All tool ( ) on the View toolbar to display an entire drawing. If 
you have drawn any entities outside the defined limits of the drawing, the extents of the 
drawing are displayed. If you drew all entities within the limits of the drawing, the 
drawing is displayed all the way to the drawing limits. 

The Zoom Extents tool ( ) on the View toolbar displays the drawing to its extents, 
making the image fill the display to the greatest possible magnification.  
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Zoom extents (displays all entities). - Zoom all (displays to drawing limits).  

2.7.4 Displaying multiple views  
When you begin a new drawing, it is displayed in a single window. You can view the 
drawing in a second window, or you can divide one window into multiple windows. You 
can also open and display multiple drawings.  

Working with multiple views of a single drawing  
You can open and work with several views of the same drawing simultaneously. There 
are two methods for dividing the current drawing into multiple views:  

• Open a new window of the open drawing.  

• Divide the current window into multiple views.  

After you divide a single window into multiple windows, you can control each window 
separately. For example, you can zoom or pan in one window without affecting the 
display in any of the other windows. You can control the grid, snap, and view 
orientation separately for each window. You can restore named views in individual 
windows, draw from one window to another, and name window configurations 
individually so you can reuse them later.  

As you draw, any changes you make in one window are immediately visible in the 
others. You can switch from one window to another at any time, even in the middle of a 
command, by clicking the window’s title bar.  

Opening a new window of the same drawing  
You can open additional windows to create more than one view of a drawing. To open 
a new window, choose Window > New Window. After you open a new window, you can 
change its display without affecting any of the other windows.  

When you open more than one window for a single drawing, each window is assigned 
a unique number (for example, mydrawing:1, mydrawing:2, and so on). If your current 
window is maximized, you can switch to another open window by selecting its name 
from the bottom of the Window menu.  

The names of other open drawings appear at the bottom of the Window menu. You can 
also use the Cascade, Tile Horizontally, and Tile Vertically commands to arrange all 
the open windows and drawings. To arrange all the windows and drawings into a stack 
of identically sized windows, choose Window > Cascade. Arranging windows and 
drawings in this way makes it easy to see the title bar for each window.   

To arrange all the windows and drawings horizontally so they are placed in order from 
top to bottom, choose Window > Tile Horizontally. Arranging windows and drawings in 
this way displays each open window. The windows are resized to fit within the available 
space. 
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To arrange all the windows and drawings vertically so they are placed side by side, 
choose Window > Tile Vertically. Arranging windows and drawings in this way displays 
each open window. The windows are resized to fit within the available space.  

ProgeCAD Architecture uses the commands in the following table to control its 
windows.  

ProgeCAD Architecture window-control commands  
Command  Result  

vports  Splits the current window into two, three, or four tiled windows.  

wcascade  Cascades (overlaps) all open windows.  

wclose  Closes the current window.  

wcloseall  Closes all windows; also closes all drawings.  

whtile  Tiles all windows horizontally.  

wiarrange  Arranges window icons.  

wopen  Opens another window of the current drawing.  
wvtile  Tiles all windows vertically.  

Dividing the current window into multiple views  
You can divide a single drawing window into multiple tiled windows (called view-ports) 
on the Model tab. You can control the number of windows created and the 
arrangement of the windows. You can also save and restore named window 
configurations and display a list of the current and saved window configurations.  

To create multiple views 
1. Do one of the following:  

• Choose View > Viewports.  

• On the View toolbar, click the Viewports tool ( ). 

• Type viewports and then press Enter. 
2. In the prompt box, choose Create 2 Viewports, Create 3 Viewports, or Create 4 

Viewports. 

3. In the prompt box, choose the viewport orientation.  

 
You can divide a drawing window into two windows arranged vertically (A) or horizontally (B); 
three windows arranged left (C), right (D), above (E), below (F), vertically (G), or horizontally 

(H); or four tiled windows (I).  
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To join two views 
1. Do one of the following:  

• Choose View > Viewports.  

• On the View toolbar, click the Viewports tool ( ). 

• • Type viewports and then press Enter. 
2. In the prompt box, choose Join. 

3. Click anywhere inside the window you want to keep. 

4. Click anywhere inside the adjacent window you want to join to the first window. 

5. Press Enter. 

Saving window configurations  
If you have divided the drawing window into multiple views, you can save the current 
window arrangement so that you can recall it to the screen later. The number and 
placement of the windows are saved exactly as they are currently displayed. The 
settings for each window are also saved.  

To name and save a window configuration 
1. Do one of the following:  

• Choose View > Viewports.  

• On the View toolbar, click the Viewports tool ( ). 

• Type viewports and then press Enter.  
2. In the prompt box, choose Save.  

3. Type a configuration name, and then press Enter.  

The name can be up to 31 characters in length and can contain letters, numbers, the 
dollar sign ($), hyphen (-), and underscore (_), or any combination.  

To restore a named window configuration 
1. Do one of the following:  

• Choose View > Viewports.  

• On the View toolbar, click the Viewports tool ( ). 

• Type viewports and then press Enter. 
2. In the prompt box, choose Restore. 

3. Type the name of the window configuration you want to restore. 

Working with multiple drawings  
With the multiple-document interface (MDI) feature, you can open more than one 
drawing inside of ProgeCAD Architecture. Because you can open and work on several 
drawings at one time, you can copy, cut, or paste an entity from one drawing to 
another. 

Each drawing appears in a drawing window, which has the following advantages: 

• You can see two or more drawings side by side.  

• You can easily copy entities from one drawing to another.  
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• Using the ProgeCAD Architecture Explorer, you can copy such elements as layers, 
linetypes, and text styles from one drawing to another.  

• Like viewports on the Model tab, you can tile or overlap drawing windows; unlike 
viewports on the Model tab, drawing windows maximize or reduce to an icon.  

 
One session of ProgeCAD with four drawings open.  

Each drawing window that you open and work on retains in the Prompt History log all 
the commands that you perform, but the command line does not indicate when you 
have switched windows.  

When you work with more than one drawing open in its own window, you can easily 
move, cut, copy, and paste in between drawings. If you move an entity from one 
window to another and then want to undo this action, you must undo it in both drawings 
for it to take effect. If you copy an entity from one window to another and then want to 
undo that action, you must undo it from the drawing into which you copied the entity. If 
you cut and paste an entity and then want to undo that action, you must undo it in both 
drawings. 
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2.8 Working with blocks, attributes, and 
external references  
Blocks, attributes, and external references provide mechanisms for managing entities 
in your drawings and for including additional information with the standard drawing 
entities. With blocks, you can combine numerous entities into a single entity, and then 
reuse it, inserting multiple copies. With attributes, you can associate text, such as part 
numbers or prices, with blocks, and then extract the text-attribute information to a 
separate file, such as a database, for further analysis. With external references, you 
can link separate reference drawing files to a drawing to combine information without 
adding the contents of the reference drawings to the current drawing. If you make 
changes to the referenced file, all references are updated automatically.  

This section explains how to:  

- Create, insert, and redefine blocks.  

- Create, edit, and insert attributes.  

- Extract attribute data to a separate file.  

- Attach and work with external references.  

2.8.1 Working with blocks 
Usually, blocks are several entities combined into one that you can insert into a 
drawing and manipulate as a single entity. A block can consist of visible entities such 
as lines, arcs, and circles, as well as visible or invisible data called attributes. Blocks 
are stored as part of the drawing file.  

Blocks can help you better organize your work, quickly create and revise drawings, and 
reduce drawing file size. Using blocks, you can create a library of frequently used 
symbols. Then you can insert a symbol as a block rather than redraw the symbol from 
scratch.  

After you create a block from multiple entities, you save it once, which also saves disk 
space. You insert only multiple references to a single block definition. You can change 
the block definition to quickly revise a drawing, and then update all instances of the 
block.  

If you insert a block that contains entities originally drawn on layer 0 and assigned color 
and linetype BYLAYER, it is placed on the current layer and assumes the color and 
linetype of that layer. If you insert a block that contains entities originally drawn on 
other layers or with explicitly specified colors or linetypes, the block retains the original 
settings. 

If you insert a block that contains entities originally assigned color and linetype 
BYBLOCK, and the block itself has the color and linetype BYLAYER, those entities 
adopt the color and linetype of the layer onto which they are inserted. If the block is 
assigned an explicit color or linetype, such as red or dashed, those entities adopt those 
qualities.  

A procedure called nesting occurs when you include other blocks in a new block that 
you are creating. Nesting is useful when you want to combine and include small 
components, such as nuts and bolts, into a larger assembly and you need to insert 
multiple instances of that assembly into an even larger drawing.  
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Creating blocks  
The tools and commands for creating blocks appear on the Tools toolbar and the Tools 
menu, respectively, when you set the program to the Advanced experience level. You 
can also use the ProgeCAD Architecture Explorer to create blocks. 

You can create blocks in two ways:  

• By saving a block for use within the current drawing only.  

• By saving the block as a separate drawing file that you can insert into other 
drawings.  

When you create a block, you specify its name, its insertion point, and the entities that 
compose the block. The insertion point is the base point for the block and serves as the 
reference point when you later insert the block into a drawing.  

To create a block for use within a current drawing  
1. Do one of the following:  

• Choose Tools > Create Block.  

• On the Tools toolbar, click the Create Block tool ( ).  

• Type block and then press Enter. 
2. Type a name for the block, and then press Enter. 

3. Specify the insertion point for the block. 

4. Select the entities that you want in the block, and then press Enter. The block is 
created and exists only in the current drawing. The entities you select are removed 
from the display, because they are now part of the block. 

5. To restore the original entities to the drawing while retaining the new block, type 
undelete or oops.  

NOTE: If you frequently restore original entities after you define a block, you can 
customize the program to add the Undelete command to a menu or toolbar.  

You can create a block as a separate drawing file that you can insert into other 
drawings.  

To save a block as a separate drawing file  
1. Do one of the following:  

• Choose Tools > Save Block To Disk.  

• On the Tools toolbar, click the Save Block To Disk tool ( ). 

• Type wblock and then press Enter. 
2. In the File Name field, type the name of the drawing file you want to create. 

3. Click Save. 

4. In the prompt box, choose one of the following:  

• Multiple Blocks This option saves one or more existing block entities to a 
separate drawing file. When prompted, type the name of the block(s).  

• All Entities This option immediately saves the entire drawing to a separate 
drawing file.  
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• Select Entities This option saves those entities you select to a separate drawing 
file. When prompted, specify the insertion point for the block, select the entities 
for the block, and then press Enter.  

NOTE: When saving multiple blocks or saving the entire drawing as a separate 
drawing file, the program assigns the 0,0,0 coordinate as the insertion base point. You 
can change the base point by opening the drawing and redefining the block.  

Inserting blocks  
You can insert blocks and other drawings into the current drawing. When you insert a 
block, it is treated as a single entity. When you insert a drawing, it is added to the 
current drawing as a block. You can then insert multiple instances of the block without 
reloading the original drawing file. If you change the original drawing file, those 
changes have no effect on the current drawing unless you redefine the block by 
reinserting the changed drawing. 

You can also insert blocks from another drawing into the current drawing, using the 
ProgeCAD Architecture Explorer. Both drawings must be open at the same time to do 
this. 

When you insert a block or drawing, you must specify the insertion point, scale, and 
rotation angle. The block’s insertion point is the reference point specified when you 
created the block. When you insert a drawing as a block, the program takes the 
specified insertion point as the block insertion point. You can change the insertion 
point, however, by first opening the original drawing and redefining the block. 

To insert a block 
1. Display the Insert Block dialog box by doing one of the following: 

• Choose Insert > Block.  

• On the Draw 2D toolbar, click the Block tool ( ). 

• • Type ddinsert and then press Enter. 
2. In the Insert Block dialog box, under Insert, click Block Name. 

3. In the Block Name box, select the name of the block you want to insert. 

4. Click Insert. 

5. Specify the insertion point for the block. 

6. Specify the x, y, and z scale factors and the rotation angle, or press Enter to accept 
the default values.  

To insert an entire drawing into the current drawing 
1. Do one of the following:  

• Choose Insert > Block.  

• On the Draw 2D toolbar, click the Block tool ( ). 

• Type ddinsert and then press Enter.  
2. In the Insert Block dialog box, under Insert, click From File.  

3. Type the path and the drawing file name, or click Browse to specify the file from the 
Insert Drawing dialog box, and click Open.  

4. Click Insert.  
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5. Specify the insertion point for the block.  

6. Specify the x, y, and z scale factors and the rotation angle, or press Enter to accept 
the default values.  

NOTE: You can specify the insertion point, scale factors, and rotation angle in the 
Insert Block dialog box before inserting the block. You can also control whether the 
block is exploded back into its original component entities after insertion. Under 
Positioning, clear the Position Block When Inserting check box, and specify the 
appropriate coordinates. If you want to explode the block immediately, select the 
Explode Upon Insertion check box.  

 

A. Click and then enter the path and drawing file name to insert the entire drawing file as a 
block. 

B. Click to position the block when inserting. 

C. Specify the insertion point, scale factors, and rotation angle before you insert the block 
(available only when Position Block When Inserting is cleared). 

D. Click to explode the block on insertion.  

E. Specify columns, column spacing, rows, and row spacing.  

F. Click to insert the block.  

G. Click to select the block insertion point in the drawing before inserting the block (available 
only when the Position Block When Inserting check box is cleared). 

Redefining blocks  
You can redefine all instances of a block within the current drawing. To redefine a 
block that was created in the current drawing, you create a new block using the same 
name. You can update all the blocks in the current drawing by redefining the block. If 
the block was inserted from a separate drawing file that was subsequently updated, 
reinsert that block to update all other instances in the current drawing.  

To redefine a block in the current drawing  
1. Do one of the following:  

• Choose Tools > Create Block.  

• On the Tools toolbar, click the Create Block tool ( ).  
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• Type block and then press Enter. 
2. Type the name of the block you want to redefine, and then press Enter. 

3. In the prompt box, choose Yes-Redefine Block. 

4. Specify the insertion point for the block. 

5. Select the entities for the block, and then press Enter. The block is immediately 
redefined, and all instances of the block in the drawing are updated. The entities 
you select for inclusion in the block are removed from the drawing, because they 
are now part of the block.  

TIP: To restore the original entities to the drawing while retaining the new block, type 
undelete or oops.  

You can update all instances of a block inserted from a separate drawing by reinserting 
the drawing.  

Exploding blocks  
You can explode an inserted block to its original component entities. When you 
explode a block, only that single instance of the block is affected. The original block 
definition remains in the drawing, and you can still insert additional copies of the 
original block. If you explode a block that contains attributes, the attributes are lost, but 
the original attribute definitions remain.  

Exploding dissociates component entities to their next simplest level of complexity; 
blocks or polylines in a block become blocks or polylines again  

To explode a block 
1. Do one of the following:  

• Choose Modify > Explode.  

• On the Modify toolbar, click the Explode tool ( ). 

• Type explode and then press Enter. 
2. Select the block. 

3. Press Enter.  

2.8.2 Working with attributes  
An attribute is a particular entity that you can save as part of a block definition. 
Attributes consist of text-based data. You can use attributes to track such things as 
part numbers and prices. Attributes have either fixed or variable values. When you 
insert a block containing attributes, the program adds the fixed values to the drawing 
along with the block, and you are prompted to supply any variable values.  

After you insert blocks containing attributes, you can extract the attribute information to 
a separate file and then use that information in a spreadsheet or database to produce a 
parts list or bill of materials. You can also use attribute information to track the number 
of times a particular block is inserted into a drawing.  

Attributes can be visible or hidden. Hidden attributes are neither displayed nor plotted, 
but the information is still stored in the drawing and written to a file when you extract it.  
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Defining attributes  
You add an attribute to a drawing by first defining it and then saving it as part of a block 
definition. To define an attribute, you specify the characteristics of the attribute, 
including its name, prompt, and default value; the location and text formatting; and 
optional modes (hidden, fixed, validate, and predefined). 

To define an attribute  
1. Do one of the following:  

• Choose Tools > Define Attributes.  

• On the Tools toolbar, click the Define Attributes tool ( ). 

• Type ddattdef and then press Enter. 
2. In the Define Attribute dialog box, type the name, prompt, and default value. 

3. Under Insert Coordinates, specify the location of the attribute, or click Select to 
select a point in the drawing. 

4. Under Attribute Flags, select the optional attribute modes. 

5. Under Text, specify the text characteristics. 

6. To add the attribute to the drawing, do one of the following:  

• Click Define to add the attribute and keep the dialog box active so you can 
define another attribute.  

• Click Define And Exit to add the attribute and end the command.  

 
A. Type the name you want to assign to the attribute.  

B. Enter the identifying prompt information displayed when you insert a block containing the 
attribute.  

C. Enter the default or constant value. For variable attributes, the default value is replaced by 
the actual value when you later insert a block containing the attribute.  

D. Specify the x-, y-, and z-coordinates for the attribute insertion point.  

E. Select to create a hidden attribute.  

F. Select to create a fixed-value attribute. 
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G. Select to create an attribute whose value must be validated when you later insert a block 
containing the attribute.  

H. Select to create an attribute whose value is defined and not requested when you later insert 
a block containing the attribute, but that you can edit after the block is inserted.  

I. Click to add the attribute and keep the dialog box active so you can define another attribute.  

J. Click to add the attribute and end the command.  

K. Specify the text rotation angle, or click to specify the rotation angle by selecting two points in 
the drawing.  

L. Specify the text height, or click to specify the height by selecting two points in the drawing.  

M. Choose the text justification.  

N. Choose the text style from those styles already defined in the drawing.  

O. Click to specify the attribute insertion point by selecting a point in the drawing.  

Editing attribute definitions 
You can edit an attribute definition before you associate it with a block and before it is 
saved as part of a block definition.  

To edit an attribute definition  
1. Do one of the following:  

• Choose Modify > Edit Text.  

• On the Modify toolbar, click the Edit Text tool ( ). 

• Type ddedit and then press Enter. 
2. Select the attribute definition text to edit. 

3. Modify the attribute name, prompt string, default value, and other attribute definition 
characteristics. 

4. Click OK.  

 
A. Modify the name assigned to the attribute. 

B. Modify the prompt that displays when you insert the attribute into the drawing. 
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C. Modify the identifying prompt information displayed when you insert a block containing the 
attribute.  

D. Modify the attribute insertion point.  

E. Modify the attribute text style and appearance.  

F. Modify the attribute insertion flags to create hidden, fixed-value, validated, or defined 
attributes.  

Attaching attributes to blocks  
You can attach attributes to a block after you define it and select it as one of the 
entities to include. Include the attributes when the program prompts you for the entities 
to include in the selection set for a block. After the attribute is incorporated into a block, 
the program prompts you each time you insert the block, so you can specify different 
values for the attributes each time you insert it into a new drawing.  

Editing attributes attached to blocks  
You can edit the attribute values of a block that has been inserted into a drawing.  

To edit an attribute attached to a block  
1. Do one of the following:  

• Choose Tools > Edit Block Attributes.  

• On the Tools toolbar, click the Edit Block Attributes tool ( ). 

• Type ddatte and then press Enter. 
2. Select the block to edit. The Edit Block Attributes dialog box displays all the 

attributes attached to the block you select. 

3. Edit the attribute values as necessary. 

4. Click OK.  

 
A. Identifies the name of the block. 

B. Displays the names of all attributes attached to the block. 
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C. Click to select attribute. 

D. Type the new value for the selected attribute. 

E. Click to update the attribute values and exit. 

F. Displays the value of each attribute attached to the block. 

G. Displays the prompt for each attribute attached to the block.  

Extracting attribute information 
You can extract attribute information from a drawing and save it to a separate text file 
for use with a database program. You can save the file in any of the following formats: 

• Comma Delimited Format (CDF) Contains one line for each instance of a block, 
with individual attribute fields separated by commas. Character string fields are 
enclosed with single quotation marks. You must specify a template file when 
extracting to a CDF file. 

• Space Delimited Format (SDF) Contains one line for each instance of a block. 
Each attribute field has a fixed length; there are no separators or character string 
delimiters. You must specify a template file when extracting to a SDF file. 

• Drawing Exchange Format (DXF) Creates a subset of a standard DXF file (a *.dxx 
file) containing all the information about each block, including the insertion points, 
rotation angles, and attribute values. No template file is required. 

Before extracting attributes to a CDF or SDF file, you must create a template file. The 
template file is an ASCII text file that specifies the attribute data fields to be written in 
the extract file. Each line of the template file specifies one attribute field. ProgeCAD 
Architecture recognizes 15 different fields, which contain elements such as the block 
name, the x-, y-, and z-coordinates of its insertion point, the layer on which it is 
inserted, and so on. You can include any of these fields. The template file must include 
at least one attribute name.  

Each line in the template file must start with the field name. Block name and insertion-
point values must begin with BL:. The next nonblank character must be either a C 
(indicating a character string field) or an N (indicating a numeric field). This character is 
then followed by three digits indicating the width of the field (in characters). The final 
three digits indicate the number of decimal places (for numeric fields). In the case of 
character fields, the last three digits must be zeros (000). A typical template file is 
similar to the one shown here:  

 
A. Field name.  

B. Block name. Block names must begin with BL:. 
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C. Insertion point. Insertion-point values must begin with BL:.  

D. Attribute tags.  

E. Number of decimal places for numeric fields or 000 for character fields.  

F. Field width for character or numeric fields.  

G. C for character fields; N for numeric fields.  

To create a template file 
1. Create a template file using any ASCII text editor (such as Microsoft® Notepad or 

Microsoft® WordPad) or a word-processing program such as Microsoft® Word.  

2. Include the necessary fields in the template file. 

3. Save the template file in ASCII text format.  

To extract attribute information 
1. Do one of the following: 

• Choose Tools > Extract Attributes.  

• On the Tools toolbar, click the Extract Attributes tool ( ).  

• Type ddattext and then press Enter. 
2. Click Select, specify the entities from which to extract attributes, and then press 

Enter. 

3. Specify the format of the extracted file. 

4. For CDF and SDF formats, specify the template file. 

5. Specify the extract output file. 

6. Click Extract.  

 
A. Click to select blocks in the drawing containing attributes you want to extract.  

B. Click to specify the format of the extracted file.  

C. Specify the template file for CDF and SDF extracts.  

D. Specify the extract output file.  

E. Click to extract attributes.  
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F. Click to specify the output file using a file dialog box.  

G. Click to specify the template file using a file dialog box.  

H. Indicates the number of blocks with attributes selected for extraction.  

2.8.3 Working with external references 
You can link entire drawings to the current drawing as external references. Unlike 
inserting a drawing as a block, in which you add all the entities from the separate 
drawing into the current drawing, external references attach a pointer to the external 
file. The entities in the external reference appear in the current drawing, but the entities 
themselves are not added to the drawing. Thus, attaching an external reference does 
not significantly increase the size of the current drawing file. 

External references provide additional capabilities not available when you insert a 
drawing as a block. When you insert a drawing as a block, the entities are stored in the 
drawing. Any changes you make to the original drawing are not reflected in the drawing 
in which you inserted it. When you attach an external reference, however, any changes 
you make to the original drawing file are reflected in the drawings that reference it. 
These changes appear automatically each time you open the drawing containing the 
external reference. If you know that the original drawing was modified, you can reload 
the external reference anytime you’re working on the drawing.  

External references are useful for assembling master drawings from component 
drawings. Use external references to coordinate your work with others in a group. 
External references help reduce drawing file size and ensure that you are always 
working with the most recent version of a drawing.  

Attaching external references 
Attaching a separate drawing to the current one creates an external reference. The 
external reference appears in the drawing as a block definition, but the drawing entities 
are linked rather than added to the current drawing. If you modify the linked drawing, 
you can reload the external reference so that the current drawing reflects the latest 
version of the external reference. 

When you attach an external reference, its layers, linetypes, text styles, and other 
elements are not added to the current drawing. Rather, these elements are also loaded 
from the referenced file each time you reload the external reference. External 
references can themselves contain other, nested reference files. When you attach an 
external reference, any nested references contained in the file also appear in the 
current drawing. If you do not want nested references, you can attach the external 
reference as an overlay.  

You can attach as many copies of an external reference file as you want. Each copy 
can have a different position, scale, and rotation angle.  

To attach an external reference  
1. Do one of the following:  

• Choose Tools  > External Reference.  

• • On the Tools toolbar, click the External Reference tool ( ).  

• Type xref and then press Enter. 
2. In the prompt box, choose Attach. 

3. Specify the drawing file to attach as an external reference, and then click Open. 
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4. Specify the insertion point for the external reference. 

5. Specify the x, y, and z scale factors and the rotation angle, or choose Done to 
accept the default values.  

Detaching external references 
To remove an external reference from your drawing, you must detach the reference 
file. Deleting the external reference does not remove elements such as layers and 
linetypes added to the current drawing.  

To detach an external reference  
1. Do one of the following:  

• Choose Tools > External Reference.  

• On the Tools toolbar, click the External Reference tool ( ).  

• Type xref and then press Enter. 
2. In the prompt box, choose Detach. 

3. Type the name of the external reference you want to detach from the drawing, and 
then press Enter.  

Reloading external references  
If you modify a drawing that is attached to the current drawing as an external reference, 
you can update the current drawing to display the latest version of the external 
reference drawing.  

To reload an external reference  
1. Do one of the following:  

• Choose Tools > External Reference.  

• On the Tools toolbar, click the External Reference tool (  ).  

• Type xref and then press Enter. 
2. In the prompt box, choose Reload. 

3. Type the name of the external reference you want to reload, and then press Enter.  

NOTE: The program automatically reloads all external references each time you open 
a drawing containing external references and each time you print or plot a drawing 
containing external references. 

Overlaying external references  
An overlay is an inserted drawing that contains a link to the original file. Overlays 
allows you to lay a drawing on top of another drawing, similar to the way you work 
manually with transparencies. 

When a drawing that contains overlaid external references is itself attached or overlaid 
as an external reference in another drawing, the overlays do not appear as part of the 
external reference. Use overlaying when you want to see reference geometry in a 
drawing but you do not need to include that geometry in drawings that will be 
referenced by others. 
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To overlay an external reference 
1. Do one of the following:  

• Choose Tools > External Reference.  

• On the Tools toolbar, click the External Reference tool ( ).  

• Type xref and then press Enter.  
2. In the prompt box, choose Overlay.  

3. In the Select File To Overlay dialog box, specify the drawing file to be overlaid as 
an external reference, and then click Open.  

4. Specify the insertion point for the external reference.  

5. Specify the x, y, and z scale factors and the rotation angle, or choose Done to 
accept the default values.  

Changing the path for external references  
If the file associated with an external reference is moved to a different directory or 
renamed, the program displays a message indicating that it cannot load the external 
reference. You can reestablish the link to the file by changing the path for the external 
reference. 

To change the external reference path  
1. Do one of the following:  

• Choose Tools > External Reference.  

• On the Tools toolbar, click the External Reference tool ( ).  

• Type xref and then press Enter. 
2. In the prompt box, choose Path. 

3. Type the name of the external reference whose path you want to change. 

4. Type the new path, and then press Enter.  

Inserting and binding external references to drawings  
External references are not part of the drawing. Rather, they are links to an externally 
referenced file. To provide a copy of a drawing containing external references to 
someone else, you must also provide all the external reference files. In addition, the 
person receiving the drawings must either re-create the same paths you used when 
linking the external references or change the paths for the external references.  

The Insert command in the External Reference feature lets you insert an externally 
referenced drawing as a block. To provide a copy of a drawing that contains an 
external reference, it is best to insert the external reference as a block.  

To insert an external reference as a block 
1. Do one of the following:  

• Choose Tools > External Reference.  

• On the Tools toolbar, click the External Reference tool ( ).  

• Type xref and then press Enter. 
2. In the prompt box, choose Insert.  
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3. Type the name of the external reference you want to insert into the drawing, and 
then press Enter.  

To provide a copy of a drawing that contains external references, it is often easier to 
first bind the external references to the drawing. Binding the external references makes 
them a permanent part of the drawing, which is the same as inserting a separate 
drawing as a block.  

To bind an external reference to a drawing  
1. Do one of the following:  

• Choose Tools > External Reference.  

• On the Tools toolbar, click the External Reference tool (  ).  

• Type xref and then press Enter. 
2. In the prompt box, choose Bind. 

3. Type the name of the external reference you want to bind to the drawing, and then 
press Enter.  

Clipping external references using boundaries  
After attaching a drawing as an external reference, you can define a clipping boundary 
using the XCLIP command. Defining a clipping boundary enables you to display only a 
portion of an external reference and to suppress the display of geometry outside the 
boundary. Clipping applies to an individual instance of an external reference, not the 
external reference definition itself. The portion of the external reference within the 
clipped boundary remains visible, and the remainder of the external reference becomes 
invisible. The referenced geometry is not altered, only the display of the external 
reference is edited.  

You can use the xclip command to do the following:  

• Create a new clipping boundary  

• Delete an existing boundary  

• Generate a polyline object coincident with vertices of the clipping boundary  

You can turn xref clipping on or off. When a clipping boundary is turned off, the 
boundary does not display and the entire external reference is visible, provided that the 
geometry is on a layer that is on and thawed. When a clipping boundary is turned off, it 
still exists and can be turned on. However, deleting a clipping boundary is permanent.  

After an external reference has been clipped, it can be edited, moved, or copied just as 
an unclipped external reference. The boundary moves with the reference. If an external 
reference contains nested clipped external references, they appear clipped in the 
drawing. If the parent external reference is clipped, the nested external reference is 
also clipped.  

TIP: You can also partially hide blocks using the xclip command.  

Clipping boundaries are moved, rotated and scaled along with the object. 
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Example of an external reference clipped by a clipping boundary. The clipping boundary is the 

rectangle in the top view.  

To define a rectangular clipping boundary 
1. Type xclip and then press Enter. 

2. Select the xrefs and/or blocks you want to be affected by the clipping boundary. All 
of the selected xrefs and blocks become highlighted.  

3. Press Enter to complete the selection. 

4. Press Enter to create a new boundary (the default option). 

5. If prompted, press Enter to delete the existing boundary. 

6. Choose Rectangular. 

7. Define the first corner of the clipping rectangle. 

8. Define the second corner of the clipping rectangle. The selected external 
reference(s) and/or block(s) are clipped by the rectangle.  

TIP: You can first select all blocks and/or external references, then right-click and 
select Xref Clip from the shortcut menu.  

To define a clipping boundary using a polyline 
1. Type xclip and then press Enter. 

2. Select the xrefs and/or blocks you want to be affected by the clipping boundary. All 
of the selected xrefs and blocks become highlighted. 

3. Press Enter to complete the selection. 

4. Press Enter to create a new boundary (the default option). 

5. If prompted, press Enter to delete the existing boundary.  

6. Choose Select Polyline. 

7. Select the polyline to use as clipping boundary.  
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Xclip options  
Option Effect 

On Activates all clipping boundaries in the drawing. 

Off Switches off all clipping boundaries. 

ClipDepth (3D only) Defines the clipping depth. 

Delete Deletes the clipping boundary for the selected objects. 

Generate Polyline Creates a polyline from the current clipping boundaries. 

New Boundary Defines a new boundary. If a boundary already exists 
for the selected objects you are prompted to delete the 
current boundary. 

If you want to see the clipping boundaries, you can turn on the xclipframe system 
variable. The xclipframe system variable determines whether the clipping boundary 
frame displays. When the clipping frame is on (set to 1), it can be selected as part of 
the object and plotted.  

To control the display of the clipping boundaries 
1. Type xclipframe and then press Enter. 
2. Choose On or Off from the context menu to toggle the display of the clipping 

boundaries. 

2.8.4 Using raster images in a drawing  
You can modify and view raster images directly inside of ProgeCAD Architecture. You 
can load, edit, and modify multiple images as overlays or underlays to your ProgeCAD 
Architecture drawings. The raster images can be selected through ProgeCAD 
Architecture commands or from the edge of the raster image frame for Image Enabler 
commands.  

Attaching raster images  
You can attach raster images to a drawing.  

To attach a raster image 
1. Do one of the following:  

• Choose Image Enabler > Image Management.  

• On the Image Enabler toolbar, click the tool (  ). 

• On the Image Enabler toolbar, click the tool ( ). 

• Type image and then press Enter. 
2. Specify a file to attach, and then click OK. 

3. In the Position dialog box, specify the position, origin, scale, insertion units, and 
rotation, and then click OK. 

4. Specify an insertion point. 
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5. Specify a scale.  

Modifying raster images  
You can modify a raster image by changing its brightness, contrast, fade, transparency, 
or quality. You can also determine whether the image frame displays and prints.  

To change the transparency of an image 
1. Do one of the following:  

• Choose Image Enabler > Image Transparency.  

• On the Image Enabler toolbar, click the Image Transparency tool ( ). 

• Type transparency and then press Enter. 
2. Select an image. 

3. Do one of the following:  

• Select ON to make the image’s background transparent.  

• Select ON to make the image’s background opaque.  

To change the quality of all images in a drawing 
1. Do one of the following:  

• Choose Image Enabler > Image Quality.  

• On the Image Enabler toolbar, click the Image Quality tool ( ). 

• Type imagequality and then press Enter. 
2. Do one of the following:  

• Select High to use high quality images.  

• Select Draft to use draft quality images, which require smaller amounts of 
system resources.  

To turn an image frame on or off 
1. Do one of the following:  

• Choose Image Enabler > Display Image Frame.  

• On the Image Enabler toolbar, click the Display Image Frame tool ( ).  

• Type imageframe and then press Enter. 
2. Do one of the following to toggle frames off and on:  

• Select ON to display and print frames for all images in a drawing.  

• Select OFF to hide all frames on the screen and during printing.  

Unloading and reloading raster images 
If you find that including a raster image affects system performance, you can unload it 
so only an outer frame displays to mark its location. If you want an unloaded raster 
image to print, reload it before printing. You may also want to reload an image if the 
original file contains new content.  

To unload and reload a raster image 
1. Do one of the following:  
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• Choose Image Enabler > Image Management.  

• On the Image Enabler toolbar, click the Image Management tool ( ).  

• Type image and then press Enter. 
2. Select the file you want to unload or reload. 

3. Do one of the following:  

• To unload the image so only its outer frame displays, click Unload.  

• To reload the image so its contents display and print, click Reload.  

Changing the path for raster images  
If the file associated with a raster image is moved to a different directory or renamed, 
the program displays a message indicating that it cannot load the image. You can 
reestablish the link to the file by changing the path for the image.  

To change the path for a raster image 
1. Do one of the following:  

• Choose Image Enabler > Image Management.  

• On the Image Enabler toolbar, click the Image Management tool ( ). 

• Type image and then press Enter. 
2. Select the file whose path you want to change. 

3. Press button Browse and find its new location. 

4. Select Save Path to store new path. 

Detaching raster images  
Once an image is no longer required in the drawing, you can detach it from the 
drawing. Detaching an image removes it from the drawing, and from the Image 
Management dialog box.  

If you want to remove the image from your drawing, but you want it to remain 
accessible without having to find it again, use the Delete command, just as you would 
delete other entities. The file is deleted from the drawing, but is kept in the Image 
Management dialog box.  

To detach a raster image 
1. Do one of the following:  

• Choose Image Enabler > Image Management.  

• On the Image Enabler toolbar, click the Image Management tool ( ). 

• Type image and then press Enter. 
2. Select the file you want to remove, and then click Detach.  
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2.9 Drawing in three dimensions 
Paper drawings typically represent two-dimensional views of three-dimensional objects. 
With ProgeCAD Architecture, you can create three-dimensional models of three-
dimensional objects.  

This section explains how to:  

• View entities in three dimensions.  

• Create three-dimensional entities.  

• Edit entities in three-dimensional space.  

• Edit three-dimensional solids.  

• Display hidden-line and shaded views of three-dimensional entities.  

The tools and commands for many of the functions described in this section appear on 
the Draw 3D toolbar and the Insert menu, respectively, when you set the program to 
the Advanced experience level.  

2.9.1 Viewing entities in three dimensions 
You can view an ProgeCAD Architecture drawing from any position in three-
dimensional space. From any selected viewing position, you can add new entities and 
modify existing entities. You can also generate hidden-line and shaded views from any 
viewing position. 

Setting the viewing direction  
You view three-dimensional drawings by setting the viewing direction. The viewing 
direction establishes the viewing position, the Cartesian coordinate corresponding to 
the viewpoint looking back at the origin point, the 0,0,0 coordinate. When you view a 
drawing from the default viewpoint (0,0,1), you see a plan view of the drawing. 

On the View toolbar, you can view a three-dimensional drawing using any of the 
following methods:  

• Preset Viewpoints ( ). 

• Dynamic View Control ( ). 

• Plan View ( ). 

You can change the viewing direction to look at the drawing from a different vantage 
point or to work on a three-dimensional model from a different orientation.  

To set a new viewing direction  
1. Do one of the following:  

• Choose View > Preset Viewpoints. 

• On the View toolbar, click the Preset Viewpoints tool ( ). 

• Type setvpoint and then press Enter. 
2. Click the preset view you want to use.  
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A. Click to select a non-axis viewpoint. 

B. Click to select the previous viewpoint. 

C. Click to select a viewpoint aligned with an axis. 

You can dynamically rotate the viewpoint within the xy plane and relative to the xy 
plane, and you can pan and zoom the drawing. As you change the viewpoint settings, 
the drawing display automatically updates.  

To dynamically set a view direction 
1. Do one of the following:  

• Choose View > Dynamic View Control. 

• On the View toolbar, click the Dynamic View Control tool (  

• Type viewctl and then press Enter. 
2. Click the appropriate tools to dynamically change the viewpoint. 

3. To complete the command, click OK.  
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A Indicates the current viewpoint. 

B Click to pan the drawing. 

C Click to display the Preset Viewpoints dialog box. 

D Click to update the drawing display whenever you click a tool. 

E Click to zoom extents. 

F Click to zoom out. 

G Click to zoom in. 

H Shows the current viewpoint orientation. 

I Type or select the rotation angle increment. 

J Click to rotate the view about a predefined axis. 

You can set the current viewing direction to the plan view of the current user coordinate 
system (UCS), a previously saved UCS, or the World Coordinate System (WCS).  

To display a plan view of the current drawing 
1. Do one of the following:  

• Choose View > Plan View.  

• On the View toolbar, click the Plan View tool ( ). 

• Type plan and then press Enter. 
2. In the prompt box, choose one of the following:  

• Current displays the plan view of the current UCS.  

• UCS displays the plan view of a saved UCS. The program prompts you for the 
name of the UCS.  

• World displays the plan view of the WCS.  



 
 

150  4M 

2.9.2 Creating three-dimensional entities 
ProgeCAD Architecture supports the following types of three-dimensional models: 

• Wire-frame models, which consist of lines and curves that define the edges of a 
three-dimensional entity. You can create a wire-frame model by drawing lines, arcs, 
polylines, and other two-dimensional entities anywhere in three-dimensional space. 
Wire-frame models have no surfaces; they always appear as outlines. Because you 
must individually draw and position each entity that makes up a wire-frame model, 
creating one can be exacting and time-consuming.  

• Surface models, which consist of both edges and the surfaces between those 
edges. You can create a surface model by applying elevation and thickness to two-
dimensional planar entities or by using specific three-dimensional entity-creation 
commands. Surface models consist of individual planes forming a faceted, 
polygonal mesh.  

Applying elevation and thickness  
By default, the program creates new two-dimensional entities with a zero elevation and 
thickness. The easiest way to create a three-dimensional entity is to change the 
elevation or thickness property of an existing two-dimensional entity. 

The elevation of an entity is its z-coordinate position in relation to the xy plane in which 
the entity is drawn. An elevation of 0 indicates that the entity is drawn on the xy plane 
of the current UCS. Positive elevations are above this plane; negative elevations are 
below it. 

The thickness of an entity is the distance it is extruded above or below its elevation. A 
positive thickness extrudes the entity upward in the positive z direction of the entity; a 
negative thickness extrudes it downward in the negative z direction. The thickness is 
applied uniformly to the entire entity. You can extrude any two-dimensional entity into a 
three-dimensional entity by changing the thickness of the entity to a nonzero value. For 
example, a circle becomes a cylinder, a line becomes a three-dimensional plane, and a 
rectangle becomes a box. 

 
You can create three-dimensional entities using any of the following methods:  

• Draw two-dimensional entities in three-dimensional space.  

• Convert two-dimensional planar entities into three-dimensional entities by 
applying elevation and thickness.  

• Convert two-dimensional planar entities into three-dimensional entities by 
revolving or extruding.  

• Create three-dimensional entities such as boxes, cylinders, cones, domes, 
spheres, and wedges.  

You can change the default elevation and thickness values to create new entities 
withan elevation and thickness already applied. 
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NOTE Three-dimensional solids are drawn as true solids with versions of ProgeCAD 
Architecture that support three-dimensional ACIS solids. Three-dimensional solids that 
you can create include: box, cone, cylinder, dish, dome, pyramid, sphere, torus, and 
wedge.  

To set the current elevation 
1. Display the current elevation setting by doing one of the following: 

• Choose Settings > Elevation. 

• On the Settings toolbar, click the Elevation tool ( ). 

• Type elev and then press Enter. 
2. Specify the New Current Value For Elevation, and then press Enter.  

To set the current thickness 
1. Display the current thickness setting by doing one of the following: 

• Choose Settings > Thickness.  

• On the Settings toolbar, click the Thickness tool ( ). 

• Type thickness and then press Enter. 
2. Specify the New Current Value For Thickness, and then press Enter. 

To set the current elevation and thickness using a dialog box 
1. Display the Drawing Settings dialog box by doing one of the following: 

• Choose Settings > Drawing Settings. 

• On the Settings toolbar, click the Drawing Settings tool ( ). 

• Type settings and then press Enter. 
2. Click the 3D Settings tab. 

3. In the Change Settings For list, click Surfaces. 

4. To change the current thickness, in the Current 3D Thickness box, type a new 
thickness value or click the arrows to select a new thickness. 

5. To change the current elevation, in the Current 3D Elevation box, type a new 
elevation value or click the arrows to select a new elevation. 

6. Click OK. 



 
 

152  4M 

 
A Type or select the current three-dimensional 

B Type or select the current three-dimensional thickness. elevation.  

To change the thickness and elevation of an existing entity 
1. Do one of the following:  

• Choose Modify > Properties. 

• On the Modify toolbar, click the Properties tool ( ). 

• Type ai_propchk and then press Enter.  
2. Select the entity, and then press Enter. ProgeCAD Architecture displays the Entity 

Properties dialog box. The exact appearance of the dialog box depends on the type 
of entity you select. 

3. To change the thickness, in the Thickness box, type a new thickness value or click 
the arrows to select the new thickness. 

4. To change the elevation, in the Z coordinate box, type a new elevation value or 
click the arrows to select the new elevation. 

5. Click OK.  

NOTE When you change the thickness of an entity, you do not change the entity type. 
If you want to extrude an entity and convert it to a three-dimensional solid, use the 
Extrude command.  
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Α. Type or select the new thickness. 

Β. Type or select the new elevation. 

2.9.3 Creating three-dimensional faces  
You can create a three-dimensional face, which consists of a section of a plane in 
three-dimensional space. You define a three-dimensional face by specifying the x,y,z 
coordinates of three or more corners. After you specify the fourth point, the program 
continues to prompt you for additional faces by alternating prompts for the third point 
and fourth point to allow you to build a complex three-dimensional entity. Each three- or 
four-sided plane is created as a separate three-dimensional face entity. 

To create a three-dimensional face  
1. Do one of the following:  

• Choose Insert > 3D Entities > Face.  

• On the Draw 3D toolbar, click the Face tool ( ).  

• Type face and then press Enter. 
2. Specify the first point of the three-dimensional face. 

3. Specify the second, third, and fourth points. 

4. Specify the third and fourth points for additional faces. 

5. To complete the command, press Enter.  

TIP Any or all edges of a three-dimensional face can be invisible to allow you to more 
accurately model entities with holes in them. As the program prompts you for the cor-
ner points, in the prompt box, choose Invisible Edge to make the next edge invisible. 
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An example of a three-dimensional model created using three-dimensional faces.  

Creating rectangular meshes 
You can create a three-dimensional rectangular mesh consisting of four-sided 
polygons. You determine the size of the mesh by specifying the number of vertices 
along the primary (M-direction) and secondary (N-direction) mesh axes and then 
specifying the coordinates for each vertex. 

To create a rectangular mesh 
1. Do one of the following: 

• Choose Insert > 3D Entities > Mesh. 

• On the Draw 3D toolbar, click the Mesh tool ( ). 

• Type mesh and then press Enter. 
 

2. Specify the number of vertices along the primary mesh axis. 

3. Specify the number of vertices along the secondary mesh axis. 

4. Specify the coordinates for each vertex. Specifying the coordinates for the last 
vertex completes the mesh and ends the command. 

 
An example of a three-dimensional terrain model created using rectangular meshes. 

TIP Although creating rectangular meshes manually can be exacting, they are useful 
for representing complex surfaces such as three-dimensional terrain models. The Mesh 
tool is most useful when combined with scripts or LISP programs that mathematically 
calculate the coordinates of the vertices. 

Creating polyface meshes  
You can create a polygon mesh consisting of faces connecting three or more vertices. 
You first determine the coordinates of each vertex and then define each face by 
entering the vertex numbers for all the vertices of that face. As you create each face, 
you can control the visibility and color of each edge and assign each edge to specific 
layers. 
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To create a polyface mesh 
1. Do one of the following:  

• Choose Insert > 3D Entities > Polyface Mesh. 

• On the Draw 3D toolbar, click the Polyface Mesh tool ( ). 

• Type pface and then press Enter. 

2. Specify the coordinates of each vertex. After each vertex that you specify, the next 
vertex number is displayed, and you are prompted for the coordinates of the vertex. 
Specify the coordinates, and then press Enter. Continue to specify the coordinates 
for each numbered vertex. 

3. To finish specifying vertex coordinates, press Enter. 

4. Specify the vertex numbers that define the first face. You specify the face by 
entering the vertex numbers that were defined when you specified coordinates in 
step 2. Each face can be composed of three or more numbered vertices. 

5. To finish defining the first face, press Enter. 

6. Specify the next face by entering its vertex numbers. 

7. To complete the command, press Enter. 

TIP To make an edge invisible, type the vertex number as a negative value. 

Creating ruled surface meshes  
You can create a ruled surface, which is a three-dimensional polygon mesh that 
approximates the surface between two existing entities. You select the two entities that 
define the ruled surface. These entities can be arcs, circles, lines, points, or polylines.  

To create a ruled surface mesh  
1. Do one of the following:  

• Choose Insert > 3D Entities > Ruled Surface. 

• On the Draw 3D toolbar, click the Ruled Surface tool ( ). 

• Type rulesurf and then press Enter. 
2. Select the first defining entity. 

3. Select the second defining entity.  

 
Select the first (A) and second (B) defining entities. The resulting ruled surface mesh.  

TIP To control the density of the mesh, change the values for the Number of M-
Direction Surfaces. Choose Settings > Drawing Settings, and then click the 3D Settings 
tab. Under Change Settings For, select Surfaces. Under Surface Settings, change the 
Number Of M-Direction Surfaces value. Or, on the Settings toolbar, use the Drawing 
Settings tool ( ) to display that dialog box.  
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Creating extruded surface meshes 
You can create an extruded surface, which is a three-dimensional polygon mesh that 
approximates the surface generated by extruding a path curve along a direction vector. 
You select the two entities that define the path curve and direction vector. The length of 
the direction vector determines the distance the path curve is moved along the 
direction vector. The extruded entity can be an arc, circle, line, or polyline. You can 
choose a line or open polyline as the direction vector. The resulting mesh consists of a 
series of parallel polygonal planes running along the specified path.  

To create an extruded surface mesh 
1. Do one of the following:  

• Choose Insert > 3D Entities > Extruded Surface. 

• On the Draw 3D toolbar, click the Extruded Surface tool ( ). 

• Type tabsurf and then press Enter. 
2. Select the entity to extrude. 

3. Select the extrusion path. 

 
Select the entity to extrude (A) and the surface mesh. The resulting extruded extrusion path (B).  

TIP To control the density of the mesh, change the values for the Number of M-
Direction Surfaces. Choose Settings > Drawing Settings, and then click the 3D Settings 
tab. Under Change Settings For, select Surfaces. Under Surface Settings, change the 
Number Of M-Direction Surfaces. Or, on the Settings toolbar, use the Drawing Settings 
tool ( ) to display that dialog box.  

 

NOTE An extruded mesh is different from an extruded solid. If you want to extrude an 
entity and convert it to a three-dimensional solid, use the Extrude command. 

Creating revolved surface meshes 
You can create a surface of revolution, which is a three-dimensional polygon mesh that 
approximates the surface generated by rotating a two-dimensional profile around an 
axis. You select the two entities that define the profile and the axis. You also specify 
the starting angle and the number of degrees to revolve the profile.  

Revolving the profile 360 degrees creates a closed three-dimensional mesh. The 
Number Of M-Direction Surfaces value determines the mesh density (the number of 
mesh segments) in the M-direction (around the axis of revolution). The N-Direction 
Mesh Density value determines the mesh density (the number of mesh segments) in 
the N-direction (along the axis of revolution).  

To create a revolved surface mesh  
1. Do one of the following:  

• Choose Insert > 3D Entities > Revolved Surface. 
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• On the Draw 3D toolbar, click the Revolved Surface tool ( ). 

• Type revsurf and then press Enter. 
2. Select the entity to revolve. 

3. Select the entity to be used as the axis of revolution. 

4. Specify the starting angle. 

5. Specify the number of degrees to revolve the entity. 

 
Select the entity to be revolved (A) and the mesh. The resulting revolved surface axis of 

revolution (B). 

TIP To control the density of the mesh, change the values for the Number Of M-
Direction Surfaces and N-Direction Mesh Density. Choose Settings > Drawing Settings, 
and then click the 3D Settings tab. Under Change Settings For, select Surfaces. Under 
Surface Settings, change the Number Of M-Direction Surfaces and N-Direction Mesh 
Density values. Or on the Settings toolbar, use the Drawing Settings tool ( ) to 
display that dialog box.  

Creating edge-defined Coons surface patch meshes 
You can create a surface called a Coons surface patch, a mesh connecting four edges. 
You select the entities that define the edges. Edge entities can be arcs, lines, or 
polylines. The four edge entities must form a closed loop and share endpoints. A patch 
is a bicubic surface (one curve extends in the M-direction and the other in the N-
direction) interpolated between the four adjoining edges. You can select the edges in 
any order. The first edge you select determines the M-direction of the mesh. 

To create an edge-defined Coons surface patch mesh 
1. Do one of the following: 

• Choose Insert > 3D Entities > Coons Surface. 

• On the Draw 3D toolbar, click the Coons Surface tool ( ). 

• Type edgesurf and then press Enter. 
 

2. Select the first edge. 

3. Select the second, third, and fourth edges. 
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TIP To control the density of the mesh, change the value for the Number of M-Direction 
Surfaces and N-Direction Mesh Density. Choose Settings > Drawing Settings, and then 
click the 3D Settings tab. Under Change Settings For, select Surfaces. Under Surface 
Settings, change the Number Of M-Direction Surfaces and N-Direction Mesh Density 
values. Or on the Settings toolbar, use the Drawing Settings tool ( ) to display that 
dialog box. 

Creating boxes 
You can create rectangular boxes, or cubes. A box consists of six rectangular surface 
planes. The base of the box is always parallel with the xy plane of the current UCS. 
You position the box by specifying either a corner or the center of the box. You 
determine the size of the box by either specifying a second corner and the height; 
defining the box to be a cube and then providing its length; or specifying the length, 
width, and height.  

NOTE The box is created as a three-dimensional ACIS solid.  

To create a box 
1. Do one of the following: 

• Choose Insert > 3D Entities > Box.  

• On the Solids toolbar, click the Box tool ( ). 

• Type box and then press Enter. 
2. Specify the first corner of the base. 

3. Specify the opposite corner of the base. 

4. Specify the height.  

 
To create a box as a three-dimensional surface  
To create a box as a surface instead of as a solid, the procedure is similar. 

1. Do one of the following:  

• On the Draw 3D toolbar, click the Box tool ( ). 

• Type ai_box and then press Enter. 
2. Specify the first corner of the base. 

3. Specify the opposite corner of the base. 

4. Specify the height.  
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Creating wedges 
You can create three-dimensional wedges consisting of five surface planes. The base 
of the wedge is always parallel with the xy plane of the current UCS with the sloped 
face opposite the first corner. The height is always parallel with the z-axis. You position 
the wedge by specifying either a corner or the center of the wedge. You determine the 
size of the wedge by either specifying a second corner and the height; defining the 
wedge based on a cube having a given length; or specifying the length, width, and 
height.  

NOTE The wedge is created as a three-dimensional ACIS solid.  

To create a wedge 
1. Do one of the following:  

• Choose Insert > 3D Entities > Wedge. 

• On the Solids toolbar, click the Wedge tool ( ). 

• Type wedge and then press Enter. 
2. Specify the first corner of the base. 

3. Specify the opposite corner of the base. 

4. Specify the height.  

 
To create a wedge as a three-dimensional surface 
To create a wedge as a surface instead of as a solid, the procedure is similar. 

1. Do one of the following:  

• On the Draw 3D toolbar, click the Wedge tool ( ).  

• Type ai_wedge and then press Enter. 
2. Specify the first corner of the base. 

3. Specify the opposite corner of the base. 

4. Specify the height.  

Creating cones  
You can create three-dimensional cones defined by a circular base and tapering to a 
point perpendicular to the base. The base of the cone is always parallel with the xy 
plane of the current UCS; the height of the cone is always parallel with the z-axis. You 
position the cone by specifying the center of the base. You determine the size of the 
cone by specifying either the radius or the diameter of the base and the height. 

NOTE The cone is created as a three-dimensional ACIS solid.  



 
 

160  4M 

To create a cone 
1. Do one of the following:  

• Choose Insert > 3D Entities > Cone.  

• On the Solids toolbar, click the Cone tool ( ).  

• Type cone and then press Enter. 
2. Specify the center of the base of the cone. 

3. Specify the radius or diameter. 

4. Specify the height.  

 
To create a cone as a three-dimensional surface  
To create a cone as a surface instead of as a solid, the procedure is similar. 

1. Do one of the following:  

• On the Draw 3D toolbar, click the Cone tool ( ) 

• Type ai_cone and then press Enter. 
2. Specify the center of the base of the cone. 

3. Specify the radius or diameter. 

4. Specify the height. 

Creating pyramids  
You can create tetrahedrons (three-sided pyramids) or four-sided pyramids. The sides 
of the resulting pyramid can meet at a point (the apex) or can form a three- or four-
edged top. The sides of a four-sided pyramid can also meet along a ridge defined by 
two points. The base of the pyramid is always parallel with the xy plane of the current 
UCS. You position the pyramid by specifying a corner of the base. You determine the 
size of the pyramid by specifying the base points and either the apex, the corners of 
the top surface, or the endpoints of the ridge.   

NOTE The tetrahedron and pyramid are created as three-dimensional ACIS solids.  

To create a tetrahedron 
1. Do one of the following:  

• Choose Insert > 3D Entities > Pyramid.  

• On the Solids toolbar, click the Pyramid tool ( ). 

• Type pyramid and then press Enter. 
2. Specify the first point for the base of the pyramid. 
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3. Specify the second and third points. 

4. In the prompt box, choose Tetrahedron. 

5. Specify the apex of the tetrahedron.  

 
To create a pyramid with a planar top 
1. Do one of the following:  

• Choose Insert > 3D Entities > Pyramid.  

• On the Solids toolbar, click the Pyramid tool ( ).  

• Type pyramid and then press Enter. 
2. Specify the first point for the base of the pyramid. 

3. Specify the second, third, and fourth points. 

4. In the prompt box, choose Top Surface. 

5. Specify the first point on the top surface of the pyramid. 

6. Specify the second, third, and fourth points.  

 
To create a pyramid as a three-dimensional surface  
To create a pyramid as a surface instead of as a solid, the procedure is similar.  

1. Do one of the following:  

• On the Draw 3D toolbar, click the Pyramid tool ( ). 

• Type ai_pyramid and then press Enter.  

2. Specify the points as described previously.  
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Creating cylinders  
You can create cylinders defined by a circular base. The base of a cylinder is always 
parallel with the xy plane of the current UCS; the height of a cylinder is always parallel 
with the z-axis. You position a cylinder by specifying the center of the base. You 
determine the size of a cylinder by specifying either the radius or diameter of the base 
and the height.  

NOTE The cylinder is created as a three-dimensional ACIS solid.  

To create a cylinder 
1. Do one of the following: 

• Choose Insert > 3D Entities > Cylinder. 

• On the Solids toolbar, click the Cylinder tool ( ). 

• Type cylinder and then press Enter. 
2. Specify the center of the base of the cylinder. 

3. Specify the radius or diameter. 

4. Specify the height. 

 
To create a cylinder as a three-dimensional surface  
To create a cylinder as a surface instead of as a solid, the procedure is similar. 

1. Do one of the following:  

• On the Draw 3D toolbar, click the Cylinder tool ( ).  

• Type ai_cylinder and then press Enter. 
2. Specify the center, radius, and height as described previously. 

Creating spheres 
You can create spheres. The latitude lines of a sphere are always parallel with the xy 
plane of the current UCS; the central axis is always parallel with the z-axis. You 
position a sphere by specifying its center point. You determine the size of a sphere by 
specifying either its radius or its diameter. 

NOTE The sphere is created as a three-dimensional ACIS solid. 

To create a sphere 
1. Do one of the following: 

• Choose Insert > 3D Entities > Sphere. 

• On the Solids toolbar, click the Sphere tool ( ). 
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• Type sphere and then press Enter. 
 

2. Specify the center of the sphere. 

3. Specify the radius or diameter. 

 
To create a sphere as a three-dimensional surface 
To create a sphere as a surface instead of as a solid, the procedure is similar. 

1. Do one of the following: 

• On the Draw 3D toolbar, click the Sphere tool ( ). 

• Type ai_sphere and then press Enter. 
 

2. Specify the center of the sphere. 

3. Specify the radius or diameter. 

4. Specify the number of longitudinal sections that are perpendicular to the xy plane. 

5. Specify the number of latitudinal sections that are parallel to the xy plane. 

Creating dishes 
You can create a three-dimensional dish. The latitude lines of a dish are always 
parallel with the xy plane of the current UCS; the central axis is always parallel with the 
z-axis. You position a dish by specifying its center point. You determine the size of a 
dish by specifying either its radius or its diameter.  

NOTE The dish is created as a three-dimensional ACIS solid. 

To create a dish 
1. Do one of the following: 

• Choose Insert > 3D Entities > Dish. 

• On the Solids toolbar, click the Dish tool ( ). 

• Type dish and then press Enter. 
2. Specify the center of the dish. 

3. Specify the radius or diameter. 
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To create a dish as a three-dimensional surface  
To create a dish as a surface instead of as a solid, the procedure is similar. 

1. Do one of the following:  

• On the Draw 3D toolbar, click the Dish tool ( ). 

• Type ai_dish and then press Enter. 

2. Specify the center and radius or diameter as described previously. 

Creating domes  
You can create a three-dimensional dome. The latitude lines of a dome are always 
parallel with the xy plane of the current UCS; the central axis is always parallel with the 
z-axis. You position a dome by specifying its center point. You determine the size of a 
dome by specifying either its radius or its diameter.  

NOTE The dome is created as a three-dimensional ACIS solid.  

To create a dome 
1. Do one of the following:  

• Choose Insert > 3D Entities > Dome.  

• On the Solids toolbar, click the Dome tool ( ). 

• Type dome and then press Enter. 
2. Specify the center of the dome. 

3. Specify the radius or diameter.  

 
To create a dome as a three-dimensional surface  
To create a dome as a surface instead of as a solid, the procedure is similar. 

1. Do one of the following:  

• On the Draw 3D toolbar, click the Dome tool ( ) 

• Type ai_dome and then press Enter. 
2. Specify the center and radius or diameter as described previously. 
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Creating tori 
You can create a three-dimensional donut or ring-shaped entity known as a torus. The 
diameter of a ring is always parallel with the xy plane of the current UCS. A torus is 
constructed by revolving a circle about a line drawn in the plane of the circle and 
parallel with the z-axis of the current UCS. You position a torus by specifying its center 
point. You determine the size of a torus by specifying its overall diameter or radius and 
the diameter or radius of the tube (the circle being revolved). 

NOTE The torus is created as a three-dimensional ACIS solid. 

To create a torus 
1. Do one of the following: 

• Choose Insert > 3D Entities > Torus. 

• On the Solids toolbar, click the Torus tool ( ). 

• Type torus and then press Enter. 
2. Specify the center of the whole torus. 

3. Specify the radius or diameter of the whole torus. 

4. Specify the radius or diameter of the body of the torus. 

 
To create a torus as a three-dimensional surface  
To create a torus as a surface instead of as a solid, the procedure is similar.  

1. Do one of the following:  

• On the Draw 3D toolbar, click the Torus tool ( ). 

• Type ai_torus and then press Enter. 
2. Specify the center of the whole torus. 

3. Specify the radius or diameter of the whole torus. 

4. Specify the radius or diameter of the body of the torus. 

5. Specify the number of longitudinal sections that are perpendicular to the xy plane. 

6. Specify the number of latitudinal sections that are parallel to the xy plane.  

Creating regions 
You can convert a closed entity into a two-dimensional region. After you create a 
region, you can modify it using the various three-dimensional tools. For example, you 
can create a region from a square, and then extrude the square to create a three-
dimensional cube. 
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You can create regions from closed entities, such as polylines, polygons, circles, 
ellipses, closed splines, and donuts. 

Creating regions typically has no visible effect on a drawing. However, if the original 
entity had a width or lineweight, that information is lost when you create the region. 

To create a region 
1. Do one of the following:  

• Choose Modify > Region.  

• On the Modify toolbar, click the Region tool (  ).  

• Type region and then press Enter. 
2. Select the entities to create the region. 

3. Press Enter. The command bar displays a message that describes how many 
regions were created.  

Creating extruded solids  
You can create three-dimensional solids by extruding closed entities, such as polylines, 
polygons, circles, ellipses, closed splines, donuts, and regions. You can extrude the 
entity along a selected path, or you can specify its height and taper angle.  

To create an extruded solid 
1. Do one of the following: 

• Choose Insert > 3D Entities > Extrude. 

• Type extrude and then press Enter. 
2. Select the entity to extrude. 

3. Select the extrusion path, or specify the height. 

 
Creating revolved solids 
You can create three-dimensional solids by revolving closed entities, such as polylines, 
polygons, circles, ellipses, and regions. You can revolve the entity about a defined axis, 
line, polyline, or two points.  

To create a revolved solid 
1. Do one of the following:  

• Choose Insert > 3D Entities > Revolve.  

• Type revolve and then press Enter. 
2. Select the entity to revolve. 

3. Do one of the following to define the axis of revolution:  
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• Specify a start point and an end point.  

• Type o and press Enter to select an entity that determines the axis.  

• Type x and press Enter to select the x-axis.  

• Type y and press Enter to select the y-axis. 

4. Specify the angle of revolution.  

 
Creating composite solids  
You can create composite three-dimensional solids by combining, subtracting, and 
finding the intersection of two or more solids.  

To combine solids 
1. Do one of the following:  

• Choose Modify > Solid Editing > Union.  

• On the Solids Editing toolbar, click the Union tool ( ). 

• Type union and then press Enter. 
2. Select the entities to combine. 

A

B

 
To subtract solids 
1. Do one of the following: 

• Choose Modify > Solid Editing > Subtract. 

• On the Solids Editing toolbar, click the Subtract tool ( ). 

• Type subtract and then press Enter. 
2. Select the entities to subtract from one another. 
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A

B

 
To intersect solids 
1. Do one of the following: 

• Choose Modify > Solid Editing > Intersect. 

• On the Solids Editing toolbar, click the Intersect tool ( ). 

• Type intersect and then press Enter. 
2. Select the entities to intersect. 

 
2.9.4 Editing in three dimensions  
You can copy, move, rotate, array, mirror, and align two-dimensional and three-
dimensional entities in both two-dimensional and three-dimensional space. You can 
also change and edit properties of three-dimensional entities much like you change 
and edit properties for two-dimensional entities. When you modify three-dimensional 
entities in two-dimensional space, you modify the entity in relation to the current UCS.  

Rotating in three dimensions  
You can rotate selected entities about a specified axis in three-dimensional space. You 
select the entities to rotate and then define the axis of rotation either by specifying two 
points; selecting an existing entity; aligning the axis with the x-, y-, or z-axis of the 
current UCS; or aligning the axis with the current view.  

To rotate an entity about an axis in three dimensions 
1. Do one of the following:  

• Choose Modify > 3D Rotate. 

• On the Modify toolbar, click the 3D Rotate tool ( ) 

• Type rotate3D and then press Enter.  
2. Select the entities to rotate, and then press Enter. 

3. Choose from one of the following options: Entity, Last, View, Xaxis, Yaxis, Zaxis. 
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4. Specify the rotation angle.  

5. Specify the reference angle.  

 
 

Arraying in three dimensions  
You can copy selected entities and arrange them in a three-dimensional rectangular or 
polar (circular) pattern. For a rectangular array, you control the number of copies in the 
array by specifying the number of rows and columns and the number of levels. You 
also specify the distance between each. For a polar array, you specify the axis around 
which to array the entities, the number of copies of the entities to create, and the angle 
subtended by the resulting array.  

To create a three-dimensional rectangular array 
1. Do one of the following:  

• Choose Modify > 3D Array.  

• On the Modify toolbar, click the 3D Array tool ( ). 

• Type 3Darray and then press Enter. 
2. Select the entities, and then press Enter. 

3. In the prompt box, choose Rectangular. 

4. Type the number of rows in the array. 

5. Type the number of columns. 

6. Type the number of levels. 

7. Specify the vertical distance between the rows. 

8. Specify the horizontal distance between the columns. 

9. Specify the depth between the levels.  
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To create a three-dimensional polar array 
1. Do one of the following:  

• Choose Modify > 3D Array.  

• On the Modify toolbar, click the 3D Array tool ( ). 

• Type 3Darray and then press Enter. 
2. Select the entities, and then press Enter. 

3. In the prompt box, choose Polar. 

4. Type the number of copies to make, including the original selection set. 

5. Specify the angle the array is to fill, from 0 to 360 degrees. The default setting for 
the angle is 360 degrees. Positive values create the array in a counterclockwise 
direction; negative values create the array in a clockwise direction.  

6. In the prompt box, choose one of the following:  

• Yes-Rotate Entities to rotate entities as they are arrayed.  

• No-Do Not Rotate to retain the original orientation of each copy as it is arrayed. 

7. Specify the center point of the array. 

8. Specify a second point along the central axis of the array.  

 
Mirroring in three dimensions  
You can create a mirror image of selected entities in three-dimensional space. You 
mirror the entities about a mirror plane that you define by either specifying three points; 
selecting an existing two-dimensional planar entity; aligning the plane parallel with the 
xy, yz, or xz plane of the current UCS; or aligning the plane with the current view. You 
can delete or retain the original entities.  

To mirror an entity about a three-dimensional plane 
1. Do one of the following: 

• Choose Modify > 3D Mirror. 

• On the Modify toolbar, click the 3D Mirror tool ( ). 

• Type mirror3D and then press Enter. 
2. Select the entities, and then press Enter. 
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3. In the prompt box, choose 3 Points, or press Enter to select the default. 

4. Specify the first point on the mirror plane. 

5. Specify the second and third points on the plane. 

6. In the prompt box, choose one of the following: 

• Yes-Delete Entities to delete the original entities. 

• No-Keep Entities to retain the original entities. 

 
Aligning in three dimensions  
You can align selected entities with other entities in three-dimensional space. You 
select the entities you want to align, and specify one, two or three pairs of points to 
align the selected entities.  

To align an entity an entity with another 
1. Do one of the following:  

• Choose Modify > Align.  

• On the Modify toolbar, click the Align tool ( ). 

• Type align and then press Enter. 
2. Select the entities, and then press Enter. 

3. Specify the first source point. 

4. Specify the first destination point 

5. Specify additional source and destination points if desired (up to three pairs). 

C D

A

B
 

2.9.5 Editing three-dimensional solids  
You can edit three-dimensional solids in several unique ways, including: chamfer, fillet, 
section, and slice. You can also modify individual faces and edges of solids, as well as 
imprint, separate, shell, and check solids.  

You can edit three-dimensional ACIS solids, including: boxes, cones, cylinders, dishes, 
domes, pyramids, spheres, tori, and wedges.  
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Chamfering and filleting solids 
You can chamfer or fillet a three-dimensional solid much like you chamfer or fillet a 
two-dimensional entity.  

To chamfer a solid 
1. Do one of the following:  

• Choose Modify > Chamfer.  

• On the Modify toolbar, click the Chamfer tool ( ). 

• Type chamfer and then press Enter. 
2. Select the edge of the base surface to chamfer. (One of two surfaces adjacent to 

the selected edge will be highlighted.)  

3. Do one of the following:  

• To select a different surface, type n and press Enter.  

• To use the current surface, press Enter. 

4. Specify the base surface distance (measured from the selected edge to the base 
surface). 

5. Specify the adjacent surface distance (measured from the selected edge to the 
adjacent surface). 

6. Do one of the following:  

• Specify the edges to chamfer.  

• To select all edges around the base surface, type l and press Enter.  

To fillet a solid 
1. Do one of the following: 

• Choose Modify > Fillet.  

• On the Modify toolbar, click the Fillet tool ( ). 

• Type fillet and then press Enter.  
2. Select the edge of the solid to fillet.  

3. Specify the fillet radius.  

4. Select additional edges to fillet, and press Enter to fillet.  

Sectioning and slicing solids  
You can section or slice a three-dimensional solid to obtain an “inside view” of the 
solid. When you section a solid, you create a cross-section through the solid as a 
region or block. When you slice a solid, you create a new solid by cutting the original 
solid and removing a specific side.  

To section a solid 
1. Do one of the following:  

• Choose Insert > 3D Entities > Section. 

• On the Solids toolbar, click the Section tool ( ). 

• Type section and then press Enter. 
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2. Select the entities to cross-section. 

3. Do one of the following:  

• Specify three points to define the cross-section plane. (The first point defines 
the origin, while the second point defines the x-axis and the third point defines 
the y-axis.)  

• Type o and press Enter to select an entity that defines the cross-sectional 
plane.  

• Specify an axis by typing the appropriate letter and pressing Enter.  

To slice a solid 
1. Do one of the following: 

• Choose Insert > 3D Entities > Slice.  

• On the Solids toolbar, click the Slice tool ( ). 

• Type slice and then press Enter. 
2. Select the entities to slice. 

3. Do one of the following:  

• Specify three points to define the cross-section plane. (The first point defines 
the origin, while the second point defines the x-axis and the third point defines 
the y-axis.)  

• Type o and press Enter to select an entity that defines the cross-sectional 
plane.  

• Specify an axis by typing the appropriate letter and pressing Enter. 

4. Specify which side to retain, or type b to retain both sides.  

2.9.6 Modifying faces 
You can edit three-dimension solids by extruding, moving, rotating, offsetting, tapering, 
deleting, or copying individual faces. You can also change the color of individual faces.  

To extrude a solid face 
1. Do one of the following:  

• Choose Modify > Solid Editing > Extrude Face.  

• On the Solids Editing toolbar, click the Extrude Face tool ( ). 

2. Select the entity with the face you want to extrude. 

3. Select the face(s) to extrude, and press Enter. 

4. Do one of the following: 

• Specify the height of extrusion. 

• Type p and press Enter to select a path for extrusion.  

5. If you specified a height, specify a taper angle.  
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To move a solid face 
1. Do one of the following:  

• Choose Modify > Solid Editing > Move Face. 

• On the Solids Editing toolbar, click the Move Face tool ( ). 

2. Select the entity with the face you want to move. 

3. Select the face(s) to move, and press Enter. 

4. Specify a base point. 

5. Specify an end point. 
C

A B

 
To rotate a solid face 
1.  Do one of the following:  

• Choose Modify > Solid Editing > Rotate Face.  

• On the Solids Editing toolbar, click the Rotate Face tool ( ). 

2. Select the entity with the face you want to rotate. 

3. Select the face(s) to rotate, and press Enter. 

4. Specify a base point. 

5. Specify another point on the rotation axis. 

6. Specify the rotation angle. 
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To offset a solid face 
1. Do one of the following:  

• Choose Modify > Solid Editing > Offset Face. 

• On the Solids Editing toolbar, click the Offset Face tool ( ). 

2. Select the entity with the face you want to offset.  

3. Select the face(s) to offset, and press Enter.  

4. Specify an offset distance.  

 
To taper a solid face 
1. Do one of the following:  

• Choose Modify > Solid Editing > Taper Faces.  

• On the Solids Editing toolbar, click the Taper Face tool ( ). 

2. Select the entity with the face you want to taper. 

3. Select the face(s) to taper, and press Enter. 

4. Specify a base point. 

5. Specify another point along the axis. 

6. Specify a taper angle. 
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To delete a solid face 
1. Do one of the following:  

• Choose Modify > Solid Editing > Delete Face. 

• On the Solids Editing toolbar, click the Delete Face tool ( ). 

2. Select the entity with the face you want to delete. 

3. Select the face(s) to delete, and press Enter. 

 
To copy a solid face 
1. Do one of the following: 

• Choose Modify > Solid Editing > Copy Face.  

• On the Solids Editing toolbar, click the Copy Face tool ( ). 

2. Select the entity with the face you want to copy. 

3. Select the face(s) to copy, and press Enter. 

4. Specify a base point. 

5. Specify an end point. 

 
To color a face 
1. Do one of the following: 

• Choose Modify > Solid Editing > Color Face. 

• On the Solids Editing toolbar, click the Color Face tool (  ). 

2. Select the entity with the face you want to color. 

3. Select the face(s) to color, and press Enter. 

4. Specify a color. 
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2.9.7 Modifying edges  
In addition to modifying faces of solids, you can modify individual edges. You can copy 
individual edges or change the color of individual edges.  

To copy an edge 
1. Do one of the following:  

• Choose Modify > Solid Editing > Copy Edge.  

• On the Solids Editing toolbar, click the Copy Edge tool ( ). 

2. Select the entity with the edge you want to copy. 

3. Select the edge(s) to copy, and press Enter. 

4. Specify a base point. 

5. Specify an end point. 

 
To color an edge 
1. Do one of the following:  

• Choose Modify > Solid Editing > Color Edge. 

• On the Solids Editing toolbar, click the Color Edge tool ( ). 

2. Select the entity with the edge you want to color. 

3. Select the edge(s) to color, and press Enter. 

4. Specify a color.  

2.9.8 Imprinting solids  
You can modify the face of a solid by imprinting another entity on it. For example, you 
can imprint a line, arc, or polyline onto the face of a box.  

To imprint a solid entity 
1. Do one of the following:  
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• Choose Modify > Solid Editing > Imprint.  

• On the Solids Editing toolbar, click the Imprint tool ( ). 

2. Select the solid entity you want to imprint. 

3. Select the entity you want to imprint on the solid. 

2.9.9 Separating solids  
You can separate solids that have been combined. After you separate them, they are 
separated into individual solids.  

To separate solids 
1. Do one of the following: 

• Choose Modify > Solid Editing > Separate. 

• On the Solids Editing toolbar, click the Separate tool ( ).  

2. Select the solid you want to separate. 

2.9.10 Shelling solids 
You can create a shell or a hollow thin wall from your 3D solid entity. ProgeCAD 
Architecture offsets existing faces to create new faces. 

To shell a solid 
1. Do one of the following: 

• Choose Modify > Solid Editing > Shell. 

• On the Solids Editing toolbar, click the Shell tool ( ) 

2. Select the entity you want to shell. 

3. Remove any faces you don’t want to include. 

4. Specify an offset distance. 

 

2.9.11 Cleaning solids  
You can remove redundant edges or vertices from solids when they are not needed.  

To clean a solid 
1. Do one of the following: 

• Choose Modify > Solid Editing > Clean.  

• On the Solids Editing toolbar, click the Clean tool ( ). 

2. Select the entity you want to clean.  
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2.9.12 Checking solids 
You can check whether a selected entity is a valid three dimensional ACIS solid. If it is 
a valid 3D solid, you can modify the entity using the 3D solid editing commands; if not, 
you cannot edit the entity using these commands.  

To check a solid 
1. Do one of the following:  

• Choose Modify > Solid Editing > Check.  

• On the Solids Editing toolbar, click the Check tool ( ). 

2. Select the entities to check. 

2 9 13 Import – Export ACIS File 
An ACIS file contains three-dimensional solids, regions, or bodies that are saved as an 
ASCII.sat file. 

To import an ACIS file 
1. Do one of the following: 

• Choose File > Acis In. 

• Type acisin, and then press Enter. 
2. Choose the directory containing the SAT file. 

3. Choose the SAT file you want to open. 

4. Click Open. 

To export an ACIS file 
1. Do one of the following: 

• Choose File > Acis Out. 

• Type acisout and then press Enter. 
2. Select the ACIS entities you want to save. 

3. Specify the name of the file you want to create. 

4. Click Save. 
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2.10 Printing 
The printing of a drawing to a printer or a plotter, or even to a file is accomplished 
through the PRINT (or PLOT) command, either clicking on the command located at the 
“FILE” group of commands, or through the command line, given that a drawing has 
been already loaded. More details about the printing procedure and the related options 
are given in the next paragraph. 

Formatting and printing drawings 
You can print a copy of your drawing exactly as you created it, or you can add 
formatting and specify print controls to change how your drawing looks when it is 
printed.  

Sometimes you may require multiple printed drawings, each with a different look or 
layout. For example, you may need one printed drawing for a client presentation, along 
with several other variations for production contractors. For each type of printed 
drawing that you require, you can create a layout that defines its characteristics, 
including scale, area to print, pen widths, and more.  

This section explains how to:  

• Set up a drawing to print from model space on the Model tab.  

• Set up a drawing to print multiple layouts from paper space on a Layout tab.  

• Define how you want your drawing to look when it is printed.  

• Print or plot your drawing.  

Understanding paper space and model space  
When you start a drawing session, your initial working area is called model space.  

Model space is an area in which you create two-dimensional and three-dimensional 
entities based on either the World Coordinate System (WCS) or a user coordinate 
system (UCS). You view and work in model space while using the Model tab.  

Your view of this area is a single viewport that fills the screen. You can create 
additional views on the Model tab, called viewports, which can show the same or 
different two-dimensional or three-dimensional views, all of which are displayed in a 
tiled manner. You can work in only one of these viewports at a time on the Model tab, 
and you can print only the current viewport.  



 
 

progeCAD Architecture  181 

 
Model space with two viewports.  

ProgeCAD Architecture provides an additional work area, called paper space. The 
contents of paper space represent the paper layout of your drawing. In this work area, 
you can create and arrange different views of your model similar to the way you 
arrange detail drawings or orthogonal views of a model on a sheet of paper. You can 
also add keynotes, annotations, borders, title blocks, and other print-related entities in 
paper space, which reduces clutter when you work with your model in model space.   

You view and work in paper space while using a Layout tab. Each view, or layout 
viewport, that you create in paper space provides a window of your drawing in model 
space. You can create one layout viewport or several. You can place layout viewports 
anywhere on the screen; their edges can be touching or not; and you can print them all 
at the same time.  

You do not need to use paper space to print your drawing, but it offers several 
advantages:  

• Print the same drawing with different print settings that you save with each 
layout, for example, pen widths, printer configuration files, lineweight settings, 
drawing scale, and more.  

• Add print-related entities that are not essential to the model itself, such as 
keynotes or annotations, to reduce clutter when you work with your model in 
model space on the Model tab.  

• For a single layout, create multiple layout viewports that print the model at 
different views and scales. 
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Paper space with layout viewports.  

Viewing drawings in paper space and model space  
When you work in paper space on a Layout tab, you can still view your drawing in 
model space. First you need to create a layout viewport in paper space; this allows you 
to view your model space entities from paper space.  

Within a layout viewport you can modify the model space entities, but it is often more 
convenient to modify these entities on the Model tab.  

Zooming or panning the drawing in model space or paper space affects the entire 
drawing, unless you use multiple windows or viewports.  

To view a drawing in model space using the Model tab  

• Click the Model tab.  

To view a drawing in paper space using a Layout tab 
Do one of the following: 

• Click one of the Layout tabs.  

• Type layout and then press Enter. In the prompt box, choose Set. Type a name 
for the layout you want to make current, and then press Enter.  

The first time you switch to a Layout tab, your drawing seems to disappear. This is 
normal. You must create at least one layout viewport to see your work. 

To view your drawing in model space using a Layout tab 
1. Click the desired Layout tab. 

2. Create and view a layout viewport. 

NOTE: You can switch between model space and paper space using the Model/Paper 
toggle in the status bar, or by typing mspace or pspace. 
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Creating a new layout  
In ProgeCAD Architecture, you can create multiple layouts for a single drawing. Each 
layout represents a sheet of paper. For each layout you can specify the print area, print 
scale, lineweight scale, pen mappings, and add viewports, dimensions, a title block, 
and other geometry specific to the layout. The entities you add to a layout in paper 
space do not appear in model space.  

Each layout requires at least one layout viewport. This viewport displays the drawing’s 
model space entities.  

When you create a new drawing, the drawing automatically contains two default 
layouts: Layout1 and Layout2. You can start by using one of the default layouts, you 
can create your own, or your can create a new layout from another template (.dwt) file, 
drawing (.dwg) file, or drawing interchange (.dxf) file.  

Each drawing can contain up to 255 layouts.  

To create a new layout using the Layout1 or Layout2 tab 
1. Click the Layout1 or Layout2 tab. 

2. Set up at least one layout viewport. 

3. If desired, rename the layout.  

To create a new layout using a new Layout tab 
1. Do one of the following:  

• Choose Insert > Layout > New Layout.  

• On the Layouts toolbar, click the New Layout tool ( ).  

• Type layout, press Enter, and choose New. 

2. Type a unique name for your layout and then press Enter. The name can be up to 
255 characters in length and can contain letters, numbers, the dollar sign ($), 
hyphen (-), and underscore (_), or any combination.  

3. Set up at least one layout viewport. 

To create a new layout from an existing file 
1. Do one of the following:  

• Choose Insert > Layout > Layout from Template.  

• On the Layouts toolbar, click the Layout from Template tool ( ).  

• Type layout, press Enter, and choose Template. 

2. Select the desired template, drawing, or drawing interchange file that contains the 
layout you want, and then click Open.  

3. Select the layout(s), and then click OK. You can choose multiple layouts by holding 
down CTRL while selecting layout names.  

Reusing layouts from other files  
Save time by re-using layouts that you have already created. Within the same drawing, 
you may want to make a copy of a layout that contains most of the settings youwant, 
and then make changes to the new copy. If you created layouts that you want touse 
again when you create new drawings, you can save the layouts as a drawing template. 
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To make a copy of a layout 
1. Type layout and then press Enter. 
2. In the prompt box, choose Copy. 

3. Type the name of the layout you want to copy, and then press Enter. 

4. Type a name for the new layout, and then press Enter. 

To save a layout as a drawing template 
1. Type layout and then press Enter. 
2. In the prompt box, choose Save. 

3. Type the name of the layout that you want to save, and then press Enter. 

4. Specify the file name and location for the template, and then click Save. 

After you save a layout as a template, you can use the template when you create new 
drawings. You can also import the template’s layouts into another drawing. 

Managing layouts in a drawing  
You can rename layouts, delete layouts, and view a list of all layouts available in a 
drawing. 

To rename a layout 
1. Type layout and then press Enter.  
2. In the prompt box, choose Rename. 

3. Type the name of the layout you want to rename, and then press Enter. 

4. Type a new name for the layout and then press Enter. The name can be up to 255 
characters in length and can contain letters, numbers, the dollar sign ($), hyphen (-
), and underscore (_), or any combination.  

To delete a layout 
1. Type layout and then press Enter. 
2. In the prompt box, choose Delete. 

3. Type a name for the layout to be deleted and then press Enter. 

NOTE: You cannot delete the Model tab or an only remaining Layout tab. To delete all 
geometry from the Model tab or a Layout tab, first select all geometry and then use the 
erase command.  

To view a list of all layouts 
1. Type layout and then press Enter. 
2. In the prompt box, choose ? to list all layouts. 

3. Type s or press Enter to scroll through the layouts. 

Working with layout viewports  
When you begin working in a drawing on the Model tab, it consists of a single view of 
your model. You may have created additional views by dividing the drawing space into 
multiple windows; each window is a separate viewport on the Model tab.  
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On a Layout tab, you must create at least one layout viewport to see your model. 
However, you can create multiple layout viewports that display unique views of your 
model located in model space. Each layout viewport functions as a window into your 
model space drawing. You can separately control the view, scale, and contents of each 
layout viewport. Each layout viewport is created as a separate entity that you can 
move, copy, or delete.  

Click any layout viewport to make it the current viewport, and then add or modify model 
space entities in that viewport. Any changes you make in one layout viewport are 
immediately visible in the other viewports (if the other layout viewports are displaying 
that portion of the drawing). Zooming or panning in the current viewport affects only 
that viewport. This section focusses on working with layout viewports in paper space on 
a Layout tab. 

Creating layout viewports  
The first time you switch to a Layout tab, all of your model space entities disappear. 
You must create at least one layout viewport on the Layout tab to see your work.  

You can create layout viewports anywhere inside the drawing area. You can control the 
number of viewports created and the arrangement of the viewports.  

To create layout viewports 
1. Do one of the following:  

• Choose View > Layout Viewports.  

• On the Views toolbar, click the Layout Viewports tool ( ).  

• Type mview and then press Enter. 
2. In the prompt box, choose Fit To View, Create 2 Viewports, Create 3 Viewports, or 

Create 4 Viewports, or specify two opposing corners to create a custom viewport. 

3. In the prompt box, choose the viewport orientation. 

4. Do one of the following:  

• To arrange the viewports to fill the current graphic area, in the prompt box, 
choose Fit To Screen.  

• To fit the viewports within a bounding rectangle, specify the corners of a 
rectangle.  

TIP: When you create a layout viewport, the layout viewport border is created on the 
current layer. You can make layout viewport borders invisible by creating a new layer 
before you create layout viewports and then turning off that layer after you create the 
layout viewports. To select a layout viewport’s borders, you must turn that layer back 
on before you can rearrange or modify the layout viewport.  
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You can create a single layout viewport, or you can divide the graphic area into two viewports 

arrangedvertically (A) or horizontally (B); three viewports arranged left (C), right (D), above 
(E),below (F), vertically (G), or horizontally (H); or four viewports (I). 

Viewing and scaling layout viewports  
If you have created numerous layout viewports, your system performance may be 
affected. If necessary, you can turn a layout viewport on or off. Turning off a layout 
viewport does not delete the viewport or its contents; it simply turns off its display.  

You can also change how you view items within a layout viewport by specifying a scale 
factor, which changes how large or small model space entities appear within the layout 
viewport.  

To turn layout viewports on or off 
1. Click the desired Layout tab.  

2. Do one of the following:  

• Choose View > Layout Viewports.  

• On the View toolbar, click the Layout Viewports tool ( ).  

• Type mview and then press Enter. 
3. Choose On or Off. 

4. Select the edge of the layout viewport to turn on or off, and then press Enter.  

To change the scale of model space entities relative to paper space 
1. Click the Model tab. 

2. Click a viewport to make it current. 

3. Choose View > Zoom > Zoom. 

4. Type the zoom scale factor relative to paper space by appending the suffix xp to 
the scale factor, and then press Enter. 

For example, to increase the scale of the entities in the viewport on the Model tab 
to twice the size of paper space units, type 2xp. To decrease the scale to half the 
size of paper space units, type .5xp. 
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Modifying layout viewports  
After you create layout viewports, you can modify them as needed. On the Layout tab, 
you can snap to the viewport borders using entity snap. You can also copy, delete, 
move, scale, and stretch layout viewports as you would any other drawing entity.  

Modifying a layout viewport on a Layout tab does not affect the model space entities 
within the layout viewport.  

To modify layout viewport properties 
1. Click the desired Layout tab. 

2. Select the edge of the layout viewport you want to modify. 

3. Adjust the center point, width, or height of the viewport. 

4. In Scale, enter the scale at which you want to view model space entities from within 
the layout viewport. 

5. Select Lock Viewport to lock the viewport scale and view in model space while 
panning or zooming in the layout viewport. 

6. Select UCS per Viewport if you want to use a unique UCS for each layout view-
port. 

7. Press Enter.  

NOTE: You can only select layout viewports for modification. If you click a viewport on 
the Model tab, it makes that viewport active, not available for modification.  

Customizing print Options 
Before you print, you can set up many aspects of printing. The following print settings 
are set globally for all drawings:  

• Specify paper size and orientation.  

• Select and configure a printer or plotting device.  

• Specify the view and scale of a printed drawing, including which portion of a 
drawing to print, the print scale, and the origin of the print area.  

• Choose whether to print and scale lineweights.  

• Choose whether to implement print style tables to control colors, pen widths, 
line-types, and lineweights. 

• Open printer configuration (PCP) files; create and save PCP files.  

Setting the paper size and orientation 
You can specify a paper size and paper orientation for all drawings.  

To select the paper size and orientation 
1. Do one of the following:  

• Choose File > Print Setup.  

• On the Layouts toolbar, click the Print Setup tool ( ). 

• Type print and press Enter, and then click Print Setup. 

2. Select the paper size and paper orientation, and then click OK.  
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Selecting a printer or plotter 
You can specify a printer or plotter to be used when printing any drawings. You can 
print your drawing on any printer or plotter that is compatible with Windows, including 
raster printers.  

To select a printer or plotter 
1. Do one of the following:  

• Choose File > Print Setup.  

• On the Layouts toolbar, click the Print Setup tool ( ).  

• Type print and press Enter, and then click Print Setup. 

2. From the Printer Name list, select a printer or plotter, and then click OK. 

Setting the scale and view  
You can print or plot the entire drawing or a selected portion, depending on which 
options you select in the Scale/View tab of the Print dialog box. You can choose to print 
what is visible on the screen, or you can specify to print an area of the drawing.  

You can control the position of the drawing on the paper by specifying the origin of the 
print area, the location of the lower left corner of the plot area, in relation to the lower 
left corner of the paper. The origin is normally set to 0,0, which places the lower left 
corner of the print area as close to the lower left corner of the paper as the printer or 
plotter will allow. You can specify a different origin, however, by specifying different 
coordinates.  

When you create a drawing, you generally draw entities full-size. When you plot the 
drawing, you can specify the scale of the resulting print or let the program adjust the 
size of the drawing to fit the paper. To plot the drawing at a specific scale, specify the 
scale as a ratio of drawing units to printed units.  

If you are printing from a Layout tab, the scale and view options you specify can be 
different for each layout that you create.  

To automatically scale the drawing for printing 
1. If necessary, click the desired Layout tab or the Model tab. 

2. Do one of the following:  

• Choose File > Print.  

• Type print and then press Enter. 
3. Click the Scale/View tab. 

4. To scale the drawing to fit on one printed page, select the check box under Print 
Scale. 

5. Select Save Changes to Layout, and then click Apply to save your changes.  

To specify the scale factor yourself 
1. If necessary, click the desired Layout tab or the Model tab. 

2. Do one of the following: 

• Choose File > Print.  

• Type print and then press Enter. 
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3. Click the Scale/View tab. 

4. In Print Scale, do one of the following: 

• Select a pre-defined scale. For example, choose 1:2 if you want 1 printed unit 
(inch or millimeter) to equal 2 drawing units. 

• Select Custom, and then under User Defined Scale, type the ratio of printed 
units of measure (inches or millimeters) to drawing units. 

5. To specify the printed units of measure, click Inches or Millimeters. 

6. Select Save Changes to Layout, and then click Apply to save your changes.  

To specify a portion of the drawing to print  
1. If necessary, click the desired Layout tab or the Model tab. 

2. Do one of the following:  

• Choose File > Print.  

• Type print and then press Enter. 
3. Click the Scale/View tab. 

4. Under Print Area, click one of the following:  

• Current View – prints the view on the screen.  

• Saved View – prints the selected saved view.  

• Extents – prints the area that contains entities in the drawing.  

• Limits – prints to the limits defined for the layout or drawing.  

• Window – prints the portion of the drawing contained in the specified window, 
maintaining the aspect ratio of the windowed area to the drawing.  

If you clicked Window, you must specify the window. Under Windowed Print 
Area, enter the diagonal x- and y-coordinates of the window, or select the area 
on the screen.  

To print only the area in the window without considering whether there is extra 
space on the screen, select the Print Only Area Within Specified Window check 
box.  

5. Under Entities To Print, click one of the following:  

• All Entities Within Print Area – prints all drawing entities contained within the 
specified print area.  

• Selected Entities Within Print Area – prints only the entities you select from 
within the specified print area.  

6. Select Save Changes to Layout, and then click Apply to save your changes.  
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A. Displays either “Model” or the layout name to which the print settings apply.  

B. Click to select the area of the drawing that you want to print.  

C. Type the x- and y-coordinates of the two opposing corners of the rectangular area of the 
drawing that you want to print; or, to specify coordinates in the drawing window, click Select 
Print Area.  

D. Select to print the area of the window while ignoring the aspect ratio to the remainder of the 
drawing.  

E. Select to activate command hide as you printing. 

F. Click to specify drawing units and paper size in millimeters or inches.  

G. Specify the scale for the print area by typing the ratio of drawing units to printed inches or 
printed millimeters.  

H. Select to fit the specified print area to the current paper size.  

I. Click to print selected entities within the specified print area.  

J. Click to print all entities within the specified print area.  

K. Select to save the print settings for the model or layout.  

L. Select to load print settings from the current layout (or model) or the last time you printed.  

To specify the print area origin 
1. If necessary, click the desired Layout tab or the Model tab. 

2. Do one of the following: 

• Choose File > Print.  

• Type print and then press Enter. 
3. Click the Advanced tab. 

4. Under Origin Of Print Area, do one of the following:  
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• To center the specified print area on the printed page, select the Center On 
Page check box.  

• To specify an origin for the print area, type the x- and y-coordinates, or click 
Select Origin and then specify a point on the drawing.  

5. Select Save Changes to Layout, and then click Apply to save your changes.  

Choosing how lineweights print 
If entities are assigned lineweights, you can control whether they print with the 
assigned lineweights. If you turn off lineweight printing, entities print with a default 
outline. You can also control whether lineweights print in proportion to the scale you set 
on the Scale/View tab. 

Each layout in your drawing can specify whether to print and scale lineweights. 

To set lineweight options 
1. If necessary, click the desired Layout tab or the Model tab. 

2. Do one of the following: 

• Choose File > Print.  

• Type print and press Enter. 
3. Click the Advanced tab. 

4. Choose how you want to print lineweights: 

• Print Lineweights – prints entities with their assigned lineweights. If not 
selected, entities print with a default outline. 

• Scale Lineweights – prints lineweights in proportion to the scale you set on the 
Scale/View tab. If not selected, lineweights print at their assigned size without 
adjustments for the print scale. (A Layout tab must be active to scale 
lineweights.) 

5. Select Save Changes to Layout, and then click Apply to save your changes. 
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A. Displays either “Model” or the layout name to which  the print settings apply.  
B. Select a print style table. 
C. Click to load print settings from a PCP file. 
D. Click to save the current configuration as a PCP file. 
E. Select to print the drawing upside down on your printer. 
F. Select to print entities with their assigned lineweights. 
G. Select to print lineweights in proportion to the scale you set on the Scale/View tab. (A Layout 
tab must be active.) 
H. Click to specify the print area origin by selecting a point within the drawing.  
I. Type x- and y-coordinates to specify the origin of the print area. 
J. Select to center the print area on the page. 
K. Click to make changes to the selected print style table.  
L. Click to create a new print style table.  
M. Select to save the print settings for the model or layout. 
N. Select to load print settings from the current layout (or model) or the last time you printed. 
Using print styles 
progeCAD uses print styles to change the appearance of your printed drawing with-out 
modifying the actual entities in your drawing. Assigning print styles allows you to 
customize the color, pen width, linetype, and lineweight that are used to print your 
drawing. 

Print styles help you control what your drawing looks like when it is printed. Rather than 
describe what an entity looks like on your screen, print styles describe what an entity 
will look like when you print it. For example, you can map all yellow entities in your 
drawing to print in blue without modifying the actual entities. You could also map all 
yellow entities to print with whatever lineweight, linetype, or pen width that you specify. 

Because print styles are saved in print style tables, which are files located on your 
computer, disk, or server, you can reuse them to help eliminate the need to reconfigure 
your print settings each time you print a drawing. For example, you may have multiple 
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clients who have their own printing preferences. You can save print styles in a named 
file for each of your clients. You can even share the file with co-workers, or store the 
files on a network to ensure that everyone in your office uses the same standards. 

Assigning print style tables 
Select a print style table before printing if you want to change how your drawing 
appears when you print it. Print style tables can modify how colors, pen widths, line-
types, and lineweights look when they are printed. 

You can assign print style tables globally for all layouts (including the Model tab), or 
individually for the Model tab or a Layout tab. Assigning a print style table to an 
individual layout allows you to further customize the layouts you use to print a drawing. 

However, assigning different named print style tables to various layouts may result in 
mismatched print style names; a named print style assigned to an entity or layer may 
not be located in the assigned print style table at print time. In this case, entities are 
printed using their default properties, which is similar to assigning the Normal print style 
to an entity or layer. 

To assign print style tables 
1. If necessary, click the desired Layout tab, or click the Model tab. 

2. Do one of the following: 

• Choose File > Print. 

• Type print and then press Enter. 
3. Click the Advanced tab. 

4. Under Print Style Table (Pen Assignments), select a print style table that you 
created or one of the following: 

• None — Applies no print style table. Entities print according to their own 
properties. 

• Icad — Uses the default print style table and its color assignments. 

• Monochrome — Prints all colors as black. 

5. At the prompt, choose Yes to assign the print style table to all layouts in the 
drawing, including the Model tab, or choose No to assign the print style table only 
to the individual layout listed in Layout Name on the Print dialog box. 

6. Select Save Changes to Layout, and then click Apply to save your changes. 

Creating new print style tables 
progeCAD offers several print style tables to help you get started. If you want to 
customize your print output further, you can create your own print style table. You can 
create a new print style table entirely from scratch, based on progeCAD registry set-
tings, or by importing a printer configuration file (PCP file). 

To create new print style tables 
1. Do one of the following: 

• Choose File > Print Styles Manager. 

• Type stylesmanager and then press Enter. 
2. Double-click Create a Print Style Table. 

3. Complete the setup wizard. 
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On the last wizard page, you can click Print Style Table Editor to set up the print 
styles for the table. For more details about the Print Style Table Editor options, see 
the next section. 

Modifying print style tables 
When your drawing was created, it was set up to use color-dependent or named print 
style tables. 

Color-dependent print style tables (.ctb files) You can modify individual print styles 
within the table, but you cannot add, rename, or delete print styles. Color-dependent 
print style tables always have 255 print styles, each named for a specific color. Your 
changes affect all entities and layers assigned that color. 

Named print style tables (.stb files) You can add, modify, rename, and delete 
individual print styles within the table. However, you cannot modify, rename, or delete 
the Nor-mal print style. Your changes affect all entities and layers that are assigned 
that print style name. 

Each print style within a print style table specifies a color, pen numbers, linetype, and 
lineweight. progeCAD recognizes additional characteristics for compatibility with 
AutoCAD only, including: dither, grayscale, screening, adaptive, line end style, line join 
style, and fill style. 

When specifying print style characteristics, be sure to consider the limitations of your 
output device. 

To modify print style tables 
1. Do one of the following: 

• •Choose File > Print Styles Manager. 

• •Type stylesmanager and then press Enter. 
2. Double-click the print style table you want to modify. 

3. Click the General tab, and then do any of the following: 

• •Enter a new table description. 

• •Select Apply Global Scale Factor to Non-ISO Linetypes to apply the scale 
factor to non-ISO linetypes used for any print style in the current print style 
table. This also applies to fill patterns, which are not used in progeCAD, but are 
recognized for compatibility with AutoCAD. 

• •Enter a scale factor to apply to non-ISO linetypes used for any print style in the 
current print style table. 

4. Click the Properties tab, and then do any of the following: 

• •Make format changes to a print style by selecting it in the Print Styles list, then 
make color, pen map, linetype, or lineweight changes for the print style. Your 
changes are saved automatically for the selected print style. 

• •Add a new print style by clicking Add Style. Enter a new name, and then click 
OK. Select the options for the print style. (Available for named print styles only.) 

• •Rename a print style by selecting it in the Print Styles list. Single-click the print 
style again, and then enter a new name. (Available for named print styles only.) 

• •Delete a print style by selecting it in the Print Styles list. Click Delete Style. 
(Available for named print styles only.) 
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5. Click OK. 

 
A. Select a print style to modify it.  
B. Enter a description for the selected print style. 
C. Click to create a new print style. (Named print style tables only.) 
D. Click to delete the selected print style. (Named print style tables only.) 
E. Click to modify the list of available lineweights for the current print style table. 
F. Click to save the print style table with a new name or in a new location. 
G. Choose a lineweight for the selected print style. 
H. Choose a linetype for the selected print style. 
I. Type or scroll to the width of the virtual pen for the selected print style (for printers that don’t 
have physical pens, such as laser or inkjet printers). 
J. Type or scroll to the width of the physical pen for the selected print style. 
K. Choose a color for the selected print style. 
 
Printing or plotting your drawing  
After you have configured your drawing and any layouts for printing, you are ready to 
print. If desired, you can preview your page before printing.  

Previewing a drawing before printing  
Viewing a drawing before printing gives you a preview of what your drawing will look 
like when it is printed. This helps you see if there are any changes you want to make 
before actually printing the drawing. 
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To preview a drawing before printing 
1. If necessary, click the desired Layout tab or the Model tab. 

2. Do one of the following: 

• Choose File > Print Preview.  

• On the Standard toolbar, click the Print Preview tool ( ).  

• Type ppreview and then press Enter. 
3. After checking the preview image, do one of the following:  

• To print the drawing, click Print Settings to display the Print dialog box.  

• To return to the drawing, click Close.  

 
A. Click to zoom in. 

B. Click to zoom out. If you have zoomed in several times, click multiple times to restore the 
entire preview image. 

C. Click to display the Print Settings dialog box.  

D. Click to print the drawing.  

E. Click to close the preview and return to the drawing.  
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Printing a drawing  
The Print dialog box is organized by tabs into three functional areas: scaling and 
viewing; color and width mapping; and advanced printing options. The print setting 
options available under each tab were described in the previous sections.  

NOTE: You cannot print a rendered image directly to a printer. To print a rendered 
image, you must first export the drawing to a different format -either a bitmap (.bmp), 
Postscript (.ps), or TIFF (.tif) file -and then print it from another graphics program.  

To print a drawing 
1. If necessary, click the desired Layout tab or the Model tab. 

2. Do one of the following: 

• Choose File > Print.  

• On the Standard toolbar, click the Print tool ( ). If you click the Print tool, the Print 
dialog box does not display. Your drawing will be sent directly to the selected 
printer.  

• Type print and then press Enter. 
3. From the Print dialog box, make any adjustments to the settings. 

4. Click Print.  

NOTE: Instead of using the print settings you saved with your layout, you can select 
Previous Plot in the Use Settings list to print according to the settings used the last 
time you printed. If necessary, you can click Reset to restore the ProgeCAD 
Architecture default print settings.  



 
 

198  4M 

 



 

 

 

 

 

3. AutoREG-Topographical 
 

 

This chapter describes the operation concept, as well as the commands of the 3D 
Topographical Component of ProgeCAD Architecture. All these commands are 
included within the AutoREG group of commands. 

 
Using these commands, the user can easily draw any topographical diagram and then 
edit it and print it. The fact that the AutoREG commands are described below in the 
order they appear in the menu, does not necessarily mean that they must be used in 
this order. 

3.1 Text Parameters 
This command enables you to specify the printing height (based on the printing scale of 
the Topographical component, selected previously in the Plus menu) as well as each 
parameter font, by properly updating the following dialog box:  
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3.2 Select Building Parameters 
The first subgroup includes the option “Select 
Building Parameters”, which you can use to 
select the specific region you refer to, from 
the corresponding library of building 
parameters. More specifically, after selecting 
the above option, a dialog box appears, with a 
list of the pre-selected regions at the left side 
and a list of the building parameters of the 
specific region (building coefficients, coverage 
coefficients, minimum distance from the street 
border, or the neighbour property border etc) 
at the right side. 

All these values will be taken into 
consideration when the topographical 
diagram will be drawn. 

3.3 Grid 
The Grid option enables the user to specify a building grid, which provides additional 
assistance when drawing architectural ground plans. 

The use of this command is not obligatory. However, it is extremely useful, especially in 
cases that you deal with side-lines of a building plot or a building. The option includes 
two secondary options, “Place” and “Modify”, which can be respectively used to 
specify the grid initially and any possible future changes. By selecting “Place” grid, the 
above window appears, in which you can specify the grid. More specifically, in this 
window, you must specify: 

• The angle of the grid with respect to the x-axis (e.g. 0 degrees) 

• The angle of its horizontal (or side) lines 
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• The distances of all 
the grid lines, 
Horizontal and Side. 
For this purpose, 
specify the line type 
in the top part (e.g. 
Horizontal), then, 
specify the value of 
the distance in the 
corresponding box 
and then press “Add”, 
in which case you 
observe that the 
distance has been 
moved to the list on 
the left. Using the 
same method, keep 
adding distances (or modifying-deleting existing ones using the corresponding 
buttons), in order to enter all the desired distances. As soon as you specify one 
group of distances (horizontal or side), you should appropriately change the above 
setting (Horizontal or Side) and specify the rest of the distances. 

• Data concerning the text that will accompany the grid (e.g. digits or letters, 
character height, distance of numbering, position etc) 

If, for example, you specify Distances in the above Grid window, Side 1, 5, 9, 14 
and Horizontal 2, 4, 8, 16 and keep unchanged the initially specified values of the rest 
of the parameters, then you can view the following grid being drawn. 
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Observe that all the relevant details (e.g. line numbering) 
have automatically been drawn. 

Any changes on the grid can be performed through the 
corresponding command “Modify”, where you can change 
any grid parameter and immediately view the result of the 
modification. 

3.4 Specify Points 
This family of commands includes a series of special 
options, through which the user can specify the points of the 
building plot. More specifically, these options are: 

Single Point: Specify a point either by using the mouse or by typing the co-ordinates in 
the bottom part (in any co-ordinate system following 
the rules of progeCAD). More specifically, you can, first 
of all, specify the point using the mouse, by viewing the 
absolute co-ordinates of the position in the top part of 
the screen. You can also specify a new point on the 
screen, with respect to the previously specified point. 
The application “remembers” the last specified point. 
Hence, select “Single Point” in the menu and type its 

relative co-ordinates with respect to the last point, in the command line. For instance, if 
you want to specify the point to be placed 3m along the horizontal axis (x) and 4m 
along the vertical axis (y), you must type @3,4. If you want to place it 3m along, with an 
angle of 45 degrees, type @3<45. Naturally, you can specify negative distances. 

Note: If you want to specify a point with respect to any other point, you should select 
this point and immediately press <Enter> again, so that the grips tool can be activated. 
In that case, specify C (Copy) and type the relative co-ordinates (using the prefix @). 
Deleting, moving, copying etc is performed normally, using the commands of 
progeCAD. 

Distances from two Points: This option is useful in the case that the distances of the 
point you want to specify, from two other, 
already specified, points are known 
(namely, the intersection of two circles). 
As soon as you select it, you are 
prompted to insert the two specified 
points, as well as the two corresponding 
distances. Finally, specify the side (the 
half plane defined by the two specified 
points), towards which the point you want 
to specify lies. After executing all the 
above, the point appears on your screen. 
It is pointed out that the existing points are 
selected using the esnap command and 
the “Reference Point" option. 

Import Points from Tachymeter: It is useful in the case that you deal with a series of 
Tachymeter readings. First of all, you should insert the reference point (the Tachymeter 
position) and following that, all the measured distances successively, along with their 
corresponding angles. 
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Note: The value of the angles is in grades (grad) and their method of measurement is 
in accordance with the user selected method (the application prompts you to define 
whether it is a clockwise or a counter-clockwise method). It is also noted that the "0" 
angle coincides with the x-axis and that all the distances are in m, meaning that the 
scale of your drawing is 1:1 (1 drawing unit corresponds to 1m). 

 
Import from a Tachymeter File: It is useful in the case that you have a file (in ascii 
format) containing the readings of the Tachymeter. The only required action is to 
specify that file and following, specify the start and the length of the data “point serial 
number”, “x co-ordinate” and “y co-ordinate”, assuming that these are located in the 
columns of a text file, each row of which corresponds to the data of one point. As soon 
as you specify the above, you can view the points being automatically inserted in your 
drawing. 

Example: You have the co-ordinates of 5 points from the tachymeter, placed in a text 
(ascii) file using the following rows (for extra help, the 1st, 2nd etc columns appear on 
top): 

1st 2nd 3rd 4th 5th 6th 7th 8th 9th 10th 

1  1 0  5     

2  2 0  8     

3  2 5  1 0    

4  2 8  1 1    

5  3 0  2 0    

As it is illustrated in the example, only the serial numbers (s/n) of the points are 
contained in the first column, the x co-ordinates in the 3rd-4th column and the y co-
ordinates in the 6th-7th column. That is, the co-ordinates of the first point are (10,5), of 
the second point (20,8) etc. 

With the above tachymeter file, and by selecting “Import from Tachymeter File” in the 
application, provide the following responses to the prompts of the application: 

Start of Record of point number: Type 1 (indicating the 1st column, which the serial 
numbers of the points occupy) 

Length of Record of point number: Specify 1 (the s/n occupy the 1st column). 

Start of Record of x co-ordinates: Specify 3 as the start of records (the x co-
ordinates start from the 3rd column). 
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Length of Record of x co-ordinates: Specify 2 as the length (the x co-ordinates 
occupy the 3rd and the 4th columns). 

Start of Record of y co-ordinates: Specify 6 as the start of records (the y co-
ordinates start from the 6th column). 

Length of Record of y co-ordinates: Specify 2 as the length (the y co-ordinates 
occupy the 6th and the 7th columns). 

3.5 3D Building Plot 
Using the “3D Building Plot” group of options, the application enables you to perform 
three-dimensional drawing and representation of your Building Plot, as well as the 
representation of the excavation or the earth fill, calculating the corresponding volume 
of the excavation or the earth fill. More specifically, there are 3 distinct commands, and 
their function is described in the following: 

Place: This command enables the automatic generation of a 3D building plot with no 
need to specify triangles. After specifying the points, which can be vertices of the 
building plot or even intermediate points, select AutoREG>Altitude>Building Plot Point. 
Then, after selecting AutoREG>3D Building Plot>Place, the “Select entities” option 
appears in the command line, where you should select all points by enclosing them in 
the selection window. This automatically generates the triangles on the building plot as 
well as the three-dimensional grid of the building plot. 

 
Running “Shade”, you can shade the image and view the generated three-dimensional 
building plot. 

Contour Lines: You are prompted to select the 3D building plot that you have 
specified, where you want to specify the contour lines. Next, you are prompted to 
specify the “Hypsometric difference of the <1.00> sections” (interval), that is the height 
difference between the curves that will be drawn (default value 1.00 m). Finally, you are 
prompted to specify the “radius of curvature <0.00>”. 

At this point, you can specify if you want, the radius of curvature of the hypsometric 
lines, so that they appear smoother. An example of representing contour lines in a 
ground plan (2D) and three-dimensional view (3D) of the building plot previously 
specified, appears in the following two screenshots:  
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Notes: 

• It is obvious that, the greater the number of the triangles you use to represent the 
morphology of the building plot is, the greater the obtained drawing accuracy of the 
contour lines will be. 

• The contour lines lie in a block. If you explode the block, you can edit each line. 
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Excavation: Using this option, you are requested to initially select the 3D Building Plot. 
Next, the dialog box ”Select Excavation Outline” appears. Select the previously drawn 
polyline, defining the outline of the excavation. Finally the application prompts you to 
specify the Altitude of the building plot (the lowest and the highest points of the building 
plot appear inside the parenthesis, e.g. 0-3), using the excavation outline. This way, 
you can specify the starting depth of the excavation. An example of such an excavation 
for the previously specified Building Plot appears in the following screenshots (hide-
lines and shade are activated). 

 
Note: In a similar way, the application can calculate the volume of rubble filling (earth 
fills). When you are prompted to specify the altitude of the building plot, specify the 
altitude of the final level of the earth fill. If the value of the altitude lies between the 
lowest and the highest point of the building plot, the volume of excavation, the volume 
of earth fill and the difference will be calculated. A positive value of difference 
represents the volume of excavation, while a negative value represents the volume of 
earth fill. 
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Ideal Solid Body: Using this command, you can create the ideal solid body. The 
definition of the ideal solid body presupposes that the plot has been specified as a 3D 
building plot and that the building line has been placed within the building plot, using 
the corresponding command of AutoREG. 

Street: Using this command, you can easily construct the adjacent streets of the 
building plot, which are useful in creating the ideal solid body. 

3.6 Building Plot Definition 
This option involves the definition of the 
building plot, which can be performed 
immediately after the detection of its 
vertices. Its function is simple: After 
you select it, use the mouse to 
successively move to the vertices and 
press the left mouse button. As soon 
as you specify the last point and press 
the right mouse button, you can view 
the sides of the building plot being 
automatically drawn, while the letters 
A,B,C,D etc are printed at the vertices, 
following the order of succession of the 
points defined during the execution of the command. 

Additionally, the dimensions of the sides of the building plot are calculated and 
automatically inserted in the drawing (e.g. AB=15.34). The user can modify the values 
printed on the sides (e.g. approximating lengths) using the DDATTE command of 
progeCAD. The user can change the position of the printed text using the grips tools of 
progeCAD. If the user wishes to modify a vertex of the building plot, he/she must delete 
the building plot and redefine it. To delete an existing building plot, select it and delete 
it using the erase command of progeCAD. It must be pointed out that when deleting a 
building plot, only its sides are deleted (along with the printed distances) and not its 
vertices. 

3.7 Building Plot Measurement 
This option outputs on your screen the analysis of the calculation of the Building Plot 
area in two ways: 

a) Irona’s Method, using 
triangles: By selecting 
“Building Plot 
Measurement”, the 
application prompts you, 
before anything else, to 
specify the position (in your 
drawing), that you want the 
“text” of the calculations to 
be inserted. You are then 
prompted to specify, in the 
desired order, the triangles 
that constitute the building 
plot. Every time you select 
a triangle, the corresponding Irona’s formula is printed on screen. 
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Having defined all the triangles that constitute the building plot and by pressing the 
right mouse button, you can view the total area of the building plot being printed right 
below the individual areas, as a sum of the above separate triangles. The user can 
easily realise the way this command functions with a simple test. 

b) Rect. Co-ordinates: In the alternative case of calculating the area using rectangular 
co-ordinates, the total area of the building plot is calculated and printed in a table, 
along with the table of the rectangular co-ordinates. 

3.8 Building Plot Sides 
This option includes 3 secondary options that can “label” the sides of the building plot 
using one of the three alternative options: 

• Outer Side 

• Border Line 

• Party Wall 

By selecting one of the above secondary options and by “moving” over a side, the latter 
is correspondingly labelled, while, at the same time, the line style changes: Hence, a 
Border Line appears as a dash-dotted line, while a Party Wall appears as a dotted line. 
Apart from the drawing representation, the labelling of the building plot sides is useful 
for automatically specifying the building line of the building plot, in accordance with the 
previously selected building parameters. More specifically: 

• For the Outer Side, the distance of the Building Line is the same with the minimum 
distance from the street border. 

• For the Border Line, the distance of the Building Line is the same with the minimum 
distance from the neighbour property border. 

• For the Party Wall, the Building Line and the Building Plot Line are identical. 

3.9 Building Plot Area 
By selecting “Area”, the area of the building plot appears in the bottom part of the 
screen, in square metres. Additionally, the perimeter of the building plot appears, in 
metres. 

3.10 Adjacent Building Plots 
Using this command, you can edit an adjacent building plot, so long as you have 
specified the points that determine its boundaries, with respect to your primary building 
plot. Hence, you can define the sides of the adjacent building plot, characterise them 
as an outer side, border line or party wall, and even calculate its area and the 
distances from several points of the drawing. In other words, the commands described 
earlier can be used not only for your building plot but also for the other, adjacent, 
building plots. 

3.11 Building Line 
This option can be used for the automatic drawing of the Building Line of the building 
plot, using the information that “exists” in the building plot and the data of the building 
parameters of the selected region. As soon as you select the option, you can view the 
Building Line being drawn within the Building Plot. 
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3.12 Symbol of North 
Select this option to define the position of north in your drawing. More specifically, by 
selecting this option, the symbol of north appears, in order to insert it in your drawing. 
Before inserting it, all the capabilities of progeCAD, involving rotation, can be used. If 
you want to rotate the symbol of north a posteriori (e.g. building rotation), use the 
"Rotate" command of progeCAD.  

3.13 Parallel Line 
Using this command, the user 
can easily draw the streets that 
are parallel to the building plot, or 
any other parallel line. By 
selecting this option, you are 
prompted to specify (using the 
mouse) the line of the building 
plot, with respect to which you 
want to draw the parallel line, 
and, by then moving the mouse, 
you can view this parallel line 
moving simultaneously. When you move the line to the exact desired distance, press 
the left mouse button to freeze the line with respect to the distance, and then specify, 
again using the mouse, the left and right ends of the drawn parallel line. 

3.14 Street Name 
Using this command, you can easily print various street names and other type of text 
on the topographic drawing, parallel to the sides of the building plot, the streets and 
other lines. Select the command, and simply use the mouse to specify the line, which 
you want the text to be parallel to. Then use the mouse to specify the starting point of 
the text as well as the direction of writing of the text. After the above actions, type the 
text which appears on the drawing. Following that, you can “point to” another line to 
repeat the above command and so on, until you exit this command by pressing the 
right mouse button. 
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3.15 Diagonal 
Using this command, you can easily draw a diagonal of the building site or any 
distance in general. You are initially prompted to specify the two ends of the distance 
(you can use the familiar snap tools of progeCAD). After specifying the second end, 
you can view the “diagonal” being drawn using a dotted line and the value of the 
distance appears approximately in the middle of the line. 

3.16 Altitude 
The “Altitude” command is used to insert the altitudes of each 
point of the building site in a small frame. There are two 
distinct secondary options: 

Building Plot Point: Using this command, you are prompted to “Select a point of the 
Building Plot”, that is, to select the point that you want to place at a specific altitude, 
with that altitude printed. To the prompt “Altitude”, specify the new altitude of the point. 

Point: This command is similar to the previous one, used to print an altitude level at 
any point, without the need to select a vertex of the Building Plot. 

3.17 Building Outline 
Using this command, draw the outline of your building, exactly the way you want, with 
respect to the building line. 

As you can see in the following, the building outline can be rough at first, but you can 
modify it later on, viewing at the same time the area of coverage. It is pointed out that 
this command is simple, the same with the polyline command of progeCAD. 

 

3.18 Modify Building 
Using this command, you can easily adjust the outline of your building, exactly the way 
you want with respect to the building line, viewing the Area of Coverage, at the same 
time (real time). You are initially prompted to specify the outline of your building, in 
which case you “move” and “point” it, using the mouse (you must remember that the 
outline of the building must be drawn using the previous command, or the polyline 
command of progeCAD. Next, the application expects you to “capture”, using the 
mouse, a vertex or a side of the building outline and move it to a new position, viewing, 
at the same time, the exact conversion of the shape of the outline as well as the area of 
the building (in the top left part). By comparing the existing coverage with the maximum 
allowed coverage, you can have the final form of the drawing. 
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3.19 Character Size 
This command can be used to specify the size of the characters in the topographical 
drawing. You are initially requested to select either “SET” to specify a new character 
height (prior to writing any new text) or “EDIT” to select the existing text (or parts of the 
text) and then specify the new character height, in which case you can view the size of 
the characters of the selected text being modified. 

3.20 Building Parameters Text 
Using this command, the table of the building parameters of the topographical diagram 
is drawn, in the desired position within the drawing. It is pointed out that the building 
parameters text is inserted in the drawing using the mtext format. Hence, you can edit it 
using the modify text command (see below). You can also modify the main file 
(c:\PA10\lang\en\region\topo.txt), so that the building parameters are inserted in your 
drawing the way you want. 
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3.21 Coverage Diagram Text 
This command can be used to draw the text corresponding to the coverage diagram, in 
the desired position in the drawing. The capabilities of the command are the same with 
the “building parameters text” of the previous section. The main text file in this case is 
(c:\PA 10\lang\en\region\rules.txt). 

 

3.22 Modify Text 
This command is used to edit building parameters text and coverage diagram text, after 
they have been inserted in your drawing. The function of the command becomes 
obvious with a simple test. 
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4. AutoBLD: General 
 

 

As mentioned in Chapter 1, the option group AutoBLD includes the drawing commands 
of the Architectural application, or in other words the drawing tools that are necessary 
for the Architectural drawing, its editing as well as the creation of the project drawings.  

 
As it is shown in the AutoBLD menu, the various options are divided into sub-groups 
which include project parameters, drawing commands of the building elements, library 
management instructions, viewing commands of the project drawings and many other 
commands. Most of these commands can also be selected through ProgeCAD 
Architecture toolbars and icons. 
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The options listed in the first section are described one by one in the following sections 
of Chapter 4, starting from the "Building Definition" option. 

4.1 Building Definition 
First of all, press <Enter> in the "Building Definition" option and the level management 
menu will appear. 

 
In this screen you can specify the floors of the project building by defining the height-
level for each Level (floor). More specifically: 

In the "Level" field, define the floor number. 

In the "Elevation" field, define the height of the floor level. The user may define 
manually a benchmark for level measurement (e.g. the pavement). You may also 
define negative levels (e.g. -3 m). 

In the "File" field, define the path and the name of the relevant DWG drawing-file, only 
if you refer to an already existing drawing (which means that you do not intend to draw 
the ground plan from the beginning). If there is no DWG architectural drawing available, 
you may leave the filename blank. In case there is no DWG file but a DXF file instead 
(if the ground plans are created by applications other than progeCAD), you will have to 
convert them first into DWG files, running the command DXFIN of progeCAD, and then 
insert the DWG files using the aforementioned option. 

You can insert and manage the ground plans with the use of the progeCAD xref 
command. Note that the files are correctly inserted when you can "Open" them with 
progeCAD (e.g. no missing fonts or menus).  

At the bottom of the dialog box you can see three available functions, which are 
actually used for managing the floor files. More specifically: 

• Press the “New” button to save a new building floor or the changes in the data of a 
floor. 
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• Use the "Current" option to select the ground plan/file you want to work on each 
time. 

• Select the "Delete" option to delete the selected floor (by clicking on it). The 
command "Erase" removes the ground plan of the relevant floor from the project. 

Note that the various ground plans should have a common reference point. 

4.2 Layers Management 
This option enables the user to define in a quick and very practical way (during 
working) the logical minor drawings of the ground plans (layers). More specifically, if 
you select "Layers Management", the following screen will appear: 

 
The user may disable whichever element group he/she wants to by simply clicking the 
indicator-box of the relative group. When the box is checked, the relative group is 
enabled. As shown in the screen, the layers that can be modified by the user (disabled 
or enabled) are those of the basic elements (Walls, Columns, Beams etc), the special 
structure elements (staircases, handrails etc), other auxiliary elements (Dimensions, 
hatch) and other informations. Furthermore, the "Plan View" & "3D View" indications, 
which cannot appear at the same time at the bottom left part of the screen, assist the 
user to manage the layers in either the ground plan or the 3D view, displaying at the 
same time the appropriate indication at the bottom. With a simple test the user may 
easily understand the utility of this command. 
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Note: In fact, the above option enables the user to avoid the progeCAD "Set Layer" 
command, which can also be used though it has proved to be very unhandy because of 
the large number of layers (in conjunction with the floors). 

4.3 Copy Building Floor 
This option is used when the architectural data of a floor should be copied to another 
one (e.g. in case of typical floors or when data should be transferred from one floor to 
another). If the above option is activated, you will be prompted to specify the parts of 
the "current" ground plan that you want to paste on another floor (you have also the 
option to copy the whole ground plan or a part of it – if you type "All" in the command 
line the entire ground plan will be selected). Then right click (which means that you 
have specified the parts) and insert the floor serial number at the bottom of the screen 
where you are prompted to do so. After you have completed the actions described 
above, you can see a new floor ground plan created on the screen. 

4.4 Copy Entities 
This option enables the user to copy any building entity (e.g. an entire wall, space, wing 
etc) on any other location. As soon as you run this command, you are prompted to 
select (through "select") the entities that you want to copy, then the reference point (like 
in the progeCAD "copy" command) and in the end the final copy point. 

4.5 Typical Elements 
First of all, select the "Typical Element" option and a list with the structural elements, 
which are going to be used in this project, will appear. 

This means that the user should select from the library the structural elements that 
he/she wants to use in the project. The typical elements should be organised before 
starting to draw and, as you will discover later, this is particularly useful for linking to 
the calculation environment. It should be noted that the pre-drawing typical elements 
are transferred to the calculation typical data, which structures and simplifies the whole 
procedure. More specifically, five types of structural elements are included in the typical 
elements: 

• OPENINGS 

• OUTER WALLS 

• INNER WALLS 

• FLOORS 

• CEILINGS 

Each category contains (by default) a list with specific structural elements selected 
from the libraries. The user may use them as they are, but of course he may modify 
them or select new ones from the libraries and add them. For example, if you select 
“Typical Outer Walls” the following window will appear on your screen: 
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If you select (by left clicking) a typical element (existing or blank) so as to “highlight” it 
in the list and then click the button “Library”, a list of structural elements from the 
program libraries will appear (if it overlaps the previous list you can move it just like any 
other dialog window) from where you can select the desired element. In order to do 
this, left click to select and then click “OK” at the bottom. 

The afore-mentioned instructions apply to every type of structural element, that is to 
say for the inner walls, the openings, the floors and the ceilings. Regarding the walls, 
the floors and the ceilings in particular, except the characteristic average thermal 
conductivity coefficients k, you can specify the accurate thermal conductivity 
coefficients as well, by assigning a specific heat-insulating sheet to those walls. 

Note: The double characterisation regarding the k of a wall is the key for the 
simultaneous elaboration of a heating – air-conditioning system (link to the E/M 
FINEHVAC package). 

4.6 Element Parameters 
The typical elements described above consist the basis of the structural elements 
which will be used in a specific project. You can pick any "Typical Element" out of the 
"Element Parameters" and draw it. 

In the "Element Parameters" you can define the current condition for each of the 
options "Wall", "Opening" etc. So, if you draw a structural element, it will automatically 
obtain all the features, which have been defined in "Element Parameters". 

The option "Element Parameters" includes also other options (e.g. viewing parameters, 
text appearance parameters etc). More specifically, the options available in the 
"Element Parameters", in the order they are displayed, are the following: 

Architectural Text Parameters: This option enables the user to select the 
printing height (based on the printing scale of the Architectural Drawing, predefined in 
the "Plus" menu) and the parameters font as shown in the following dialog box: 
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Outer wall: Use this option to select the 
type of the current wall, by pressing the button 
"Type". Depending on the selected wall type, 
the relevant features appear in the window 
(Coefficient k, wall colour, weight and type by 
Ashrae). Furthermore, in the same window, the 
user may specify the current value for the 
height and the thickness of the wall, the 
colours of the wall on the screen (for 3D or 
2D), the height of the beam suspension as well 
as the existence of insulation in the wall. The 
user can define the wall type (‘’Linear’’ or 
‘’Acr’’) as well as whether he wishes the unions 
of walls to be cleaned or not. More specifically, 
the options for the wall parameters are 
described below: 

3D Color: The option "Color 3D" is double 
because it refers to both sides of the wall 
(inner and outer), as it is necessary to 
associate different materials to both sides in photorealism (in the case of PhotoIDEA). 
More specifically, by selecting "Color 3D" the following window appears: 
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The user can select colour and material at the same time since each colour is 
associated automatically with a specific material (the order of the materials in the 
above screen is indicative). Note that the selected colour will be used in shading or 
photorealism (through the "render" command), while the material will be used in 
photorealism through PhotoIDEA. Of course, photorealism with PhotoIDEA is by far 
superior, since materials have texture as well. After you have associated walls with 
materials in "Wall Parameters” from the beginning, you can create the conditions for 
the almost automatic construction of photorealistic images through PhotoIDEA, 
provided of course that it is included in your package. Finally, note that, as in the case 
of walls, you can define as well the materials for all the other elements (e.g. window 
casings, rails, handrails) in an entirely similar way, something that you will have to 
repeat many times. 

Color 2D: The option “Color 2D" enables the user to select the desired colour of the 
walls in the ground plan. The default colour is set to magenta (which corresponds to a 
0.6 pen in the default colours of progeCAD). The user can select a different colour from 
the relevant colour palette which appears: 

 

Insulation: The option "Insulation", which is disabled by default, provides the 
possibility to make the insulation visible on the specific wall. If you check the relevant 
box (with the mouse), you can select the button "Insulation", and the following window 
will appear: 

 
In this window you can define (in m) the exact insulation thickness (e.g. 0,05 m) as well 
as the distance from its outer side (e.g. 0,10 m). As a result, a double line with the 
above geometric parameters will appear within the wall. In case that you want the 
insulation drawing displayed within this double line, you only have to enable the 
"Drawing" frame and "Select" among the various drawing types appearing in slides. 
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Note: Because of the fact that the insulation in the wall "impedes" the drawing in 
a way, it can also be defined afterwards through the command "Modify Wall" 
(one or many). 

Beam: The "Beam Suspension" serves the collaboration with STRAD, the structural 
analysis program of 4M Suit. This way you can define the beam type, exactly as for the 
wall, as well as the suspension height (in m), elevation (in m), width (in m) and color. 

 
Fixed Side: The user can define the side of the wall where the beam will be positioned. 
This side could be the fixed side of wall (the side wich the wall was drawn) and the no 
fixed side (the side wich the wall grew during the drawing).  

Connection with Roof: Enabling the “Connection with Roof” dialog box, the user can 
connect a wall with the roof, so that the wall is not necessarily rectangular but so 
shaped that is limited on the upper side by the roof (e.g. in the case of a two-sided roof 
where the side walls generate a triangular space along with the roof). Pressing “Roof <” 
in this dialog box, a message in the command line prompts the user to select roof; 
then, the wall properties window appears, where pressing OK leads to the desired 
effect. 

Scotias: The user can define scotias on the wall as follows: 

• First, by choosing the positioning of the scotia on the upper side of the dialog box. 
The alternative options are a) fixed side (of the wall) only, b) no fixed side, two 
sides equal, two sides different. 
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• Then, by defining the elevation, height and depth of each scotia from the menu. By 
filling in a set of values on the lower side and by pressing the “Add” button, these 
values are trasfered to the “Fixed Side” (or any other above selected case) of the 
wall. 

Hide Horizontal Lines: This option is also enabled by the “AutoBLD>Project 
Drawings>Hide lines between walls-slabs" command as the user can hide the 
intermediate line that appears during the generation of side views and cross sections 
and contributes to a non-uniform result. Then, by double-clicking on the desired wall, 
you can see that the “Hide Horizontal Lines” dialog box is active; therefore, if you press 
“Define”, the relative window appears. 

Thus, you can see the properties of the points of the wall sides. Pressing “Display” 
opens the drawing where the line you chose to hide appears dotted. If the line is 
incorrectly specified, you can delete it by selecting "Delete".  Moreover, you can add or 
modify a line. In this case, you are prompted, via relative messages in the command 
line, to specify the 1st point and, then, the 2nd point so that the line properties are 
inserted in the relative window. 

 
Inner wall: All the above apply here too, plus an additional option in which the user 
may define the wall type, whether it is "inner" (which means it is adjacent to a heated 
space) or "inner to a non-heated space". This information is quite useful in case there 
is a link to FINE-HVAC, the Heating-Cooling Program. 

Window: You can specify the window type and its features will be automatically 
defined according to k, the glass coefficient and the frame type. Furthermore, you can 
define the window geometric parameters (height, rize, etc) as well as its exact 
morphology. In particular, the appearing dialog screen is the following: 
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This dialog includes two options: 

3D Drawing: Enables you to choose the type of the window. As far as this type is 
concerned, there are two alternative ways of defining windows, which practically cover 
every need. 

• Parametrical Window: In order to define a window in this way you need simply to 
select the option “Selection” and select a window drawing (as a result, the 
following screen appears): 
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Through this screen, you can choose a window type and then click “OK” in order to 
locate it at the previous dialog. Before any selection you can see the different types of 
windows on the left or by using the keys “Next” and “Previous”, the PgUp/PgDn keys 
and so on. In addition you can sort our windows according to the categories that are 
defined, in order to speed up the selection procedure. Finally, you can see all types of 
windows either on their 3D or 2D form, by selecting accordingly the representation 
mode up on the dialog. For example, if you select the 2D representation, the following 
screen will appear. 

 
• Parametrical Window of the user: This option enablesyou to select a window 

type that has been drawn freely from the user. That drawing from scratch procedure 
is described in a subsequent paragraph, in the instruction “Open”>”Library” along 
with a comprehensive example. 

The “Slide Type” radio button enables you to view either the slides or the photorealistic 
images of the windows. Finally, through the key “Characteristics” the following dialog 
appears: 

 

progeCAD Architecture  223 



 
 

Within this dialog you can define the properties of the casing (if there exist or not, 
width, thickness, 3D colour etc), the frame properties (width, thickness, 3D colour), the 
openness percentage (how much the opening is open) concerning both, 2D and 3D 
representations. You can also define the glass properties (thickness and colour) and 
the properties of the cubits (width, thickness and colour 3D). In addition, you have the 
two options “Reset from local block” and “Reset from general library”. The first option 
enables you to give to a certain opening the default properties from the library. For 
example, if you have changed the properties of an opening within a project drawing you 
can “recall” anytime the default properties from the library. In general, any changes 
implemented on the openings from the menu AutoBLD>Opening>Library are updating 
the user opening library. However the openings of a current project drawing are not 
affected in any way, which means that they keep their own local definitions. If you want 
to update from the user library an opening that has been already located within your 
drawing, then you have to select “Reset from general library”. Finally, through the 
selection “frames” you can see the number of frames which constitute the specific 
window. You can either select a certain material, or modify the material of a specific 
frame during defining the way of opening. The option ”Colours of a library opening”, 
which is located at the lower part of the window is activated in case that the type of one 
of the opening frames has been defined as from the library. Within chapter 5 you can 
find detailed instructions regarding these frames, defining the way of opening firstly and 
the window secondly. The user can easily understand all these functions through a few 
simple examples. 

Note: The option “Material” is activated if the type of the selected frame is “fulfilled”’. 

Apart from the options described above, the initial window dialog includes the following 
options, as well: 

Justification: It justifies the casing relatively to the one or the other side of the wall, 
practically by entering the appropriate distance (zero or greater) with respect to the 
side of the wall (1st or 2nd). In case you select “center” the casing is centered cross the 
wall (along its thickness). The frame justification justifies the frames relatively to the 
one or the other side of the casing, through the appropriate distance (zero or greater). 
If you select “center”, the frames will be centered with respect to the width of the 
casing. 

Include in the lighting/ventilation control: You define whether you want to include 
this window in the lighting/ventilation calculations and control, or not. 

Shutters: This option is used in order to define whether there are shutters on the 
windows or not. In particular, you have the following options:  

• No Shutters 

• Parametrical shutter: Through this selection you can choose one of the shutter 
types included in the application. You just have to click “select” and the following 
screen appears: 
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Here you can select any type and bring it at the previous screen by clicking "ΟΚ". 
Before any selection, you can go to the next or previous page in the shutter library, 
using the keys “Previous” and “Next”. In addition you can sort the types according to 
the categories that you have defined, in order to speed up the selection procedure. 
Finally, you can see the shutters, either on their 3D or 2D representation, by selecting 
respectively the mode of representation on the upper side of the dialog. If you select 
2D representation, the following dialog will appear: 
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• User’s parametric shutter: This option is used for selecting a certain type of 
shutter among those that have been freely defined by the user. The procedure for 
defining the shutters is described below (see instruction “Opening”>”Library” along 
with a comprehensive example. 

Through the “Shutters” option you can define if you prefer to view the shutters as slides 
or as photorealistic images. Finally, the key “Properties” leads to the following dialog. 

 
Through this dialog you can define the thickness and colour of the frame, the location 
and the leader (rail) of the sliding opening (it is activated in case of a sliding shutter), 
the alignment and the distance of the frames from the side of the casing, the openning 
percentages concerning both, 3D and 2D representations. Also the shutter material 
and the way of opening of the 2nd and 3rd panel of the shutter (in case there are more 
than 2 panels). Finally, the option “Modify opening side” is used to define the direction 
of the opening side in case you want to change the default value. The selections 
“Reset from local Block” and “Reset from General Library” are used to modify the 
properties on the shutters that you have introduced in the drawings, as already 
mentioned above in the window properties. 

Window-Sill: Through this option you can define whether you will 
have a window-sill or not. In the first case, the fields thickness, 
projection 1, projection 2 and colour 3D are activated, ready to get 
the desirable values by the user.  

Cornice: Check the relevant box and click the button “Cornice” to 
place a frame around the opening with the parameters appearing 
in the adjacent dialog box, which appears. In this dialog you define 
the side where the cornice is going to be located (1st, 2nd or 
double), as well as the width, the thickness and the colour of the 
cornice. 
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Label: The indication “Label” is also found at the bottom, on 
the right. Click this button and the adjacent dialog box will 
appear. Click the button “Type” and the label type group (in 
slides) will appear, from which you can select the one that 
you desire. Furthermore, at the bottom you can add the value 
for the Scale as well as the relevant words for the 
construction material. When the scale is 1, the label is 
adjusted to the usual size of the previous version (for 1:50). 

Down on the left, there are two more options “Turn X” and 
“Turn Y” respectively, which can be used for the rotation of 
the window on the plan view. Also, the selection “Draw 2D” 
which is used for declaring whether you want the window to 
be drawn on the plan view or not.  

Door: You can define the type, the height and the length of the door as well as a 
series of additional items for which apply what is mentioned above for the windows. 

 
The selection of the door drawing is defined through the program libraries (parametrical 
or user parametrical), after clicking “Selection”, exactly as you did for the windows, as 
well. The screen that appears is the following: 
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Respectively, for the ground plan drawings the first screen is: 

 
As far as the other features are concerned, apply the afore-mentioned for the windows. 
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Opening: Everything mentioned above, regarding the windows, applies in this case 
as well. Note that the options ‘’Properties’’ and ‘’Shutters’’ are disabled for “Openings’’. 

 
Floor: The "Floor" features concern, first of all, the type which can be selected from 
"Typical Elements" with the use of the "Type" button-command (consequently you can 
see the coefficient k, the colour and the weight, which are features used when link to 
FINEHVAC program is established. You can also select one of the three floor types, 
"Towards Soil", "Towards Non-Heated Space" and "Towards Heated Space". This 
information can also be used for link to FINEHVAC. 

 
Ceiling: Similar to "Floor", the "Ceiling Parameters" concern first its type, which is 
selected from the "Typical Elements" with the use of the "Type" command-button, while 
you can at the same time select one of the four types "Towards External Environment", 
"Towards Non-Heated Space", "Towards Pilotis" and "Towards Heated Space".  
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Dimensioning: This command leads to the dialog box with the dimensioning 
parameters, where the user can define the desired dimensioning parameters. More 
specifically, the user can modify the appearance of the distances between the text and 
the dimensional lines, the text position, the height, the arrows, the colours of 
dimensions and lines etc. Furthermore, the “Modify Dimensioning” command enables 
the user to modify the features of an existing dimension in the drawing a posteriori. 
Finally, with the "User Arrow" option, 2 new dimension endpoints are available: 
4mt1.dwg and 4mt2.dwg. 

 
Viewing: The "Viewing" option enables the user to specify the "angle" from 
which he prefers to view the 3D image. In other words, the "3D View" command 
at the bottom of the ProgeCAD Architecture option group, respects the specified 
viewing features. In order to specify the viewing angles, simply define the two 
angles displayed on the screen: 
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You can specify these angles in the above window either by typing the corresponding 
values or by "moving" the mouse directly on the graphical readings and right clicking 
the desired point. It is made clear that the viewing angle from the Χ axis is the viewing 
direction of the user in relation to the horizontal level and from the Υ axis in relation to 
the vertical level. Moreover, you can enable (with check) in the same window the “Hide 
Lines” option, so as to hide automatically the lines in the “Project Drawings” (views, 
sections, perspectives etc). 

Note: When “Hide Lines” is enabled, the appearance of the project drawings on the 
screen is naturally delayed. Thus it is better not to enable the “Hide Lines” in the above 
window, but hide the lines at will, by typing the command "Hide" of progeCAD in the 
command line. 

Show information in the status bar: If you select  this option a dialog box 
will appear where you can enable (with check) the fields "version" and "floor" 
respectively, in order to see at the bottom (status bar) the version of the current 
program as well as the floor in which you are working (current floor). 

Miscalleaneous: If you select “Miscellaneous” a dialog box with the following two 
options will appear: 

• Display dialog box before drawing: When you enable this option (by checking 
the box), before drawing an element, a dialog box appears with its “Parameters”. 
For example, whenever you want to draw a wall the “Wall Parameters” dialog box 
appears, in order to select the desired features and then continue to draw the wall 
by clicking “OK”. Depending on your convenience, you can make your selection in 
this window. 

• Length of seagments (circular section): It is the default value concerning the 
length of a circular section according to what is mentioned in the drawing of a 
circular wall. 
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4.7 Project recognition commands (xref) 
The project recognition commands group includes specific “recognition” commands of 
the ground plan sections, in order to minimise the time needed for redefining (creating 
entities) an architectural ground plan, which was created by another architectural 
application (except ProgeCAD Architecture). These commands mainly concern 
snapping of wall and opening angular points, so as the structural elements of an 
existing ground plan are "copied" with only a few movements, becoming an entity, that 
is "obtaining" the current features of the AutoBLD structural elements.  

• Outer Wall Outline: This command enables the user to define easily the building 
outline and consequently its outer walls. With this command, the program asks for 
sequential points of the outer outline, while at the same time the edges (junctions) 
of the walls are automatically snapped. When the points are successively defined, 
right click and the drawing of the wall with its current parameters will be added over 
the existing architectural drawing (xref). 

• Inner Wall Outline: This command is similar to the previous one, using an inner 
outline in this case. 

• Window from xref: Primarily you are prompted to determine the wall and then the 
two window edges. Snapping is performed automatically and the window is 
positioned on the wall creating an architectural xref window entity. Follow a similar 
procedure for the commands of the door, the opening and the sliding door from 
xref. 

4.8 Building Exploration 
This command enables an even more dynamic drawing since it allows direct switching 
among the side views, the axonometric projections, the perspective projections, the 
cross sections and the plan views which have been created. Moreover, the fact that, for 
each modification applied on the plan view, the other drawings are automatically 
updated constitutes an unquestionable time-saving advantage, which relieves the user 
from the need to create the relative drawings (side views, cross sections, perspective 
projections) from the beginning. 

 

This command is activated by pressing the “Building Exploration” icon ( ) in the 
“Drawings” toolbar; thus, the adjacent window appears on the screen. The options 
included in this window are: “Side Views”, “Axonometric Projections”, “Perspective 
Projections”, “Cross Sections” and “Plan Views”. All the user-created drawings are 
listed in this window, after the name defined by the user during creation. 

Thus, switching between the various building drawings is quite simple. It is important to 
mention that each time the user selects one of these drawings, any changes applied on 
the plan view are displayed on the selected drawing. 
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5. AutoBLD: Basic Elements 
 

 

This chapter refers to the drawing commands for the basic structural elements (walls-
openings-columns-slabs-beams), which can be found in the second subgroup of the 
AutoBLD menu. Each command is described and analyzed separately, so that the user 
can understand its function completely. It is pointed out that chapter 5 also presents 
the "Symbol Libraries" command, with which you can transfer symbols from the 
program libraries into the architectural drawing. 

5.1 Wall 
If you want to draw or edit walls (or wall outlines) select the option "Wall", which can be 
found in the second subgroup of the AutoBLD option group. This option includes the 
sub-options "Outer", "Inner", "Outer wall from polyline", "Inner wall from polyline" and 
“Outline” as well as the sub-options "Modify", "Delete", "Extend", "Break", "Join", "Trim" 
and "Move". The first group deals with the wall drawing, while the second with their 
further processing after having been drawn. Finally there is also the option "Elevation 
of Merge Intersection", which affects the drawing structure as you will see hereunder. 
In the following sections each group is described analytically.  

Note: After enabling the option "Show Dialog Box before Drawing", which can be found 
in the "Parameters -> Miscellaneous", each time you select the wall drawing option, the 
"wall parameters" window appears automatically. Alternatively, you can (with the above 
option disabled) first enter the "Wall Parameters" and then the "Wall Drawing" either in 
the normal menu or, much easier, in the command menu which is on the right side of 
the screen. However, it depends on the user's preference to enable or disable the 
above option, since in the various architectural programs both alternatives are 
possible.  

5.1.1 Wall Drawing 
The type of wall that will be drawn using the corresponding command is the one which 
corresponds to “Wall Parameters”. More specifically, the wall drawing commands 
function as follows: 

Outer wall (straight / arc): After you have activated the command (by pressing 
<Enter> in the menu), you are prompted to enter successively: 

i) the starting point of the wall (the application message in the command prompt is: 
‘’Wall start \ Relative to wall \ Toggle shape <Linear>’’ 

ii) the ending point of the wall (the application message in the command prompt is 
‘’Wall end \ Relative to wall \ Toggle shape <Linear>’’ 
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iii) the direction towards which the wall will grow, by entering any point on one of the 
two half-planes defined by the wall line (the application message in the command 
prompt is "Enter Side Point"). 

 
After the above described actions, you can see that the wall has been drawn and that 
you can continue to draw another wall starting from the ending point you defined 
earlier, unless you right click, which means that you want to stop. You can change the 
wall drawing from linear into circular, by typing T, in the following program prompts, and 
pressing Enter. As you can see while you are drawing, the feature of consecutive wall 
drawing is very convenient because it requires fewer moves. As mentioned earlier, in 
the “Element Parameters” section, the thickness of the wall, its height and its level in 
relation to the floor level (when the level is 0, the wall starts from the floor), will have 
the values stored in the “Element Parameters” for the wall. 

You can deal with all possible cases of walls with different heights by entering the 
proper values for the wall height and level. 

In the following sections, the techniques for constructing walls and all the relevant 
features of the application are described in detail: 

a) Simple Wall: After you have defined the first point of a wall and as you are moving 
to define the second point, in the coordinates system, you can see the length of the 
wall being drawn as well as the angle towards which it is drawn. The user can provide 
a number for the size of the wall he/she draws, either in Cartesian or polar coordinates, 
in the same way as in progeCAD. For example, if you want to draw a horizontal wall 
that is 2 meters long, in the command prompt:  

‘’Wall end/Relative to Wall \ Toggle shape <Linear>” 

type: 

@2<0 

and you can see that the wall shown on the right is drawn. 
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Nevertheless, if you know the point where the end of the wall 
lies with respect to the initial point (relative distances Δx and 
Δy), you can type: 

@2,3 

which means that the distance between the first and the 
second point is 2m along the x-axis and 3m along the y-axis. 
In this last case, the wall that is drawn is the one shown on 
the right. 

b) Connect to another wall: If you want to connect a wall to 
another wall, you can use the special snap features ("osnap") provided by progeCAD. 
In this way, you can activate osnap by pressing 
the middle button of a 3-button mouse (or by 
holding the key <Shift> down and right click 
with a 2-button mouse) and select either the 
end or the middle of a wall or bring the wall in a 
position vertical to another one or provide the 
nearest point etc.  

For example, if you activate the “Wall” 
command, define the first starting point of the 
wall so that it falls exactly upon the bottom right 
endpoint of the previous one (using osnap – 
"ENDPOINT") and provide the growing side. 
Then, you can see the two connected walls, as 
shown in the adjacent example. 

Moreover, you can join two walls by grabbing the grips of the first wall and moving it 
onto the point you want on the second wall. Thus, you can move, expand etc walls 
using only their grips as if they were simple lines. 

As you can see, when the "Cleanup Join" option of the External Wall tab is checked the 
program can automatically erase the wall joint. Furthermore, it should be pointed out 
that the program performs the joint even if you do not ”grab” a point using the snap 
points ("osnap") but one of the points (starting or ending) simply lies within another 
wall. 

c) Create a wall in a position relative to another wall: With this option you can view 
the distance from the end of the wall with which another wall will be connected. More 
specifically, if you select the ”Wall” option and press ”R” (for "relative"), you will be 
prompted to move the mouse and select an existing wall (either from the inner or the 
outer side and towards the left or the right side). As soon as this happens, the graphics 
cursor automatically acquires the direction of the wall and the coordinates on the top of 
the screen indicate the distance from the end of the previously selected wall. Moreover, 
the 0 point (that is, the point where the value for distance is zero) is exactly the end of 
the wall that is lying towards the side you selected the wall. In this way, the newly 
created wall can have the exact relative distance you want with respect to the other 
one, with no effort at all. Apparently, this feature (viewing the desired relative distances 
on the screen during drawing) is extremely useful and in a similar way you can draw 
inner walls or openings on walls. 
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Outer Wall from Polyline: This option enables the user to specify more than one walls 
simultaneously or an outlined area (or outline). This command is much alike the option 
"Outline", which is described further down. The only difference is that, using this 
command, you just have to draw the room outline using a polyline. If you want to close 
the polyline, just type ”c” (letter c) in the command line of AutoCAD or progeCAD (at 
the bottom of the screen), and you will see the polyline closing on the screen (that is, 
the last line is automatically drawn) and the only action left is to specify (with a single 
point) the side towards which you want the walls to grow. The program prompts you to 
delete the polyline used as a guide for the wall drawing. 

Inner Wall: This command is similar to the “Outer Wall" option. While drawing an inner 
wall, the feature mentioned above for the outer wall is very helpful. 

Inner Wall from Polyline: This command is similar to the “Outer Wall from Polyline’’ 
option. 

Outline: This option enables the user to define more than one walls simultaneously or 
an outlined area (or outline). Begin by providing the starting and the ending point of 
each wall (consecutively) and then the side (outer or inner) towards which you want the 
walls to grow.  

If you want to close the outline, just type ”c” (letter c) in the command line of progeCAD 
(at the bottom of the screen), and you will see the outline closing on the screen (that is, 
the last line is automatically drawn) and the only action left is to define (with a single 
point) the side towards which you want the walls to grow. 
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5.1.2 Editing Wall Data  
The commands you can use to edit the wall data are the following: 

Erase: There are four ways available for deleting a wall: 

1. After selecting the wall or the walls to be deleted, press Delete on the keypad. 

2. If you select AutoBLD > Wall > Erase the Erase command, which is described in 
the following sections, is executed. 

3. Execute the Erase command of AutoCAD or progeCAD. This command is 

executed by selecting the relevant icon ( ) from the toolbars or by selecting 
Modify -> Erase from the menu or by typing "erase" in the command line and 
pressing Enter. The command prompts in cases 2 and 3 are: 

• Select entities to delete: Select the wall or the walls you want to delete and then 
press Enter or right click. 

4. After selecting the wall or the walls you want to delete, right click and select Erase. 

Modify: Using this command, you can view the parameters of existing walls or even 
modify them if you want to. As soon as you activate the command, you only need to 
move to the relevant wall. Then, a window with the wall parameters appears. 

 
These parameters are exactly the same with the ones appearing in the ”Element 
Parameters” window, mentioned in the previous chapter, with two additional lengths for 
the wall (the outer and the inner length). The user can modify any of the above 
parameters (e.g. insert insulation to a single wall, modify its height etc). 
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This command is also activated by selecting the desired wall (left click) and then right 
click and select Properties or even by double clicking on the desired wall. 

Enabling the “Connection with Roof” dialog box, the user can connect a wall with the 
roof, so that the wall is not necessarily rectangular but so shaped that is limited on the 
upper side by the roof (e.g. in the case of a two-sided roof where the side walls 
generate a triangular space along with the roof). Pressing “Roof <”, a message in the 
command line prompts the user to select roof; then, the wall properties window 
appears, where pressing "OK" leads to the desired effect. 

Multiple Change: This command is similar to the previous one, with the difference that 
you can make mass modifications to the walls, e.g. alter the height of all the walls on a 
certain level. If you select with the mouse 2 or more walls, the following dialog box 
appears, in which you should activate the field you want to modify (e.g. height) and 
insert the new value. Click "OK" for the corresponding updates to be performed: 

 
This command is also activated by successively selecting via left clicking the desired 
walls and then by right clicking and selecting Properties. 

3D Colors alternation: Run this command to alternate the materials on the sides of a 
wall, that is, the inner side becomes outer and vice-versa. The utility of this command is 
obvious in case of photorealism. 

Change Fixed Side: Use this option to change the fixed side of a wall. It is pointed out 
that the "Fixed Side" of a wall is the side from which the wall thickness is filled 
vertically. The material assigned to the fixed side is the one that will be applied to the 
wall side as well. 

Move: There are four ways available for moving a wall: 

1. Using the grips that appear as soon as a wall is selected. To move a wall using the 
grips, you should first select the wall in order to make the grips appear and then 
click on a grip and drag it. The grip selected depends on the type of the wall you 
want to move. For example, to move a linear wall, you should select the grip that 
lies in the middle. To move a circular wall, you should select the grip that lies on its 
centre. 

2. Selecting AutoBLD > Wall > Move executed the Move command mentioned also 
further down. 
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3. Executing the Move command of AutoCAD or progeCAD. This command is 

executed by selecting the relevant icon ( ) from the toolbars or by selecting 
Modify -> Move from menu or by typing "move" in the command line and pressing 
Enter. The command prompts in cases 2 and 3 are: 

• Select entities to move: Select the wall or the walls you want to move and then 
press Enter or right click. 

• Vector (V) / <Base point (B)>: Specify a fixed point on the entities you want to 
move. 

• Displacement point: Specify the point where you want to move the selected 
entities. 

4. After selecting the wall or the walls you want to move, right click and select Move. 
The prompts appearing in the command line are the same as the ones mentioned 
in the previous case, starting from the second one. 

Stretch: There are four ways available for changing the size of a wall: 

1. Using the wall grips. To stretch a wall using the grips, you should select the wall, for 
the grips to appear, and then click on a grip to activate it. This grip is equivalent to 
the base point which is also described further down. Then, you should move the 
grip to a new position. The grip selected depends on the exact item that you want 
to change. For example, to modify the angle of two walls that join, you should 
select the grip that lies on the angle. To stretch a wall, you should select one of the 
end grips. 

2. Selecting AutoBLD > Wall > Stretch executes the Stretch command mentioned also 
further down. 

3. Executing the Stretch command of AutoCAD or progeCAD. This command is 

executed by selecting the relevant icon ( ) from the toolbars or by selecting 
Modify -> Stretch from the menu or by typing "stretch" in the command line and 
pressing Enter. The command prompts in cases 2 and 3 are: 

• Select entities to stretch by crossing window or crossing polygon: Select the 
wall or the walls which size you want to change and, after finishing, press Enter 
or right click. 

• Base point of displacement: Select the base point with respect to which the size 
will be changed. 

• Second point of displacement: Specify the displacement point where you want 
to select the base point in the previous step to be moved. 

4. After selecting the wall or the walls to modify the size, right click and select Stretch. 
The prompts appearing in the command line are the same as the ones mentioned 
in the previous case, starting form the second one. 

Note: The entities crossing the selection window (rectangular or polygon) are 
stretched. The entities fully enclosed within the selection window are just moved. 

Extend: There are three ways available for extending a wall: 

1. Using the grips that appear as soon as a wall is selected. To extend a wall using 
the grips, select the wall and when the grips appear click one of the end grips and 
drag it to the point up to which you want the wall to be extended. 
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2. Selecting AutoBLD > Wall > Extend executes the Extend command mentioned also 
further down. 

3. Executing the Extend command of AutoCAD or progeCAD. This command is 

executed by selecting the relevant icon ( ) from the toolbars or by selecting 
Modify -> Extend from the menu or by typing "extend" in the command line and 
pressing Enter. The command prompts in cases 2 and 3 are: 

• Select boundary entities for extend <ENTER to select all>: Select the wall or the 
walls comprising the extension boundaries and then press Enter or right click. 

• Edge mode (E) / Fence (F) / Projection (P) / <Select entity to extend>): Select 
the wall that you want to extend and press Enter or right click. 

1. Trim: Using the grips that appear as soon as a wall is selected. To trim a wall using 
the grips, select the wall and when the grips appear click one of the end grips and 
drag it to the point up to which you want the wall to be trimmed. 

2. Selecting AutoBLD > Wall > Trim executes the Trim command mentioned also 
further down. 

3. executed. 

1. Executing the Trim command of AutoCAD or progeCAD. This command is 

executed by selecting the relevant icon ( ) from the toolbars or by selecting 
Modify -> Trim from the menu or by typing "trim" in the command line and pressing 
Enter. The command prompts in cases 2 and 3 are: 

• Select cutting entities for trim <ENTER to select all>: Select the wall or the walls 
comprising the trimming boundaries and then press Enter or right click. 

• Edge mode (E) / Fence (F) / Projection (P) / <Select entity to trim>): Select the 
wall that you want to trim and press Enter or right click. 

Break: There are two ways available for cutting a piece from a wall. 

1. Selecting AutoBLD > Wall > Break executes the Break command mentioned also 
further down. 

2. Executing the Break command of AutoCAD or progeCAD. This command is 

executed by selecting the relevant icon ( ) from the toolbars or by selecting 
Modify -> Break from the menu or by typing "break" in the command line and 
pressing Enter. The command prompts in cases 1 and 2 are: 

• Select entities to break: Select the wall or the walls comprising the breaking 
boundaries and then press Enter or right click. 

• First break point (F) / <Second break point>): Specify the second breaking point 
of the wall. The first point is the point from which the wall is selected in the 
previous step. If you want to specify a different first breaking point, type F and 
press Enter. In this case, you can firstly specify the first breaking point and then 
the second one. 

Unify: This option enables the user to unify two collinear walls into one. This command 
is executed by selecting AutoBLD > Wall > Unify from the menu or by typing "unify" in 
the command line and pressing Enter. The command prompts are: 

• Select 1st wall: Select the first wall you want unified. 

• Select 2nd wall: Select the second wall. 
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If the walls are not collinear and, therefore, cannot be logically composed into one, a 
message appears on the screen informing you that ”the walls are not collinear”. 

The above wall data editing commands are found in the AutoBLD > Wall menu. 
However, there are also some other basic wall data editing commands, which will 
appear if you select one or more walls and right click on them. These options are 
detailed below: 

Mirror: There are two ways available for copying a wall with respect to an axis of 
symmetry: 

1. Executing the Mirror command of AutoCAD or progeCAD. This command is 

executed by selecting the relevant icon ( ) from the toolbars or by selecting 
Modify -> Mirror from the menu or by typing "mirror" in the command line and 
pressing Enter. The command prompts are: 

• Select entities to mirror: Select the wall or the walls you want to copy with 
respect to an axis of symmetry and then press Enter or right click. 

• Start of mirror line: Specify the first point of the axis of symmetry. 

• End of mirror line: Specify the second point of the axis of symmetry. 

• Delete the original entities <N>: The program asks the user if the initially 
selected entities should be deleted. If you press Enter or right click, the entities 
shall not be deleted, whereas, if you type "Y" and press Enter, the selected 
entities shall be deleted. 

2. After selecting the wall or the walls you want copied with respect to an axis of 
symmetry, right click and select Mirror. The prompts appearing in the command line 
are the same as the ones mentioned in the previous case, starting form the second 
one. 

Rotate: There are two ways available for rotating a wall: 

1. Executing the Rotate command of AutoCAD or progeCAD. This command is 

executed by selecting the relevant icon ( ) from the toolbars or by selecting 
Modify -> Rotate from the menu or by typing "rotate" in the command line and 
pressing Enter. The command prompts are: 

• Select entities to rotate: Select the wall or the walls you want to rotate and then 
press Enter or right click. 

• Rotation point: Specify the fixed point with respect to which you want the 
selected walls to be rotated. 

• Base angle (B) / <Rotation angle>: Specify the angle with respect to which you 
want the selected walls to be rotated. You can either type the angle value in 
degrees or show it on the drawing by rotating the cursor and clicking on the 
desired point. 

2. After selecting the wall or the walls you want to rotate, right click and select Rotate. 
The prompts appearing in the command line are the same as the ones mentioned 
in the previous case, starting form the second one. 

1. Scale: Executing the Scale command of AutoCAD or progeCAD. This command is 

executed by selecting the relevant icon ( ) from the toolbars or by selecting 
Modify -> Scale from the menu or by typing "scale" in the command line and 
pressing Enter. The command prompts are: 
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• Select entities to scale: Select the wall or the walls which you want to scale and 
then press Enter or right click. 

• Base point: Select the base point with respect to which the scaling shall be 
performed. 

• Base scale / <Scale factor>: Specify the ratio for scaling up or down the 
selected walls. You can either type the scaling ratio value or show it on the 
drawing by moving the cursor and clicking on the desired point. It should be 
mentioned that if you enter a value lower than 1, the selected walls shall shrink 
whereas, if you enter a value higher than 1, the selected walls shall be 
magnified. 

2. After selecting the wall or the walls which you want scaled, right click and select 
Scale. The prompts appearing in the command line are the same as the ones 
mentioned in the previous case, starting form the second one. 

Base point: This option enables the user to specify a base point on the drawing, which 
shall be used during insertion into another. By default, the specified base point is 
<0,0,0>. 

Copy: There are two ways available for copying a wall: 

1. Executing the Copy command of AutoCAD or progeCAD. This command is 

executed by selecting the relevant icon ( ) from the toolbars or by selecting 
Modify -> Copy from the menu or by typing "copy" in the command line and 
pressing Enter. The command prompts are: 

• Select entities to copy: Select the wall or the walls you want to copy and then 
press Enter or right click. 

• Multiple (M) / Vector (V) / <Base point>: Specify a fixed point on the entities you 
want to move. If you want to copy the selected walls more than once, type "M" 
and press Enter. Now the program prompts you to enter the base point. 

• Displacement point: Specify the point where you want to copy the selected 
walls. 

2. After selecting the wall or the walls you want to copy, right click and select Copy. 
The prompts appearing in the command line are the same as the ones mentioned 
in the previous case, starting form the second one. 

Undo: This option enables the user to undo the last command that was executed. 

Properties: This option enables the user to view the attributes of a wall and change a 
property, if necessary. The window appearing in this case is the same as the one 
mentioned above in the "Modify Wall" option. 

5.1.3 Joint Intersection Plane 
This command enables the user to specify the height where the ground plan 
intersection should be created, with the corresponding results on the ground plan 
drawing. More specifically, select the above option and enter the new desired height in 
the command line (e.g. 1.40 m). 
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5.2 Opening 
If the command "Opening" is activated, a second option menu is displayed where you 
can either select drawing one of the various opening types (window, sliding door, door 
etc) or use one of the "Erase", "Modify" or "Move" commands for an already drawn 
opening. At the bottom of this menu lies the very useful option “Libraries”, which was 
also mentioned in the previous chapter and which enables the user to define his own 
windows freely, drawing them according to his will. 

Drawing an opening leads to the following options: 

Window: In the option "Window" you must first select the wall on which the opening will 
be placed and then define the stating and the ending points of the opening (all these 
actions are carried out using the mouse and pressing <Enter> each time). The window 
will be automatically assigned the data that are predefined in the “Characteristic Data”, 
namely the corresponding values for the height, the rize, the coefficient k etc). Of 
course, you can draw the window from the ground plan as well as in the three-
dimensional (3D) view. During drawing a window, it is very helpful to the user the fact 
that, after selecting the wall where the window will be automatically placed, the 
distance from the wall edge is displayed in the coordinates position on the top of the 
screen, while the graphics cursor is transferred parallel to the wall for supervision 
reasons. The measurement starting point (distance 0) as well as the side (inner or 
outer) are defined, depending on which one of the two edges is closer and which side 
was "grabbed" during the wall selection. 

Example: Suppose you want to place a window at a 
distance of 1.30 from the outer side of the wall that is 
shown on the drawing. After having specified the desired 
window in the "Parameters -> Window" and selected the 
"Window" command for drawing, click a point of the 
outer side of the wall, on the ending point side, in 
relation to which you want the distance measured. 

Note that the graphics cursor becomes automatically 
parallel to the wall direction and the coordinates are 
zeroed on the top side. 

 
In this way, in order to specify the first ending point of the window, all you have to do is 
type 1.30 in the command line (at the bottom), while if you insert a second point slightly 
below (with the mouse), you can specify the window direction, which is finally drawn 
with the length that has already been entered in "Parameters". Alternatively, you can 
enter its length in the command line right after typing the initial point. 
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Door: If the option "Door" is selected, you should “point” the wall where you want the 
door placed, define the beginning and the end of the door (the beginning also defines 
the axis where the door opens) and finally show 
(with a point) the side towards which it opens. In 
the following figure you can see the order in which 
the points 1, 2 and 3 are defined. The first point is 
entered according to either the screen coordinates 
or the relative coordinates (e.g. type "2.5" if you 
want to place the door axis in a distance 2.5 
meters from the wall edge). The second point 
determines the door width and in case it is shorter 
than the length defined in the "Door Parameters" it 
is assigned this value. Finally, the third point is entered freely either on the one side of 
the wall or the other, since you simply determine the half-plane side towards which the 
door is placed. 

For measuring the distances from the wall edge, the same instructions referring to the 
window apply. 

Opening: The instructions regarding the window (see above) apply here as well. The 
only existing difference is its drawn image. For measuring the distances from the wall 
edge, the same instructions referring to the window apply. 

Finally, the opening management options are divided into the following: 

Erase: There are four ways available for deleting an opening: 

1. After selecting the opening or the openings you want to delete, press Delete on the 
keypad. 

2. Selecting AutoBLD > Opening > Erase executes the Erase command mentioned 
also further down. 

3. Executing the Erase command of AutoCAD or progeCAD. This command is 

executed by selecting the relevant icon ( ) from the toolbars or by selecting 
Modify -> Erase from the menu or by typing "erase" in the command line and 
pressing Enter. The command prompts in cases 2 and 3 are: 

• Select entities to delete: Select the opening or the openings you want to delete 
and then press Enter or right click. 

4. After selecting the opening or the openings you want to delete, right click and select 
Erase 

Modify: Use this option to modify the features of any desired opening. Once you have 
activated this command, you are asked to select the opening and then specify, in the 
dialog box appearing on the screen (displaying the opening parameters), the desired 
new height, rize or type. 

This command is also activated by selecting the desired opening (via the left mouse 
button) and then right clicking and selecting Properties or even by double clicking on 
the desired opening. 

Multiple Change: Use this command to perform mass changes, e.g. modify the height 
of all the windows on a certain level. Click the walls with the existing openings that you 
want to edit, while the ability to add or remove to the pre-selected ones is granted, 
activate the desired field (e.g. the rize height) and enter the new value. Click "OK" for 
the corresponding updates to be performed.  
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This command is also activated by successively selecting, via left clicking, the desired 
openings and then right clicking and selecting Properties. 

Move: There are four ways available for moving an opening: 

1. Using the grips that appear as soon as an opening is selected. To move an 
opening using the grips, you should select the opening and when the grips appear 
click on the grip the lies in the centre of the opening and drag it. 

2. Selecting AutoBLD > Opening > Move executes the Move command mentioned 
also further down. 

3. Executing the Move command of AutoCAD or progeCAD. This command is 

executed by selecting the relevant icon ( ) from the toolbars or by selecting 
Modify -> Move from the menu or by typing "move" in the command line and 
pressing Enter. The command prompts in cases 2 and 3 are: 

• Select entities to move: Select the opening or the openings you want to move 
and then press Enter or right click. 

• Vector (V) / <Base point (B)>: Specify a fixed point on the entities you want to 
move. 

• Displacement point: Specify the point where you want the selected entities 
moved. 

4. After selecting the opening or the openings you want to move, right click and select 
Move. The prompts appearing in the command line are the same as the ones 
mentioned in the previous case, starting form the second one. 

Center: Select this option whenever you want to place an opening exactly in the middle 
of a wall (centering). If this option is selected, the program prompts you to click first the 
opening you want to center and then the side of the wall towards which you want this 
opening to be centered (in case the length of the two wall sides is not the same, e.g. 
outer and inner side). 

Library: This option is useful for user-defined openings and consists of 6 sub-options: 
Opening Shape, Opening Mode, Shutters, 3D Parametrical Openings, Windows and 
Doors. The management of each one of the above libraries is described in detail below. 
To create a new opening, door or window, you should first specify the shape of the 
opening, i.e. if the opening shall be rectangular of curved-angled etc, and then the 
opening mode, i.e. if the opening shall be glass or compact, sliding or hinged etc. 

1. Editing the "Opening Shape" Library 
Selecting the Opening Shape library opens the Edit User's Opening Shape dialog that 
appears below. 
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The following options are available in this dialog. 

Display: This field in the particular dialog is inactive. 
Display type: This field in the particular dialog is also inactive. 
Categories: In this field, there is no option of defining certain categories for the 3D 
parametrical openings. 
Slide type: This field in the particular dialog is inactive. 
Create: The following dialog window appears on the screen where you can create your 
own opening shape. 

 
In order to use the commands of this dialog, you should first draw the shape of the 
opening you want to create near <0,0>, using a closed polyline.  

Attention: The last section of the polyline is defined by typing “c” (close) and not via an 
endpoint. 
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The following example explains you how to create a shape. 

Example: Suppose you want to create a curved-angled shape, e.g. an arch. 

Using the polyline command of AutoCAD or progeCAD, draw the outline of the 
opening. 

Attention: If you want the bottom of the casing to be removable, you should specify 
the polyline from left to right, so that the endpoints of the polyline are at the bottom of 
the opening. 

 
Next act as follows: 

• Select polyline: You are taken to the drawing where you should select the polyline 
you have already drawn. 

1. Rise: You are taken to the drawing where you can set the rise of the opening.  

Note: Rise is defined as the vertical distance between the top of a shape and an in-
between point in the shape. In the case of an arch, rise is defined as the distance from 
the highest point of the arch arc to the point where the arch starts. Thus, you can 
specify an opening with specific arch height, e.g. 0.40m or 0.35m. If no rise value is 
entered, the height of the resulting arch shall be proportional to the ratio of the initial 
arch height to the total height of the opening. Defining rise enables defining of vaulted 
windows with variable arch ratios to the total height of the opening. 

• Slide screen: You are taken to the drawing where you can select from a window 
what you want to appear in the slide. Then, right click and return to the above 
dialog. 

• Save slide: The slide of the opening created is displayed in the black screen on the 
top of the dialog. 

• Save drawing: Thus, the opening created is saved in the libraries and the program 
informs the user of the name of the block created, via a warning message. 

Delete: This option enables you to delete an opening shape you have created. The 
program confirms deletion with a warning message. 

Copy: This option enables you to copy an opening shape to another location. The 
program informs the user of the block copied, via a warning message. 

Trim: This option enables you to move an opening shape from one location to another. 
The program informs the user of the block copied, via a warning message. 
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Paste: This option copies or moves the opening shape selected in the two previous 
options (Copy & Trim) to the desired location. The program prompts you to confirm the 
action to be executed. 

Locations Insert: This option enables you to insert a blank location for the creation of 
a new shape. The program informs the user of the point where the blank location is to 
be added, via a warning message. 

Locations Delete: This option enables you to delete a location where an opening 
shape has been created. The program informs the user of the location to be deleted, 
via a warning message. 

Locations Number: In this field, you can specify the number of the locations you want 
inserted or deleted. 

In the bottom left field you can type the name for the opening shape you created and, 
selecting Change name, the given name is transferred to the column lying on the left 
side of the dialog. 

On the top of the dialog, there are the Categories, Display, Display type and Slide type 
fields, which are inactive in the case of the opening shape. 

Finally, at the bottom of the dialog window you can see the options Previous and Next, 
which you can use to move between pages, as well as the options OK and Cancel. 

2. Editing the "Opening Mode" Library 
Selecting the Opening Mode library opens the Edit User's Opening Mode dialog that 
appears below. 

 
The following options are available in this dialog. 

Display: This field enables you to select the opening modes you want displayed. The 
first option is "All", where all existing opening modes are shown, and the second option 
is "Categories", where the Categories field is activated. 
Display type: This option is inactive in this particular dialog. 
Categories: In this field you can select the categories of opening modes you want 
shown. When a category is selected (so that it appears in blue), you can select the 
checkbox on the left of "Display" by clicking on it and display all the opening modes 
belonging to that particular category. Click on All to select all categories and click on  
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None to select no category. Clicking on Edit opens the dialog below, where you can 
set the desired categories. 

 
To add a category, type the name you want in the field "Title" and click on Add. 
Clicking on Change, you can change the name of a category whereas clicking on 
Delete you can delete a category. 

Slide type: This field enables the user to select how he/she wants the existing opening 
modes to be displayed. You can select between displaying the slide of the opening 
modes or their rendered view. 
Create: The following dialog window appears on the screen where the user can create 
an opening mode of his/her own. 

 
In order to use the commands of this dialog, you should first draw, with closed polylines 
or rectangular shapes, near 0,0, the opening mode you want to create. In fact, you 
should draw the frames which shall comprise the opening.  

The following options are available in this dialog: 

• Slide – Screen: You are taken to the drawing where you can select from a window 
what you want to appear in the slide. 

• Slide – Save: The slide of the opening mode created is displayed in the black 
screen on the top of the field "slide". 
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• Frames – Rise: This option enables the user to specify the desired rise for the 
particular opening mode. 

Note: In the case of opening mode, a rise must be defined when the frames are placed 
so that they are separated in 2 parts. The upper frames that act as skylight and which 
may have no ability of opening and the lower frames which can open. Thus, in a 
rectangular opening shape, which is combined with opening mode consisting of a 
skylight frame and, below it, 2 frames which open on the right and on the left, if a rise is 
set in the opening mode, then you can insert similar windows with variable skylight 
height. For example, you can create a window 1.2m high with skylight frame 0.5m high 
and another window of the same type but with skylight 0.4m high. Moreover, if you 
combine an opening shape with rise with an opening mode with rise, then the program 
sets the ratio of the skylight frames to the lower frames, so that the skylight fits 
precisely in the rise of the opening shape, i.e. in the arch.  

• Frames – New: This option enables you to specify the frames comprising the 
opening mode you want to create. You are prompted to specify two points, which 
are the two diagonally opposite points of the frame. 

• Frames – Select: This option is an alternative way to specify the frames 
comprising the opening mode to be created. You are prompted to select the 
polyline making the frame. 

• Frames – Delete: This option enables you to delete a frame. 

• Frames – Modify: This option enables you to modify one of the frames. If, for 
example, you change the type of a frame, e.g. from frame with grass into compact 
frame, to save this change in the current frame, you should select the Modify 
option. 

• Frame width: Specify the width of the frame. The default value is 0.05. 

• Frame thickness: Specify the thickness of the frame. The default value is 0.05. 

• Frame dimensions – 3D Colour: This option enables you to select the colour of 
the frame in the 3D display as well as the material with which it will appear in 
rendering mode. 

• Glass thickness: Specify the glass thickness, in case of a frame with glass or only 
glass. The default value is 0.001. 

• Glasses – 3D Colour: This option enables you to select the colour of the glass in 
the 3D display as well as the material with which it will appear in rendering mode. 

• Categories: This option enables you to assign the opening mode to some of the 
categories you have created. Clicking on "All", all categories are selected whereas, 
clicking on "None", no category is selected. The "Edit" option opens the "Edit 
categories" dialog, where you can add, delete or change a category. 

• Position depth: Specify the depth where the frame shall be positioned. This option 
is necessary in case of sliding openings, e.g. cascade, where the position depth 
should be set so that the 2 frames of the sliding opening open one next to the 
other. Typically, the value of the position depth is set equal to the frame thickness. 
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• Type: This option enables the user to set the type of the current frame. The 
available options are: compact, frame with glass, frame without glass, only grass 
and library. Selecting Library as frame type activates the option of choice between 
two 3D libraries (Library and User's library). Clicking on Type enables you to select 
a frame type whereas, clicking on Colours, enables you to change the colour of the 
various frame features. In case you select Compact as frame type, you can assign 
a material to the frame. To achieve this, you have to select the checkbox beside the 
option Material. Thus, you can choose between two libraries for the selection of the 
material (Library and User's library). Clicking on Material opens the Select Material 
or Select User's Material dialog, where you can choose the material you want to 
assign to the frame. 

Attention: The "Material" option is activated in case the selected frame type is 
"Compact". 

• Opening mode: This option enables the user to set the opening mode for the 
current frame. The following options are available: Not opening, Rotating, Moving 
and Accordion. The option Rotating activates the "Set rotation" dialog, where the 
following options are available: 

1. Rotation axis: This option enables the user to set two points on the rotation axis of 
the frame. Clicking on Point 1 activates the drawing window, where, via the mouse 
and with snapping active, you can set the first point of the rotation axis. Similarly, 
you can also set the second point as well. 

2. Closed Position Angle: This option enables the user to set the angle that is formed 
by the opening frame and the opening casing or the wall axis, when the frame is 
regarded compact. In most cases, this angle is zero.  

Note: An opening where this angle has a value different from zero is a cylindrical 
rotating door. To create such an opening mode, you should draw 3 rectangular 
frames, 1 of which is on the left and the other 2 on the right of the first one and the 
one onto the other. For the frame on the left, you should set as rotation axis the 
right vertical edge, closed position angle 60ο and maximum turn angle 120ο. For 
the other two frames lying on the right, you should set as rotation axis the left 
vertical edge, closed position angle 0ο for the one and 120ο for the other and 
maximum turn angle 120ο for both. In this opening mode, no casing is required. 

3. Maximum Turn Angle: Specify the maximum angle by which the frame can rotate. 

4. Symmetrical Turn: Set whether the frame shall rotate symmetrically. Selecting the 
checkbox activates this option. 

The option Moving activates the "Set movement" dialog, where the following 
options are available: 

1. Direction: This option enables you to specify the direction of the frame movement. 
The options Up, Down, Right and Left are available. 

2. Maximum distance: This option activates the drawing window and enables you to 
specify the maximum distance for the frame movement. 

The option Accordion activates the "Set accordion" dialog, where the following 
options are available: 

1. Fixed edge: This option enables the user to set the fixed edge for the accordion-
type frame. The options Left and Right are available. 

2. type frame. The options Left and Right are available. 
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Blinds number: Set the number of blinds for the accordion. 

Attention: To select Accordion opening mode, you should have already selected 
Compact frame type. 

• Separators: This option enables the user to specify if there shall be separators in 
the current frame or not. The available options are: No separators, Parallel 
separators and Radial separators. The option Parallel activates the relevant dialog, 
where you can set the number of the horizontal and vertical separators. The option 
Radial activates the relevant dialog, where you can set the centre and the number 
of the separators. Clicking on the centre activates the drawing window, where you 
can specify the point on the current frame using the mouse. 

Attention: To set separators for the frame, you should have already selected Frame 
with glass or Frame without glass or Only glass as frame type. 

• Separator: This option enables the user to set some properties of the separators. 
More particularly, you can set the width and the thickness of the separators. The 
default value is 0.010. Also, you can set the 3D Colour of the separators and the 
material with which they shall be displayed in rendering mode. 

• Knob: This option enables the user to specify if there shall be a knob in the current 
frame or not. The available options are: No knob, Knob on side 1, Knob on side 2 
and Knob on both sides. Typically, the first side is the top side of the wall, as shown 
on the ground plan. However, you should check towards which side frames open 
and specify the position of the knob accordingly. You can select the knob design 
from 2 libraries (Library and User's Library), where clicking on the Type option 
opens the relevant dialogs, where you can select the desired design.  

Clicking on Position activates the drawing window, where you can specify on the 
frame the precise position of the knob. Finally, selecting 3D Colour, you can specify 
the colour of the frame in the 3D display as well as the material shown in the rendering 
mode. 

Attention: When you select Frame with glass or without glass as frame type, if you set 
as knob position a point precisely on the frame, i.e. on the frame line, then the program 
will centre the knob on the frame at the relevant position according to the frame width. 
This means that, if the width of the frame is 5cm, the knob shall be positioned 2.5cm 
inner than the position you have set. If you set a point inside the frame as knob 
position, then this position shall be scaled according to the final dimensions of the 
frame, i.e. the length and the height, resulting in the final position of the knob. When 
you select a compact frame or a frame from the library, the knob should be positioned 
inside and not precisely on the frame outline, whereas, when the frame is with or 
without glass, the knob should be positioned on the outline. 

The above mentioned are explained in the following example: 

Example: Suppose you want to create an opening comprising of 3 frames, where 
frame 1 is a frame with glass opening horizontally, frame 2 is hinged and compact and 
frame 3 is fixed, with glass and separators. Using the polyline or rectangular command 
of AutoCAD or progeCAD, draw the frames comprising the desired opening. 
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Next act as follows: 

• In the Edit User's Opening Mode dialog, select a blank location and click on New. 

• In the new dialog, deselect the Rise checkbox and click on Select. The drawing 
window is activated, where you can select the polyline comprising the first frame. 
Clicking on Select again, you can select the other frames which comprise the 
opening mode you want to create. 

• In the Frame dimensions – 3D Colour option, on the top of the dialog, set 32 Wood 
Ash-coloured Middle and, in the Glasses – 3D Colour option, set 4 Glass. 

• Select frame 1 and, in the Position Depth option, leave value 0 whereas, in the 
current frame Type option, set frame with glass. In the Opening Mode option, select 
Rotating and, clicking on Point 1, you are taken to the drawing where you can 
specify the first point of the rotation axis. Likewise, clicking on Point 2, specify the 
second point of the rotation axis. 

 
In the Maximum Turn Angle option, enter the value 90 and do not check the option 
Symmetrical Turn. Note that in the left part of the dialog, on the right side of the 
screen showing the current frame, there is the word "Modified", which means that 
you should click on Frames – Modify to save the changes in the current frame. In 
the Separators option, select No separators. In the Knob option, set Side 1 and 
click on Position to activate the drawing window where you can set the centre of 
the top edge as knob position. Click on Frames – Modify again to save the 
changes in the current frame.  

• Select frame 2 and, in the Position Depth option, leave value 0 whereas, in the 
current frame Type option, set Compact. Click on Frames – Modify to save changes 
in the current frame. In the Opening Mode option, select Rotating and, clicking on 
Point 1, you are taken to the drawing where you can specify the first point of the 
rotation axis. Likewise, clicking on Point 2, specify the second point of the rotation 
axis. 
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In the Maximum Turn Angle option, enter the value 90 and do not check the option 
Symmetrical Turn. In the Separators option, select No separators. In the Knob 
option, set Side 1 and click on Position to activate the drawing window where you 
can set the centre of the right edge as knob position. Since frame 2 is Compact, as 
mentioned above, the knob should be positioned inside and not precisely on the 
frame outline. Thus, go to field X and change the value from 0.800 to 0.780, so 
that the knob is not precisely on the outline but inside the frame. Click on Frames – 
Modify again to save the changes in the current frame. 

• Select frame 3 and, in the Position Depth option, leave value 0 whereas, in the 
current frame Type option, set Frame with glass. In the Opening mode option, set 
Not opening. In the Separators option, set Parallel and type number 3 in the 
Horizontal option. Click on Frames – Modify to save the changes in the current 
frame and, finally, in the Knob option, set No knob. 

• Clicking on Slide – Screen activates the drawing window, where you can use a 
selection window to select the 3 frames you have already drawn. Then, right click to 
return to the New Opening Mode dialog. 

• Clicking on Slide – Save activates the drawing window where the program prompts 
you to enter Slide Type, Detail (D) or View (V). Type D and press Enter. Thus, the 
program automatically creates the slide of the drawn opening mode. 

• You should select the categories assigned to the opening mode you have just 
created. In the Categories field, select the desired categories one-by-one (so that 
they appear in blue) and select the checkbox beside the Assigned option. 

• Finally, click OK and the program will ask you if you want to save the block you 
have just created. Clicking on OK, the program informs you that the block is saved 
and you return to the first Edit Opening Mode dialog. In the bottom left box you can 
type the name of the Opening Mode you created. Clicking on Change Name saves 
the name. 

The other options available in the first Edit Opening Mode dialog are the following: 

Delete: This option enables you to delete an opening mode you have created. The 
program confirms deletion with a warning message. 

Copy: This option enables you to copy an opening mode to another location. The 
program informs the user of the block copied, via a warning message. 

Trim: This option enables you to move an opening mode from one location to another. 
The program informs the user of the block copied, via a warning message. 
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Paste: This option copies or moves the opening mode selected in the two previous 
options (Copy & Trim) to the desired location. The program prompts you to confirm the 
action to be executed. 

Locations Insert: This option enables you to insert a blank location for the creation of 
a new opening mode. The program informs the user of the point where the blank 
location is to be added, via a warning message. 

Locations Delete: This option enables you to delete a location where an opening 
mode has been created. The program informs the user of the location to be deleted, via 
a warning message. 

Locations Number: In this field, you can specify the number of the locations you want 
inserted or deleted. 

In the bottom left field you can type the name for the opening mode you created and, 
selecting Change name, the given name is transferred to the column lying on the left 
side of the dialog. 

Finally, at the bottom of the dialog you can see the options Previous and Next, which 
you can use to move between pages, as well as the options OK and Cancel. 

3. Editing the "Shutters" Library 
Selecting the Shutters library opens the Edit User's Parametrical Shutter dialog that 
appears below. 

 
The following options are available in this dialog. 

Display: This field enables you to select the shutters you want displayed. The first 
option is "All", where all existing shutters are shown, and the second option is 
"Categories", where the Categories field is activated. 
Display type: This field enables you to display the existing shutters in 3D or 2D view. 
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Categories: In this field you can select the categories of shutters you want to appear. 
When a category is selected (so that it appears in blue), you can select the checkbox 
on the left of "Display" by clicking on it and display all the shutters belonging to that 
particular category. Click on All to select all categories and click on None to select no 
category. Clicking on Edit opens the dialog below, where you can specify the desired 
categories. 

 
To add a category, type the name you want in the field "Title" and click on Add. 
Clicking on Change, you can change the name of a category whereas clicking on 
Delete you can delete a category. 

Slide type: This field enables you to select the existing shutters view. You can select 
between displaying the slide of the shutters or their rendered view. 
Create: The user is led into the following screen where he/she can create a shutter of 
his/her own. 

 
In order to use the commands of this dialog, you should draw, using closed polylines or 
rectangular shapes, near 0,0, the frames comprising the shutter you want to create. 
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The following options are available in this dialog: 

• 3D: This option enables you to set the properties of the shutter in 3D view and to 
create the shutter slide. More specifically: 

1. 3D opening (%): Specify the opening percentage with which you want the 
shutter shown in 3D display. 

2. 3D Preview: Clicking on this option creates the slide of the shutter on 
screen. There are various options available: View (V), where you can see 
the shutter in various views (up, front, right, axonometric), Zoom (Z), where 
you can zoom in the shutter you created, Netting (W), where you can see 
the shutter coloured, Hide lines (H), where you can see the shutter in 
hidden mode, Shading (S), where you can see the shutter shaded, 
Rendering (R), where you can see the shutter rendered, Slide file (Μ), 
where the program creates the necessary file for the slide of the shutter 
and, via a warning message, informs the user of the file created and, finally, 
File bmp (B), where the program creates the necessary rendering file and, 
via a warning message, informs the user of the file created. 

3. Finally, t the "Slide" and "Rendering" options enable the user to see the 
shutter in netting or rendering mode, respectively. 

• 2D: This option enables the user to create the ground plan of the shutter. The 
following options are available: 

1. 2D Preview: Clicking on this option creates the slide of the shutter ground 
plan on the screen. The options mentioned above are also available here.  

2. 2D Opening (%): Specify the opening percentage with which you want the 
shutter displayed on the ground plan. 

• Categories: This option enables you to assign the shutter to some of the 
categories you have created. Clicking on All, all categories are selected whereas, 
clicking on None, no category is selected. The "Edit" option opens the "Edit 
categories" dialog, where you can add, delete or change a category. 

• Type: This option enables the user to set the type of the frame. The available 
options are: Compact, Frame with blinds and Library. Selecting Library as frame 
type activates the option of choice between two 3D libraries (Library and User's 
library). Clicking on Type enables you to select a frame type whereas, clicking on 
Colours, enables you to change the colour of the various frame features. In case 
you select Compact or Frame with blinds as frame type, you can assign a 
material to the frame. To achieve this, you have to select the checkbox beside the 
option Material. Thus, you can choose between two libraries for the selection of the 
material (Library and User's Library). Clicking on Material opens the Select Material 
or Select User's Material dialog, where you can choose the material you want to 
assign to the frame. In case you select Frame with blinds as frame type, the 
Blinds dialog is activated, where the following options are available: 

1. Frame width: Specify the width of the frame. The default value is 0.050. 

2. Blind width: Specify the width of the blind. The default value is 0.040. 

3. Separator level: Set the level where there shall be a separator among the 
blinds. 

4. Separator width: Set the width of the separator among the blinds. 
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5. Separators – Add: This option enables you to add a separator at the 
specified level. 

6. Separators – Modify: This option enables you to modify a specified 
separator. 

7. Separators – Delete: This option enables you to delete a specified 
separator. 

• Frame thickness: Specify the thickness of the frame. The default value is 0.050. 

• 3D Colour: This option enables you to select the colour of the frame in the 3D 
display as well as the material with which it will appear in rendering mode. 

• Opening mode: This option enables the user to set the opening mode of the 
frame. The following options are available: Hinged, Sliding and Roll. The Hinged 
option activates the Rotate dialog, where you can set the desired position of the 
rotation axes. The available options are Left and Right. Also, depending on the 
existing frames, in the Hinged dialog, the following options are activated: 

2. Opening of 2nd panel: It is activated in case of 2 frames. This option enables 
you to set how the 2nd panel shall open. The available options are: 
Inclination of 1st, which follows the inclination of the first panel, Horizontal, 
where the second panel is horizontal and Symmetrical, where the second 
panel is symmetrical to the first one. 

3. Opening of 3rd panel: It is activated in case of 3 frames. This option enables 
you to set how the 3rd panel shall open. The available options are the ones 
mentioned above.  

The Sliding option activates the Move dialog, where you can see the following 
options: 

1. Direction: This option enables you to specify the direction of the frame 
movement. The available options are Right and Left. 

2. Maximum distance: This option activates the drawing window and enables 
you to specify the maximum distance for the frame movement. 

Also, when Sliding is selected as opening mode, the Sliding Position option is 
activated, where the options In, Out (Side1) and Out (Side2) are available. If you 
select one of the options Out (Side1) and Out (Side2), the Sliding Guide option is 
activated, where you can select No, that is no guide for the sliding opening, Up, 
where the guide of the opening is on top, Down, where the guide of the opening is 
at the bottom and Up & Down, where the guide of the sliding opening is both on 
the top and at the bottom. Furthermore, you can set the width and the thickness of 
the guide of the sliding opening. The default values are 0.020 and 0.050, 
respectively. 
The Roll option activates the Maximum Distance option, which activates the 
drawing window and enables you to set the maximum distance for the roll 
movement. 

• Frames – New: This option enables you to specify the frames comprising the 
shutter you want to create. You are prompted to specify two points, which are the 
two diagonally opposite points of the frame. 

• Frames – Select: This option is an alternative way to set the frames comprising the 
shutter to be created. You are prompted to select the polyline making the frame. 
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• Frames – Delete: This option enables you to delete a frame. 

• Knob: This option enables the user to specify if the current frame shall have a knob 
or not. The available options are: No knob, Knob on side 1, Knob on side 2 and 
Knob on both sides. Typically, the first side is the top side of the wall, as shown on 
the ground plan. However, you should check towards which side the frames open 
and specify the position of the knob accordingly. You can select the knob design 
from 2 libraries (Library and User's Library), where clicking on the Type option 
opens the relevant dialogs, where you can select the desired design. Clicking on 
Position activates the drawing window, where you can specify on the frame the 
precise position of the knob. Finally, selecting 3D Colour, you can specify the 
colour of the frame in the 3D display as well as the material shown in the rendering 
mode. 

Attention: The knob should be positioned inside the frame and not on the frame 
outline. 
The above mentioned are explained in the following example: 

Example: Suppose you want to create a two-panel hinged shutter, where each of the 
two parts shall consist of 3 panels.  

Follow the steps below: 

• First, you should draw, near 0,0, using some closed polylines or the rectangular 
command of AutoCAD or progeCAD, the six frames comprising the shutter you 
want to create. 

• In the New Shutter dialog, select a blank location and click on New. 

• In the Frames dialog, click on Select and select the polyline comprising the first 
frame on the drawing. Clicking on Select again, set the other frames which 
comprise the opening mode you want to create. In this case, you should set six 
different frames. 

• Select frame 1 and, in the Type option, set frame with blinds whereas, in the Frame 
Width option, leave unchanged the value 0.05. In the 3D Colour option, set 32 
Wood Ash-coloured Middle. In the Opening Mode field, select Hinged and, in 
options Opening of 2nd Panel and Opening of 3rd Panel, select Horizontal. This 
means that, when the shutter is open, the second and the third panel shall be 
horizontal. In the Rotate – Axis Position option, leave the option Left and, in the 
Knob option, set No knob.  

• Select frame 2 and, in the Type option, leave unchanged the option frame with 
blinds and, in the Frame Width option, leave unchanged the value 0.05. Also, in the 
3D Colour option, leave 32 Wood Ash-coloured Middle. In the Opening Mode field, 
select Hinged and, in options Opening of 2nd Panel and Opening of 3rd Panel, select 
Horizontal. This means that, when the shutter is open, the second and the third 
panel shall be horizontal. In the Rotate – Axis Position option, leave unchanged the 
option Left and, in the Knob option, set No knob. 

• Select frame 3 and set whatever you have already specified for the above 2 
frames. In the Knob option, however, set Side1 and click on Position to activate the 
drawing window, where you can set the centre of the right side of the third frame as 
knob position. According to all the above mentioned, however, the knob should not 
be placed directly on the frame, but inside it. That's why you should go to the 
Position X option and change the value slightly so that the knob is transferred 
inside the frame. For example, if this value is 0.75, set it to 0.73. 
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• Select frame 4 and set whatever you have already specified for the above frames. 
In the Rotate – Axis Position option, leave unchanged the Right option and, in the 
Knob option, set Side1 and click on Position to activate the drawing window, where 
you can set the centre of the left side of the forth frame as knob position. According 
to all the above mentioned, however, the knob should not be placed directly on the 
frame, but inside it. That's why you should go to the Position X option and change 
the value slightly so that the knob is transferred inside the frame. For example, if 
this value is 0.75, set it to 0.77. 

• Select frame 5 and set whatever you have already specified for the above frames. 
In the Rotate – Axis Position option, leave unchanged the option Right and, in the 
Knob option, set No knob. 

• Similarly, select frame 6 and set whatever you have already specified for the above 
frames. In the Rotate – Axis Position option, leave unchanged the option Right and, 
in the Knob option, set No knob. 

• Select the categories to assign to the shutter you have just created. In the 
Categories field, select the desired categories one-by-one (so that they appear in 
blue) and select the checkbox beside the Assigned option. 

• In the 3D Opening option (%), set 0 and click on 3D Preview. You can see the 
shutter slide on the screen. Type M, to have the slide file created, and press Enter. 
The program informs you of the file created; click OK. To return to the New Shutter 
dialog, right-click and click OK to the prompt "Exit Preview?". 

• In the 2D dialog, set opening percentage equal to 30 and click on 2D Preview to 
have the slide of the ground plan of the shutter created. Type M, to have the slide 
file created, and press Enter. The program informs you of the file created; click OK. 
To return to the New Shutter dialog, right-click and click OK to the prompt "Exit 
Preview?". 

• Finally, click OK and the program prompts you to save the block you have just 
created. Clicking on OK, the program informs you that the block is saved and you 
return to the first Edit Parametrical Shutter dialog. In the bottom left box you can 
type the name of the Shutter you created. Clicking on Change Name saves the 
name. 

Delete: This option enables you to delete a shutter you have created. The program 
confirms deletion with a warning message. 

Copy: This option enables you to copy a shutter to another location. The program 
informs the user of the block copied, via a warning message. 

Trim: This option enables you to move a shutter from one location to another. The 
program informs the user of the block copied, via a warning message. 

Paste: This option copies or moves the shutter selected in the two previous options 
(Copy & Trim) to the desired location. The program prompts you to confirm the action 
to be executed. 

Locations Insert: This option enables you to insert a blank location for the creation of 
a new shutter. The program informs the user of the point where the blank location is to 
be added, via a warning message. 

Locations Delete: This option enables you to delete a location where a shutter has 
been created. The program informs the user of the location to be deleted, via a warning 
message. 
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Locations Number: In this field, you can specify the number of the locations you want 
inserted or deleted. 

In the bottom left field you can type the name for the shutter you created and, selecting 
Change name, the given name is transferred to the column lying on the left side of the 
dialog. 

Finally, at the bottom of the dialog you can see the options Previous and Next, which 
you can use to move between pages, as well as the options OK and Cancel. 

4. Editing the "3D Parametrical Openings" Library 
This option enables you to create some 3D openings, which shall comprise the library 
from where you will be able to select a type for the frames you set in the New Opening 
Mode as well as in the New Shutter dialogs. Selecting the 3D Parametrical Openings 
library opens the Edit User's 3D Parametrical Opening dialog that appears below. 

 
The following options are available in this dialog. 

Display: This field in the particular dialog is inactive. 
Display type: This field in the particular dialog is also inactive. 
Categories: In this field, there is no option of defining certain categories for the 3D 
parametrical openings. 
Slide type: This field in the particular dialog is inactive. 

Create: The following screen appears where the user can create a 3D opening of 
his/her own. 
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In order to use the commands of this dialog box, you should first draw a window 
section following some simple rules: Use closed polylines (which include straight or 
curved sections) to specify the outlines for the surfaces and the glasses and straight 
lines to specify the separators. The window outer outline does not necessarily have to 
be rectangular. It could be of any shape, since the remaining part will be automatically 
“filled” with wall. 

The following example explains all the above: 

Example: Suppose you want to create the window of the following figure (the figure is 
intentionally asymmetrical, so that you can understand that the program can create all 
possible shapes). 

 
Run the command "polyline" of progeCAD to define the outer outline of the window and 
the outline of the glass and select "line" to define the separators, exactly as shown in 
the adjacent figure. 
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Next act as follows: 

• In the "New User's Opening" dialog, click the "Surfaces" key and select the outer 
polyline, leaving the default thickness at 0.05. 

• Select "Glasses-Select" and select the polyline for the glass. 

• Select "Separators-Select" and select the two lines for the separators. 

• Select "Solid Object" to have the opening converted into a three-dimensional 
drawing. 

• Select "Icon-Slide screen" to select what you want to be shown in the slide. 

• Select "Icon-Save Slide" to have the opening slide created. 

• Select "Insertion Point" and provide the point in relation to which the opening will be 
inserted. 

• Select "Pattern length" and show on the screen the length of the drawn prototype 
opening or just type it. 

• Select "Pattern height" and show on the screen the height of the drawn prototype 
opening or just type it. 

• Select "Save Drawing"; if you select the drawing that appears currently on the 
screen, it is saved in the 3D openings library. 

• Select "Close" to exit the dialog screen. 

Delete: This option enables you to delete a 3D parametrical opening you have created. 
The program confirms the deletion with a warning message. 

Copy: This option enables you to copy a 3D parametrical opening to another location. 
The program informs the user of the block copied, via a warning message. 

Trim: This option enables you to move a 3D parametrical opening from one location to 
another. The program informs the user of the block copied, via a warning message. 

Paste: This option copies or moves the 3D parametrical opening selected in the two 
previous options (Copy & Trim) to the desired location. The program prompts you to 
confirm the action to be executed. 

Locations Insert: This option enables you to insert a blank location for the creation of 
a new 3D parametrical opening. The program informs the user of the point where the 
blank location is to be added, via a warning message. 
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Locations Delete: This option enables you to delete a location where a 3D 
parametrical opening has been created. The program informs the user of the location 
to be deleted, via a warning message. 

Locations Number: In this field, you can specify the number of the locations you want 
inserted or deleted. 

In the bottom left field you can type the name for the 3D parametrical opening you 
created and, selecting Change name, the given name is transferred to the column 
lying on the left side of the dialog. 

Finally, at the bottom of the dialog you can see the options Previous and Next, which 
you can use to move between pages, as well as the options OK and Cancel. 

5. Editing the "Windows" Library 
Selecting the Windows library opens the Edit User's Parametrical Window dialog that 
appears below. 

 
The following options are available in this dialog: 

Display: This field enables you to select the windows you want displayed. The first 
option is "All", where all existing windows are shown, and the second option is 
"Categories", where the Categories field is activated. 
Display type: This field enables you to display the existing windows in 3D or 2D view. 
Categories: In this field you can select the categories of windows you want to appear. 
When a category is selected (so that it appears in blue), you can select the checkbox 
on the left of "Display" by clicking on it and display all the windows belonging to that 
particular category. Click on All to select all categories and click on None to select no 
category. Clicking on Edit opens the dialog below, where you can specify the desired 
categories. 
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To add a category, type the name you want in the field "Title" and click on Add. 
Clicking on Change, you can change the name of a category whereas clicking on 
Delete you can delete a category. 
Slide type: This field enables you to select the existing windows view. You can select 
between displaying the slide of the windows or their rendered view. 
Create: The following dialog window appears on the screen where the user can create 
a window of his/her own. 

 
The following options are available in this dialog: 
• Opening shape: This option enables you to select the opening shape of the 

window. You can select a shape from the Library or the User's Library. Clicking on 
Opening Shape opens the Edit Opening Shape dialog, where you can select the 
shape you want and click OK. The other options available in this dialog have 
already been described in detail. 
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• Opening mode: This option enables you to select the opening mode of the 
window. You can select an opening mode from the Library or the User's Library. 
Clicking on Opening Mode opens the Edit Opening Mode dialog, where you can 
select the opening mode you want and click OK. The other options available in this 
dialog have already been described in detail. 

• Casing: This option enables you to specify the characteristics of the casing.  
1. Existing: This option enables the user to specify if there shall be casing for 

the windows or not. Selecting this checkbox activates the other options. 

2. Width: Specify the width of the casing. The default value is 0.050. 

3. Thickness: Specify the thickness of the casing. The default value is 0.100. 

4. Equal to wall width: Selecting the checkbox beside this option, you specify 
that the width of the casing shall be equal to the width of the wall where it is 
placed. 

5. There is casing at the bottom: This option enables you to set if you want 
casing at the bottom of the window or not. 

6. 3D Colour: This option enables you to select the colour of the casing in the 
3D display as well as the material of the casing in the rendering mode. 

• 3D: This option enables you to set the properties of the window in 3D display and 
to create the window slide. More specifically: 

1. Length: Specify the length of the window. 

2. Height: Specify the height of the window. 

3. Opening percentage: Specify the opening percentage with which you want 
the window displayed. 

4. 3D Preview: Clicking on this option creates the slide of the window on the 
screen. There are various options available: View (V), where you can see 
the window in various views (up, front, right, axonometric), Zoom (Z), where 
you can zoom in the window you created, Netting (W), where you can see 
the window coloured, Hide lines (H), where you can see the window in 
hidden mode, Shading (S), where you can see the window shaded, 
Rendering (R), where you can see the window rendered, Slide file (M), 
where the program creates the necessary file for the slide of the window 
and, via a warning message, informs the user of the file created and, finally, 
File bmp (B), where the program creates the necessary rendering file and, 
via a warning message, informs the user of the file created. 

5. Finally, the "Slide" and "Rendering" options enable the user to see the 
window in netting or rendering mode, respectively. 

• 2D Parametrical: This option enables the user to create the ground plan of the 
window. Select the checkbox before the word Parametrical in order to activate this 
dialog. Without a checkmark, the 2D Parametrical dialog is inactive and the 2D 
Library dialog, which is described further down, is activated. More specifically, the 
following options are available in the 2D Parametrical dialog: 

1. Show rise frames: This option enables you to specify if you want the rise 
frame to appear in the ground plan slide. 

2. Show wall lines: This option enables you to specify if you want the wall 
lines to appear in the ground plan slide. 
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3. 2D Preview: Clicking on this option creates the slide of the window ground 
plan on the screen. The options mentioned above are also available here.  

4. Opening percentage: Specify the opening percentage with which you want 
the window displayed. 

• 2D Library: This option is active if there is no checkmark in the checkbox beside 
the word Parametrical, as mentioned above. The available options are Library and 
User's Library, where clicking on 2D Library opens the relative dialog, from which 
you can select the drawing of the ground plan for the window. 

• Categories: This option enables you to assign the window you created to some of 
the categories you have specified. Clicking on All, all categories are selected 
whereas, clicking on None, no category is selected. The "Edit" option opens the 
"Edit categories" dialog, where you can add, delete or change a category. 

The following example explains how you can create a window. 

Example: Suppose you want to create a single-panel sliding rectangular window with 
separators. 

Follow the steps below: 

• In the Edit Parametrical Window dialog, select a blank location and click on New. 

• Click on Opening Shape and, in the Edit Opening Shape dialog, select the desired 
shape of the window. In this case, set rectangular. 

• Click on Opening Mode and, in the Edit Opening Mode dialog, select the way in 
which the window shall open. In this case, set an opening mode which consists of a 
frame with glass, is sliding and has separators. 

• Select the option of having a casing at the bottom and leave unchanged the default 
values for width and thickness. 

• Set Length 1.000, Height 1.200, Opening percentage 50 and click on 3D Preview. 
You can see the window slide on the screen. Type M, to have the slide file created, 
and press Enter. The program informs you of the file created; click OK. To return to 
the New Window dialog, right-click and click OK to the prompt "Exit Preview?". 

• Click on 2D Preview to create the slide for the window ground plan. Type M, to 
have the slide file created, and press Enter. The program informs you of the file 
created; click OK. To return to the New Window dialog, right-click and click OK to 
the prompt "Exit Preview?". 

• Finally, depending on the specified categories, select the ones to which the window 
shall be assigned. 

After the above procedure, the New Window dialog should be as follows: 
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Clicking on OK, the program informs you of the block created. Finally, in the Edit User's 
Parametrical Window dialog, type the name of the window you created and click on 
Change Name to save it. 

Delete: This option enables you to delete a window you have created. The program 
confirms deletion with a warning message. 

Copy: This option enables you to copy a window to another location. The program 
informs the user of the block copied, via a warning message. 

Trim: This option enables you to move a window from one location to another. The 
program informs the user of the block copied, via a warning message. 

Paste: This option copies or moves the window selected in the two previous options 
(Copy & Trim) to the desired location. The program prompts for confirmation of the 
action to be executed. 

Locations Insert: This option enables you to insert a blank location for the creation of 
a new window. The program informs the user of the point where the blank location is to 
be added, via a warning message. 

Locations Delete: This option enables you to delete a location where a window has 
been created. The program informs the user of the location to be deleted, via a warning 
message. 

Locations Number: In this field, you can specify the number of the locations you want 
inserted or deleted. 

In the bottom left field you can type the name for the window you created and, selecting 
Change name, the given name is transferred to the column lying on the left side of the 
dialog. 

268  4M 



 
 

Finally, at the bottom of the dialog, you can see the options Previous and Next, which 
you can use to move between pages, as well as the options OK and Cancel. 

6. Editing the "Doors" Library 
Selecting the Doors library opens the Edit User's Parametrical Door dialog that appears 
below. 

 
The following options are available in this dialog. 

Display: This field enables you to select the doors you want displayed. The first option 
is "All", where all existing doors are shown, and the second option is "Categories", 
where the Categories field is activated. 
Display type: This field enables you to display the existing doors in 3D or 2D display. 
Categories: In this field you can select the categories of doors you want to appear. 
When a category is selected (so that it appears in blue), you can select the checkbox 
on the left of "Display" by clicking on it and display all the doors belonging to that 
particular category. Click on All to select all categories and click on None to select no 
category. Clicking on Edit opens the dialog below, where you can specify the desired 
categories. 

 
To add a category, type the name you want in the field "Title" and click on Add. 
Clicking on Change, you can change the name of a category whereas clicking on 
Delete you can delete a category. 
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Slide type: This field enables you to select the existing doors view. You can select 
between displaying the slide of the doors or their rendered view. 
New: The following dialog window appears on the screen where the user can create a 
door of his/her own. 

 
The following options are available in this dialog: 
• Opening shape: This option enables selecting the opening shape of the door. You 

can select a shape from the Library or the User's Library. Clicking on Opening 
Shape opens the Edit Opening Shape dialog, where you can select the shape you 
want and click OK. The other options available in this dialog have already been 
described in detail. 

• Opening mode: This option enables you to select the opening mode of the door. 
You can select an opening mode from the Library or the User's Library. Clicking on 
Opening Mode opens the Edit Opening Mode dialog, where you can select the 
opening mode you want and click OK. The other options available in this dialog 
have already been described in detail. 

• Casing: This option enables you to specify the characteristics of the casing.  
1. Existing: This option enables the user to specify if there shall be casing for 

the door or not. Selecting this checkbox activates the other options. 

2. Width: Specify the width of the casing. The default value is 0.050. 

3. Thickness: Specify the thickness of the casing. The default value is 0.100. 

4. Equal to wall width: Selecting the checkbox beside this option, you specify 
that the width of the casing shall be equal to the width of the wall where it is 
placed. 
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5. There is casing at the bottom: This option enables you to set if you want 
casing at the bottom of the door or not. 

6. 3D Colour: This option enables you to select the colour of the casing in the 
3D display as well as the material of the casing in the rendering mode. 

• 3D: This option enables you to set the properties of the door in 3D display and to 
create the door slide. More specifically: 

2. Length: Specify the length of the door. 

3. Height: Specify the height of the door. 

4. Opening percentage: Specify the opening percentage with which you want 
the door displayed. 

5. 3D Preview: Clicking on this option creates the slide of the door on the 
screen. There are various options available: View (V), where you can see 
the door in various views (up, front, right, axonometric), Zoom (Z), where 
you can zoom in the door you created, Netting (W), where you can see the 
door coloured, Hide lines (H), where you can see the door in hidden mode, 
Shading (S), where you can see the door shaded, Rendering (R), where 
you can see the door rendered, Slide file (M), where the program creates 
the necessary file for the slide of the door and, via a warning message, 
informs the user of the file created and, finally, File bmp (B), where the 
program creates the necessary rendering file and, via a warning message, 
informs the user of the file created. 

6. Finally, the "Slide" and "Rendering" options enable the user to see the door 
in netting or rendering mode, respectively. 

• 2D Parametrical: This option enables the user to create the ground plan of the 
door. Select the checkbox before the word Parametrical in order to activate this 
dialog. Without a checkmark, the 2D Parametrical dialog is inactive and the 2D 
Library dialog, which is described further down, is activated. More specifically, the 
following options are available in the 2D Parametrical dialog: 

1. Show rise frames: This option enables you to specify if you want the rise 
frame to appear in the ground plan slide. 

2. Show wall lines: This option enables you to specify if you want the wall 
lines to appear in the ground plan slide. 

3. 2D Preview: Clicking on this option creates the slide of the ground plan of 
the door on the screen. The options mentioned above are also available 
here.  

4. Opening percentage: Specify the opening percentage with which you want 
the door displayed. 

• 2D Library: This option is active if there is no checkmark in the checkbox beside 
the word Parametrical, as mentioned above. The available options are Library and 
User's Library, where clicking on 2D Library opens the relative dialog, from which 
you can select the drawing of the ground plan for the door. 

• Categories: This option enables you to assign the door you created to some of the 
categories you have specified. Clicking on All, all categories are selected whereas, 
clicking on None, no category is selected. The "Edit" option opens the "Edit 
categories" dialog, where you can add, delete or change a category. 
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The following example explains how you can create a door. 

Example: Suppose you want to create a two-panel openable door with glass, which 
shall be curved-angled and have a fixed upper part with separators. 

Follow the steps below: 

• In the Edit Parametrical Door dialog, select a blank location and click on New. 

• Click on Opening Shape and, in the Edit Opening Shape dialog, select the desired 
shape of the door. In this case, set curved-angled. 

• Click on Opening Mode and, in the Edit Opening Mode dialog, select the way in 
which the door shall open. In this case, specify an opening mode which consists of 
3 frames with glass, where the upper one is fixed with 3 radial separators and the 
other 2 are openable. 

 
• Select the option of having no casing at the bottom and leave unchanged the 

default values for width and thickness. 

• Set Length 1.500, Height 2.200, Opening percentage 0 and click on 3D Preview. 
You can see the door slide on the screen. Type M, to have the slide file created, 
and press Enter. The program informs you of the file created; click OK. To return to 
the New Door dialog, right-click and click OK to the prompt "Exit Preview?". 

• In the 2D Parametrical dialog, set opening percentage equal to 100 and click on 2D 
Preview to have the slide of the ground plan of the door created. Type M, to have 
the slide file created, and press Enter. The program informs you of the file created; 
click OK. To return to the New Door dialog, right-click and click OK to the prompt 
"Exit Preview?". 

• Finally, depending on the specified categories, select the ones to which the door 
shall be assigned. 

After the above procedure, the New Door dialog should be as follows: 
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Clicking on OK, the program informs you of the block created. Finally, in the Edit User's 
Parametrical Door dialog, type the name of the door you created and click on Change 
Name to save it. 
Delete: This option enables you to delete a door you have created. The program 
confirms deletion with a warning message. 

Copy: This option enables you to copy a door to another location. The program informs 
the user of the block copied, via a warning message. 

Trim: This option enables you to move a door from one location to another. The 
program informs the user of the block copied, via a warning message. 

Paste: This option copies or moves the door selected in the two previous options 
(Copy & Trim) to the desired location. The program prompts you to confirm the action 
to be executed. 

Locations Insert: This option enables you to insert a blank location for the creation of 
a new door. The program informs the user of the point where the blank location is to be 
added, via a warning message. 

Locations Delete: This option enables you to delete a location where a door has been 
created. The program informs the user of the location to be deleted, via a warning 
message. 

Locations Number: In this field, you can specify the number of the locations you want 
inserted or deleted. 

In the bottom left field you can type the name for the door you created and, selecting 
Change name, the given name is transferred to the column on the left side of the 
dialog. 
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Finally, at the bottom of the dialog you can see the options Previous and Next, which 
you can use to move between pages, as well as the options OK and Cancel. 
Below you can find a complete example regarding the creation of a window. 

Example: Suppose you want to create a window that is two-panel, cascade, sliding, 
with separators and has an upper frame which is reclining. Follow the following steps: 

• In the Edit User's Parametrical Window dialog, select a blank location and click on 
New. 

• Click on Opening Shape and, in the Edit Opening Shape dialog, select the desired 
shape of the window. In this case, set rectangular. 

• Click on Opening Mode and, in the Edit Opening Mode dialog, select the way in 
which the window shall open. In this particular case, specify an opening mode, 
which consists of 3 frames with glass, where the upper frame is reclining and the 
two below are sliding cascade frames and also have parallel separators. 

• Select the option of having a casing at the bottom and leave unchanged the default 
values for width and thickness. 

• Set Length 1.000, Height 1.200, Opening percentage 30 and click on 3D Preview. 
You can see the window slide on the screen. Type M, to have the slide file created, 
and press Enter. The program informs you of the file created; click OK. To return to 
the New Window dialog, right-click and click OK to the prompt "Exit Preview?". 

• Click on 2D Preview to create the slide for the window ground plan. Type M, to 
have the slide file created, and press Enter. The program informs you of the file 
created; click OK. To return to the New Window dialog, right-click and click OK to 
the prompt "Exit Preview?". 

• Finally, depending on the specified categories, select the ones to which the window 
shall be assigned. 

• After the above procedure, the New Window dialog shall be as follows: 

274  4M 



 
 

 
Clicking on OK, the program informs you of the block created. Finally, in the Edit User's 
Parametrical Window dialog, type the name of the window you created and click on 
Change Name to save it. 
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5.3 Column 
If “Column>Placement” is selected, the following dialog box is displayed, with all the 
necessary features of the column or the prop you are going to draw. 

 
Generally, the column definition may be performed with either points or polylines. If the 
column cross section is rectangular, activate the box below and define width, thickness 
and angle. If the column cross section is circular, activate the box below with the 
column radius. The values for the level and height of the column are lower while on the 
right you have the ability to define the column “Filling” with 3 alternative options: Empty, 
Solid or Hatch. In the last case you can define scale (density) and angle, by updating 
the corresponding values that are displayed in the window. 

If any Column is defined, e.g. Rectangular, by clicking “OK” it is inserted in the drawing 
for the user to place. Use the snap points to place the edge of the column on any 
characteristic point (e.g. the wall endpoint, the nearest wall side point etc). Next, having 
defined the column edge you can turn it 
if you wish to place it exactly where you 
want (also by using the snap points). 
Once you have placed the column, if it 
is placed on a wall, you can hide the 
unwanted lines by running the 
progeCAD "HIDE" command (see the 
example below). At the same time the 
wall preserves its entity (it does not 
break in two parts). 

You can also move a corner of the prop 
using the grips. This means that, after 
selecting the prop to activate the grips, you can grab anyone of them and move it 
towards the desired location. 
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Notes: 

• When a column is placed on a wall and the outline is too thin for some wall lines to 
be visible, you can hide the lines with the option HIDE (for the screen display as well 
as the printout where the HIDE LINES option should be selected). Note that the 
column and the hatching comprise a single object. Therefore, it can be copied, 
deleted, moved etc like all the other progeCAD elements. 

• Columns and walls are placed on different layers so that they can be edited 
separately. Specifically, the layer name for the two-dimensional Column is 
Build_columns_2d, while the layer name for the three-dimensional Column is 
Build_columns_3d. 

• Columns can be deleted through the progeCAD "Erase" command. Copying 
columns is allowed through the respective progeCAD command or even the "Array" 
command in case you want to draw a grid of columns. Moreover, the copies (that 
were created through COPY) of an original column will all be assigned the new 
changes that will take place to the original column or to any other copy. 

Selecting "Pillar > Modify" enables you to modify the properties of a pillar you have 
already drawn. The program asks you to select the pillar and then you can modify the 
properties you want in the appearing dialog which is also mentioned above. Moreover, 
a pillar can also be modified by double clicking it, or by selecting the pillar, right clicking 
and selecting "Properties". 

5.4 Slab 
This option is used for the slab definition on a building level. 

 
As shown above, in the corresponding "Slab" dialog screen, the dialog of this option 
includes the following keys-options with the functions described below: 

Outer Outline: This command enables the user to define the slab outline. 

Polyline: By selecting "Polyline", all you have to do is use the mouse to "show" any 
already drawn closed polyline (with straight and round sides) in order to convert it into a 
slab with the level and thickness that is displayed on the bottom left of the dialog box.  

Points: Alternatively, instead of a polyline you can define a series of points for the Slab 
definition. Specifically, by activating this option, the following message is displayed: 

Outline type \Polygonal(Ρ)\Circular(C): 
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If the user types "P", the program will allow him/her to draw the slab outline, by entering 
the polygonal vertices which define it. 

If the user types "C", the program will allow him/her to draw a slab with circular outline. 

Hole: This command enables the user to define any holes (spaces) that exist in the 
slab.  

Polyline: Clicking any closed polyline that is contained in the Slab outline converts it 
into a Hole. 

Points: Alternatively, instead of defining the Hole by Polyline, you can define it by 
points. In this case the following message is displayed: 

Outline type \Polygonal(Ρ)\Circular(C): 

If the user types "P", the program will allow him/her to draw the hole outline, by 
entering the polygonal vertices which define it. 

If the user types "C", the program will allow him/her to draw a hole with a circular 
outline. 

• Elevation: Define the level (in m) where the lower surface of the slab will be placed 
with regard to the current floor level. 

• Width: Define the slab thickness (in m), which should be a positive number. 

The following commands provide outline modification features that have already been 
defined: 

• Outline-Move: It enables the user to move a slab that is already created. 

• Outline-Delete: It enables the user to delete a slab that is already created. 

• Outline-Rotate: It enables the user to turn a slab that is already created. 

• Point-Add: It enables the user to add a new vertex to the outline of a slab that is 
already created. 

• Point-Move: It enables the user to move a vertex of a slab that is already created. 

• Point-Delete: It enables the user to delete an existing vertex of a slab outline that is 
already created. 

Note: You can run the command "slab" to draw any element (e.g. low walls, horizontal 
or vertical elements etc). Furthermore, you can draw a slab on the ground plan and 
then rotate in three dimensions through the "rotate3D" command, so the rotation axis 
and the rotation angle will be requested. This way you can construct inclined slabs. 
Moreover, by combining the "slab" with "rotate3D" commands you can draw practically 
any element (e.g. inclined slabs with holes, gables, pergolas etc). 

278  4M 



 
 

Example: Suppose you want to draw the slab that is shown below, by entering Points 
(second way): 

 
Select "Slab -> Placement" in the menu and "Outline" in the appearing dialog window. 
Then type "P" and press <Enter>. You are now ready to start drawing the slab outline, 
with the mouse, by "pointing" the outline endpoints (by left clicking). Once you have 
defined the last point, right click and the slab is automatically shaped. If you right click 
once more, the dialog screen "Slab" is displayed so that you can continue with its 
definition (until you finally click "OK" at the bottom side). 

 
In order to draw the circular hole, click the key "hole" and "C" (circular) and then press 
<Enter>. Left click at the hole centre and then move the mouse to define the circle 
radius.  

Left click to set the radius definite and afterwards press <Enter> (accepting the section 
number e.g. 16) for the hole to be drawn. Once you have completed the hole and right 
clicked, the dialog window "Slab" appears again. 
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You can continue editing the slab, but in order to complete the above example, all you 
have to do is insert "-0.25" for level and "0.25" for thickness, so that the slab is placed 
at the appropriate height. Select "3D View" to see that the slab is placed exactly the 
way you wanted. Select "Modify" to come back any time and perform any changes 
through the corresponding command-keys that were described above. 

The above slab can be easier defined by a polyline (1st way) since all you have to do is 
primarily draw a closed polyline, shaped as the slab outline, and a circular polyline with 
the hole size. Next run the command "Slab"->"Placement" and in the displayed window 
select "Outline –Polyline", so you "show" the outline with the mouse, and then select 
"Hole-Polyline", so you "show" the hole. Next watch the slab being drawn, with the 
thickness and the other dialog box characteristics. 

It is useful to practise through various examples so that the user can 
understand how a slab is dynamically configured and comprehend the utilities 
provided by the program. 

Note: The slab configuration is not always instant but it may take a few seconds. 

Selecting "Slab > Modify" enables you to modify the properties of a slab you have 
already drawn. The program asks you to select the slab and then you can modify the 
properties you want in the appearing dialog which is also mentioned above. Moreover, 
a slab can also be modified by double clicking on it, or by selecting the slab, right 
clicking and selecting "Properties". 

5.5 Beam 
Selecting "Beam > Position" displays the following dialog, with only the keys enabling 
the beam specification activated, that is the "Points" and "Polyline" keys. 
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After the user has geometrically specified the beam, as well as the development side, 
the following window returns with the other properties of the beam activated. 

 
These properties are identical to the ones appearing in the "Element parameters" 
screen mentioned in the previous chapter. The user may modify any of the above 
parameters (e.g. the width of the beam, its colour etc) in the following ways: By 
selecting "Beam > Modify", where the program prompts you to select the beam, the 
dialog also mentioned above appears and the user modifies the desired parameters, by 
double clicking on the beam and, finally, by selecting the beam, right clicking on it and 
selecting "Properties".  

5.6 Floors – Roofs  
Selecting Floors – Roofs displays a menu where you can choose between the two 
available options: (Floor or Roof). Selecting Floor displays the following dialog: 
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In this dialog, you can select the desired floor type; clicking "Accept" activates the 
drawing window, where the program prompts you to specify the outline points of the 
floor. To modify the floor type, select "Modify". The program prompts you to select the 
floor you want to modify. Moreover, a floor can be modified by double clicking on it or 
by selecting the floor, right clicking on it and selecting "Properties". 
Selecting Roof displays the following dialog: 

 
In this dialog, you can select the desired roof type; clicking "Accept" activates the 
drawing window, where the program prompts you to specify the outline points of the 
roof. To modify the roof type, select "Modify". The program prompts you to select the 
roof you want to modify. Moreover, a roof can be modified by double clicking on it or by 
selecting the roof, right clicking on it and selecting "Properties". 
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5.7 Library Drawings - Symbols 
This option enables the user to select among a 
series of drawings and symbols to place within 
his/her drawing. These drawings and symbols 
are grouped in categories. ProgeCAD 
Architecture includes 4 library groups, each of 
which is divided into 9 subcategories. These 4 
groups include 2D Symbols, 3D Symbols, View 
Symbols and User Symbols respectively. The 
first and the second group are used for the 
symbol placement (2D or 3D) on the ground 
plans, the 3rd group for the symbol placement 
on views (provided the user wishes to edit 
further any view or cross-section of a project 
drawing), while the 4th group practically enables 
the user to create his/her own libraries with the 
desired category name as shown in the adjacent dialog window. If the "Insert Drawing" 
command is selected, the familiar manager of the drawing slides libraries is displayed. 
This library manager includes the drawings that are already saved in the specific 
library. Apparently, in order to place a symbol on your drawing, you should first select 
the library category where it belongs and then select the specific symbol.  

As far as the sub-categories are concerned, they are the same in the first two symbol 
libraries (2D and 3D) and they are the following: 

1. General Symbols 

2. Bedroom Furniture 

3. Living-room Furniture 

4. Dining-room Furniture 

5. Kitchen Furniture 

6. Office Furniture 

7. Hydraulics 

8. Additional Furniture 

9. Surrounding Space (trees, plants, cars, etc) 

Each one of the libraries includes sheets with images-slides, formed as shown below 
on the right side: 
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Regarding the sub-categories of the 3rd group, that is view libraries, these are the 
following: 

1. Windows: 

2. Doors: 

3. Trees 

4. People - Cars 

5. Hydraulics 

6. Drawers 1 

7. Drawers 2 

8. Details 1 

9. Details 2 

These drawings are nothing more than the program libraries drawings, which can be 
enhanced or updated by the user, according to what is mentioned under the 
corresponding command "Libraries-Drawings", which is described below. By selecting 
a drawing or symbol, this is automatically placed on the corresponding layer, namely 
an individual layer corresponds to each one of the drawing categories. This is done for 
better drawing management, e.g. the user may want to isolate the plants from the 
drawing or all the symbols except the hydraulic receptors. In this case, the user should 
select the option "LAYER CONTROL" and FREEZE the layers of the library categories 
which he/she wishes to hide. In order to make this easier, the library layers have 
standard names in the form of "BUILD_FL00x_LIBS_y". 

Thus, for example, the layer named "BUILD_FL001_LIBS_6" stands for category 6 
Symbols that have been placed on the first floor (level), the layer named 
"BUILD_FL003_LIBS_1" stands for category 1 Symbols that have been placed on the 
third floor etc. Note that any deactivation is temporary, namely in case the user exits 
the floor (level) x, enters any other and returns to the x floor, then all the library layers 
of this floor will be displayed, regardless if he had deactivated them. 
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In order to place a symbol in your drawing, you should first select the library category 
where it belongs and then select the specific symbol. Specifically, by selecting one of 
the aforementioned library categories, a screen appears with the slides of the specific 
library category, where the user can select the desired symbol to be placed on the 
ground plan. For example, by selecting from the 3rd library group (views), the plant-tree 
category etc, the following slides screen is displayed: 

 
Placement is carried out through the known features of progeCAD, and more 
specifically: In the selected library symbol or drawing screen, press <Enter> on the 
symbol you desire and then press "OK". During insertion, the program prompts you to 
enter only the position where the drawing will be placed. All you have to do then is left 
click on the proper spot to set the placement position definite. 

 
Next you can provide the angle according to which the object will be placed, by moving 
the mouse respectively.  
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Left click to set the object placement completely definite. Note that, once the indication 
"scale xy" (on the top left) is activated, you can zoom in (or out) the corresponding 
symbol by x and y during the symbol placement. This is done by moving the mouse, 
immediately after you have placed the selected symbol on the drawing. Through 
various relative tests the user can easily comprehend the way symbols are placed on 
ground plans. 
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6. AutoBLD: Special Elements 
 

 

The "Draw Special Elements" menu, which includes the items 
shown on the right, allows the user to draw or insert in his/her 
drawing the most complicated parts of the construction, such as 
Roofs, Staircases, Rails, Vertical Elements (Gables), Chimneys 
and Ramps. The program considers all these elements as 
objects, the parameters of which can be modified in real time by 
the user. Each of the above "Special Elements" categories is 
described in the respective section that follows. Each section 
includes guidelines for solving simple or typical as well as 
difficult and more complicated cases and includes detailed 
examples to help the user understand and use the program, 
even in the most complicated or special cases. 

6.1 Roof 
The "Roof" command creates all kinds of roofs in three 
dimensions (3D) as well as their projections on the drawing 
surface (2D); it also allows the selection of hatch on the 3D 
drawing and the ground plan. 

6.1.1 Typical Roof Types 
In order to draw a roof, open "Special Elements" from the AutoBLD menu and select 
"Roof". The following window will appear, with the various roof types (Single-sided, 
Two-sided, Four-sided, Isoclinal and Anisoclinal). Alternatively, you can select the 
command from the relative toolbar, which appears in the following picture: 

. 

Selecting the Roof drawing command displays the following dialog box: 
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Depending on the selected roof type, a dialog box will appear, prompting the user to 
enter the characteristic points of the roof, the roof height, its protruding distance from 
the wall etc. 

The following sections describe the various roof types and their parameters, in the 
order they appear in the menu. 

Single-sided Roof: When "Single-sided Roof" is selected, the following dialog box 
appears, where you can choose "Points" and define the single-sided roof. More 
specifically, three points have to be specified, the two of which define the horizontal 
side of the roof and the third defines the roof plane following the inclination that has 
been entered in the roof parameters.  
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Two-sided Roof: Similarly to the previous case, the following dialog box appears 
where three points should be specified. Two of these points define one of the 
horizontal sides of the roof, while the third – which is at the opposite side – is specified 
in such a way that the ridge is equidistant from points 2 and 3. The user can easily 
comprehend the drawing of a two-sided roof by trying a simple test. 

 
Four-sided Roof: In the four-sided roof dialog box, select 3 points to specify the roof. 
The first two of these points define one horizontal side, whereas the 2nd and the 3rd 
point define the other horizontal side. The program assumes that both sides are equally 
inclined and specifies the roof vertices automatically. 
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Isoclinal and Anisoclinal roof: The dialog box shown next will appear. 

 
To draw an isoclinal or anisoclinal roof, you can either select "Points" and determine 
one by one all the edges on the ground plan (after determining the last point, you must 
right-click to indicate that there will be no other points) or select "Polyline" and point on 
a closed polyline (the outline of which must have already been drawn). You should also 
make sure that the inclination, height, elevation, width and extension of the roof from 
the outer sides of the walls is correct. The exact data you have to enter are the 
following: 

Points: Specify the points (vertices) of the roof base outline. When you have 
determined the last point, right-click and the roof "closes" automatically. The "Points" 
command can be used as an alternative for the "Polyline" command. 

Polyline: Point the mouse on the polyline you have already drawn to determine the 
roof outline. The "Polyline" command can be used as an alternative for the "Points" 
command. 

Outline Editing: This command group enables moving, adding or deleting a point of 
the roof outline, allowing the user to modify the roof without having to create it from the 
beginning. This command group is activated after a roof is drawn and is used primarily 
in combination with the “Change Roof” command, which shall be described later. 

In detail, this command group consists of the following modifications: 

Move Point: Allows the user to move a vertex of the roof outline. To specify the vertex 
you want to move, all you have to do is point the mouse on a point near the vertex, 
drag it and watch the vertex move correspondingly. 

Add Point: Allows the user to define a new vertex of the roof outline. Select the side 
where you want the new vertex to be located and specify the new vertex position. 

Delete Point: Allows the user to delete a vertex of the roof outline. 

Inclination (°): Enter the roof inclination in degrees. 

Inclination (%): Enter the roof inclination in percentage. 
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Double Inclination: Select this option if you want the roof to have double inclination. In 
this case, specify the second inclination and the height of separation. By default, the 
second inclination value is 50 and the separation height value is 1.00. These values 
become active upon selecting the “Double Inclination” checkbox and can be modified 
from the Roof dialog box. 

Sections on vertical sides: This option enables the creation of sections on the vertical 
sides of the roof, in order to create complex forms. (This command is presented in 
detail further down.) 

Height: Enter the roof height in meters (m). 

When you have specified one of the above values, the other is calculated automatically 
(the values can be seen on the screen). 

Elevation: Enter the roof distance (in m) from the floor level of the current floor. 

Width: Enter the roof thickness in meters (m). Roof thickness helps better imaging of 
the drawings (e.g. cross sections). 

Extension: Determine how much the roof protrudes in meters (m) from the specified 
outline, which is usually the propping outline. 

Connection with Roofs: When you want to insert two or more roofs which intersect on 
the plan view, these roofs are automatically connected so that the correct effect is 
created on the plan view as well as in 3D display. The same applies in the case of a 
skylight on a roof. 

Connection with Walls: This option enables the walls to be raised up to the roof. 
Upon inserting the roof, select “Connection with Walls” to raise the 3 walls up to the 
roof. Then, the following window appears, where, pressing “New Connection”, you can 
select the roof and the walls you want to connect. You are prompted to select the roof 
first and then the walls you want to raise up to the roof, one by one. Then, press Enter; 
the “Connection with Walls” dialog box appears, updated with the relative wall 
properties. Finally, pressing OK, you return to the Roof dialog box and, pressing OK 
again, you can see the walls raising and their connection with the roof. 

 

Skylight: This option allows the insertion of an “Inclined” or “Vertical with walls” 
skylight as well as the definition of its properties. This command operates as follows: In 
the Roof dialog box, select the desired skylight type (inclined or vertical with walls) in 
the “Skylight” field. Then, select “Properties” and the following dialog box appears: 
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This window enables specifying the distance from the roof, the properties of the 
skylight walls (facade length, facade height, wall width and colors) as well as the other 
properties of the roof (type, inclination, height, thickness, colors and draw).  

Apart from the above properties, the user can specify the properties of the skylight 
opening through the “Opening Attributes” option. Pressing this button displays the 
skylight opening attributes, which can be modified in the following window which is 
similar to the window described in AutoBLD>Opening>Window: 
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Hatch: Select the hatch type of the roof. Press <Enter> on the [Hatch] button to view 
the respective menu from where you may select the desired hatch. Each hatch uses a 
scale in order to be printed correctly. This scale is user-defined. It should be mentioned 
that there is a “switch” available for inactivating the hatch, in case that the user wants 
to process a “lighter” drawing.  

Example: Draw an isoclinal roof for the following ground plan: 

 
Select "Isoclinal roof" for the following dialog box to appear: 

 
If you choose to define the roof outline using points, click the "Points" button. Enter the 
outline points as shown in the picture of the next page. 
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After entering the last point (or, in case you have selected "Polyline", after closing the 
polyline), right-click to view the "Roof" dialog box. Click "OK" and see the isoclinal roof 
(with its ridges) being drawn: 

 
Using the "Hide" command, you can hide everything that is under the roof, so that it 
can be better viewed. You can also view the roof in 3D: 
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In the above example, the roof height was calculated automatically based on the initial 
default value of the inclination (25). Of course, the user can change the inclination or 
enter directly the desired roof height. For every change of either the height or 
inclination, the program calculates the other value (inclination or height) automatically. 

The roof parameters include its color (in 2D or 3D) and its hatch as well. The following 
picture shows a roof with hatch (note that the two roof-shades are hatched differently 
from the main roof):  

 

Note: The use of hatch makes the drawing more complicated and, therefore, the file 
size increases accordingly. Also, the time needed to create the hatch depends on the 
number of the roof sides and the complexity of the hatch type (sometimes the creation 
of the hatch may take a few minutes). For all these reasons, it is suggested that the 
hatching of the roof should be the last task. 
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A very useful feature of the program is that it allows the dynamic management of 
the roof, that is the ability to modify one or more of the above mentioned parameters 
and directly monitor the result. This feature is provided through the "Modify Roof" 
command, which activates again the roof dialog box that contains all the values 
associated with a particular roof. For example, run the "Modify Roof" command, select 
a specific roof and then you can modify the roof height in the appearing dialog window. 
Click "OK" and see how the roof changes. This way, you can modify any parameter 
and view the results. The ability to change the inclination of one or more sides of the 
roof is very helpful as it makes it easy to create practically any roof type in minimum 
time. 

More specifically, a roof can be modified in the following ways: 

Move Point: Allows the user to move the vertex of the roof outline. To specify the 
vertex you want to move, all you have to do is to place the cursor on a point near the 
vertex, drag it and watch the vertex move. 

Add Point: Allows the user to define a new vertex of the roof outline. Select the side 
where you want the new vertex to be located and specify the vertex position. 

Delete Point: Deletes a vertex of the roof outline. 

Inclination: Allows the user to modify the inclination of one or more sides of the roof. 
To change the angle, you must first specify the new inclination [between 0 degrees (for 
horizontal parts of the roof) and 90 degrees (for vertical parts)] and then point on the 
sides you want to change. Please note that no section is drawn when the inclination is 
set at 90 degrees. 

Example: Make the following modifications to the roof drawn in the previous example: 
Change the height (from the one initially calculated to 1.5 m), extend the entire roof by 
0.40m and especially by 1m on the right side, the inclination of which should also be 
changed into vertical (90 degrees). 

Select "Modify Roof"; in the appearing dialog box, enter the new values for height (1.5 
m) and extension (0.40 m) and click "OK": 
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These first changes can already be viewed on the screen. Select "Modify Roof" again 
or simply right-click (which repeats the last command) to re-open the dialog box and 
choose "Inclination". Provide 
the new inclination (90) in the 
command line, as prompted. 
Then, click the side of the roof 
which inclination you want to 
change and watch the 
inclination changing into 90 
degrees (the user can see the 
inclinations of all sides at 
anytime, as they are 
automatically displayed in the 
center of the side). Click "OK" 
and see how the roof is 
changed (the change will be 
more evident if you activate 
the 3D view). As you will see below, the "gap" can be "filled" with the "Raise Wall" 
command. 

To complete the example, you must move the right side (as shown in the ground plan) 
by 1m to the right. For this purpose, select the "Move" command and, using the snap 
points, grab the roof edge and move it accordingly: 

 
When you have moved the first endpoint to its final position, the drawing will appear as 
follows: 
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Follow the same procedure with the lower right endpoint and then right-click to view the 

dialog box. Click "OK" to confirm the action. You will see 
that the right side of the roof has been extended to the 
desired point: 

An additional feature of the program is that it allows the 
user to specify points and inclinations on an existing roof 
and automatically view the corresponding altitudes and 
inclinations on the ground plan. Select "Roof Height 
Dimension" or "Roof Inclination Dimension" from the 
same command group. You will be prompted to specify 
the roof and enter the desired points. These points will be 
indicated on screen with the appropriate symbols. This 
action should take place only if the roof has reached its 
final form. 

Besides, the “Details of the Roof view” option enables the user to enhance the view file 
with some drawing details. 

Finally, if there are any "gaps" created, you can extend a wall 
to the roof edge. In the above example, you can fill the gap 
with the "Raise Walls" command. You will be prompted to 
point the roof to which the wall will be attached and the wall 
itself. 

To familiarize yourself with the program faster, you can 
continue modifying the roof of the above example, using the 
other commands as well. 
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6.1.2 Special Roof types 
Using all the provided utilities, the user can draw roofs of practically any type. This 
section describes some more complicated roof types and the way they can be drawn: 

Roof with vertical side(s) (gable): This is an isoclinal roof with one or more sides 
angled vertically (90o). This is accomplished through the technique used in the example 
of the previous section. 

Roof - Shade: The "Roof" command can be also used for drawing shades, roofed 
verandahs and other inclined surfaces (e.g. ramps, like drawing single-sided roofs). 

Example: Suppose you want to construct a 1.5 m wide shade, with the shape shown in 
the following picture: 

 
Select "Isoclinal Roof" and provide the outline, following the known procedure. The 
following roof will be created: 

 
Change the angles of the four sides shown in the picture to 90 degrees to create the 
desired shade. 

In the above example, the roof was drawn as one part, because the two parts have 
equal width. If the width is different, you should create two separate parts. In this case, 
draw the first part as an isoclinal roof and change the inclinations; then, do the same 
for the second part. 
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Roof with support sides of different 
height: This type of roof (shown in the 
picture) is drawn as two parts, like two 
single-sided roofs. 

Roof as a simple geometric shape: 
You can convert a roof from an object 
into a geometrical shape with lines (or 
3D faces), if this helps in further editing 
the drawing. The conversion of a roof 
into a number of simple lines is 
performed using the CAD "Explode" 
command. 

Of course, this manual cannot describe all possible roof types. However, as proved in 
practice, the program facilitates drawing even the most special roof types. As long as 
the user has understood and become familiar with all the features mentioned in the 
previous sections, he/she will be able to deal with practically any case. 

6.1.3 Chimney 
Selecting AutoBLD>Special Elements 
Drawing>Chimney or typing "chimney" in the 
command line, you can insert a chimney in the 
drawing with the desired properties. Upon selecting 
this command, the following dialog box appears, 
where you can select the chimney type (rectangular 
or circular) and specify its desired properties (width, 
thickness, height, hat attributes) as well as the level 
where it should be located.  
 
Upon creating the chimney, you can modify it and 
change any of its attributes you want. This can be 
done either by double clicking on the chimney to be 
modified or by right-clicking on the chimney and 
selecting “Properties” from the pop-up menu or by 
selecting the chimney and pressing the “Modify 
Entities” option in the Property Panel. Any way the 
user chooses, executing one of the above displays 
the Chimney dialog box again, where you can modify 
the chimney properties. 
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6.2 Staircases 
6.2.1 General 
Select "Special Elements" in the AutoBLD menu and then choose "Staircases". A slide 
screen will then appear, where each slide corresponds to a specific staircase type. 

 
These are standard staircase types, except for the last one (free-route staircase), with 
which the user can create any type of staircase. Depending on the selected staircase 
type (by double-clicking the corresponding slide or by left-clicking once and then 
clicking "OK"), a dialog box will appear with the parameters corresponding to the 
particular staircase. After inserting the correct values for each of these parameters and 
then clicking "Calculations" and "OK" to exit, you can see the staircase being created 
on the ground plan. As expected, the required parameters for each staircase type are 
different. In general, these parameters involve the staircase "points", which are the 
characteristic points of the staircase route and are differently standardized for every 
staircase type as well as other parameters such as height, elevation, width etc, which 
are common in all types. 

When you have specified the appropriate "points" of the staircase, directly on the 
ground plan (where the respective option of the staircase dialog box automatically 
leads), and confirmed that the values of the other parameters are correct, you can click 
the "Calculations" button to view the results for the various calculated staircase 
parameters (the tread and the riser of the step, the number of steps etc). At the bottom 
left part of the window there are indications for the compliance of the result values with 
the General Building Code (GBC) regulations. If the boxes are ticked, the 
corresponding result complies with the GBC. If a box is empty, the particular value 
does not comply with the code. However, you can still construct the staircase if you 
want to and if it is technically possible (otherwise, a relevant message appears). In any 
case, you can change any parameter, in order for the program to re-calculate and 
provide results that comply with the code. Please note that, besides the parameters 
you have initially set, you can also change the number of steps, by entering the desired 
number in the "No of Desired Steps" field and clicking the "Calculations" button. The 
program will then perform the calculations; based on the number of steps you have 
specified. If you want to cancel the desired number of steps, you have to enter "0" in 
the corresponding field and click the "Calculations" button again. 
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The "Begin Symbol – End Symbol" and 
"Stairs Section" commands are common in all 
staircase dialog boxes. Select this command to 
view the symbols window. After the staircase is 
calculated, these symbols will be placed at its 
starting and ending points. In the staircase 
cross section menu, you can specify which part 
will be visible and which not and select the type 
of the line that will be used for drawing the 
invisible part. The cross section line is the one that separates the visible from the 

invisible part. 

A very important feature, in case you want to re-draw 
a staircase of the same type, is that you do not need 
to delete the previous one and repeat the procedure, 
but you can simply change the parameters and 
dynamically modify the staircase. This is carried out 
through the "Modify Staircase" option, which is very 
useful for every change or even tests that need to be 
performed, until you manage to draw the desired 
staircase. 

Example: Draw a 2.90 m high circular staircase, with 1.20 m outer and 0.20 m inner 
radius. Assume that the staircase begins horizontally and turns by 3/4 (i.e. 270o) 
clockwise. 

Select "Staircase" to view the main window with the standard staircase types and 
choose "Circular Staircase". 

The circular staircase dialog box will appear: 
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Click "Center" to enter the screen and specify the characteristic points of the staircase. 

• The first point you are prompted to specify (see 
command line) is the center of the staircase. 

• Then you are prompted to provide the length of the 
big radius, which can be also defined using the 
mouse (and monitoring the length on the screen) 
or typing @ x,y, making sure that the line you see 
corresponds to the starting side of the staircase. 

• Then enter the length of the small radius. 

• Finally, enter the side where the staircase ends, namely the arc between the starting 
side and the ending side. 

When you have finished entering all the data mentioned above, you are transferred 
again in the circular staircase dialog box. Now, if you click "Calculation" you will see the 
number of steps and the 3 basic geometrical characteristics of the staircase (tread, 
riser and 2h+b) at the bottom left part of the screen. Note that the calculated values are 
within the General Building Code limits, as indicated by the three ticked boxes. 

 
After making sure that all values in the dialog box are correct (height, rotation etc), click 
"OK" to see the staircase being drawn. 
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Through the "3D View" command, you can view the staircase in 3D (e.g. from a 
viewing angle of 45o). 

 
Any possible modifications can be carried out easily and quickly. For example, if you 
want the staircase to have 16 steps and to turn to the opposite direction, all you have 
to do is run the "Modify Staircase" command, point the mouse on the staircase (as 
seen in 3D) and enter the appropriate values in the dialog box that will appear (for the 
rotation, you have to select the lower field ("Counterclockwise"). Finally, do not forget to 
click the "Calculation" button in order for the program to recalculate the staircase with 
the new values: 
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As you can see, with the new data, "Tread" does not comply with the GBC provisions, 
but assume that you want to build the staircase anyway. If you click "OK", the new 
staircase will be drawn (in the same viewing angle). 

 
You can try all possible ways of changing the staircase [radii, arc, width, number of 
steps (note that in order to cancel the desired number of steps, you must first delete 
the corresponding value and then re-calculate) etc], in order to become familiar with the 
features of real-time dynamic staircase drawing. 

6.2.2 Staircase Additional Elements 
The dimensions of a staircase as well as the way they should be defined in order for a 
staircase to be constructed were described above. This section presents the facilities 
provided by the program concerning the definition of additional elements, such as rails, 
handrails, parapets etc, along with the staircase. These elements can be defined from 
the beginning or added later on, so that the drawing file is easy to work with. In the 
following dialog screen, which is activated when "Rails" is selected through the 
respective command, the above additional elements are specified: 
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As shown in this screen, the upper part regards the left outline of the staircase whereas 
the bottom part concerns the right outline. In each one of them, there are 3 main 
options available: "No", "Low Wall" and "Rail" respectively. By default, buttons for both 
outlines are in the "No" position, while the items concerning the parapet or the rail 
dimensions are activated when the option "Low Wall" or "Rail", respectively, is 
selected. More specifically: 

The parapet definition is based on the following data (values are in m): 

• Elevation: The level where the low wall starts in relation to the staircase 

• Height: The low wall height 

• Width: The low wall width (thickness) 

The rail definition is based on the following data (all dimensions are in m as well): 

• Width: The rail width. 

• Thickness: The rail thickness. 

• Type: Click the key "Type" to select the rail pattern (e.g. circular, square etc cross 
section) from the appearing screen with slides. 

• Distance: It concerns the spacing between rails and it can be defined as desired. 

The above two cases can be associated with a handrail. Regarding rails in particular, 
handrail exists in any case. Provided there is a handrail, select the checkbox (with an 
"x" mark) and determine the elevation, height and width (in m). 

Example: Suppose you want to add parapet at the inner side and circular cross 
section rails at the outer side of the circular staircase drawn above. Let the parapet be 
0.7 m high, the handrail 0.1 m wide and the rail 0.85 m high while the spacing between 
rails will be 0.20 m. 

Run the "Modify Staircase" command and select the circular staircase drawn in the 
previous example to enter the dialog screen carrying the parameters of the particular 
staircase. Select "Rails" within this window to enter a new dialog screen where you 
should provide the appropriate values: 
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Click "OK" at the bottom to return to the previous dialog screen where you are 
prompted to perform calculations once more and then click "OK" to exit. You can 
then see the staircase being drawn. If the viewing angle is set at 225° (within "Viewing 
Parameters"), the staircase is displayed as in the following picture: 
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Apart from rails, the additional 
elements include the staircase 
colors as well as the materials used 
for its construction. This selection is 
carried out through the "3D Color" 
and "2D Color" options, which 
function similarly to everything 
mentioned in the previous chapter 
regarding walls. Therefore, if, for 
example, “2D Color” is selected, the 
adjacent window appears, 
presenting all the alternative colors 
for the user to select the desired 
one. Once "3D Color" is selected, a 
window appears displaying colors 
that correspond to particular materials, which you can select if you are interested in 
running Photorealism through PhotoIDEA. Finally, in case you want to "fill" the section 
under the staircase, you should insert the same values in the fields "thickness" and 
"height". 

6.2.3 Staircases of Wood or Metal 
ProgeCAD Architecture can draw wooden or metal staircases, as well. By choosing 
metal or wood on the material check list, the following dialog appears with a series of 
parameters concerning the construction of the wooden/metal staircase. 

 
By pressing the “Cross section and Location” key, a new dialog appears prompting for 
the combination of the cross section and the location of the staircase. Then, by 
selecting a certain combination (the program displays a message if this combination is 
invalid) and returning to the previous dialog, the slides of the “Rung” and “Staircase 
Beam” have been defined. 

Then, by pressing the keys “Rung” and “Staircase Beam” below the slides, you can 
choose the right type of those parameters from the alternative options (see the 
following example for the Rung). 

308  4M 



 
 

  
After having defined all the values for the parameters of the staircase, you can create 
the desired staircase, according to the instructions given previously for the concrete 
staircase. 

Once the staircase is created, you can use the “Staircase Table” command in order to 
append a table with all the details of this staircase. 

6.2.4 Standard Staircases 
The circular staircase mentioned above is one of the standard staircases included in 
the program. The other standard staircases are constructed similarly provided their 
particular features are determined in each case. Regarding the additional elements, 
such as rails, parapets, colors etc, they are specified according to the guidelines 
provided above. Therefore, the only thing left is to have a look at the standard cases 
and what parameters are required in each one of them, so that the desired staircase is 
created. Note that, apart from "Standard Staircases", you can also specify a staircase 
of any particular type by running the "Free-route Staircase" command, which is the last 
one in the standard staircase screen). Instructions for the creation of a free-route 
staircase are provided in the following section.  

The "Standard Staircases" screen includes the following cases: 

Straight Staircase: When the "straight staircase" option is selected, the appearing 
dialog presents all its features: 
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The determinant features of such a staircase are its Definition Points, which have to be 
provided. When you click the "Point Definition" key, the program prompts for the 
following characteristic points of the staircase: 

• the starting point of the staircase (in the middle of the step) 

• the ending point of the staircase (in the middle of the step) 

Regarding the elevation, the height, the width and the thickness of the staircase, the 
values inserted in the respective fields shall be taken into account. 

Straight Staircase with Landing: When the "Straight Staircase with Landing" option is 
selected, its features are displayed in the respective dialog screen that appears: 

 
The determinant features of such a staircase are its Definition Points, which need to be 
provided. When you click the "Point Definition" key, the program prompts for the 
following characteristic points of the staircase: 

• the starting point of the staircase (in the middle of the step) 

• the ending point of the staircase (in the middle of the step) 

Regarding the elevation, the height, the width, the number of steps prior to the landing, 
the landing length and the thickness of the staircase, the values inserted in the 
respective fields shall be taken into account. 
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Staircase with Landing and 90° Angle: In this case the following dialog screen 
appears: 

 
• the starting point of the staircase (from the outer side) 

• the staircase endpoint at the landing corner (from the outer side) 

• the ending point of the staircase (from the outer side) 

Regarding the other items, the values inserted at the bottom are taken into account. 

Staircase with Landing and 180° Angle: Everything mentioned above applies here 
as well. The only difference is that here the user should determine 4, instead of 3, 
endpoints. In this case, the appearing dialog screen is the following: 
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Staircase with Reformation and 90° Angle: The same actions performed in the case 
of a straight staircase with landing and 90° angle apply here as well while the dialog 
screen is the following: 

 
Staircase with Reformation and 180° Angle: The same actions performed in the 
case of a straight staircase with landing and 180° angle apply here as well. 
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Staircase with Reformation and 270°Angle: The applying instructions are similar to 
those described above. 

 
Circular Staircase: It concerns the staircase described in detail and with an example 
in the first section of this chapter. 
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6.2.5 Free-Route Staircase 
The "Free-Route Staircase" option is found in the last position of the slide screen. 
When you select to draw a free-route staircase, you will be prompted to "mark" its 
ascension line and its outlines (boundaries). Therefore, you should first draw the 
ascension line and the boundaries of the staircase and then select the respective 
option. In order to draw the ascension line, run the respective command "Ascension 
Line" (alternatively, you can select the option "polyline" -pay attention not to select the 
"line" option- in the CAD option group "Draw") in the ascension direction. 

Furthermore, to draw the outlines you can either use polyline or run the command 
"Copy Ascension Line", provided they are parallel to the ascension line. In this case, 
you are prompted to enter the distance from the ascension line and the side in relation 
to the ascension line where the outline will be drawn, that is outwards or inwards 
(alternatively you can run the progeCAD "offset" command). Regarding the ascension 
line, it is important for the changes in direction to be normal, that is why you should use 
the "Smooth Ascension Line" command, setting the curvature radius equal to half 
the value of the step width (alternatively, you can run the progeCAD "fillet" command). 
After that, you can see the ascension line forming following the curvature radius you 
provided. Another parameter, which is initially estimated automatically but the user may 
later modify (running "Modify Staircase"), is the "Minimum distance of the ascension 
line from the outlines". Note that the more the above value approaches 0 the more 
vertically are the steps placed to the ascension line. 

 

314  4M 



 
 

Finally, select the "Landing" option to determine along the 
ascension line as many landings as desired. In particular, 
running this command triggers the following dialog box to 
appear, where you can add, modify or delete the staircase 
landings. The landing definition includes its length, which 
corresponds to a section of the ascension line, as well as 
the number of steps prior to the landing (start counting 
from the last landing or the staircase starting point). 

Example 1: Draw the staircase shown in the following 
figure. Its width equals to 1.20 m. 

 
First of all, define the outline (let it be the outer 
one), by a polyline, providing the 3 terminal 
points, as shown in the figure. 

Run the "Copy Ascension Line" or the progeCAD 
"Offset" command (providing distance equal to 
0.6, half the width) to copy the outer outline 
shifted by 0.6, so that an ascension line is 
created. Run the above command once more 
(retain 0.6) to create the inner outline of the 
staircase as well. 

progeCAD Architecture  315 



 
 

 
The only thing left is to select "Smooth Ascension Line" providing a radius equal to 0.6 
m. 

 
Now you are ready to select to draw a free-route staircase from the menu. Select 
"Dimension Definition" in the appearing dialog screen and click the ascension line as 
well as the outlines, exactly as required. In the dialog window, which appears on the 
screen once more, select "Calculations" and make sure that the calculated steps are 
19 and the lengths corresponding to the tread and riser of the steps are 0.290 and 
0.160, respectively. Click "OK" to see the staircase being created on the ground plan, 
exactly as desired, while in a 3D image it is displayed as in the bottom left figure: 
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Suppose you want to add a landing 1m long starting after the 8th step. All you have to 
do is select "Landings", insert values 8 and 1 at the bottom right side (and click "Add" 
right after so that it is saved in the landing table) and finally click "OK". You can then 
see the staircase being modified accordingly. 

Apparently you can work similarly to create any possible version out of the above case, 
like the one displayed on the top right side (pay attention so that there is always one, 
even a very small, angled section in the inner outline). 

Example 2: Draw the staircase shown below: 
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Start to draw the outer outline with Polyline and form the 
ascension line through "Offset" (by 0.6). Continue with 
the inner outline (lantern) and create the 3 characteristic 
lines of the staircase. Afterwards, smooth the ascension 
line (with radius 0.6) as well as the inner outline (with 
radius 0.1). If you select "Draw free-route staircase", 
define the 3 characteristic lines and select 
"Calculations", you will see that there are 15 steps 
calculated in the dialog window. Finally, clicking "OK" 
triggers the creation of the staircase on the ground plan. 
However, the staircase looks much more impressive in 
the 3D image. 

Studying the two above examples, the user is able to comprehend the utilities provided 
by the program concerning the creation of any other type of staircase.  

Finally, in the AutoBLD->”Draw Special Elements” menu, the “Analysis to Outlines’’ 
command enables the user to see the outlines that constitute the staircase. 

6.3 Rails 
If "Rails" is selected, the following dialog box appears including all the parameters, 
which define the rails. 

 
More specifically, these parameters regard: 

• Dimensions of the low wall (Elevation, Height, Thickness), on which the rails are 
placed, as well as the 2D and 3D Color of the low wall. 

• Rail Dimensions (Height, Thickness, Motif Length) as well as its 2D and 3D Color. 

• Width and Thickness of the Handrail, which you may want to place on top of the 
rails. 
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Provided these parameters are defined, you can select a Rail "Drawing", through the 
corresponding option, from the existing rails which will appear in the respective slide 
group. Alternatively, you can select one of the "User's" Rails, which are included in the 
Rail Library and can be easily created by the user. Note that, in order to create a rail, 
you have to select the "Rail Library" option first. 

Then you can draw the Rail by either specifying Points or clicking a polyline (previously 
drawn) and the selected rail (along with the parapet) is formed on the screen. Any later 
modification is possible through the "Modify Rail" option. 

Example: Create a rail on a parapet, like the one shown in the following figure. Keep in 
mind that the rail of the figure is 0.70 m high, the parapet is 0.30 m high and the 
spacing between rails is 0.25 m. 

 
Select "Rail" and specify the following values: 

 
Then enter the ground plan (of course, it is also possible in the 3D drawing) and draw 
the rail as shown below: 
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User’s Rails 
Select this option to enter the User's Rails Library, which corresponds to a screen with 
slides that are initially blank. 

 
If you select one of the slides and click the "Create" key on the right, the following 
dialog box appears: 

In order to run the commands included in this dialog box, you should have already 
drawn a rail section, according to some specific rules which will be also described in a 
simple example below. The displayed sections, the rail profile, can be lines or polylines, 
which will later obtain volume (thickness) with the help of the program. 
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Example 1: Suppose you want to create the rail type shown in the following figure: 

 
First of all, use lines or polylines to draw the rail pattern (on the ground plan). Then, 
select "Object Definition" to define the desired width and thickness and select the lines 
which will be drawn following these parameters. Then: 

• Select "Icon Slide Screen" to determine in the appearing window what you want 
included in the rail slide. 

• Select "Solid Object" to have the rail converted into a three-dimensional drawing. 

• Select "Icon Save Slide" to create the rail slide. 

• Select "Insertion Point" and provide the point in relation to which the rail should be 
inserted in the drawing. 

• Select "Pattern length" and show on the screen the length of the prototype rail you 
drew or just type it. 

• Select "Pattern height" and show on the screen the height of the prototype rail you 
drew or just type it. 

• Select "Pattern thickness" and show on the screen the thickness of the prototype rail 
you drew or just type it. 

• Select "Save Drawing" and the on-screen drawing is saved in the "User's Rails" 
library, provided of course it has been selected. 

• Select "Close" to exit the dialog screen. 

Example 2: Suppose you want to create a more complex 
rail, which elements are not necessarily on the same 
level, as in the previous example. More specifically, 
suppose you want to create a rail like the one shown in 
the adjacent figure (or any other similar to this or even a 
much more complex one). 

First of all, run the "Pline" command to create the 
"elementary" shape, e.g. the one displayed on the 
bottom left. 
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Select "Rail Library" and "Create" in the "User's Rails" window. During 
definition, select the above pline. Press <Esc>, to exit the user's rail 
creation menu. 

Run the "extrude" command and select the above "pline", providing 
0.05 as height of extension and 0.0 as extension taper angle. Then run 
the "pline rotate3D" and it will be displayed on the ground plan as a line 
(its projection). You can now copy this element (through simple copy-
"copy" or multiple copy-"array"), so that the repeated rail unit is created, 
by joining them with lines as shown in the following figure. 

Run again the commands "Rail Library" and 
"Create" in the "User's Rails" window. During 
definition, select only the 4 lines (line in the 
adjacent figure), but in the "Solid Object" window 
select the entire figure. 

Carry on running the other commands, exactly 
as described in the previous example, until the 
rail creation procedure is completed. 

6.4 Vertical Element - Gable 
This command supports drawing of vertical elements, such as gables. Furthermore, the 
user may run this command to create vertical layers with slight thickness so that 
different materials can be assigned to surfaces (or surface sections) for photorealism 
(e.g. wall section with bricks, wooden facing etc). 

If "Gable" is selected, the following dialog box appears: 

 
Select the option "Plane Definition" to specify on the ground plan the first and the 
second point of the axis in relation to which the gable will be defined. Once these two 
points are specified, the program automatically shows the view corresponding to the 
determined axis. On the side view, the "Outline>Outer" command displays the following 
message in the command line: “outline type/polygonal (p)/circular (c)”, where typing p 
prompts you to specify the 1st point or to draw the polyline of the desired shape. The 
latter option enables the user to create complex polygonal shapes as well as shapes 
including straight lines and arches.  
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This way, you can define the desired gable. In the view, run the "Outline" command to 
define the desired gable. Similar to "Slabs", the command "z axis" converts the 
thickness from positive to negative; in other words, the gable is mirrored with regard to 
the axis which was initially determined. 

Any possible change of an existing vertical element can be implemented within the 
respective dialog which appears through the command “modification of the vertical 
element” or by double clicking on the element and selecting “Properties”. 

Example: Suppose you want to create the gable (in view) which is shown in the 
following figure: 

Select "Vertical Element-Gable" and click "Plane 
Definition" in the appearing window. On the ground plan 
specify the first and the second point of the axis in 
relation to which the gable will be defined. 

In the view that is automatically displayed after the 2 axis 
points are provided, select the "Outer Outline" option to determine the outline type (in 
this particular case, it is polygonal - P) and draw the Gable outline, exactly as shown in 
the above figure. Then select the created Gable through the "Modify Vertical Element" 
command to return to the view of the Gable for which you should specify a hole (with 
circular outline - C) by providing the centre and the radius. Accept the recommended 
number of sections (for circle simulation), press <Enter>, <Enter> and <OK> and look 
at the final form of the Gable in view. Select "3D View" for better monitoring and run the 
"Move" command to place the Gable in the desired position. 

6.5 Ramp 
The "Ramp" option supports drawing of inclined surfaces and the following dialog box 
appears when it is selected: 

 
Define the ramp points using the relevant button on the top for a ramp to be created 
according to the inclination and dimensions provided in the corresponding fields. More 
specifically, 3 points are required. The first point is one of the lower endpoints of the 
ramp; the second one is the respective upper endpoint while the second along with the 
third point specify the upper horizontal side of the ramp. Any possible modification (e.g. 
of the inclination) of a drawn ramp can be easily performed through the respective 
dialog, which appears through the "Modify Ramp" command or even by double-clicking 
on the ramp and selecting “Properties”. 
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Example: Suppose you want to draw a ramp that is 5 m long, 2 m wide and 0.6 m 
high. 

Run the "Ramp" command. In the appearing dialog screen, click "Points Definition" and 
provide the starting point. Then, type in the command line @5.0<0 (for length) and 
finally type @2.0<270 (for width). After that, the "Ramp" dialog box appears again. 
There you should set the desired height at 0.6 m and the inclination will be 
automatically calculated (in % and in degrees), since both the height and the length of 
the ramp have been determined. If you wish, you can modify the ramp width, which will 
be increased towards the side, which was initially defined. 

Free-Route Ramp: It can be defined following the method applying in free-route 
staircases. In particular, first specify the polyline corresponding to the ascension line 
and then run the "Copy ascension line" command, found in the management menu for 
staircase commands, to define the outlines that determine the boundaries of the ramp. 
Then, if you select the option "Free-Route Ramp" and type "Outlines" in the command 
line, you will be prompted for the ascension line first and then the outer outlines 1 and 
2. 
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7. AutoBLD: Other Options 
 

 

In this chapter the rest of the AutoBLD commands are described, besides the drawing 
commands for the basic and specific structural elements, which were individually 
described in the previous chapters due to their importance. More specifically, the rest 
of the AutoBLD commands deal with the drawing editing (e.g. "Dimensioning"), the 
Libraries Manager as well as the monitoring commands group for the construction and 
creation of the project files. These commands are described in the following sections, 
in the order they appear in the AutoBLD menu. 

7.1 Dimensioning 
This option can be used for the dimensioning of the project ground plans. It includes 5 
sub-options; the horizontal, the vertical as well as the slope dimensioning, the wall 
dimensioning and the dimensioning switch. The use of the "Wall Dimensioning" 
command is recommended because it offers the advantage of automatic update after 
each drawing modification. The rest options should be used on the final drawings. 
Finally, the option “modification” helps the user to modify some of the dimension 
attributes, such as the text height, the arrow type etc. In the following sections, the 
above commands are described in brief, in the order they appear in the menu. 

7.1.1 Horizontal Dimensioning 
If you select horizontal dimensioning, the program will ask for the points where you 
want to create sections with dimensions (by left clicking each time) and then (after right 
clicking which means that you have finished selecting points) the location where the 
dimensions are going to be written. The dimensions are written horizontally in the 
selected location. An example of horizontal dimensioning is shown below: 
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7.1.2 Vertical Dimensioning 
The vertical dimensioning command is executed exactly in the same way as the 
horizontal dimensioning mentioned above, with the only difference that here the 
dimensions are written vertically. 

7.1.3 Oblique Dimensioning 
For the oblique dimensioning what is mentioned 
above applies too, with the difference that instead of 
an insertion point the user has to define an insertion 
straight line, that is two points. A simple example is 
shown beside. 

7.1.4 Automatic Dimensioning 
This command provides automatic dimensioning by 
drawing a simple line. More specifically, all 
dimensions are automatically drawn through the 
path of a line defined by the user. 

7.1.5 Wall Dimensioning 
With the wall dimensioning option, the user gets the desired dimensioning lines 
automatically (dimensions are automatically written on the walls and every opening etc) 
and he also has the great advantage of the dynamic modification of dimensioning 
lines at every a posteriori drawing modification. For example, if the user inserts an 
additional opening, the respective dimension is also inserted automatically; if the user 
deletes an opening the dimensions are readjusted accordingly; if the user moves a wall 
the dimensioning line is also moved and so on. In the following example, you can see 
the automatic dimension change after moving the left wall to the right and deleting as 
well the outer door.  

The user can practice with many similar examples in order to understand the function 
and utility of the above command. 
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7.1.6 Automatic Dimensioning Switch 

This switch enables the user to select at will a small or large dimension (from side to 
side) or both of them at the same time. If "Switch" is selected, the program prompts you 
to select in the command line one of the 3 alternative cases of dimensioning line: 

• Segments: Select it by typing S 

• Full: Select it by typing F 

• Both: Select it by typing B 
The default program option is the first one (“Segments”). In the example seen above, 
"Both" lines are used. It is clear that in case you select the option "Both" lines, the 
program asks for two insertion locations. Here also one or two tests are enough for the 
user to understand the way the switch functions. 

7.1.7 Modify 
This command serves to modify the characteristics of a certain dimension. First, you 
must select the dimension you want to modify and then you just have to make the 
changes on the following respective dialog. 
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7.2 Drawing Libraries 
The Drawing Libraries, which include a series of existing objects that can be selected 
and inserted in the drawing, are presented in Chapter 4. The drawings are inserted in 
the libraries and you can edit them through the Library Manager described in this 
section. In order to insert a new drawing in the libraries, you should, first of all, select 
with the mouse the desired symbol category (e.g. category 5) from the libraries list of 
the package (the libraries list "opens" by pressing the arrow in the top right corner). 

 
Then, after you have selected the category, select the location where you want to insert 
the symbol or the drawing, within the relevant category. Use the right and the left arrow 
to move to the various symbol locations. You can see the serial number of the symbol 
(on the left) and the corresponding screen (on the right). Move to a blank location and 
use the arrows appearing below to enter the new symbol. More specifically: 

Click the button "Select Object" to select the drawing (object) you want to insert. 
Select the object using the mouse exactly as you select an object to be deleted, moved 
etc. As soon as you select the object and left click, the above window appears again 
automatically (dialog box). Use the insertion point to define the base point (reference 
point), according to which the drawing will be inserted whenever you call it from the 
library. 

Click the button "Slide Screen" to enter the drawing in order to determine the "image" 
of the object that you want to appear on the slides (screens) of the libraries. The 
definition is easy to carry out through a window (just like zoom). After the image 
definition, the above window (dialog box) appears again. 

Select the "Save Slide" option to update the corresponding slide. 

In the field ‘’Symbol name’’ type the name and then select ‘’Enter’’ to save the name. 

Provided that you have run the commands mentioned above and most of all you have 
selected an object, select "Save Drawing" (which is automatically activated - it gets 
black - when an object is selected) and the object is finally saved into a file. 
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Example: Insert in the 3D libraries, in the subcategory 
"Office Furniture", the adjacent armchair drawn in progeCAD 
(or loaded from an existing drawing). 

Enter the "Drawings Library" and select the subcategory 
"Office Furniture" at the top of the appearing dialog screen: 

 
Go to "Location of Symbol" 9 (use the sliding keys or type the value 9) and you can see 
that there is no symbol in the location 9 (the slide is blank). Having on your screen the 
three-dimensional drawing on one side and the dialog screen on the other, use one by 
one the commands - buttons of the dialog screen, following the procedure described 
above. With the command "Save Slide" the program prompts the user to replace the 
previous symbol (if there is one, of course) and then the following screen appears: 

 
Providing the rest of the information as well (insertion point, symbol name etc) the new 
symbol is saved with all its data and from this point on you can select it and insert it in 
the drawing. 

7.3 Project Drawings Monitoring Commands 
These commands relate to the monitoring utilities offered to the user during the 
Architectural design, which enable him/her to work in the desired way. The commands 
are described in the following sections according to the order they appear in the menu, 
although the user can use them in any order, without limitations. 
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7.3.1 Plan view 
It is the main monitoring way, which is applied during drawing the building. When 
drawing walls, the ground plan should be always active, so that the user can have 
better monitoring and the wall "joints" are created correctly. The program automatically 
generates and uses a two-dimensional ground plan. 

 
7.3.2 3D View 
This command provides a quick solution for three-dimensional monitoring of the ground 
plan of the current floor, with the viewing angles previously determined in the "Viewing 
Parameters". For better monitoring you can hide the "back" lines through the command 
"HIDE", or even shade them through the command "SHADE". This is possible by typing 
the relative command in the progeCAD command line. 

 

330  4M 



 
 

7.3.3 Project Drawings 
This command includes a series of sub-options that help you to create the required 
project drawings. In particular, these options manage the view, the cross section, the 
axonometric and the perspective drawings for the building, as well as the necessary 
tools for improving the appearance of the final project drawings (hatch attributes, 
materials etc). 

If you select one of the above options, you will be prompted successively, depending 
on the case, to provide some necessary information (viewing point, viewing side, 
intersection line etc). More specifically, the information requested in each case is the 
following: 

View: It is required to successively provide the point where the user stands (viewer 
point) and the viewing point (in fact, the side is defined). In the above example, 
providing a point at the bottom of the screen as a viewer point and a viewing point from 
bottom to top, the following view appears on the screen: 

 
An important advantage of the application is the automatic update of the side views 
upon any change applied by the user on the plan view. 

Selecting Project Drawings>Side View, you are prompted to specify the desired side 
view. Upon specifying the second point, the "Should the Side View Layers be created?" 
message appears. Selecting “Accept”, you are prompted to specify a name for the side 
view which you should type in the command line. Thus, an icon with the side view 
name is created on the plan view; you can open the side view at any time, in order to 
modify it, by just double-clicking that icon. Then, if you wish to return to the plan view, 
select AutoBLD>Plan View or type “plan” in the command line. You can see that any 
change of the model affects directly the created side views. That is, there is direct and 
dynamic relation between the plan view and the side views of the project. The same 
apply in creating and editing cross sections, as it is mentioned further down. 

Note: What you see on the screen is saved in a separate drawing within the bld folder 
of the project. For this operation it is necessary to include the .dwg file in a .bld type of 
folder and the project path should not be too long.  
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Cross section: You are requested to successively enter the intersection line (by 
defining two successive points that determine this line) and finally the point towards 
which viewing takes place (viewing point). This is clarified in the following example: 

 
The above procedure results in the following cross section that appears on your 
screen, while at the same time the program prompts you to "Create File for Section". 

 
An important advantage of the application, in this case as well, is the automatic update 
of the cross sections upon any change applied by the user on the plan view. 

Selecting Project Drawings>Cross Section, you are prompted to specify the desired 
cross section. Upon specifying the second point, the "Should the Cross Section Layers 
be created?" message appears. Selecting “Accept”, you are prompted to specify a 
name for the cross section which you should type in the command line. Thus, an icon 
with the cross section name is created on the plan view; you can open the cross 
section at any time, in order to modify it, by just double-clicking that icon.  

Then, if you wish to return to the plan view, select AutoBLD>Plan View or type “plan” in 
the command line. You can see that any change of the model affects directly the 
created cross sections. That is, there is direct and dynamic relation between the plan 
view and the cross sections of the project. 
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In this way, the user can easily manage the plan view, the side views and the cross 
sections of his/her project through an organic structure of the plan view. 

Note: When a cross section is created and appears on the screen, it is also saved in a 
separate file as a cross section drawing. 

Undo Cross Section: With this command you can cancel the cross section that was 
created with the command "Cross Section". If you select another command, like 
"Ground Plan", the cross section will be cancelled automatically. 

Screen Drawing: The command "Screen Drawing" enables you to save any drawing 
(e.g. a ground plan, an axonometric etc), which is displayed on the screen at the time, 
in a file (DWG). It is different from the command "Save as" because it has been 
designed for attaining the greatest possible economy in the file size (it does not save 
anything else but the entities appearing on the screen). It is a very useful command 
and it is mainly used for the creation of the final drawings to be printed, with the 
advantage of their small size even if they derive from a DWG project file with significant 
size.  

The procedure is simple: After selecting the command, the program prompts you to 
select the section of the drawing appearing on the screen that you want to save in a 
file. Of course, you can select the whole drawing (by typing "ALL" in the command line) 
or any section, through the "select" command. After completing the selection, the 
program asks you to wait for a while and then asks for the name of the file into which 
you want to save the drawing. When you enter the file name, the program creates the 
file in the directory BLD of the project. If the entered name already exists, the program 
asks if you want to replace the older file. Then you are transferred automatically within 
the created drawing, so as to view and edit it (if you want). In order to return to the 
drawing of the project, in which you were before the execution of the command, you 
should “Open” the file of your project or select the project again, by running "Open 
Project". This way you return to the point you were before the creation of the screen 
drawing. 

Note: Instead of the above command “Screen Drawing", the user can alternatively use 
the command "WBLOCK". In particular, type "WBLOCK" in the command line and the 
filename with which you want to save the drawing, in the field "File Name" in the 
appearing window. Then, in the prompt that appears in the command line "Block 
Name" press <Enter>, in the prompt "Insertion Point" insert 0,0 and in the prompt 
"Select Objects" select the drawing (or the drawing section) you want to transfer into 
the file. The drawing is saved, but it disappears from the screen. To bring it back on the 
screen, you should run "undo" (e.g. by typing "U" in the command line and pressing 
<Enter>). 

View File: Run this command to create the side view of the drawing and the active 
window is saved in a separate drawing as a view drawing, after the name you specify. 
Upon running this command, you are prompted for the two points required to create the 
side view. The drawing is created and you are prompted for the file name (e.g. View1) 
with which you want the relevant view drawing to be saved. Specifying the name opens 
this drawing. To return to the original, select it from “Window”. 

Cross Section File: Run this command to create the cross section of the drawing and 
the active window is saved in a separate drawing as a cross section drawing, after the 
name you specify. Upon running this command, you are prompted for the two points 
required to create the cross section. The drawing is created and you are prompted for 
the file name (e.g. Section1) with which you want the relevant cross section drawing to 
be saved. Specifying the name opens this drawing. To return to the original, select it 
from “Window”. 
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A basic advantage of this command is that it highlights the intersected elements from 
the projected ones with different color (line thickness) in the created file. 

Axonometric: This command provides three-dimensional monitoring of the whole 
building (for all floors), with the given viewing angles as they have been selected in 
"Viewing Parameters". Regarding the creation of an axonometric file, what is 
mentioned above for the views and the cross sections apply too. 

 
Cross Section Hatch Attributes: This command allows you to define different types 
of hatches on a cross section drawing. As shown on the command dialog box, a hatch 
attribute with its scale and angle corresponds to every type of building element. 
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The user can easily select the hatch attribute he prefers for each type of building 
element by pressing the “Selection” key. Then a number of slides will appear on the 
hatch selection window. The “Previous” and “Next” keys serve for browsing to previous 
or next pages within the nine pages of slides, while the “Accept” key selects the 
highlighted hatch attribute. 

 
A typical example is shown below: 
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Elevation Materials-Colors: This command allows you to assign a color to every real 
material of the building view. The term “colors” refers to the colors of the lines on the 
view. The colors-materials correspondence is given automatically by the command “3D 
Color” used for Photorealism for each building element. 

For any change on the existing correspondence, you can use the options given on the 
lower side of this window. First you should select the line that you want to change and 
then write the new name of the material (or color of the view). 

By pressing the “Reset Materials” or “Reset Colors” keys, all materials or colors are 
deleted. 

 
Material Table: Having defined the Materials-Colors correspondence described in the 
previous paragraph, this command permits you to locate on the view drawing pointer 
lines for each material, as well as the overall table of materials. More specifically, this 
command asks you to select an edge (corresponding to a building element and a 
certain material), then the first (ending) point of the pointer line (the ending point) and 
finally the second point of the line (the starting one with a serial number indication, 
automatically created). This procedure is repeated for the various materials-elements 
of the building.  
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Then, by clicking on the right button of the mouse the program asks if you have 
finished entering new edges. By selecting “Yes” the overall table of materials is located 
on the right-upper side.  

 
Perspective: The option "Perspective" in the "Project Drawings" leads to 4 sub-
options, "Building", "Floor (Level)", "Building in Cross Section" and "Floor in Cross 
Section", respectively. In case of a building Perspective, you can see the perspective of 
the whole building from any side and height. The perspectives in cross section are 
used in case of inner perspectives. The way of function is common in all 4 cases, with 
the difference that an intersection line is not requested in the first 2 cases. This way, 
the program initially requires the viewer point as well as the viewing point, which are 
easily defined with the mouse. Then you are prompted to enter the viewer height and 
the viewing height (the default values are 1.5 and 1.5 m). In case of perspective in a 
cross section, "cut" the area between the viewer and the viewing point which may hide 
what you want to see (e.g. outer or inner walls) by placing properly the vertical to the 
viewing axis line, which appears automatically and is moved with the mouse: Whatever 
is found between this line and the viewer is ignored.  

Finally, provide the lens opening (e.g. 35). After that you can see the perspective which 
the observer sees on the basis of the data you have specified. In this way you can see 
the building or any inner space from any side and height. 

Example 1: If you specify as viewer and viewing points the points 1 and 2 respectively, 
insert heights 6 and 6 (the program default values), then specify the vertical to the 
viewing axis line between points 1 and 2 in a way that it does not intersect the building 
and then provide lens 35 (by typing this value in the command line), the following 
perspective will appear on the screen: 

 

progeCAD Archetecture  337 



 
 

 
Example 2: If you specify as viewer and viewing points the points 1 and 2 respectively, 
insert the program default initial 
values, afterwards define the 
vertical to the viewing axis line 
between the points 1 and 2 so 
that it intersects the ground plan 
interior in the way shown in the 
figure and then provide lens 17 
for greater deformation (by typing 
this value in the command line), 
the following perspective will 
appear on the screen, provided 
you select "Level Perspective": 

 
And if you select "Building Perspective" the following perspective will appear: 
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Roof Ground Plan: The ground plan of the building roof is created. 

Save every Drawing in a different file: As mentioned above, in each one of the 
above cases, right after the relative project drawing is created on the screen, the 
program prompts you to create a corresponding file (in the disc). If you click "YES", the 
program asks you to enter a name for the file. The same procedure can be performed 
through the commands "View File" and "Cross Section File" seen above.  

The user should note that, for organization and convenience purposes, it is better to 
follow a certain name designation procedure for the drawings. For example, views can 
be saved as view1, view2 and so on, or viewA, viewB and so on, cross sections as 
crossA, crossB etc. You will not have a problem if you assign the same drawing name 
(e.g. view1) in two different projects since they are stored in the directory BLD of the 
project, that is, they coexist in different directories. 

The user should know that when a drawing file is created, the program transfers 
him/her automatically to the corresponding drawing file, so as to be able to further edit 
it and print it if he/she wants. For this reason it is recommended to select the "File 
Creation" option after the user’s final decision, so as not to waste valuable time for 
loading and unloading drawings. 

Moreover, in case that a project drawing is created in a file, the user can open it any 
time, simply by using the command "OPEN" and entering the drawing name, as 
defined during its creation (e.g. crossA, view1 etc). In other words, it manages the 
project drawing as if it were a Dwg file-drawing. You are reminded that during the 
project drawing editing (views, cross sections etc) the project drawing is just a group of 
lines, because the objects (e.g. windows, walls etc) have lost their entity and are 
reduced to simple lines. Nevertheless, the user has important freedom in editing the 
drawing (symbol selection from libraries, line drawing/deletion, color modification etc). 

Moreover, the user should also know that, once transferred into a drawing, he/she 
should necessarily reload the project through the option "PROJECT SELECTION", if 
he/she wants to return to the project. That is why, each time you enter a project file-
drawing, the project is unloaded and the corresponding project drawing is loaded. 

Hide lines between walls-slabs: Run this command to optimize the result when 
creating side views and cross sections. When a structural element intersects another, 
the appearing intermediate line can be hidden on the side view and the cross section, 
avoiding the effect of a non-uniform result. 
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Hide side view and cross section line: Run this command to optimize the result 
when creating side views and cross sections. Running this command displays a 
message in the command line which prompts the user to specify the outline of the area, 
where he/she does not want any line to appear, via points or a polyline. The following 
image  shows the drawing of a wall in side view and a triangular area (polyline) which 
has been selected so that there will be no line within its boundaries. 

 
Show hiding frames: Running this command shows the hiding frame, that is the frame 
of the user-defined area, within which no line appears, in side view or cross section. 

Hide hiding frames: Running this command hides the hiding frame, that is the frame 
of the user-defined area, within which no line appears, in side view or cross section. 
For our example, upon running this command, the on-screen image is the one 
following. 

 
You can see that the desired lines are still hidden; just the hiding frame is not shown.  

If you want to delete the hiding frame, select “Show hiding frames”, so that you can 
easily select the desired hiding frame, and press Delete or run the "Erase" command. 

The above commands enable the user to edit the side views and the cross sections 
he/she creates, in order to reach the desired result. 

The user can easily comprehend the operation of the above commands, as well as 
their usefulness, in a complex drawing, from which side views and cross sections will 
be generated. 
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8. Plus Drawing Tools 
 

 

As it is mentioned in the Introduction, progeCAD Architecture includes a large group of 
options under the general menu PLUS. 

 
These are a series of additional drawing tools, which have been embodied in the 
package in order to help the user during drawing. 

In the top part, the first option included in the PLUS menu of options is “Printing Scale”, 
which is used to specify a scale: 
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Following that, the PLUS menu of options includes general menus of drawing tools, 
each of which consists of specific tools. These menus are listed below: 

• TEXT 

• TEXT FRAME 

• LINES 

• LAYERS 

• BLOCKS 

• HATCH 

The tools of each category are described in detail next. 

8.1 Text 
The text menu of options includes a number of tools, especially useful for manipulating 
text inside drawings. 

These tools are described next, in the order they appear in the menu. The use of 
parentheses indicates commands, which are identical with the corresponding 
commands in progeCAD. 

8.1.1 Text Height 
Using the above command, you can set the current height of the drawing, in drawing 
millimetres. 
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8.1.2 Select Style 
Using the above command you can specify the font you want to use. 

 
The selected font will then be the current font. 

8.1.3 Text 
The above command enables you to write text directly on your drawing, as soon as you 
specify the height and the angle of the text, requested by the application. If you press 
<Enter> twice, the default values of height and angle are maintained, in which case you 
immediately write the desired text. 

8.1.4 Edit Paragraph (Ptext) 
The above command activates a paragraph text editor. Using this command, the 
following prompts appear: 

Center/Edit/Fit/Right/Slack/?/<Startpoint>: Specify the starting point of the text. 
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Text height <0.2000>: Specify the height of the text in drawing units (Drawing Units). 
By pressing <Enter>, the default value is assumed. 

Rotation angle <0>: Specify the angle of writing of the text. 

Ιnter_line spacing <0.3000>: Specify the distance between lines of text. 

Maximum line length <2.000>: You set the maximum length of a line of text in 
drawing units (Drawing units) 

Text: Write the text. If you want to write in a new line, before you reach the end of the 
current one, simply press <Enter>. 

8.1.5 Sequence (Arithmetic Progression) 
The above command places a sequence of letters or digits (consecutively) on your 
drawing. It is useful for the automatic numbering of identical objects (eg. switches, 
lights, fire boxes etc.). During the execution of the command, the following prompts 
appear: 

Alphabetic <Α> or Numerical <Ν> Sequence<A or N>?: Type “A” if an alphabetic 
sequence is needed, or “N” if a numeric sequence is needed. 

If you type “A”, these prompts will follow: 

Which is the first letter?: Specify the starting letter of the sequence eg. B. 

Text alignment <Left Right Center Middle>?: Specify the text alignment to be left, 
right, middle etc. 

Writing Angle?: Specify the angle of writing of the text (in degrees). 

Add Prefix <P> or Suffix <S>?: Specify if you want to add a prefix or a suffix to the 
text which results from the numbering. 

Added Text: Specify the text that will be used as Prefix or Suffix. 

Give Text Points: Specify the points where you want the text to be placed. 

If you type “N”, these prompts will follow: 

Which is the first number?: Specify the starting digit of the numbering. 

Number to be added?: Specify the step that will be used to create the sequence. 

Text Alignment <Left Right Center Middle>?: Specify the text alignment to be left, 
right, middle etc. 

Writing Angle?:  Specify the angle of writing of the text (in degrees). 

Add Prefix <P> or Suffix <S >?: Specify if you want to add a Prefix or a Suffix to the 
text that results from the numbering. 

Added text: Specify the text that will be used as Prefix or Suffix. 

Give Text Points (Text Location): Specify the points where you want the text to be 
placed. 

8.1.6 Get Style (StyleSet) 
The above command is used when you want to write text using the parameters of the 
existing text (fonts, character height etc.). The command prompts are the following: 

Select existing Text: Select the piece of text that will be used as the basis for writing 
new text. 
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Justify/style/<start point>: Specify the starting point of the text. You can, however, 
modify the alignment of the text (justify) by pressing J, or the character style, by 
pressing S. 

Rotation angle <0>: Specify the angle of writing of the text. 

Text: Write the text. 

8.1.7 Text Edit (DDEDIT) 
This command enables you to edit an entire piece of text, using a text editor. The 
command prompts are: 

Select entity to modify: Select the text you want to edit. The application composes 
the lines of the text based on its existing position. You enter the text editor and perform 
the desired changes. When you are finished, press <OK>. 

8.1.8 Change Style (CSTYLE) 
The above command is used to change the character style (style). More specifically, 
the command prompts are: 

Global <G> or Selective <S>: Pressing G will modify all the existing text, whereas, 
pressing S only the selected text: 

Select Objects: Select the text you want to edit. 

New style (or?): Specify the new character style. 

8.1.9 Capital-Lower case (TCASE)  
The above command is useful for converting lowercase characters to uppercase and 
vice versa. More specifically, the prompts are: 

Select entities: Select the text you want to edit. 

Convert Text: <Upper (U) or Lower (L)>?: Pressing U (Upper) will convert the text to 
Uppercase, whereas pressing L (Lower) to lowercase. 

8.1.10 Change Height (Τheight) 
The above command is used to modify the height of the text, in the case you want to. 
As soon as you select it, you are prompted to: 

Select entities: Select the text you want to edit. 

Enter new text height in Printing mm: Specify the new character height in drawing 
units. 

8.1.11 Stretch (ΤSTRETCH) 
The above command is used to stretch or shrink text. As soon as you select it, the 
command prompts are: 

Select text to stretch: Select the text you want to stretch. 

Select Side to stretch <Left or Right>?: Select the side towards which you want to 
stretch the text. 

8.1.12 Justify (TJUSTIFY) 
The above command is useful in aligning text. As soon as you select it, you are 
prompted to: 
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Select objects: Select the text you want to edit. 

New Justification Left/Right/Center/Middle: Specify the new alignment. 

8.1.13 Add (TAPPPEND) 
The above command is used to extend a word towards the left or the right side (prefix 
or ending). As soon as you select this command, select the desired word, answer the 
question “left or right” and write the additional desired text, in which case you can view 
the result of your actions. 

8.1.14 Replace (TREPLACE)  
This command is useful for replacing a piece of text with another one in a drawing. The 
execution of the command is simple: first, specify the word you want to replace and 
next, type the new word. 

8.1.15 Search-Replace (TSEARCH) 
This command is useful in replacing a piece of text with another one in a drawing. If the 
text to be replaced is located in more than one places in the drawing, that is, it is 
repeated, it will be replaced in each one of them. The execution of the command is 
simple: first, specify the word you want to replace and next, type the new word. 

8.2 Text Frame 
8.2.1 Orthogonal (Boxtxt) 
This command is used to place a word or a piece of text inside a box (orthogonal 
frame). The only required action is to select the desired word and then press <Enter> 
(or the right mouse button), in which case you can view, on your screen, the selected 
word being enclosed by a frame. 

8.2.2 Circular (Cirtxt) 
This command is used to place a word or a piece of text inside a circle. The only 
required action is to select the desired word and then press <Enter> (or the right 
mouse button), in which case you can view, on your screen, the selected word being 
enclosed by a circle. 

8.2.3 Elliptical (Eliptxt) 
This command is used to place a word or a piece of text inside an ellipse (elliptical 
frame). The only required action is to select the desired word and then press <Enter> 
(or the right mouse button), in which case you can view, on your screen, the selected 
word being enclosed by an ellipse. 

8.2.4 Polygonal (Polgtxt) 
This command is used to place a word or a piece of text inside a polygon  (polygonal 
frame). The only required action is to select the desired word and then press <Enter> 
(or the right mouse button), in which case you can view, on your screen, the selected 
word being enclosed by a polygon. 
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8.3 Lines 
The Lines menu of options includes tools for 
drawing different types of line, as the ones that 
appear in the adjacent figure (continuous, dashed, 
dash-dotted etc.), as well as tools for manipulating 
lines. These tools are described in the order they 
appear in the menu. 

8.3.1 Continuous 
This command is used to draw a continuous line on 
the current layer. As soon as you select the 
command, you can start drawing the line using the 
mouse. 

8.3.2 Dotten (Hidden) 
This command is used to draw a discontinuous line on the current layer. As soon as 
you select the command, you can start drawing the line using the mouse. 

8.3.3 Dashed 
This command is used to draw a dashed discontinuous line on the current layer. As 
soon as you select the command, you can start drawing the line using the mouse. 

8.3.4 Dash-Dotted (Dashdot)  
This command is used to draw a dash-dotted line on the current layer. As soon as you 
select the command, you can start drawing the line using the mouse. 

8.3.5 Dash-Double-Dotted (Divide) 
This command is used to draw an dash-double-dotted line on the current layer. As 
soon as you select the command, you can start drawing the line using the mouse. 

8.3.6 Dash-Triple-Dotted (3Dot) 
This command is used to draw an dash-triple-dotted line on the current layer. As soon 
as you select the command, you can start drawing the line using the mouse. 

8.3.7 Dash-Spaced (Center) 
This command is used to draw a dash-spaced line on the current layer. As soon as you 
select the command, you can start drawing the line using the mouse. 

8.3.8 Double 
This command is used to draw an double line on the current layer. As soon as you 
select the command, you can start drawing the line using the mouse. 

8.3.9 Change Width 
This command is used to modify the width of an existing line. More specifically, the 
command prompts are: 

Select objects: Select the lines, the width of which you want to modify. 

New width for selected objects: Specify the new width in drawing units (drawing 
units). 
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8.3.10 Multiple Trim/Extend 
The above command performs a multiple TRIM or EXTEND. More specifically, the 
series of command prompts is: 

Do you want to Trim or Extend <T or E>: Specify the new width in drawing units 
(drawing units). 

Select cutting edges: Select the edges you want to cut. 

Select objects: Select the desired lines. 

First Point: specifies the first point of a line intersecting the lines that will be trimmed. 

Second Point: specifies the second point. 

If you specify E (Extend) in the above command, the following prompts will appear: 

Select entities: Select the desired lines. 

First Point: specifies the first point of a line intersecting the lines that will be extended. 

Second Point: specifies the second point. 

8.3.11 Clear 
This command clears the drawing from multiple lines (one lying exactly upon the other). 

8.4 Layers 
The Layers menu of options includes tools for manipulating layers. These tools are 
described in the order they appear in the menu. Again, the use of parentheses 
indicates commands in English, which are identical with the corresponding commands 
in progeCAD. 

8.4.1 Set Layer (Layset) 
This command enables you to set the current layer by simply selecting an object which 
belongs to that layer. The command prompt is: 

Select an Entity on existing layer: Select an object that is part of the layer that you 
want to switch to. 

8.4.2 Freeze (Layr_Frz) 
The above command freezes the layer of the object you select. If this layer is the 
current layer, a message appears, stating that it is not possible to freeze this layer. 

8.4.3 OFF (Layr_Off) 
The above command deactivates the layer of the object you select. If this layer is the 
current layer, a message appears, stating that it is not possible to freeze this layer. The 
difference with the previous command, LAYR_FRZ, lies in the fact that the 
LAYER_OFF command does not deactivate any blocks that are contained in blocks of 
the layer in question. Consider, for example, the top view of a building that has been 
drawn with AutoBUILD, in which case the windows are blocks inside the “wall” block. If 
you use the LAYR_OFF command to deactivate the layer of the walls, the windows will 
still be active, whereas if you used the LAYER_FRZ command, both walls and windows 
would “freeze". 
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8.4.4 Lock (Layr_Lok) 
The above command locks the layer of the object you select. This command can 
additionally be used on the current layer. 

8.4.5 Unlock (Layr_Unl) 
This command is the opposite of the command above, meaning that, it unlocks a layer 
that was previously locked using the Layr_Lok command. 

8.4.6 LAYER Info (Layr_see) 
Using this command, which is entirely auxiliary, you can view the layer of the object 
you select. 

8.4.7 Move to Current (CCL) 
This command moves objects from other layers into the current layer. The prompts are: 

Select entities to entry into current layer: Select the objects that you want to be 
moved into the current layer. 

8.4.8 Change (ChgLayr) 
This command enables you to change the layer of existing objects to another one. Its 
function is simple: Select the objects, the layer of which you want to change. After you 
select them, you press <Enter> (or the right mouse button), in which case you should 
next select an object of the layer that you want the previously selected objects to be 
moved to. 

8.4.9 Delete (DelLayer) 
This command deletes all the objects that exist in a layer that you will select by 
selecting an object belonging to that layer. That is, after you activate this command, 
you should simply select an object which belongs to the layer that you want to delete. 
All the objects of the layer are deleted except for the selected object. 

8.4.10 Current Only (Isolate) 
This command specifies the layer of a selected object to be the current one, while 
freezing all the other layers. The command prompt is: 

Select an entity on the selected layer: Select an object of the layer that you want to 
become the current one. 

8.4.11 Change Color 
This command changes the colour of a layer. Initially, you are asked to select the 
object, the colour of which you want to change, in which case you use the mouse to 
select it. Next, you are asked to specify the serial number of the new colour. 
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8.5 Blocks 
The Blocks menu of options includes tools for manipulating blocks. These tools are 
described in the order they appear in the menu. 

8.5.1 Replace 
Using the above command, blocks can be replaced by some other block (replace). The 
command prompts are: 

Select objects: Select the blocks you want to replace. 

Enter the name of new block: Specify the name of the block that will replace the 
previously selected blocks. 

8.5.2 Xplode 
The above command explodes the blocks of progeCAD (and the mirrored blocks of 
progeCAD). 

8.5.3 Count 
This command can count the number of times a block has been inserted into the 
drawing. The command prompts are: 

Enter the name of the block that will be count: Specify the name of the block to 
count the number of times it has been inserted. 

8.5.4 View (Show) 
Using the above command, you can view the positions that a block has been inserted 
into, while deactivating the rest of the objects of the drawing. The command prompts 
are: 

Enter the name of the block ....:  Specify the name of the block you want to view.  
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9. Examples 
 

 

In this chapter, several examples, aiming at helping the user understand in practice 
everything that has been described in the previous chapters, are presented. Initially, 
section 9.1 provides an analytical description of an example, involving a relatively 
simple building, but, at the same time, describing each and every step necessary for its 
completion. Following that, in section 9.2, certain examples originating from real 
projects, created with ProgeCAD Architecture are demonstrated.  

9.1 Simple Example 
As already mentioned earlier, in this section, a relatively simple example is described, 
including all the steps, from the beginning (creating a new project) until the end 
(printing drawings), so that the user can 
easily and quickly understand the function 
of progeCAD Architecture in practice. More 
specifically, the way that the two-storeyed 
building, which is shown in the adjacent 
figure, is constructed will be described step-
by-step. 

As already mentioned in previous chapters, 
the steps necessary for the completion of a 
project are the following: 

• Define Building (number of floors - 
levels) 

• Draw floor Ground Plans. You should 
follow the steps below for each floor separately: 

• Select floor to work with 

• Draw walls-openings and other elements (slabs etc) 

• Draw special elements (staircases, rails, roofs) 

• Insert symbols & drawings from the libraries 

• Create drawings (views-cross sections-perspective views etc.) 

• Printouts 
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Start drawing the ground plan of the example, illustrated above, by describing all the 
necessary steps one-by-one: 

1. Select "New project’’, type a name and click "Accept" to begin. 

2. Your first task is to select the "Building Definition" command. In the appearing 
screen, specify Floor 1 Level = 0 and below that, Floor Level = 3. Before you go on, set 
floor 1 to be the "Current" floor, in order to begin drawing the ground plan of floor 1. 

3. You are now ready to draw the ground plan of floor 1, which is the active floor. 

9.1.1 Outer Wall Drawing 
You can start drawing the walls one-by-one. For this purpose, perform the following 
actions: 

• Select the command "Wall" -> "Outer", in which case the following dialog box 
containing the wall "Parameters" appears, where suppose that you select the T1 
wall and specify thickness = 0.25 (m), level = 0 (m) (relative to the level of the floor 
on which it will be placed) and height = 3 (m). 

Note: The value given on the floor level concerns the specific current level, which 
means in other words that the height of the walls, slabs etc, starts always from zero. 
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• Next, click "OK", in which case the following prompt appears in the command line: 

Wall start \ Relative to wall \ Toggle shape <Linear>: 

prompting you to specify the starting point of the wall. If you left click on the desired 
point (starting from the top left part, at the end of the wall), the following prompt 
appears: 

Wall end \ Relative to wall \ Toggle shape <Linear>: 

prompting you to specify the 2nd point of the wall being drawn. 

By left clicking again, the prompt "Side Point" appears, prompting you to specify the 
side towards which you want the wall to grow. Use the mouse to move accordingly 
towards the corresponding side. Left click again to view the wall being drawn. 

Note: The 2nd point can be specified with respect to the 1st. That is, if you want the 
Wall to have a horizontal length of 5m, specify @5.0<0 (or @5.0,0) in the prompt ‘’Wall 
end \ Relative to wall \ Toggle shape <Linear>:’’.
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The application expects you to continue drawing walls, in which case the end of the 
previous wall is assumed to be the start of the new one. In order to stop, simply right 
click. Continue drawing, in this manner, to create the outer walls, until all the straight 
outer walls are completed. 
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Note: If you selected the secondary option "Outline" in the "WALL" menu, you should 
specify the corner points of the outline one-by-one, by pressing the left mouse button 
successively. Having drawn what is illustrated in the figure, if you right clicked 
(meaning that you had finished), the application would prompt you to specify the side 
point of the outline. You should then specify an inner point, in order for the wall to grow 
towards the inside, since the outline was drawn based on the outer dimensions. 

 
By either drawing walls or using the "Outline" option, you have drawn the straight outer 
walls, as illustrated on the screen. 

 
In order to draw the circular wall which remains, we select “Wall”>”External”, so the 
wall properties dialog appears again. In the “Wall Type” option (on the upper left side of 
the dialog) we set the switch on “Circular” mode. Then the following message appears:  

Wall start \ Relative to wall \ Toggle shape <Circular>: 

This message asks for the starting point of the wall. By using the snap tools (Shift + 
right button to select the endpoint) we select the left edge of the wall. Then the 
following message appears: 

2nd wall point \ Relative to wall \ Toggle shape <Circular>: 

We define the second point on the line which is located at the same distance  from the 
two parallel walls; the distance is given in that way so that the arc of the wall to be 
created has the “curvature” we want. Then the following message appears:  
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Wall end: 

We select (by using the left button of the mouse) the left edge of the upper wall. Finally, 
the message “Side Point” appears, asking for the side we want the wall to grow. 
Moving properly the mouse and using the left button, after the click the circular wall is 
finally created. In case that the circularity of the wall is not the one we want, we can 
select the circular wall, grab it from the grib in the middle and move it properly as much 
as needed in order to achieve the desirable curvature. 

Note: As far as the construction of the circular wall is concerned, we can also proceed 
as follows: After completing the construction of the latest line wall, regarding the 
question “End wal\Relatively to wall(R)\ Change of shape (T) <Straight>:”, we can give 
the answer (selection)  “T” , so that the shape of the wall is automatically changed from 
straight to circular. 

 
9.1.2 Inner Walls 
In order to draw the inner walls, perform the following actions: 

• Select "Wall" -> "Inner" and in the appearing wall "Parameters" dialog box, suppose 
that you select the I2 wall. Next, press "OK", in which case the following prompt 
appears in the command line: 

Wall start \ Relative to wall \ Toggle shape <Linear>: 

prompting you to specify the starting point of the wall. Suppose that you move to the 
corner formed by the outer walls (in the bottom left part). Run OSNAP (by pressing 
either the middle mouse button or <Shift> & <right button>) to specify "ENDPOINT" 
snap and then "grab" the corresponding endpoint using the left mouse button. Then, 
the following prompt appears: 

Wall end \ Relative to wall \ Toggle shape <Linear>: 

prompting you to specify the 2nd point of the inner wall being drawn. 

356  4M 



 
 

 
Continue drawing and, in order to bring the wall in a vertical position with respect to the 
opposite (outer) wall, activate "ESNAP", by pressing either the middle mouse button or 
<Shift>&<right button>, and select "Perpendicular". 

By pointing to the outer wall (using the left mouse button), the following prompt 
appears: 

Enter Side Point: 

prompting you to specify the side towards which you want the wall to grow. Specify a 
point towards the corresponding side to view the wall being drawn and its joints being 
automatically "cleared". Right click to complete the wall, for the time being. Right click 
again, after that, to repeat the "Inner Wall" command and begin drawing the horizontal 
inner wall starting from a point of the other inner wall (see the section referring to inner 
walls and distance, in particular), in order to draw the rest of the inner walls, which 
results in the ground plan illustrated below. 
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9.1.3 Opening Drawing 
Next, in order to draw the window on the Outer Wall in the bottom left part, follow the 
steps below: 

• Select "Opening"->"Window", in which case the Window parameters dialog box 
appears. Suppose that you select a "Parametric" type of window and specify its 
length, the rize height as well as its window-sill and shutters, as illustrated in the 
following dialog box. 

 
Click "OK", in which case the following prompt appears in the command line: 

Select Wall: 

prompting you to specify the wall that you want to place the window on. Left click, 
aiming at the outer side of the wall, near its left end. Then, you can see the selected 
wall displayed in dotted line and the coordinate system transferred to the starting point 
of the wall closer to the point you selected. 

To the new prompt: 

Enter first point: 

specify the starting point of the window. While placing the starting point of the window, 
use the value of the distance from the end of the wall, appearing automatically on the 
top of the screen, as extra help, or specify 0.80 directly to place the starting point at a 
distance of 0.80 m. Press <Enter> and the following prompt appears: 

Enter second point: 
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where you should specify the second point of the window. As long as you have 
specified the length of the window in the "WINDOW PARAMETERS", it is not 
necessary to specify the second point exactly. You only need to specify a point near 
the start, towards the side the second point of the window is located. The application 
will automatically detect the second endpoint. It is noted that this option is useful in the 
case that you want to draw several identical (having the same dimensions) windows. 

After the above actions, you can view the window being drawn on the wall. 

 
Additionally, an auxiliary label (containing the geometric parameters) of the window 
appears, which you can place anywhere you wish, by moving it accordingly and 
pressing the left mouse button. The window drawn is better viewed using the "3D View" 
option: 

 
Next, in order to draw the door located on the right side of the window, on the Outer 
Wall: 
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Select "Opening"->"Door" and specify the appropriate parameters, as illustrated in the 
following screenshot:  

 
Click "OK", in which case, the following message appears: 

Select Wall: 

prompting you to specify the wall that you want to place the door on. Right click while 
aiming at the wall. Then, you can view the selected wall displayed in dotted line and the 
coordinate system transferred to the starting point of the wall closer to the point you 
selected. 

To the new prompt: 

Enter first point: 

Specify the starting point of the door. While placing the starting point of the door, use 
the value of the distance from the end of the wall, appearing automatically on the top of 
the screen, as extra help. By specifying the desired starting point (in the command line, 
the same way with the window, or simply using the mouse), the following prompt 
appears: 

Enter second point: 

where you should specify the second point of the door. As long as you have specified 
the length of the door in the "DOOR PARAMETERS", it is not necessary to specify the 
second point exactly. You only need to specify a point near the start, towards the side 
that the second point of the door is located. The application will automatically detect 
the second endpoint. 

Finally, the following prompt appears: 

Enter Opening Side: 
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where you can specify the direction towards which the door will open. After the above 
actions, you can view the door being drawn on the wall. 

 
Additionally, the auxiliary circular label (containing the geometric parameters) of the 
door appears, which you can place anywhere you wish, by moving it accordingly and 
pressing <Enter>. 

The other openings are drawn in a similar way (sliding windows and doors). The user 
can practise on its own, drawing several types of doors and windows and also 
performing several tests and modifications to realise the flexibility of the package. Also 
we can copy some openings, by using the progeCAD “copy” command.  

 

9.1.4 Columns 
In order to place the column in the corner of the wall, on the right of the door, select the 
"COLUMN" option in the AutoBLD menu and specify dimensions 30 x 40. Next, click 
"OK" and the following prompt appears: 

Enter Insertion Point: 

prompting you to specify the first 
endpoint (insertion point) of the column. 
As soon as you specify it, the "Insertion 
Angle" is requested. 

Specify it using OSNAP and setting 
"Closest Point" to the inner side of the 
wall, to view the drawn column. 

Any modification of the column 
parameters or hatch is possible through the "Modify" option, or though double clicking 
on the column (with the left button), or by selecting “Properties” after selecting the 
column and pressing the right button. 
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9.1.5 Slab 
Before placing the slab, draw a 
closed polyline, which shape should 
be identical to the outline of the slab, 
as well as a closed circle polyline, in 
the position that the staircase will be 
placed. 

Next, in order to place the slab, 
select the "SLAB" option and then 
select "Outer Outline" by "Polyline" in 
the appearing dialog box. Using the 
mouse, "point to" the earlier drawn 
outline. Following this, "point to" the 
hole and finally specify slab level = -
0,25 and slab thickness = 0.25, to draw the slab at the bottom part of the building. 

 
Run the "3D View" command to view the newly created slab in more detail. 
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Note: Instead of defining a slab using a polyline, you can define it using "Points". 
Select "Slab Outline" by "Points" and type "P" (polygonal) to the prompt that appears, 
in order to specify the outer outline of the slab next. 

The following prompt appears: 

First point: 

prompting you to specify the starting point of the slab. As soon as you specify it, the 
prompts involving the second point and so on appear, until you specify all the outline 
points (pressing the left mouse button each time). Having specified all the points 
(beware! the circular wall section is assumed to consist of a large number of short 
straight segments), right click to view the outline of the slab being drawn, while focus is 
switched to the dialog box again. Then, select "Hole" and "Circular" and specify the 
centre of the circle in the area where the staircase will be placed. Next, the application 
prompts you to specify the radius. Specify the radius moving accordingly, using the 
mouse, and press <Enter> in the prompt "16 segments", in which case the circular hole 
is drawn on the screen. Following this, specify slab level = -0,25 and slab thickness = 
0.25, to draw the slab at the bottom part of the building. 

9.1.6 Rails 
In order to draw the rails, the following actions should be performed: 

• Select "Special Elements"->"Rail" and specify the type and parameters of the rail 
you want to draw in the appearing dialog box: 
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Suppose that you have specified the above parameters for the rail. 

-> Click "Definition - Poins" and the following prompt appears in the command line: 

Enter first point: 

prompting you to specify the first endpoint (one of the 
endpoints) of the rail in the ground plan. As soon as 
you specify it (move, using the mouse and press 
<Enter>), the following prompt appears: 

Enter next point: 

prompting you to specify the second endpoint of the 
rail. 

Continue in the same manner, specifying the rest of the 
endpoints. As soon as you are finished, press the right 
button of the mouse and the following prompt appears: 

Insert Side Point: 

We need to define the side on which the width of the rail will be located. 

Finally the dialog appears again. By clicking “OK” we can see on our screen how the 
rail is being shaped. 

9.1.7 Staircase 
In order to draw the staircase, select "SPECIAL ELEMENTS" in the AutoBLD menu 
and "Staircase" after that. Following this, a window appears, containing slides that 
correspond to different types of staircases provided by the application. 

In this window, select the circular type of staircase, in which case the corresponding 
dialog box appears. By selecting "Centre", focus is switched to another dialog box, 
where you initially specify the centre, and then the big radius (at the starting point), the 
small radius as well as the arc of the staircase. 

 
Returning to the initial dialog box, you can view the following parameters: 
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Select "Compute" and click "OK" to view the staircase on your screen. 

 
We can anytime modify the staircase by using the "Modify Staircase" command, either 
by double clicking on the stair or through the right button of the mouse and pressing 
“Properties”. Here we can add rails or low walls with handrails etc, in accordance with 
the instructions given in the corresponding section of this Guide, regarding staircases. 

9.1.8 Copy Floor 
As already mentioned in the beginning of the example, there exists a second floor 
identical to the first one. By selecting "Copy Floor", you are prompted to select the 
desired section of the ground plan. If you type "All" in the command line and right click, 
you will be prompted to specify the s/n of the identical floor. Type "2" to view the 
ground plan of the 2nd floor being drawn on the screen, in a manner identical to the 
ground plan of the first floor. 
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Perform any desired changes (e.g. delete the staircase, add rails to the balcony of the 
first floor) and switch to "Project Drawings" -> "Axonometric", to see the axonometric 
view of the building drawn (use the HIDE command to hide the lines). 

 
9.1.9 Roof 
• Select "Special Elements" in the AutoBLD menu and "Roof" after that, in which 

case a window appears, containing slides that correspond to different types of 
roofs. Suppose that you specify an isoclinal roof. Next, the dialog box of the roof 
appears on the screen. Click the "Points" button on the top of the box. Then, the 
following prompt appears in the command line: 

Enter first point: 

prompting you to specify the first endpoint (one of the endpoints) of the roof in the 
ground plan. As soon as you specify it (move, using the mouse and press <Enter>), the 
following prompt appears: 

Enter Next point: 

prompting you to specify the second endpoint of the side of the roof. Continue, in the 
same manner, to specify the other roof endpoints (in the circular section, specify 
several points as if you dealt with a polygon). Right click to see the outline of the roof 
being drawn and a dialog box appearing on your screen, where you can specify the 
values of the inclination (e.g. 15%, in which case you can view the inclination being 
calculated in degrees, and shown simultaneously) and the roof height. The values of 
level (e.g. 3 m), thickness (e.g. 0.10 m) and extension (e.g. 0.40 m) can be adjusted by 
the user. 
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Click "OK" to view the roof being drawn on the screen. 

 
Note: The outline of the Roof can be alternatively specified using a "Polyline", instead 
of being specified using "Points", which you encountered earlier. 
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9.1.10 Library Objects 
You can select objects or symbols from 
the libraries and place them on the 
ground plan, using the "Library Drawings 
- Symbols" option. In order to place a 
symbol or object in your drawing (e.g. a 
double bed in the bedroom), you should 
first select the library category where it 
belongs and then select the specific 
symbol. More specifically, after selecting 
the library with bedroom furniture, you 
can select the desired drawing-symbol, 
in order to place it on the ground plan. 

Placement is performed according to the 
instructions mentioned in the main 
section of this guide. 

Finally, in order to print the drawings of this example, follow the steps described in 
Chapter 2. 

Assuming that, although the above example is simple, it is rather illuminating 
(especially for those short of CAD experience), the only thing remaining for the user to 
do is to familiarise himself/herself with the application. This can only be performed 
through continuous practice and tests. 
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10. PhotoIDEA 
 

 

As it has already been mentioned in the "Introduction" of this User's Guide, PhotoIDEA 
is a tool for quality photorealism, which supports photorealistic images of high quality 
through a simple procedure. PhotoIDEA uses a series of actual materials with texture 
(e.g. Marble, Wood, Stone, Carpets etc) which are integrated and can be selected 
through ProgeCAD Architecture. 
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The fact that the structural elements – objects that are used in building construction 
contain their material from the beginning (thanks to the general structure of the 
ProgeCAD Architecture package) results in the simplification of the whole procedure of 
using PhotoIDEA. According to the above-mentioned in this User's Guide, every object 
(e.g. walls, frames, pillars etc) is univocally linked to a color-material, in its 
"parameters" screen. In case it is associated with a color that is not linked to a material, 
PhotoIDEA will simply take into consideration this color. Additionally, PhotoIDEA, 
thanks to its unique commands "Adjust Materials to Objects", spares the user of time 
consuming procedures of data definition, which should be performed by the user.  

The selection and editing of the materials the user wishes to use in his/her project, the 
positioning of the lighting sources, the background selection, the selection of 
photographic objects and, naturally, the execution of the "Photorealism" command with 
all the relative parameters are performed through the options group "PhotoIDEA", 
which can be found in the ProgeCAD Architecture menu.  

 
All these commands can be selected from the menu or from the "Render" icon bar that 
looks like the adjacent figure. If this bar is not "open", run the "View"->"Toolbars" 
command and activate the "Render" option in the window with the check boxes and the 
bar will appear on the screen (and it can be positioned wherever the user wishes). 

 
Note: In case the PhotoIDEA program is not available (or it is not installed), the option 
group "PhotoIDEA" and its relevant options appear on the menu but they are inactive. 
Provided it has been installed, it is active on condition that you have previously 
specified a project name. 
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10.1 Hiding, shading and rendering 
As you create three-dimensional entities, the program displays both wire-frame and 
surface models in wire-frame view, which makes it difficult to visualize your three-
dimensional models. To better visualize the model, you can remove all the lines that 
are hidden behind other entities or surfaces when seen from the current viewpoint.  

Shading goes a step further by removing hidden lines and then assigning flat colors to 
the visible surfaces, making them appear solid. Shaded images are useful when you 
want to quickly visualize your model as a solid entity, though they lack depth and 
definition.  

Rendering provides an even more realistic image of your model, complete with light 
sources, shadows, surface material properties, and reflections, giving your model a 
photo-realistic look. As shown in the following illustrations, when you render a model, 
the program removes hidden lines and then shades the surfaces as though they were 
illuminated from imaginary light sources.  

 

10.2 Creating hidden-lines images 
Creating a hidden-line view of your drawing removes all the lines that are hidden 
behind other surfaces when seen from your vantage point. When you remove hidden 
lines or shade a model, the program treats the entities differently, depending on how 
you created them. Wire-frame models always appear transparent, because they have 
no surfaces. Surface models appear filled, with surfaces applied to all visible sides.  

To create a hidden-line image  
Do one of the following:  

• On the Rendering toolbar, click the Hide tool ( ). 

• Type hide and then press Enter.  
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10.3 Creating shaded images 
Creating a shaded image of your drawing removes hidden lines and then applies 
shading to the visible surfaces based on their entity color. Since they are intended to 
provide a quick visualization, shaded images do not have a light source and use 
continuous colors across surfaces, and as a result they appear flat and unrealistic.  

To create a shaded image  
Do one of the following:  

• On the Rendering toolbar, click the Shade tool ( ). 

• Type shade and then press Enter.  

To control the appearance of the shaded image, choose Settings > Drawing Settings, 
and then click the 3D Settings tab and select the options you want. You can shade the 
surfaces and edges of the model in four ways:  

• Faces shaded; edges not highlighted.  

• Faces shaded; edges highlighted in the background color.  

• Faces filled in the background color; edges drawn using the entity color (similar to a 
hidden-line view).  

• Faces filled using the entity color; edges highlighted in the background color.  

10.4 Material Library 
This option opens the Material Libraries that are included in the program and the user 
can select the materials which will be used in the project. More specifically, if the option 
"Material Library" is selected, the following dialog box appears: 

 
On the left side there is a list of the materials that are available at that moment for the 
needs of the particular project, while on the right side there is a list of the materials that 
you have generally at your disposal, from the material library (e.g. the Render.mli). 

372  4M 



 
 

In case you need a material from the General List of the PhotoIDEA Library in your 
project, all you have to do is to select this material (it is highlighted in blue color) and 
click "Insert". You can then see that this material is transferred on the left side. Before 
you "Insert" it, you can view this material through the "Preview" option in the window in 
the middle of the dialog box. Preview can be performed either in the form of spheres or 
in the form of cubes, selecting accordingly from the list right below the "Preview" 
button. The rest of the dialog box options are the following: 

Export: This is the reverse of the "Insert" option, e.g. you can transfer a material from 
the project in the Material Libraries.  

Delete: Deletes a material, either from the project file or from the Material Library that 
is open. 

Purge: Deletes the materials that have not been linked (to object, color or layer) in the 
current drawing. 

Open: Another library list (file) can open and materials can be saved in or selected 
from this library. 

Save: Saves the modifications that have been made in the open library or saves this 
library with a different name. 

To enable the Material library 
Do one of the following:  

• Choose PhotoIDEA > Material Library. 

• On the Rendering toolbar, click the tool ( ). 

• Type matlib and then press Enter.  

10.5 Edit Materials 
Through the "Edit Materials" option the following dialog box appears with the materials 
that have been selected for the project, but there is also the possibility to activate the 
previous dialog box in order to select materials from the "Material Library".  

 
Apart from the "Preview" option, which can be performed here as well, there are also 
the following possibilities: 
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Attach: This option associates the selected material with an object that is going to be 
selected later on. Selecting the desired material and then pressing “Attach” displays 
the drawing and you are prompted to select the entities where the specified material 
should be applied. This command applies for user-drawn objects and not for entities 
inserted from libraries or typical elements (such as walls, openings etc).  

To modify the materials for drawings inserted from a library, you should run the "Edit 
3D Objects" command which is described further down. Moreover, to modify the 
materials of typical elements (walls, openings etc), you should open the corresponding 
dialog box selecting "3D Color" and "2D Color". 

Detach: Similarly, pressing “Detach”, you are prompted to select the objects from 
which you want to remove the selected material. This option also does not apply for 
entities inserted from libraries or typical elements (walls, openings etc). 

Κατά ACI: This option allows assigning colors to materials. Upon selecting the desired 
material, press “By ACI…”; a dialog box entitled “Assign color to material” opens. 

 
First, select the desired material (left column); then, select the position where it should 
be located (right column). It is recommended to use a blank location and then press 
“Attach”. As a result, the selected material appears in the right column. Then, press OK 
to close this dialog box and return to the “Materials” window. A color is now assigned to 
the specified material and, selecting any menu with colors, this material appears in the 
specified location. 

Κατά layer: This option allows assigning layers to materials. First, select the desired 
material (left column); then, select the layer name which should be assigned to it (right 
column) and press “Attach”. As a result, the selected material appears in the right 
column. Then, press OK to close this dialog box and return to the “Materials” window. A 
color is now assigned to the specified material and, selecting any menu with colors, 
this material appears in the specified location. 
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Modify: This option opens the following dialog box that helps you modify the selected 
material: 

 
More specifically, you can modify anyone of the material "Attributes" that appear on the 
left side, by specifying a "Value" with the sliding key on the upper side. You can also 
modify "Color", by altering the ratios of Red, Green and Blue or selecting between the 
color systems RGB and HLS. More specifically, the material properties which you can 
modify are: 

1. Color/Pattern: Color is the basic color that reflects from the object. In order to 
import a drawing through "File selection", select the image (Bitmap) that will be used 
as a drawing. 

2. Ambient: The option for lighting the material with the ambient light determines the 
quantity of the ambient light that will illuminate the material. In general, keep the 
ambient value lower that 0.3. The greater the value the more faded the image will 
appear. 

3. Reflection: Here it is determined the amount of the striking on the material light that 
will be reflected, as well as the reflection color. For shiny objects set the refection 
value at 0.7 and the color at 0.3. If you wish the color of the highlighted areas to be 
white, change the value of Red, Green and Blue until it becomes 1. 

4. Roughness: The roughness value determines the size of the highlighted areas. 
Roughness has no meaning at all if reflection has no value. The lower the 
roughness value is, the smaller the highlighted area that will appear on the object 
will be. 

5. Transparency: The transparency value enables the user to make an object, or just 
a part of it, transparent. You can set the transparency value from "0" to "1". The 
greater the value is, the more transparent the object will be displayed. Transparency 
increases the photorealism period. In many cases it can double or triple this period. 

PhotoIDEA  375 



 
 

6. Refraction: Through this option you can specify a value for the refraction coefficient 
of a transparent material. The refraction value has a meaning only if transparency 
has a value. Indicative values for the refraction coefficient are: 1.0 for air, 1.33 for 
water, 1.5 for glass and 2.4 for diamonds. 

7. Bump-Map: This option supports the creation of a file, according to which the height 
differences will appear on a material, e.g. the grooves among the bricks. In this file, 
the lighter an area appears, the higher it is above the others. 

Adjust Bitmap: Through this option it is possible to set the size of the image that is 
positioned as a material, so that it will appear in its natural dimensions. The existing 
image has some natural dimensions. If you maintain the default values for offset and 
scale, then it is possible the image not to be visible on a natural scale. A methodology 
so that the image is displayed with natural dimensions is the following: 

Suppose you have a bitmap with the following natural dimensions in meters: a for the 
horizontal dimension and b for the vertical one. Next, insert the following values: 

 U V 

Offset (a-1)/2 (b-1)/2 

Scale 1/a 1/b 

For example, you have an image with a tile with dimensions 0.15m x 0.15m, and you 
should insert the following values: 

 U V 

Offset (0.15-1)/2= -0.425 (0.15-1)/2= -0.425 

Scale 1/0.15=6.666 1/0.15=6.666 

The materials specified in PhotoIDEA have a natural scale, but the user may modify 
them, if this is desired. 

Attention! If you want to save a material in a material library (e.g. the Render.mli) in 
scale, type the actual size and not the reciprocal (e.g. in the above example, 
concerning the tile, you should type 0.15 and 0.15). 

Upon completing the modification of the selected material properties, press OK to save 
the changes and return to the “Materials” window.  

Dublicate: Copies a material to a new material, in order to modify it. 
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New: Creates a new material, through the adjacent dialog screen, by typing its name 
and specifying the color and the other properties, similarly to the "Modify" section. 

The type of the new material that is created can be one of the following: 

• Basic 

• Granite 

• Marble 

• Wood 

For example, if a new material of "Wood" type is selected and the proper values for its 
parameters are specified (Light color, Dark color, Reflection etc) the desired type of 
wood can be selected. Performing successive tests and previews after each parameter 
modification, the desired material can be approached satisfactorily. 

 
To edit the Material library 
Do one of the following:  

• Choose PhotoIDEA > Edit Materials. 

• Type rmat and then press Enter.  

10.6 Edit 3D Objects 
This option opens the dialog box for 
editing 3D objects, which have been 
inserted in the drawing from the 3D 
libraries of the program. All 3D objects in 
the library are edited, so that they can be 
associated with materials. An example is 
shown in the adjacent figure. Running the 
command in the PhotoIDEA menu and 
selecting (with the mouse) the 3D object, 
the dialog box "Modify Colors" appears, 
where you can link a material to every 
color you see. 
Attention! The objects that can be edited through the above command should be 
included in a 3D library. 
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10.7 Sun 
If you want to have natural light photorealism, the sun position can be easily defined via 
this command. In the appearing dialog window select the city you want (e.g. Ismirn) 
and the month for which the sun position is taken into account (e.g. September) as well 
as the day and time (normal or daylight saving) you wish photorealism to take place. 

Based on the above data and in conjunction with the setting of the north direction, 
which can be defined by placing the relevant symbol via the "Set North" command 
within the Topographic (AutoREG), the program automatically places the sun, so that 
the photorealism scene that will be created complies with the natural lighting 
completely. 

To Define the Sun 
Do one of the following:  

• Choose PhotoIDEA > Sun. 

• Type sun and then press Enter.  

10.8 Lights Placement 
Through this option the user may define, easily and quickly, the position of a lighting 
source. When "Illuminator Position" is selected, 
the program prompts you to insert (in the 
command line), first of all, the illuminator name 
(e.g. 1), then its x and y co-ordinates, indicating 
its location on the ground plan, which is easily 
done with the mouse, and finally type its height. 
After entering all the above information, the 
illuminator appears at the location and the height 
that you positioned it, with the symbol shown 
above and its name in the middle. 

10.9 Edit Lights 
This option opens directly the following illuminator editing dialog box, including the 
options which are described below. 

 
Ambient light: Through this option you can adjust the intensity of the ambient light. 
Ambient light is the lighting that exists in a specific space, without coming directly from 
a certain light source, e.g. the natural lighting that exists in a room on a cloudy day. 
The intensity is constant for all surfaces in all directions. 
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The greater the value is, the more intensely the areas that are not directly illuminated 
by a source will be lighted. You may select a different colour for ambient light, except 
the white, through the "colour" option. 

Point light: It is the fixed light source that emits to all directions. You may define or 
modify the intensity, the colour and whether there will be any fading or shadows. 

Spot Light: Spotlight creates a light cone. You can define the direction, the size of the 
central cone of the middle beam (define the angle of the cone vertex), the size of the 
penumbra cone (define the angle of the penumbra cone vertex), the colour, the fading 
and whether shadows are created from objects. 

Distant light: Distant light creates parallel light beams in only one direction. The sun is 
an example of such a light source. In Photoidea, of course, it will not be necessary to 
select the "Distant light" option to define the sun since you can easily do so by running 
the "Sun" command instead. 

To edit the lights 
Do one of the following:  

• Choose PhotoIDEA > Edit Lights. 

• Type light and then press Enter.  

10.10 Background 
This option is used to select the Background, that is the image behind your scene. For 
example, the background may be a plain colour, a scenery, a cloudy sky and any kind 
of picture in general. If the "Background" option is selected, the following dialog window 
appears, on the top of which there are 2 options: "Solid" and "Image". Each of these 
options excludes the possibility to activate the other one. 
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Solid Background: Solid Background may simply correspond to the existing CAD 
background (since the relevant box is checked) or any other colour (since this box is 
not checked). In the last case the user may select the colour he wishes to use for the 
background from the colour palette shown below. 

 
Moreover, after the user has selected the colour, he can modify it slightly by setting 
accordingly the 3 sliding bars that exist for this purpose, and activate the "Preview" 
window at every change in order to view the background colour in the frame. 

Image: Select, through the "File" option, the image-file of the "Landscape" where your 
drawing will be inserted. 

 
For example, if you select the "Biglake.tga" file from the "Textures" subfolder, the 
corresponding background will appear. 

Note: Provided you have shooted (from the appropriate aspect) the area where the 
building site is located and you have digitized the picture (e.g. by using a scanner or 
directly a digital camera), you can easily use it as it was mentioned earlier. Naturally, 
when you create a "perspective" in the "Project Drawings", you should provide angle 
and height relevant to those of the shooting. 
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To edit the background 
Do one of the following:  

• Choose PhotoIDEA > Background. 

• Type background and then press Enter.  

10.11 Fog 
This option is used to activate the fog directly through the PhotoIDEA menu dialog 
window. 

 

To set the Fog 
Do one of the following:  

• Choose PhotoIDEA > Fog. 

• Type fog and then press Enter.  

10.12 Landscape objects 
Through this option you may insert objects from a picture (e.g. trees, human figures 
etc) in your drawing. These objects have the advantage of occupying limited space on 
the drawing while they have an impressive impact on photorealism. 

In the appearing screen, select the desired object from the library list. Run "Preview" to 
see the object on the screen. 

In the Geometry option you may define the geometry of the appearing linear drawing 
because this is a bitmap (image). 

The first option "Single face" places a triangle to determine the object location or two 
triangles vertical to each other. The selected type affects the shadow created by the 
object. 
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Through the "Height" option you can define in meters the height of the object in the 
drawing (e.g. 1.8 m for a human figure). 

Through the "Position" option you can position the object to the drawing. 

Attention! If you are working in axonometric mode but the drawing is not displayed, it 
is possible that the Ortho is active which might be the reason for not appearing in the 
scenery. 
 

Note: If you want to edit a landscape object then you may run the "Edit Landscape 
Objects" (LSEDIT) command. In order to save a new object in the library, run the 
"Landscape Object Library" (LSLIB) command. The landscape objects are saved in 
files with the extension "lli" (e.g. Render_eg.lli). 

To insert landscape objects 
Do one of the following:  

• Choose PhotoIDEA > Landscape Objects. 

• Type lsnew and then press Enter.  

10.13 Edit bitmap Objects 
This option opens the dialog window for editing Bitmap objects. This way, you can edit 
the object geometry as well as its height and its location in the drawing. 

To edit bitmap objects 
Do one of the following:  

• Choose PhotoIDEA > Edit Bitmap Objects. 

• Type lsedit and then press Enter.  

10.14 Bitmap Object Library 
This command opens the Bitmap Object Libraries where you can edit Bitmaps. You are 
enabled to modify them, create new objects as well as edit objects of another library 
(render_en.lli etc) via the "Open" command and save them in any other desired library. 

 

 

To enable the Bitmap object library 
Do one of the following:  
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• Choose PhotoIDEA > Bitmap Objects Library. 

• Type lslib and then press Enter.  

10.15 Render Settings 
Rendering will be based on a series of parameters. These parameters include the 
selection of a rendering algorithm, the shading method and many other options, which 
are described in detail below.  

Selecting the “Render Settings” command displays the following dialog box. 

 
OpenGL: This option allows very quick rendering as well as moving within the 
ProgeCAD Architecture environment. In particular, you can run the “Pan”, “Zoom in”, 
“Zoom out” and “3D Orbit” commands, while in rendering mode, to get a rendered 
image of the drawing from every side. This way, the user is able to have an overall 
view of the rendering effects, for all the objects and materials he/she has selected, 
without having to repeat the "Render" option segment by segment. 

Render: The "Render" option shows the materials on the surfaces (e.g. Brick) but does 
not create shadows. 

Circumambient Lighting: If this option is activated, you can see shadows on the 
surfaces from circumambient lighting (e.g. Sun). 

Shadows: Provided this option is active, rendering will create shadows from the 
various surfaces. 

Lights: If this option is activated, you can see shadows from lighting sources (point 
light, distant light, spotlight).  
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Materials: If this option is active, with rendering you can see the materials that have 
been specified before. 

Optical: If this option is active, with rendering surfaces will be properly updated 
according to all the above (shades, materials, lights). 

The other options in this window are described below: 

Destination: Define where rendering will be performed. By selecting the button under 
the "Destination" indication, an option list appears, where you can define the rendering 
mean. 

• Window: Rendering will be performed on your screen as shown. 

• File: This option is used when you want to save the image in a file, in order either 
to save it to a diskette or to further edit it through another application. 

File Type: By clicking the pull down menu box of this section option list, an option 
menu appears, from where you may select the file type on which photorealism will be 
applied. ProgeCAD Architecture supports the following file types: BMP, TGA 
(compressed and uncompressed), and PNG. Clicking the lower pull down menu box of 
this section option list, an option menu appears from which you may select the image 
dimensions in pixels. These dimensions are proportional to the desired screen 
resolution. If you select a standard image size (e.g. 800x600 or 640x480), the readings 
"Χ:", "Y:" and the "Aspect Ratio" are automatically adjusted and cannot be selected. 
But if a user-defined size is selected instead, you may then modify them. Through "Χ:", 
"Y:" adjust the image size that will be created within the file. 

Aspect Ratio: Here you can adjust the ratio of the screen pixel size to the file pixel 
size (for user-defined resolution). 

Colors: In this section, you may set the colours of the image created through 
rendering. 

After you have completed the settings, click “ΟΚ” to return to the previous dialog box. 

To control the render settings 
Do one of the following: 

• Select PhotoIDEA > Render Settings. 

• Type rpref and press <Enter>. 

10.16 Render 
Through this command you can have the desired scene rendered. The command is 
executed by typing "render" (and pressing "enter") in the line command, by clicking the 
corresponding icon or from the menu. 

Creating a rendered image of your drawing removes hidden lines and then shades the 
surface as though it were illuminated from multiple light sources.  

Full rendering creates a photo-realistic image of your model, complete with light 
sources, shadows, surface material properties, and reflections. You can illuminate your 
image with spotlights, distant lighting to simulate sunshine, and ambient light. If you 
choose not to customize the light sources, the program generates default light sources 
for you.  
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Rays from these imaginary light sources are traced as they reflect off and refract 
through the surfaces of the model, a process called ray tracing. Ray tracing determines 
where shadows fall and how reflections on shiny materials such as metal and glass 
appear. You can modify the reflective properties of the materials that make up your 
model to control how the light rays reflect off its surfaces.  

Full rendering creates automatically a base on which your model is displayed, if you 
don’t already have one, so it does not appear suspended in space. A background is 
also automatically added to the image. A background such as a cloudy sky or an 
imported raster graphic such as a stone wall can also be added behind the image, 
making it even more realistic.  

When the Photorealism procedure is completed, the corresponding image appears on 
your screen. You may repeat the whole procedure as many times as you wish, after 
modifying any of the above parameters, until the desired outcome is achieved. 

Note: In order to print a photo, you should either define the destination (destination 
render window) or copy it to a file and then run a Windows "Painting" program (such as 
Paintbrush or Paint) to load (through "Open") the file (e.g. BMP or TGA type) and print 
it (through "Print"). Apparently, a colour photo requires a colour printer and of course 
the relevant printer driver to be correctly set. 

To create a fully rendered image  
Do one of the following:  

• Choose PhotoIDEA > Render  

• On the Rendering toolbar, click the Render tool ( ). 

• Type render and then press Enter.  

10.17 Printing a rendered image  
You cannot print a rendered image directly from a printer. Instead, you must first export 
the drawing to a different format -either bitmap (.bmp), PostScript (.ps), or TIFF (.tif). 
After you export a rendered image, you can print it from a different application that 
supports graphics.  
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11. WalkIDEA 
 

 

WalkIDEA is the virtual walkthrough component of IDEA, which enables the user to 
"walk" inside and outside the building. In the following sections, all the WalkIDEA 
commands are successively described in every detail, so that the user understands 
how to accomplish the desired "walkthrough" and take the maximum benefit of the 
program utilities. For the well understanding of the WalkIDEA function and the proper 
use of materials, lights, backgrounds, surrounding space objects etc, a good 
knowledge of PhotoIDEA, is required.  

11.1 Project definition 
In order to start a walkthrough you should, first of all, define the project name via the 
relevant WalkIDEA menu. 

 
Every new project is created in the architectural project Directory, with the extension 
OSG. The user may define different projects for the same building and create 
walkthrough files, each time with different materials, lighting etc. 
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11.2 Insert viewing point 
The viewing point is the position from where an observer may view the building. A 
viewing point can be defined by either using the mouse or by typing the coordinates 

at the bottom (in any coordinate system following the 
rules of progeCAD or AutoCAD). More specifically, 
you can, first of all, specify the point by using the 
mouse, viewing at the same time the absolute 
coordinates of its position on the bottom of the 
screen. You can also define a new point on the 
screen, with respect to the previously defined point. 

The application "remembers" the last defined point. Hence, select "Viewing Point" in 
the menu and type its relative coordinates, with respect to the last point, in the 
command line. You are also asked, for each viewing point, to provide its angle 
(viewing point orientation), its level as well as its name. 

11.3 Viewing point level 
By using this command, you are prompted to select "viewing points", that is, to select 
the viewing points that you want to be placed at a specific altitude. When prompted to 
define the "viewing point level", determine the new level of the viewing point. 

11.4 Insert path 
A path is a route which is defined as a succession of viewing points. By using this 
command, you are prompted to "select viewing points", that is, to select, one by one, 
the viewing points that you want the path to consist of. 

11.5 Insert path from a polyline 
The above mentioned path may be inserted with the use of a polyline. Since the 
desired path is defined by drawing a polyline, you are prompted to select the polyline, 
the direction of the viewing points, the level of the path and a prefix in order to 
perform numbering of the viewing points. 

11.6 Merge Paths 
By using this command, you are requested to "select path", that is, to select, one by 
one, the paths that you want the new path to consist of. 

11.7 Insert staircase ascension 
This command supports the insertion of a path that corresponds to the ascension of 
a staircase. The program requests to "select staircase" and "observer altitude". When 
the above data are provided, the program automatically places viewing points on 
every stair of the staircase and draws, following these viewing points, a path which 
corresponds to the ascension route of the staircase. 

11.8 Geometry File 
Through this option you can create the file of the building geometrical data (walls, 
windows, doors, slabs etc). In order to do that the drawing should be 3D animated. 
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11.9 Walkthrough 
Through this option you can finally simulate on your screen a live walkthrough within 
the building. The program "walkthrough" menu includes the following options (from 
the option menu) and option buttons. 

 
11.9.1 File 
The options of this group cover the file management according to the Windows 
standardisation. More specifically: 

The "Open File" option is used when you want to load an existing file for further 
editing. When you enter the program via the architectural IDEA, the walkthrough 
project entitled "Project Name.osg" is automatically selected. 

The ‘’Save’’ option is used when you want to save the open file. 

The ‘’Save as’’ option is used when you want to save the open file, with a different 
name. In the Save As tab that opens, you can define the desired name and the path 
where the file shall be saved. 

Run the "Exit" command to exit the walkthrough program. 

11.9.2 Show 
The ‘’Show’’ option comprises the toolbars of the icons that are related to the various 
menu options. These are divided in sections, as for example the toolbars for the 
‘’Tool Bar’’, the ‘’Movement’’, the ‘’Paths’’, the ‘’Viewing points’’ etc.  

By activating one of the toolbars (clicking on the relevant menu option so that the 
check mark is shown), we get the corresponding toolbar in the menu. This toolbar 
can be moved towards any direction the user wishes, e.g. at the top, left, right or 
bottom of the screen. 



 
 

This can be easily done by dragging the toolbar with the use of the left mouse button 
and moving it to the desired location (with the mouse button pressed), exactly the 
same way it is done in any windows application. In the following example (screen) 
several "open" toolbars in all possible places are shown 

 

11.9.3 Properties 
11.9.3.1 Background 
With this option the following dialogue box is displayed: 

 
The above screen enables you to select the Background type between the options 
Compact and Images.  

In case you select Compact as the background type, the corresponding field is 
activated which enables you to select the desired colour by changing the values for 
the three basic colours, Red, Green and Blue. 
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In case you select Images as the background type, the corresponding field is 
activated, where you have the following options: Simple Background, where you can 
define a unique bmp file as the background and CubeMap, where you can define 6 
different bmp files. These 6 files correspond to the 6 edges of a hypothetical cube, at 
the centre of which is considered to be the item in which you walkthrough. Finally, the 
option Level ΧΥ enables you to select whether you want to use any XY level, and in 
that case you can define either a bmp image, or a compact colour, which shall be 
used by the program as the base, after you provide the value for the altitude z in 
which you should desire to place it. 

With the option Define as default, you are enabled to define as the default settings 
the settings that you desire (e.g. bmp image, XY plane, sun position etc) and use 
them in any file you wish with the option Default. 

11.9.3.2 Lights 
With this option the following dialogue box is displayed: 

 
This dialogue box enables you to define at first the Type of scene lights. The 
available options are: None, in case that you do not wish to have any lights, Generic 
Light, in case that you wish to have the default lighting of the program and Main 
Light, in case that you wish to have a light that shall follow the route of the 
walkthrough. 

With the option Lights from drawing, you can select whether you want the lights 
that are defined in the PhotoIDEA application to participate or not. 

Finally, with the option Light colour, you can define the colour of the Main Light. 



 
 

11.9.3.3 Video recording 
• Encoder 
With this option the following display appears, in which you can select the encoder 
that you wish for the video recording. The appearing options depend on the installed 
version of Windows in the user's computer. 

 
With the option Configure you can perform some additional settings, depending on 
the selected encoder. 

• File name 

This option requires the path for saving and the name of the video file with ending 
avi. 

11.9.3.4 Images 
• File name 
The program enables you to create some image files, by printing the scene that 
appears at this moment on the screen. With the File name option, you are required to 
provide the path for saving and the image file name, and consequently the image file 
opens on the screen whenever the relevant icon is pressed. 

11.9.3.5 Paths 
This option enables you to increase or decrease the speed, for the defined paths, as 
well as to change the repetition mode. The options for the repetition mode are three: 
either to execute the path once and then stop, or to execute the path once and then 
execute the reverse path, or, finally, to repeat the path illimitably. 

11.9.3.6 Stereoanaglyph 
This command activates the stereoscopic view of the 3D model, based on blue-red 
colors technique (stereoanaglyph). Using the appropriate blue-red glasses, the user 
can observe its model in its real 3 dimensions. In order to get the maximum 
performance the user has the option to set properly the value of the distance 
between the two eyes. 
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11.9.4 Help 
The option ''About'' provides information for the program version. 

11.9.5 Toolbar of the paths 
This option displays all the paths defined by the user and you may select whichever 
path you want. You can browse to the various paths using the relevant arrow keys 
that appear in the toolbar. 

11.9.6 Viewing points toolbar 
This option displays all the viewing points defined by the user, from which you may 
select whichever you want. You can browse to the various viewing points using the 
relevant arrow keys that appear in the toolbar. 

11.9.7 Movement management toolbar 
The function of the icons that are included in the specific toolbar is described in the 
following: 

•  This option activates the 1st set of movements that includes the following 
movements: 

1. Use the right mouse button to rotate your building around the two axes 
(x,y), which define a plane parallel to the screen plane.  

2. Use the middle mouse button to move the visible part of the screen, so that 
a new (previously not visible) part is revealed. The visible part of the 
screen moves towards the desired area by moving the mouse 
correspondingly. 

3. Use the right mouse button to zoom in and zoom out the existing building, 
in order to approach or to distance, correspondingly. 

•  This option activates the 2nd set of movements which includes the following 
movements: 

1. Press the right mouse button in order to 'walk' in the building using the 
mouse. 



 
 

2. Press the middle mouse button to rotate your building around the axis 
which is vertical to the building plane and passes through the metacenter 
of the polygon that envelops the building.  

3. Press the right mouse button to move the visible part of the screen, so that 
a new (previously not visible) part is revealed. The visible part of the 
screen moves towards the desired area by moving the mouse 
correspondingly. 

•  If you keep this icon activated, the building is not free to move or rotate 
continuously, by pressing the mouse buttons (as described above). 

•  With this option the program returns to the starting point of the walkthrough 
(as with pressing the <space bar>). 

11.9.8 Display mode toolbar 
The function of the icons in the specific toolbar is described below: 

•  By activating this option you can see the drawing with the defined materials 
at its surfaces. 

•  By activating this option you can see the polygons that consist the drawing. 

•  By activating this option you can see the points which consist the drawing. 

•  If you keep activated the option to show the drawing with the materials of the 
surfaces, when you press this icon, the program illuminates by 100% any surface 
with ambient light. 

•  If you activate this option, the program removes the materials from the 
surfaces and colours them with white colour. This enables the user to check 
which surfaces are stated to have material and which not. 

•  If you activate this option, the program reverses the reaction mode of each 
surface to the light. If you consider a cube in which a light vector outside of the 
cube is defined, then the internal of the cube shall not be illuminated. If you 
activate the above option, the program reverses the light vector, that is to say the 
cube shall be illuminated internally. 

11.9.9 Video toolbar 
The function of the icons that exist in the specific Toolbar is described below: 

•  If you press this button you can start video tape recording the walkthrough. 
When you press the button you are prompted to state the path for saving and the 
name of the Video file with ending avi. When the video tape recording is 
completed, you can see the file in a video by double clicking on the file name. 

•  By pressing this button again you can pause the video tape recording of the 
walkthrough. By pressing this button for a second time, the recording starts 
again. 

•  By pressing this button, you can stop video tape recording the walkthrough. 
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11.9.10 Images toolbar 
The function of the icons that exist in the specific Toolbar is described below: 

•  By pressing this button you can print in an image file the image that appears 
at this moment in the screen. At first the program requires the path for saving and 
the name of the image file. 

•  This button enables you to create different continuous image files. The 
program requires the path for saving and the name of the image file, by adding 
successively the numbers 1, 2 etc. 

11.9.11 Stereoanaglyph Toolbar 
The functionality of each icon of this toolbar is described below: 

•  The “3D glasses” icon activates the stereoscopic view of the 3D model. 

•  The “+” icon sets (increases) the distance between the observers’ eyes. 

•  The “-” icon sets (reduces) the distance between the observers’ eyes. 
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