progeCAD Professional manual The low-cost alternative to AutoCAD

Index



Do you want to try progeCAD Professional?
Download the trial: you can try the product, without any limit, for 30 days!

A manual page a day... Click here to see the manual table of contents.

Customizing progeCAD - Customizing menus

Creating new menus and commands

You can create a new menu by inserting a menu item at the top level of the Menu Tree. Then you can add commands to the new menu item. You can also add submenus and modify existing menu names and commands by adding, deleting, and rearranging them.

NOTE A green bullet in front of a menu item or command indicates that the menu item or command is available for you to use at the experience level you have set. A red bullet in front of a menu item or command indicates that the menu item or command is not available for you to use at the experience level you have set. To change your experience level, choose Tools > Options.
To create a new menu
  1. Do one of the following:
  2. Choose Tools > Customize > Menu.
  3. Type customize and then press Enter.
  4. Click the Menus tab.
  5. In the Menu Tree, select the menu name above which you want to add a new menu.
  6. Choose Insert > Menu Item.
  7. Type a name for the new pull-down menu, and then press Enter.
  8. Click Close.
  9. To see the new menu, you must perform the following steps for adding a command to the menu.
To add a command to a menu
  1. Do one of the following:
  2. Choose Tools > Customize > Menu.
  3. Type customize and then press Enter.
  4. Click the Menus tab.
  5. In the Menu Tree, select the menu to which you want to add the new command.
  6. Choose Insert > Menu Sub-Item.
  7. Type a name for the new command, and then press Enter.
  8. Assign a command string to the command you added by doing one of the following:
  9. In the Available Commands list, choose the command, and then click Add Command.
  10. In the Command box, type the command string, and then click Add Command.
  11. In the Help String box, type the text to be displayed in the status bar when the cursor is positioned over the new command.
  12. To add another command, repeat steps 3 through 7.
  13. When you have finished, click Close.
  14. NOTE When you type a name for a new command, you can specify an access key by including an ampersand (&) immediately preceding the letter you want to use as the access key. Be sure not to assign the same access key to more than one menu or command within a menu. For example, if you add a command named Quick Line to the Insert menu, including an ampersand immediately preceding the letter Q causes that letter to appear underlined in the menu. You can then select that command by displaying the menu and pressing the Q key.
To rename a menu item
  1. Do one of the following:
  2. Choose Tools > Customize > Menu.
  3. Type customize and then press Enter.
  4. Click the Menus tab.
  5. In the Menu Tree, select the menu item you want to rename.
  6. Click Rename.
  7. Type a new name for the menu item by typing over the highlighted name, and then press Enter.
  8. Click Close.
To delete a menu item
  1. Do one of the following:
  2. Choose Tools > Customize > Menu.
  3. Type customize and then press Enter.
  4. Click the Menus tab.
  5. In the Menu Tree, select the menu item you want to delete.
  6. Click Delete.
  7. In the Confirmation dialog box, click Yes to delete the menu item.
  8. Click Close.
  9. NOTE Deleting a menu item that has sub-items below it in the Menu Tree also deletes all those sub-items.