progeCAD Professional manual The low-cost alternative to AutoCAD

Index



Do you want to try progeCAD Professional?
Download the trial: you can try the product, without any limit, for 30 days!

A manual page a day... Click here to see the manual table of contents.

Customizing progeCAD - Setting and changing options

Changing the options on the Display tab

In the Options dialog box, the Display tab contains settings for displaying the command bar, progeCAD window, menus, and real-time view rotation.

Setting the command lines to track progeCAD tracks the commands and command prompts you used most recently. You can control the number of lines that the program keeps in memory as you work. The default value is 256. You can display the commands in the Prompt History window. To display the Prompt History window, press F2. To close the window, press F2 again.

Displaying tabs and scroll bars Hiding window elements if you do not use them can help increase drawing space in the progeCAD window.

To show or hide the Model tab and Layout tabs, select the Show Tabs check box. You may want to hide the tabs if you only work on the Model tab or if you use the command bar and status bar to switch between tabs.

To show or hide the scroll bars that display on the right side and bottom of the progeCAD window or viewport, select the Show Scroll Bars check box. You may want to hide the scroll bars if you only use the Pan command to scroll drawings.

Enabling continuous view rotationWhen you use the Real-Time Sphere command to rotate your view of entities, you typically move the mouse to rotate the view. If you want the rotation to continue after you release the mouse, turn on the Continuous Inertial Motion in Real Time check box. The rotation also continues when you use the Real-Time X, Real-Time Y, and Real-Time Z commands.

Changing the zoom direction of the mouse wheel By default when working in a drawing and using the mouse wheel, you spin the mouse wheel forward to zoom in and spin it backward to zoom out. If you want to reverse the zoom direction relative to the zoom wheel, that is, spin the wheel forward to zoom out and spin it backward to zoom in, enable the Reverse Mouse Wheel Zoom Direction check box. This can be especially helpful if you use the mouse with your left hand.

Setting the graphics screen color By default, drawings are displayed on a black background. You can change this color and specify the background screen color that you want.

Displaying prompt boxes When a command offers several options, a prompt box is displayed with those options. If you prefer to select options by typing, you can turn off the prompt boxes by clearing the Display Prompt Boxes check box.

Setting automatic menu loading The first time you start progeCAD, a default menu is loaded, and the Automatic Menu Loading check box in the Options dialog box is checked. The Automatic Menu Loading feature allows you to load drawings with associated menus without overwriting the default menu. You can turn off the Automatic Menu Loading option.

Selection Area Effect When you create a selection window, by default, you are able to recognize it being identified with two colors: green and blue. In this part of the dialog box you are able to modify these colors, set their opacity or disable them.

Selection Preview When a command is active and you place the mouse cursor over an entity, this is highlighted. It is possible to set the selection options in a way that the elements are highlighted when there is not an active command or you can completely disable this functionality. With this last option selected the elements will not be highlighted.

Selection Preview Filtering When you activate any of the Preview Filtering options you can define which elements not to highlight, it is possible to chose among locked layers, external references (Xrefs), multiline text and hatches.

To change the options on the Display tab
  1. Do one of the following:
  2. Choose Tools > Options.
  3. Type config and then press Enter.
  4. Click the Display tab.
  5. Select the options you want.
  6. When you have finished, click OK.
  7.  
    1. Type or select the maximum number of command lines to track.
    2. Click to show or hide the Model and Layout tabs.
    3. Click to show or hide scroll bars.
    4. Click to select paper color.
    5. Click to show or hide prompt boxes.
    6. Click to toggle automatic menu loading on or off.
    7. Click to select screen color
    1. Select to zoom out when spinning the mouse wheel forward and zoom in when spinning the mouse wheel backward.
    2. Select to continue rotating the view when using the Real-Time Sphere, Real-Time X, Real-Time Y, and Real-Time Z commands.
    3. Select how the area that you select will appear
    4. Choose to see the selection preview when you pass the cursor over the objects if a command is active or not. You can also decide what objects not to see in the preview (xrefs, multiline text, hatch, ecc...)