progeCAD Professional manual The low-cost alternative to AutoCAD

Index



Do you want to try progeCAD Professional?
Download the trial: you can try the product, without any limit, for 30 days!

A manual page a day... Click here to see the manual table of contents.

Render

Preferences

Toolbar: Render > Render Preferences (

).

Menu: View > Render > Preferences.

Keyboard: SETRENDER.

Alias: RPREF.

The Render Preferences command allows you to control several aspects of the rendering system and the Render Settings dialog box is divided into five different worksheets entitled: Rendering, Shadows, Floor, Site, and Render to File.

The first worksheet, entitled "Rendering" is used to control rendering quality, antialiasing, and surface smoothing. It also provides buttons that allow you to save your rendered image to a file or to redisplay the last rendered image.

The second worksheet, entitled "Shadows" is used to control some of the aspects of the shadow computations in the rendering module.

The third worksheet, entitled "Floor" is used to control the optional floor that can be placed beneath drawings when they are rendered.

The fourth worksheet, entitled "Site" is used to set the location of the drawing on earth and the orientation of the drawing axes to true North. This information is used in calculating sun angles for lighting purposes.

The fifth worksheet, entitled "Render to File" is used to rendering the drawing directly to a file on disk. This allows you to generate rendered images at any desired resolution independent of the screen resolution.

Each different worksheet can be accessed by clicking on the corresponding tab at the top of the dialog box.

Render settings are stored in the drawing.

Rendering Worksheet
  1. The Rendering worksheet appears on the Render Settings Dialog box and is used to control rendering quality, antialiasing, surface smoothing, and shadow depth. It also provides buttons that allow you to save your rendered image to a file or to redisplay the last rendered image.
  2. The Rendering worksheet is shown below and is followed by a table listing each of the available controls and their function.
  1.  
  2. Control

    Description

    Rendering Quality

    The Rendering Quality pulldown menu allows you to control the quality of the rendered image and hence the time needed to compute it. Three options are available, "Low Quality," "Medium Quality," and "High Quality."

    • Low Quality - Rendering is calculated without shadows, reflections, or transparency.
    • Medium Quality - Rendering is calculated without shadows.
    • High Quality - Rendering is calculated with approximate shadows using a technique called "Adaptive Shadow Testing." This accelerates the rendering significantly when rendering scenes with multiple lights, but some artifacts and inaccuracies in the shadows may be noted in the image.
    • Very High Quality - Rendering is calculated with detailed shadows, reflections, and transparency.

    Redisplay Last Image

    When a rendered image is computed and displayed on the screen, a copy is saved in memory for later use. After the image is displayed, it will be erased if you interact with the drawing or perform a redraw or regen of the drawing. The Redisplay Last Image button will redisplay the last rendered image onto the drawing window.

    The image will be displayed exactly as it was seen before. Any changes to the drawing or drawing view will not be reflected. Moreover, the last rendered image could even be from a different drawing than the one currently displayed.

    Save Last Image

    Once you have generated a rendered image that you would like to save, you can use the "Save Last Image" button to save the image to a file. Once you click on this button, you will have the opportunity to select a filename for the rendered image. Images can be saved in BMP, JPEG, TIFF, TGA, or PNG format. The saved image will be in 24 bit, full-color format at the same resolution as rendered on the screen.

    Antialiasing

    In regions of the rendered image where the light intensity changes dramatically such as near surface edges, jagged edges may appear due to the sampling nature of the rendering process. Antialiasing attempts to aleviate these problems by taking multiple samples for each pixel in the rendered image and averaging the result. This can significantly improve the quality of the final image, but also significantly increases rendering time. By default, antialiasing is turned off. You may wish to active it for your final rendering step.

    Surface Smoothing

    progeCAD approximates curved surfaces by subdividing the surface into multiple flat polygons. The surface smoothing option smooths the transitions between individual faces on asurface so that curved surfaces will appear more rounded.

    Double Sided

    Individual surfaces in the image are considered to have a front and a back face. This check box controls whether the renderer treats the front and back faces the same or not. If this box is not checked, then any light rays that hit the back face of a surface are essentially ignored (i.e. the back face is considered black and non reflective). If the box is checked, then the back face is treated the same as the front face.

    Which face is considered front and which is considered back is controlled by the order of the vertices. Looking at the face, if the vertices proceed around the face in a counter-clockwise order, then the face is the front. If the vertices proceed around the face in a clockwise fashion, then you are looking at the back of the surface.

Shadows Worksheet
  1. The Shadows worksheet appears on the Render Settings Dialog box and is used to control some of the aspects of the shadow computations in the rendering module.
  2. The Shadows worksheet is shown below and is followed by a table listing each of the available controls and their function.
  1.  
  2. Control

    Description

    Area Lights/Soft Shadows

    This option allows you to control the quality of the soft shadow computations. Soft shadows from area lights, that is lights that have some non-zero diameter, are calculated by taking multiple samples of the light at each point in the image. The higher this number the more accurate the lighting calculations will be, but the longer the rendering process will take.

    Shadow Depth

    Shadow depth controls the number of light reflections or transmissions that are considered when generating the image. If your scene contained several mirrored surfaces that faced each other, the software could spend a considerable amount of time bouncing rays of light back and forth between the mirrored surfaces. The shadow depth option controls this by only allowing the renderer to consider a specified number of "bounces." Each time a light ray hits a surface and reflects off of it, or travels through it if the surface is transparent, the "depth" of the ray is increased. The number specified in this entry box will control how many reflections or transmissions the renderer considers.

    Adaptive Shadow Testing

    Adaptive Shadow Testing is an algorithm used to speed up the rendering process when rendering scenes with multiple light sources. This algorithm attempts to identify which light sources are most significant for each part of the scene and only directly samples those lights. The light cast by less significant light sources is estimated based on statistical techniques.

    This slider controls the degree to which the technique will be applied. The higher the value set, the more rendering will accelerated, but the more approximate the lighting calculations. If the slider is set to 0, all of the light sources will be tested and shadows will be calculated exactly. If the slider is set to 1, only the strongest light source at each pixel will be tested and the contributions for other lights will be estimated. The Adaptive Shadow Testing algorithm is only used when Rendering Quality is set to High.

Floor Worksheet
  1. The Floor worksheet appears on the Render Settings Dialog box and controls whether or not a floor is displayed underneath the rest of the drawing during rendering. As an example, the drawing on the left below is shown without a floor and the drawing on the right is shown with the floor. The floor is drawn in the X-Y plane touching the lowest point (smallest Z value) on the drawing. The Z direction is assumed to be "up".
  1. The Floor worksheet is shown below and is followed by a table listing each of the available controls and their function.
  1.  
  2. Control

    Description

    Enable Floor

    This checkbox controls whether or not the floor is displayed. If the box is checked, then the floor is displayed. If the box is not checked then the floor is not displayed.

    Edit Floor Material

    This button opens the material selection dialog so that you can control the appearance of the floor. By default, a solid white/gray color floor is provided.

    Floor Size

    This slider bar controls the size of the floor. If the slider is at the minimum position, then the floor will extend to the X and Y limits of the drawing. If the slider is moved to the right the size of the floor will increase.

Site Settings
  1. The Site tab of the Render Settings dialog allows you to specify the location and orientation of the site where the drawing is located. This information is used in calculating the position of the sun for lighting purposes. The tab contains entries for the site latitude and longitude, the time zone, and site orientation relative to true north. In addition, it includes a pull-down menu containing a list of a number of major cities around the world. If your building site is in or near one of these cities you can choose that city and the latitude, longitude and time zone will be entered automatically.
  2. The site orientation represents the angle of true north relative to the drawing axes. By default, true north is assumed to be in the +Y direction. The site orientation value measures the angle from the +Y direction in drawing coordinates to true north. If the site orientation value is 90 degrees, then true north would be in the +X direction. If it is set to 180 degrees, then true north would be in the -Y direction.
  3.  
  1. Note that the Site Location parameters take effect the next time the sun position is calculated. The Site Orienation parameter will take effect when the next rendering is performed.
Render to File
  1. The Render to File tab will allow you to produce a rendered image directly to a file on disk rather than to the progeCAD screen. The tab includes two entry blanks so that you can specify the desired width and height of the image in pixels. Once you have entered the desired values, you can click the button labeled "Render" to start the rendering process. There is no preset limits on the width and height dimensions, however, the larger they are the longer the process will take and the more memory will be required.
  2. After the rendering process has been started, you can interrupt it by pressing the Escape (Esc) button. You will not be able to use the progeCAD software until rendering processing is completed or cancelled.
  3.