progeCAD Professional manual The low-cost alternative to AutoCAD

Index



Do you want to try progeCAD Professional?
Download the trial: you can try the product, without any limit, for 30 days!

A manual page a day... Click here to see the manual table of contents.

Drawing in three dimensions

Creating three-dimensional entities

progeCAD supports the following types of three-dimensional models:

Wire-frame models, which consist of lines and curves that define the edges of a three-dimensional entity. You can create a wire-frame model by drawing lines, arcs, polylines, and other two-dimensional entities anywhere in three-dimensional space. Wire-frame models have no surfaces; they always appear as outlines. Because you must individually draw and position each entity that makes up a wire-frame model, creating one can be exacting and time-consuming.

Surface models, which consist of both edges and the surfaces between those edges. You can create a surface model by applying elevation and thickness to two-dimensional planar entities or by using specific three-dimensional entity-creation commands. Surface models consist of individual planes forming a faceted, polygonal mesh.

3D solids, which are three-dimensional ACIS entities that consist of faces and edges. 3D solids appear to have volume and are easier to work with than wire-frame and surface models. progeCAD full version allow you to create and more completely edit 3D solids.

Applying elevation and thickness
  1. By default, the program creates new two-dimensional entities with a zero elevation and thickness. The easiest way to create a surface is to change the thickness property of an existing two-dimensional entity.
  2. The elevation of an entity is its z-coordinate position in relation to the xy plane in which the entity is drawn. An elevation of 0 indicates that the entity is drawn on the xy plane of the current UCS. Positive elevations are above this plane; negative elevations are below it.
  3. The thickness of an entity is the distance it is extruded above or below its elevation. A positive thickness extrudes the entity upward in the positive z direction of the entity; a negative thickness extrudes it downward in the negative z direction. The thickness is applied uniformly to the entire entity. You can extrude any two-dimensional entity into a three-dimensional entity by changing the thickness of the entity to a nonzero value. For example, a circle becomes a cylinder, a line becomes a three-dimensional plane, and a rectangle becomes a box.
  4.  

     

     

    Two-dimensional entities.

     

    Two-dimensional entities with thickness added.

  5. You can create three-dimensional entities using any of the following methods:
  6. Draw two-dimensional entities in three-dimensional space.
  7. Convert two-dimensional planar entities into three-dimensional entities by applying elevation and thickness.
  8. Convert two-dimensional planar entities into three-dimensional entities by revolving or extruding.
Create three-dimensional entities such as boxes, cylinders, cones, domes, spheres, and wedges.
  1. NOTE Three-dimensional solids are drawn as true solids with full versions of progeCAD that include a license for the ACIS solids modeling system. Three-dimensional solids include the following: box, cone, cylinder, dish, dome, pyramid, sphere, torus, and wedge.
  1. You can change the default elevation and thickness values to create new entities with an elevation and thickness already applied.
To set the current elevation
  1. Display the current elevation setting by doing one of the following:
  2. Choose Format > Elevation.
  3. Type elevation and then press Enter.
  4. Specify the New Current Value For Elevation, and then press Enter.
To set the current thickness
  1. Display the current thickness setting by doing one of the following:
  2. Choose Format > Thickness.
  3. Type thickness and then press Enter.
  4. Specify the New Current Value For Thickness, and then press Enter.
To set the current elevation and thickness using a dialog box
  1. Display the Drawing Settings dialog box by doing one of the following:
  2. Choose Tools > Drawing Settings.
  3. Type settings and then press Enter.
  4. Click the 3D Settings tab.
  5. In the Change Settings For list, click Surfaces.
  6. To change the current thickness, in the Current 3D Thickness box, type a new thickness value or click the arrows to select a new thickness.
  7. To change the current elevation, in the Current 3D Elevation box, type a new elevation value or click the arrows to select a new elevation.
  8. Click OK.
 
 
  1. Type or select the current three-dimensional thickness.
  1. Type or select the current three-dimensional elevation.
To change the thickness and elevation of an existing entity
  1. Type entprop and then press Enter.
  2. Select the entity, and then press Enter.

progeCAD displays the Entity Properties dialog box. The exact appearance of the dialog box depends on the type of entity you select.

  1. To change the thickness, in the Thickness box, type a new thickness value or click the arrows to select the new thickness.
  2. To change the elevation, in the Z coordinate box, type a new elevation value or click the arrows to select the new elevation.
  3. Click OK.
  4. NOTE When you change the thickness of an entity, you do not change the entity type. If you wish to extrude an entity and convert it to a three-dimensional solid, use the Extrude command.
 
 
  1. Type or select the new thickness.
  1. Type or select the new elevation.
Creating three-dimensional faces
  1. You can create a three-dimensional face, which consists of a section of a plane in three-dimensional space. You define a three-dimensional face by specifying the x,y,z coordinates of three or more corners. After you specify the fourth point, the program continues to prompt you for additional faces by alternating prompts for the third point and fourth point to allow you to build a complex three-dimensional entity. Each three- or four-sided plane is created as a separate three-dimensional face entity.
To create a three-dimensional face
  1. Advanced experience level
  2. Do one of the following:
  3. Choose Draw > Surfaces > 3D Face.
  4. On the Surfaces toolbar, click the 3D Face tool (
  5. ).
  1. Specify the first point of the three-dimensional face.
  2. Specify the second, third, and fourth points.
  3. Specify the third and fourth points for additional faces.
  4. To complete the command, press Enter.
  5. Note Any or all edges of a three-dimensional face can be invisible to allow you to more accurately model entities with holes in them. As the program prompts you for the corner points, in the prompt box, choose Invisible Edge to make the next edge invisible.
 

An example of a three-dimensional model created using three-dimensional faces.

Creating rectangular meshes
  1. You can create a three-dimensional rectangular mesh consisting of four-sided polygons. You determine the size of the mesh by specifying the number of vertices along the primary (M-direction) and secondary (N-direction) mesh axes and then specifying the coordinates for each vertex.
To create a rectangular mesh
  1. Advanced experience level
  2. Do one of the following:
  3. Choose Draw > Surfaces > 3D Mesh.
  4. On the Surfaces toolbar, click the 3D Mesh tool (
  5. ).
  • Type mesh and then press Enter.
  • Specify the number of vertices along the primary mesh axis.
  • Specify the number of vertices along the secondary mesh axis.
  • Specify the coordinates for each vertex.

Specifying the coordinates for the last vertex completes the mesh and ends the command.

  1. Note Although creating rectangular meshes manually can be exacting, they are useful for representing complex surfaces such as three-dimensional terrain models. The Mesh tool is most useful when combined with scripts or LISP programs that mathematically calculate the coordinates of the vertices.
 

An example of a three-dimensional terrain model created using rectangular meshes.

Creating polyface meshes
  1. You can create a polygon mesh consisting of faces connecting three or more vertices. You first determine the coordinates of each vertex and then define each face by entering the vertex numbers for all the vertices of that face. As you create each face, you can control the visibility and color of each edge and assign each edge to specific layers.
To create a polyface mesh
  1. Advanced experience level
  2. Do one of the following:
  3. Choose Draw > Surfaces > Polymesh.
  4. Type pface and then press Enter.
  5. Specify the coordinates of each vertex.

After each vertex that you specify, the next vertex number is displayed, and you are prompted for the coordinates of the vertex. Specify the coordinates, and then press Enter. Continue to specify the coordinates for each numbered vertex.

  1. To finish specifying vertex coordinates, press Enter.
  2. Specify the vertex numbers that define the first face.

You specify the face by entering the vertex numbers that were defined when you specified coordinates in step 2. Each face can be composed of three or more numbered vertices.

  1. To finish defining the first face, press Enter.
  2. Specify the next face by entering its vertex numbers.
  3. To complete the command, press Enter.
  4. Note To make an edge invisible, type the vertex number as a negative value.
Creating ruled surface meshes
  1. You can create a ruled surface, which is a three-dimensional polygon mesh that approximates the surface between two existing entities. You select the two entities that define the ruled surface. These entities can be arcs, circles, lines, points, or polylines.
To create a ruled surface mesh
  1. Advanced experience level
  2. Do one of the following:
  3. Choose Draw > Surfaces > Ruled Surface.
  4. On the Surfaces toolbar, click the Ruled Surface tool (
  5. ).
  • Type rulesurf and then press Enter.
  • Select the first defining entity.
  • Select the second defining entity.
.
 

 

 

Select the first ( A ) and second ( B ) defining entities.

 

The resulting ruled surface mesh.

  1. Note To control the density of the mesh, change the values for the Number of M-Direction Surfaces. Choose Tools > Drawing Settings, and then click the 3D Settings tab. Under Change Settings For, select Surfaces. Under Surface Settings, change the Number Of M-Direction Surfaces value.
Creating extruded surface meshes
  1. You can create an extruded surface, which is a three-dimensional polygon mesh that approximates the surface generated by extruding a path curve along a direction vector. You select the two entities that define the path curve and direction vector. The length of the direction vector determines the distance the path curve is moved along the direction vector. The extruded entity can be an arc, circle, line, or polyline. You can choose a line or open polyline as the direction vector. The resulting mesh consists of a series of parallel polygonal planes running along the specified path.
To create an extruded surface mesh
  1. Advanced experience level
  2. Do one of the following:
  3. Choose Draw > Surfaces > Tabulated Surface.
  4. On the Surfaces toolbar, click the Tabulated Surface tool (
  5. ).
  • Type tabsurf and then press Enter.
  • Select the entity to extrude.
  • Select the extrusion path.
  •  
  •  

     

     

    Select the entity to extrude ( A ) and the
    extrusion path ( B ).

     

    The resulting extruded
    surface mesh.

  • Note To control the density of the mesh, change the values for the Number of M-Direction Surfaces. Choose Tools > Drawing Settings, and then click the 3D Settings tab. Under Change Settings For, select Surfaces. Under Surface Settings, change the Number Of M-Direction Surfaces.
  1. NOTE An extruded mesh is different from an extruded solid. If you wish to extrude an entity and convert it to a three-dimensional solid, use the Extrude command.
Creating revolved surface meshes
  1. You can create a surface of revolution, which is a three-dimensional polygon mesh that approximates the surface generated by rotating a two-dimensional profile around an axis. You select the two entities that define the profile and the axis. You also specify the starting angle and the number of degrees to revolve the profile.
  2. Revolving the profile 360 degrees creates a closed three-dimensional mesh. The Number Of M-Direction Surfaces value determines the mesh density (the number of mesh segments) in the M-direction (around the axis of revolution). The N-Direction Mesh Density value determines the mesh density (the number of mesh segments) in the N-direction (along the axis of revolution).
To create a revolved surface mesh
  1. Advanced experience level
  2. Do one of the following:
  3. Choose Draw > Surfaces > Revolved Surface.
  4. On the Surfaces, click the Revolved Surface tool (
  5. ).
  • Type revsurf and then press Enter.
  • Select the entity to revolve.
  • Select the entity to be used as the axis of revolution.
  • Specify the starting angle.
  • Specify the number of degrees to revolve the entity.
  •  

     

     

    Select the entity to be revolved ( A ) and the axis of revolution ( B ).

     

    The resulting revolved surface
    mesh.

  • Note To control the density of the mesh, change the values for the Number Of M-Direction Surfaces and N-Direction Mesh Density. Choose Tools > Drawing Settings, and then click the 3D Settings tab. Under Change Settings For, select Surfaces. Under Surface Settings, change the Number Of M-Direction Surfaces and N-Direction Mesh Density values.
  1. NOTE An revolved mesh is different from an revolved solid. If you wish to revolve an entity and convert it to a three-dimensional solid, use the Revolve command.
Creating edge-defined Coons surface patch meshes
  1. You can create a surface called a Coons surface patch, a mesh connecting four edges. You select the entities that define the edges. Edge entities can be arcs, lines, or polylines. The four edge entities must form a closed loop and share endpoints. A patch is a bicubic surface (one curve extends in the M-direction and the other in the N-direction) interpolated between the four adjoining edges. You can select the edges in any order. The first edge you select determines the M-direction of the mesh.
To create an edge-defined Coons surface patch mesh
  1. Advanced experience level
  2. Do one of the following:
  3. Choose Draw > Surfaces > Edge Surface.
  4. On the Surfaces toolbar, click the Edge Surface tool (
  5. ).
  • Type edgesurf and then press Enter.
  • Select the first edge.
  • Select the second, third, and fourth edges.

 

 

 

 

Select the entities to be used as the four edges ( A , B , C , and D ).

 

The resulting Coons surface patch mesh.

  1. Note To control the density of the mesh, change the value for the Number of M-Direction Surfaces and N-Direction Mesh Density. Choose Tools > Drawing Settings, and then click the 3D Settings tab. Under Change Settings For, select Surfaces. Under Surface Settings, change the Number Of M-Direction Surfaces and N-Direction Mesh Density values.